Add deprecation warning for GlobLists, which will stop working in 3.0.
[ikiwiki.git] / debian / preinst
index e566939f6c6e0a1e7c083cd7897620ae42a5a3cf..c588901df914968a70cbb3242b883f75e518043b 100755 (executable)
@@ -1,10 +1,13 @@
 #!/bin/sh
-
+set -e
 #DEBHELPER#
 
 if [ "$1" = upgrade ] && dpkg --compare-versions "$2" lt 1.2; then
        if [ -e /etc/wikilist ]; then
                if [ ! -e /etc/ikiwiki/wikilist ]; then
+                       if [ ! -e /etc/ikiwiki ]; then
+                               mkdir /etc/ikiwiki
+                       fi
                        mv -f /etc/wikilist /etc/ikiwiki/wikilist
                else
                        rm -f /etc/wikilist