]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/changelog
Fix CSRF attacks against the preferences and edit forms. Closes: #475445
[ikiwiki.git] / debian / changelog
index c608043f432eb3a6f3b26972c9ac52a55a443b99..9085d97cb6c0167186faaf220b9949ea5b857f73 100644 (file)
@@ -1,5 +1,183 @@
+ikiwiki (2.42) UNRELEASED; urgency=low
+
+  * aggregate: Correct a mistake in the code that dummy up a guid for feeds
+    lacking one.
+  * inline: Correct handling of urls relative to baseurl in feeds.
+  * Fix CSRF attacks against the preferences and edit forms. The fix involved
+    embedding the session id in the forms, and not allowing the forms to be
+    submitted if the embedded id does not match the session id. Closes: #475445
+
+ -- Joey Hess <joeyh@debian.org>  Thu, 03 Apr 2008 02:35:39 -0400
+
+ikiwiki (2.41) unstable; urgency=low
+
+  [ Adeodato Simó ]
+  * Preprocessor directives generated by the shortcut plugin accept a `desc`
+    parameter that overrides the anchor text provided at shortcut definition
+    time. (Closes: #458126)
+
+  [ martin f. krafft ]
+  * The meta plugin now allows for the robots tag to be specified without the
+    risk of it being scrubbed.
+  * Let meta.openid set X-XRDS-Location header
+  * Make makerepo set the Git merge remote.
+    branch.master.remote previously used to default to origin, which has
+    recently been changed; it now needs to be set explicitly, which this
+    patch does. Closes: #470517
+  * meta: Also generate openid2 headers.
+  * Handle SimpleXMLRPCDispatcher arg count change in python 2.5
+  * Provide XML-RPC proxy abstraction for Python plugins.
+
+  [ Joey Hess ]
+  * Add recentchangesdiff plugin that adds diffs to the recentchanges feeds.
+  * rcs_diff is a new function that rcs modules should implement.
+  * Implemented rcs_diff for git, svn, and tla (tla version untested).
+    Mercurial and monotone still todo.
+  * Support Text::Markdown::markdown, which is the spelling used by 
+    version 1.0.16 of Text::Markdown.
+  * Updated Spanish translation from Victor Moral.
+  * Fix example exclude regexp. Closes: #469691
+  * Remove locking code in git rcs_commit. I'm not sure if this was ever
+    correct, and it's certianly not correct now, since the wiki is locked
+    before rcs_commit is ever called, and should not be unlocked by
+    rcs_commit either.
+  * monotone: Require version 0.38 or greater, and stop using the mtnmergerc
+    option. (Brian May)
+  * Use forcebaseurl to make page previews be displayed with the html base
+    set to the destination page. This avoids need for hacks to munge the urls
+    in preview mode, which fixes several bugs.
+  * Several destpage fixes in plugins.
+  * Use absolute url for feedurl when filling out the feed templates.
+    Closes: #470530
+  * Fix expiry of old recentchanges changeset pages.
+  * French translation update. Closes: #471010
+  * external: Fix support of XML::RPC::fault.
+  * htmltidy: Pass --markup yes, in case tidy's config file disabled it.
+  * external: Add getargv and setargv methods to allow access to ikiwiki's
+    @ARGV.
+  * Correct bug in encoding of %pagestate keys, fixes edittemplate.
+  * Detect invalid pagespecs and do not merge them in add_depends,
+    as that can result in a broken merged pagespec that matches nothing.
+  * Record new pages in %pagesources temporarily when previewing so that
+    things that need to know the page source or type can query it from there.
+    Fixes previewing of tables when creating a new page.
+  * German translation update. Closes: #471540
+  * Time::Duration is no longer used, remove from docs and recommends.
+  * Store userinfo in network byte order for easy portability.
+    (Old files will be automatically converted.)
+  * Close meta tag for redir properly.
+  * smiley: Detect smileys inside pre and code tags, and do not expand.
+  * inline: Crazy optimisation to work around slow markdown.
+  * Precompile pagespecs, about 10% overall speedup.
+  * Changed to a binary index file, written using Storable, for speed.
+  * external: Work around XML RPC's lack of support for null by passing
+    a special sentinal value.
+  * inline: Allow the "feedshow" parameter to take values greater than the
+    value for "show".
+  * Added a hardlink option in the setup file, useful if the source and
+    dest are on the same filesystem and the wiki includes large media files,
+    which would normally be copied, wasting time and space.
+
+ -- Joey Hess <joeyh@debian.org>  Sat, 29 Mar 2008 21:07:22 -0400
+
+ikiwiki (2.40) unstable; urgency=low
+
+  [ Josh Triplett ]
+  * Add new preprocessor directive syntax¸ using a '!' prefix.  Add a
+    prefix_directives option to the setup file to turn this syntax on;
+    currently defaults to false, for backward compatibility.  Support
+    optional '!' prefix even with prefix_directives off, and use that in
+    the underlay to support either setting of prefix_directives.  Add NEWS
+    entry with migration information.
+
+  [ Joey Hess ]
+  * Danish translation update from Jonas Smedegaard. Closes: #465152
+  * Generate XML RPC messages with the encoding set to utf-8 instead
+    of XML::RPC's default of us-ascii. Allows interoperation with
+    python's xmlrpc library, which threw invalid encoding exceptions and
+    caused the rst plugin to hang.
+  * Add the linkify and scan hooks. These hooks can be used to implement
+    custom, first-class types of wikilinks.
+  * Move standard wikilink implementation to a new link plugin, which
+    will of course be enabled by default.
+  * camelcase: Convert to use new linkify and scan hooks rather than the old
+    hack.
+  * Setting NOTAINT=1 had no effect when building ikiwiki itself, fix this.
+  * Depend on HTML::Scrubber, since the scrubber is enabled by default and
+    dies if its can't be loaded.
+  * The search plugin needs to override <base> to point to the directory
+    containing ikiwiki.cgi, but this should not change the urls to the style
+    sheets etc. Add a new forcebareurl parameter to misctemplate to allow
+    it to do that.
+  * Preview limits the page dropdown to what's selected previously
+    (as preserving the full list across preview would be tricky). Userdirs
+    were still being offered as an option there, remove them.
+  * Fix a bug where user A created a page concurrently with user B, and
+    when B previewed it would redirect B to A's new page, losing B's work.
+    Instead, don't redirect and let conflict handling resolve it.
+  * monotone: Add code to default mergerc file to run
+    _MTN/ikiwiki-netsync-hook when a commit is merged in from the net.
+  * tla: Remove call to escapeHTML when constructing recentchanges message;
+    the html is escaped at a different level. Closes: #466495
+  * bzr, mercurial: Remove unused import of escapeHTML.
+  * Fix another preview will_render bug. This one involved inline,
+    which forced a scan of the page to make available metadata that
+    appeared after the inline directive. Problem is that scan made it forget
+    about any other files rendered due to the page. The scan also turns out
+    to be unnecessary now, since meta persistently stores state and it's
+    always available. So it was just removed.
+  * Disable taint checking for all builds as people keep complaining about it,
+    and since all versions of perl seem to be hopelessly broken.
+  * Fix links generated by preprocessor directives when previewing.
+  * inline: When forcing urls absolute for rss feeds, skip mailto and other
+    such urls.
+  * ikiwiki-makerepo: Don't fail if the third argument ends in a slash.
+  * Allow colons in URLs after the first slash. (Adeodato Simó)
+
+ -- Joey Hess <joeyh@debian.org>  Fri, 29 Feb 2008 23:05:39 -0500
+
+ikiwiki (2.31.3) unstable; urgency=high
+
+  [ Josh Triplett ]
+  * Do not allow the about: URI scheme; some browsers interpret about:
+    URIs like a limited version of data: URIs.  In particular, some
+    versions of Internet Explorer interpret arbitrary HTML content in
+    about: URIs.
+  * Also filter the attributes cite, longdesc, and usemap, which can contain
+    URIs.
+
+  [ Joey Hess ]
+  * meta: Check that the urls provided for authorurl, permalink, and openid
+    are safe and can't contain javascript.
+
+  [ Josh Triplett ]
+  * Match literal '.' in URI schemas containing '.', rather than matching any
+    character.
+  * Do not allow the steam: URI scheme.
+  * Allow the snews: URI scheme.
+  * Allow the smb: URI scheme.
+
+ -- Josh Triplett <josh@freedesktop.org>  Sun, 10 Feb 2008 14:48:48 -0800
+
+ikiwiki (2.31.2) unstable; urgency=high
+
+  * The security fix in the last release had buggy handling of data:image,
+    now fixed. Closes: #465110 (CVE-2008-0808, CVE-2008-0809)
+
+ -- Joey Hess <joeyh@debian.org>  Sun, 10 Feb 2008 15:31:17 -0500
+
+ikiwiki (2.31.1) unstable; urgency=low
+
+  * htmlscrubber security fix: Block javascript in uris.
+  * Add htmlscrubber test suite.
+  * Thanks to Josh Triplett for pointing out the holes and for his help
+    in implementing and checking fixes.
+
+ -- Joey Hess <joeyh@debian.org>  Sun, 10 Feb 2008 13:22:59 -0500
+
 ikiwiki (2.31) unstable; urgency=low
 
+  [ Joey Hess ]
   * Revert preservation of input file modification times in output files,
     since this leads to too many problems with web caching, especially with
     inlined pages. Properly solving this would involve tracking every page
@@ -39,8 +217,12 @@ ikiwiki (2.31) unstable; urgency=low
   * Don't die if running with --getctime and rcs_getctime throws an error.
     There are several cases (recentchanges files, aggregated files)
     where some source files are not in revision control.
+  * Page templates can now use CTIME to show when the page was created.
+
+  [ Josh Triplett ]
+  * README.Debian: Mention user wikilists.
 
- -- Joey Hess <joeyh@debian.org>  Wed, 06 Feb 2008 15:10:20 -0500
+ -- Joey Hess <joeyh@debian.org>  Sat, 09 Feb 2008 23:09:45 -0500
 
 ikiwiki (2.30) unstable; urgency=low