]> sipb.mit.edu Git - ikiwiki.git/blobdiff - doc/bugs/Problems_with_graphviz.pm_plug-in.mdwn
indeed not fixed, but patch needs improvement
[ikiwiki.git] / doc / bugs / Problems_with_graphviz.pm_plug-in.mdwn
index 7abf152b9a951327fd4757a1ff0e374b99aa8734..d3629f840a15b5158c366cf988613f5e28196513 100644 (file)
@@ -3,8 +3,50 @@ The graphviz.pm plug-in currently attempts to read PNG data in UTF-8 mode, which
     utf8 "\x89" does not map to Unicode at /usr/local/lib/perl5/site_perl/5.8.8/IkiWiki/Plugin/graphviz.pm line 53, <IN> chunk 1.
     Wide character in subroutine entry at /usr/local/lib/perl5/site_perl/5.8.8/IkiWiki/Plugin/graphviz.pm line 68.
 
+> Ok, will remove the binmode IN then. done --[[Joey]]
+
+>> Thanks --[[HenrikBrixAndersen]]
+
 It also generates image URLs relative to the page being rendered, which means the URLs wont work when previewing a graph from the CGI script.
 
+> You seem to be using an old version of ikiwiki, these preview isues have
+> been fixed for some time, and the code doesn't look like what you patch
+> in your second hunk. --[[Joey]]
+
+>> I have just tested ikiwiki-2.5. The code in question still looks
+>> the same, and the patch is still needed for making the graphviz
+>> plug-in work in preview mode here.
+
+>>> You're right, it doesn't preview properly. However, your patch doesn't
+>>> really fix it, since it only makes it show any old files that are lying
+>>> around, and not a current one updated for the current page. Fixing it
+>>> really right calls for embedding the file in a data uri in the preview
+>>> page, as the sparkline plugin does. --[[Joey]]
+
+>> Here is an updated patch againt ikiwiki-2.5:
+
+
+    --- IkiWiki/Plugin/graphviz.pm.orig        2007-07-27 11:35:05.000000000 +0200
+    +++ IkiWiki/Plugin/graphviz.pm     2007-07-27 11:36:02.000000000 +0200
+    @@ -69,7 +69,12 @@ sub render_graph (\%) { #{{{
+               }
+       }
+     
+    -  return "<img src=\"".urlto($dest, $params{page})."\" />\n";
+    +  if ($params{preview}) {
+    +          return "<img src=\"".urlto($dest, "")."\" />\n";
+    +  }
+    +  else {
+    +          return "<img src=\"".urlto($dest, $params{page})."\" />\n";
+    +  }
+     } #}}}
+     
+     sub graph (@) { #{{{
+
+
+>> --[[HenrikBrixAndersen]]
+
+
 The patch below fixes these two issues.
 
     --- graphviz.pm.orig       Thu Jun  7 15:45:16 2007