Add simple patch to silence a warning when using monotone
[ikiwiki.git] / IkiWiki / Plugin / monotone.pm
index 40a41c765b7142f5973c4ec63a956c6fd7569494..f31a8606bb4f664b6d626c345e668bf4e884dda3 100644 (file)
@@ -55,7 +55,7 @@ sub checkconfig () { #{{{
                error("Monotone version too old, is $version but required 0.38");
        }
 
-       if (length $config{mtn_wrapper}) {
+       if (defined $config{mtn_wrapper} && length $config{mtn_wrapper}) {
                push @{$config{wrappers}}, {
                        wrapper => $config{mtn_wrapper},
                        wrappermode => (defined $config{mtn_wrappermode} ? $config{mtn_wrappermode} : "06755"),