]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/changelog
typo
[ikiwiki.git] / debian / changelog
index 277245a27d68fc6978128a3fe2fad725c7c32aba..6026cdc0e3b602654273683ff826daa92ebe4bd6 100644 (file)
-ikiwiki (1.44) UNRELEASED; urgency=low
-
-  * Patch to fix validaton of atom feeds by fixing the category tags.
+ikiwiki (1.48) UNRELEASED; urgency=low
+
+  * Fix link() PageSpecs to not just look at the raw link text, but at where
+    that given link points based on the page doing the linking. Note that this
+    could make such PageSpecs match different things than before, if you
+    relied on the old behavior of them only matching the raw link text.
+  * This required changing the match_* interface, adding a third parameter.
+  * Allow link() PageSpecs to match relative, as is allowed with globs.
+  * Add postform option to inline plugin.
+  * Add an bug tracker to the softwaresite example.
+
+ -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 16:58:00 -0400
+
+ikiwiki (1.47) unstable; urgency=low
+
+  * Fix a security hole that allowed insertion of unsafe content via the meta
+    plugins's support for inserting html link and meta tags. Now such content
+    is passed through the htmlscrubber like everything else.
+  * Unfortunatly, that means that some valid uses of those tags are no longer
+    usable, and special case methods needed to be added for including
+    stylesheets, and for doing openid delegation. If you use either of these
+    in your wiki, it will need to be modified. See the meta plugin docs
+    for details.
+
+ -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 14:05:00 -0400
+
+ikiwiki (1.46) unstable; urgency=low
+
+  * Fix a bug with inlined create page links, including Discussion links on
+    blog post pages. The links will now create pages relative to the page that
+    actually contains the link.
+  * French update. Closes: #414597
+  * Fix some broken logic in cgi creation of a subpage when a toplevel page
+    with the same name already exists, and generally simplify the edit code.
+  * Make ikiwiki -verbose -setup with a setup file that enabled syslog logging
+    output the verbose build log to stdout, rather than to the syslog.
+  * Detect the case of two people independently creating the same page at the
+    same time, and let the second person resolve the conflict.
+  * Applied a patch from MichaƂ to make the mercurial backend pass --quiet to
+    hg.
+  * Fix a security hole that allowed a web user to insert arbitrary html in
+    the title of a page due to missing escaping of titles in the meta plugin.
+
+ -- Joey Hess <joeyh@debian.org>  Wed, 21 Mar 2007 01:51:30 -0400
+
+ikiwiki (1.45) unstable; urgency=low
+
+  * Allow for underscores to appear in page titles, if encoded appropriately
+    (__95__) in filenames. Previously, all underscores were replaced with
+    spaces. Thanks, Enrico Zini for noticing that bug.
+  * Add "template" option to inline plugin to allow for use of customised
+    templates.
+  * Add titlepage template for inline plugin.
+  * Add preview parameter to preprocesser calls, use this rather than the
+    previous ugly hack used to avoid writing rss feeds in previews.
+  * Fix the img plugin to avoid overwriting images in previews. Instead it
+    does all the work to make sure the resizing works, and dummys up a resized
+    image using width and height attributes.
+  * Also fixes img preview display, the links were wrong in preview before.
+  * Add a sparkline plugin.
+  * Add a postsparkline plugin.
+  * The slash escaping when adding to a blog from the CGI was not working
+    since it ended up being double-escaped. Instead, just remove slashes.
+  * Fix some nasty issues with page name escaping during previewing
+    (introduced in 1.44).
+  * Add a table plugin, derived from the one written by Victor Moral.
+  * The underscore escaping support exposed a bug in edit links: Such links
+    were titlepage escaped in the urls, and then doubly escaped by the CGI
+    when editing. To fix this, I removed the titlepage escaping in the edit
+    urls.
+  * That means that *every edit link* on the wiki is potentially changed.
+    Rebuilding wikis on upgrade to this version therefore necessary; enabled
+    that in postinst.
+  * Correct a deadlock that could occur in post-commit if the aggregate plugin
+    was enabled and tried to lock the already locked wiki.
+
+ -- Joey Hess <joeyh@debian.org>  Sat, 10 Mar 2007 21:11:05 -0500
+
+ikiwiki (1.44) unstable; urgency=low
+
+  * Patch by Ben to fix validaton of atom feeds by fixing the category tags.
   * Add a openidlogin-bg.gif to wikiicons and have the stylesheet use it for the
     OpenID login form rather than linking to a remote logo, to avoid various
     issues. Since there is not yet a license for the actual OpenID logo, this
     file is currently a blank image. Users who want to can copy
     http://openid.net/login-bg.gif into their wiki.
-
- -- Joey Hess <joeyh@debian.org>  Mon, 19 Feb 2007 18:34:58 -0500
+  * Allow setting NOTAINT=1 when building the wiki to remove taint checking
+    flags, which can be useful on some hosting providers.
+  * Fix a bug that made links like [[0|foo]] use "foo" as the link text,
+    instead of "0".
+  * Changed calling convention for httmllink slightly. The first three
+    parameters remain the same, but additional options are now passed in using
+    named parameters.
+  * Change plugin interface version to 1.02 to reflect this change.
+  * Add a new anchor option to htmllink. Thanks Ben for the idea.
+  * Support anchors in wikilinks.
+  * Add a "more" plugin based on one contributed by Ben to allow implementing
+    those dreaded "Read more" links in blogs.
+  * Don't error out if estcmd fails, just print a warning message. estcmd is
+    too fragile to let it kill ikiwiki.
+  * Make img plugin not fail immediately if Image::Magick is not available.
+    This lets ikiwiki not build depend on perlmagic.
+  * Detect old versions of xgettext and avoid using them.
+  * perl is broken: print "" || die fails! Work around this insanity.
+  * Smarter detection of no-op changes to po files.
+  * Elegant patch from Ethan to clean up the display of page names in the
+    dropdown when creating a new page.
+  * Since the CGI had to drop the wiki lock to avoid deadlocking the
+    commit hook, it was possible for one CGI to race another one and "win"
+    the commit of both their files. This race has been fixed by adding a new
+    commitlock, which when locked by the CGI, disables the commit hook
+    (except for commit mails). The CGI then takes care of the updates the
+    commit hook would have done.
+  * French translation update. Closes: #411899
+  * Patch from HenrikBrixAndersen to fix a broken use of foreach in the
+    search plugin.
+  * Correct a bug that could lead to infinite looping after signin in some
+    circumstances.
+  * Patch from Ethan to improve behavior if a page is deleted or moved while
+    someone is editing it.
+  * Some cleanup of field setting in the failed edit and conflict handling
+    code.
+
+ -- Joey Hess <joeyh@debian.org>  Sat, 24 Feb 2007 20:16:35 -0500
 
 ikiwiki (1.43) unstable; urgency=low