]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/rules
Merge branch 'master' of ssh://git.ikiwiki.info
[ikiwiki.git] / debian / rules
index 115b3f0c20fae4ecd26c9747d8f9790988a7d71b..0a7ce7a267e43c0999d6e468f7e6844abbc8d660 100755 (executable)
@@ -2,6 +2,18 @@
 %:
        dh $@
 
+override_dh_auto_configure:
+       # keeps it out of /usr/local
+       dh_auto_configure -- PREFIX=/usr
+
+override_dh_compress:
+       # avoid compressing files in the doc wiki
+       dh_compress -Xhtml
+
+override_dh_auto_clean:
+       # distclean moans about MANIFEST, this is quieter
+       if [ -e Makefile ]; then $(MAKE) realclean; fi
+
 # Not intended for use by anyone except the author.
 announcedir:
        @echo ${HOME}/src/ikiwiki/doc/news