remove some links to gitweb
[ikiwiki.git] / doc / bugs / attachment:_failed_to_get_filehandle.mdwn
index e6ab45feeb8fd9d9a64501573cc66bcfb756c074..acfc60078e2ee7871bb84035f69fdef52e242e9c 100644 (file)
@@ -44,7 +44,7 @@ the error message like below:
 >>>>>>     $CGI::VERSION='3.15';
 
 >>>>> I've just checked in a fix that should work, can you test it?
->>>>> [diff](http://git.ikiwiki.info/?p=ikiwiki;a=commitdiff;h=71f10579c00a8ddc20ada1a1efd33aac25a3da7e) --[[Joey]]
+>>>>> 71f10579c00a8ddc20ada1a1efd33aac25a3da7e --[[Joey]]
 
 >>>>>> I've patched `attachment.pm` module, but the bug still occurs.
 >>>>>> However I can see a little progress. I changed invoking `error()`
@@ -63,7 +63,7 @@ the error message like below:
 >>>>>>> though. I've checked in a second try at dealing with things, can
 >>>>>>> you try it? --[[Joey]]
 
->>>>>>>> Do you mean that [diff](http://git.ikiwiki.info/?p=ikiwiki;a=commitdiff;h=66f35e30dcea03c631a293e2341771277543b4ae)?
+>>>>>>>> Do you mean that 66f35e30dcea03c631a293e2341771277543b4ae?
 >>>>>>>> If so, then it causes "Internal Server Error" for me:
 
 >>>>>>>>     Can't use string ("test.txt") as a symbol ref while "strict refs" in use at /usr/share/perl5/IkiWiki/Plugin/attachment.pm line 144.
@@ -101,3 +101,15 @@ Is it Ikiwiki bug or my attachment plugin is misconfigured? --[[Paweł|ptecza]]
 
 > I've reproduced the bug, and it does seem to be a bug with the perl in
 > debian stable/ubuntu hardy. Trying to figure it out --[[Joey]]
+
+> This was amazingly disgusting, see commit message for the full horror of
+> the details. I think it's [[done]] -- at least it works on debian stable
+> now. --[[Joey]]
+
+>> Wow! It's probably the biggest Ikiwiki commit message I've ever seen :)
+
+>> Yes, I can confirm that now the plugin works for me and I'm able to add
+>> attachments to my wiki. Yupiii! :D
+>> Thanks a lot, Joey! You're really great! :) --[[Paweł|ptecza]]
+
+>> Thank you very much for your effort, Joey! :) --[[Paweł|ptecza]]