]> sipb.mit.edu Git - ikiwiki.git/blobdiff - doc/install/discussion.mdwn
fix
[ikiwiki.git] / doc / install / discussion.mdwn
index 88830398f4cbea41786ca390feae83f1edf12622..60a059089e2b86920b17b3a7217aa557ccd114a6 100644 (file)
@@ -28,3 +28,66 @@ How do I fix this?  There may be a bit of old ikiwiki left behind because
 I did once have an older version installed but I thought I had removed all
 traces of it.
 
+> I'm quite sure that you still have some of it floating around, since
+> ikiwiki seems to be loading an old IkiWiki.pm.
+> 
+> I don't understand though why it's not finding ./IkiWiki.pm first. The
+> `-I` in the command line should make it look for files in the current
+> directory first. --[[Joey]]
+
+Well I have searched around and there really is nothing left that I can see.
+
+I have removed *everything* found by 'find' and 'locate' that contains 'ikiwiki' except the tar file
+and started from the beginning again and I see exactly the same error.
+
+Is it that I maybe have a too old version of some of the Perl dependencies?  The only mdwn.pm files
+that I have are the two I have just extracted from the new tar file.  There is *no* ./IkiWiki.pm file
+
+> It's interesting that you say you have no ./IkiWiki.pm file, since one is
+> included in the tarball. What happened to it, I wonder? 
+
+so what/where is it loading to satisfy the ....... aaaaaaaaaaahhhhhhhhhhhhhh!!!!!!
+
+I wasn't noticing the case of the filename, I'd missed the upper case W and guess what 'find' shows me:-
+
+    /usr/local/lib/perl5/site_perl/5.8.8/IkiWiki.pm
+
+Removing the above file has fixed my basic problem, now I'm getting lots of (non-fatal) errors
+about "Can't locate Locale/gettext.pm", presumably that's a missing Perl module, I can probably
+sort that out.
+
+
+## Errors when running 'make test'
+
+OK, I've now got it to compile and install and presumably it's basically working.  However there
+are a few errors when I run 'make test'.  Several errors have disappeared by installing more Perl
+stuff (specifically XML::SAX) 
+
+> XML::SAX is a requirement of XML::Simple, which is a documented build
+> requirement. (Only really needed if you'll be using subversion actually).
+
+and one error disappeared when I did a 'make install', i.e. the 'make
+test' has a test which requires IkiWiki to be installed first.
+
+> Yes, that bug is already fixed in subversion for the next release
+> --[[Joey]]
+
+However I'm still getting the following error in 'make test':-
+
+       t/pagename.................ok                                                
+       t/pagespec_match...........ok 1/52Modification of a read-only value attempted at /home/chris/webdev/ikiwiki/blib/lib/IkiWiki.pm line 1023.
+       # Looks like you planned 52 tests but only ran 23.
+       # Looks like your test died just after 23.
+       t/pagespec_match...........dubious                                           
+               Test returned status 255 (wstat 65280, 0xff00)
+       DIED. FAILED tests 24-52
+               Failed 29/52 tests, 44.23% okay
+       t/pagespec_merge...........ok                                                
+
+> What version of perl are you using? It seems to have some problem with
+> operator overloading.
+> --[[Joey]]
+
+home$ perl -v
+
+This is perl, v5.8.8 built for i486-linux