]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/changelog
web commit by http://joey.kitenet.net/: response
[ikiwiki.git] / debian / changelog
index 491f735089bac60d0e9e32ce038086eadda9d6e9..b622fa006396ac8c1e6665bdd74afd3966333021 100644 (file)
-ikiwiki (1.25) UNRELEASED; urgency=low
+ikiwiki (1.34) UNRELEASED; urgency=low
+
+  * Add an openid plugin to support logging in using OpenID.
+  * Web commits by OpenID users will record the full OpenID url for the user,
+    but in recentchanges, these urls will be converted to a simplified display
+    form+link.
+  * Modified svn, git, tla backends to recognise such web commits.
+  * Move httpauth support to a plugin.
+  * Add openidsignup config option.
+  * Make the openid plugin support the callbacks from myopenid.com via its
+    affiliate program.
+  * Change how post signin actions are propigated through the signin process;
+    they're now stored in the session.
+  * Add optional "desc" parameter to shortcut definitions.
+  * Avoid locking the wiki at all when handling some basic cgi stuff
+    (searches, recentchanges).
+
+ -- Joey Hess <joeyh@debian.org>  Mon, 20 Nov 2006 06:54:12 -0500
+
+ikiwiki (1.33) unstable; urgency=low
+
+  * Fix issue with aggregate plugin updating expired pages.
+  * Avoid syntax errors in templates used by the template plugin crashing
+    ikiwiki.
+  * Enable utf8 file IO in aggregate plugin.
+  * Fix some issues with the new registration form.
+  * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
+  * Make sure to check for errors from every eval.
+  * Fix img plugin's handling of adding dependencies for images that do not
+    yet exist.
+  * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
+    FORM-SUBMIT unusable on customised formbuilder templates. For now,
+    hardcode the submit buttons in editpage.tmpl instead of using the
+    template variable, which is ok, since the buttons are static.
+  * Work with hyperestraier 1.4.9.
+
+ -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
+
+ikiwiki (1.32) unstable; urgency=low
+
+  * Add a separate pass to find page links, and only render each page once,
+    instead of over and over. Typical speedup is ~4x. Max possible speedup:
+    8x.
+  * Add "scan" parameter to hook(), which is used to make the hook be called
+    during the scanning pass, as well as the render pass. The meta and tag
+    plugins need to use the new scan parameter, so will any others that modify
+    %links.
+  * Now that links are calculated in a separate pass, it can also
+    precalculate backlinks in one pass, which is O(N^2) instead of the
+    previous code that was O(N^3). A very nice speedup for wikis with lots
+    (thousands) of pages.
+  * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
+    Erdem.
+  * Add a default stylesheet entry for the pagecloud.
+  * Add examples page with some examples of things that can be done using
+    ikiwiki, like a weblog. The examples can be copied into a user's wiki
+    for a quick start, without needing to learn everything about how to put
+    them together.
+  * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
+  * Add perlmagick to build-depends so syntax check of img plugin works.
+    Closes: #396702
+  * Improve login/register process, the login dialog has only name and
+    password fields, which allows more web browsers to regognise it as a login
+    field, and is less confusing.
+  * Implemented expiry options for aggregate plugin.
+  * Use precalculated backlinks info when determining if files need an update
+    due to a page they link to being added/removed. Mostly significant if
+    there are lots of pages.
+  * Remove duplicate link info when saving index. In some cases it could
+    pile up rather badly. (Probably not the best way to deal with this
+    problem.)
+  * Patch from James Westby to support podcasting, photoblogging, vidcasting,
+    or what have you, by creating enclosures for non-page items that are
+    included in feeds.
+
+ -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
+
+ikiwiki (1.31) unstable; urgency=low
+
+  * Patch from Pawel Tecza to cp -a the templates in the Makefile.
+  * Change the rss feed title from the wikiname to the page title, with
+    an exception for the wiki's toplevel index page, which will still use the
+    wikiname as the feed title.
+    Overriding the page title with meta title already overrode the rss feed
+    tittle.
+  * Add an img plugin, based on Christian Mock's img plugin, but stripped
+    down to the bare essentials. Useful for handling large images on websites.
+  * Sanitize possibly problimatic characters out of the polygen grammar names,
+    just in case. Should not be exploitable anyway, since it only tries to run
+    polygen after finding the specified grammar file.
+  * Add missing dependency on the URI perl module.
+  * Add basic spam fighting tool for admins: An admin's prefs page now allows
+    editing a list of banned users.
+
+ -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
+
+ikiwiki (1.30) unstable; urgency=low
+
+  * Add no_override parameter to hook().
+  * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
+    plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
+    can be configured using a page in wiki.
+  * Fix support for --pingurl at the command line.
+  * Fix a subtle bug in will_render that broke some builds, by only clearing
+    items from renderedfiles the first time per build.
+  * Wrap entire technortati ping operation in an eval to catch all possible
+    failure modes, after I observed a simple ->value crashing ikiwiki when
+    a ping failed.
+
+ -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
+
+ikiwiki (1.29) unstable; urgency=low
+
+  * Patch from Paul Tötterman to use CP in the Makefile.
+  * Patch from Alec Berryman adding a http_auth config item that allows
+    using HTTP Authentication instead of ikiwiki's built in authentication.
+    Useful for eg, large sites with their own previously existing user auth
+    setup. Closes: #384534
+  * Change %renderedfiles to store an array of files rendered from a given
+    source file, to allow tracking of extra rendered files like rss feeds.
+  * Note that plugins that accessed this variable will need to be updated!
+    The plugin interface has been increased to version 1.01 for this change.
+    As few plugins use %renderedfiles I haven't done anything else to ensure
+    compatability of old plugins.
+  * Add will_render function to the plugin interface, used to register that a
+    page renders a destination file, and do some security checks. Previously
+    but no longer rendered files will be cleaned up.
+  * Use will_render in the inline and linkmap plugins.
+  * You will need to rebuild your wiki on upgrade to this version.
+  * Atom feed support based on a patch by Clint Adams.
+  * Add feeds=no option to inline preprocessor directive to turn off all types
+    of feeds.
+  * $IkiWiki::version now holds the program version, and is accessible to
+    plugins.
+  * Make the aggregate plugin emphasize error messages.
+  * Patch from Recai to limit recentchanges to displaying max 10 files for a
+    given changeset (to avoid large number of file changes excessively
+    bloating the page).
+
+ -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
+
+ikiwiki (1.28) unstable; urgency=low
+
+  * inline: Add ability to sort by page name, based on a patch from
+    Benjamin A'Lee.
+  * Fix a forkbomb in various calls to IPC::Open2, which has a highly
+    braindead interface. Closes: #389383
+  * Don't rm -rf ikiwiki on distclean, since a) there's no such file
+    and b) those poor Mac OSX users and their case insensative files!
+  * Don't fail syntax check if Text::Typography isn't installed.
+    Closes: #389406
+
+ -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
+
+ikiwiki (1.27) unstable; urgency=low
+
+  * Work on firming up the plugin interface:
+    - Plugins should not need to load IkiWiki::Render to get commonly
+      used functions, so moved some functions from there to IkiWiki.
+    - Picked out the set of functions and variables that most plugins
+      use, documented them, and made IkiWiki export them by default,
+      like a proper perl module should.
+    - Use the other functions at your own risk.
+    - This is not quite complete, I still have to decide whether to
+      export some other things.
+  * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
+    referring to stuff now exported by the IkiWiki module.
+  * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
+    to declare which version of the interface your plugin needs.
+  * Anyone with a third-party ikiwiki plugin is strongly encouraged
+    to make like changes to it and avoid use of non-exported symbols from
+    "IkiWiki::".
+  * Link debian/changelog and debian/news to NEWS and CHANGELOG.
+  * Support hyperestradier version 1.4.2, which adds a new required phraseform
+    setting.
+  * If an inlined page has a permalink, link the page title to that.
+  * Patch from Recai to use utf8 when reading the setup file, so that
+    utf8 wikinames from there will be used properly.
+  * Patch from Recai to kill utf-8 on the wiki name when generating the
+    session cookie.
+  * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
+  * Fix a baseurl problem in hyperestradier search results.
+  * Add a stub local.css to avoid problems with 404's.
+  * Patch from Recai to fix a wide character warning from the search plugin
+    during setup if the wikiname contains utf8.
+  * Yet another fix for those poor case-insensative OS X users.
+  * pagetemplate hooks are now also called when generating cgi pages.
+  * Add a favicon plugin, which simply adds a link tag for an icon to each
+    page (and cgis).
+  * Patch from James Westby to deal with the case where you're editing a
+    new page, hit cancel, and need to be redirected to somewhere sane.
+  * Various documentation improvements by various wiki users.
+  * Support Text::Markdown from CPAN, which has a different interface from
+    the original markdown or the one in Debian.
+  * Version the libcgi-session-perl dependency, some features that need
+    the new version are used in some cases (sslcookie).
+  * Numerous tla fixes from Clint.
+  * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
+    a multi-resolution favicon.ico.
+  * README.Debian: typo Closes: #388110
+  * chomp trailing newline at the end of templates read in by the template
+    plugin, to allow use of the template preprocessor directive in
+    whitespace-sensative situations. Closes: #387073
+  * Patch from James Westby to make the location of the estseek.cgi script
+    configurable.
+  * Add typography (SmartyPants) plugin by Recai.
+  * Add --render mode, which can be used to preview an edit at the command
+    line by test rendering a single page.
+  * Add a googlecalendar plugin. A bit special-purpose, but it shows
+    one way to to deal with user-supplied content that could cause XSS
+    issues w/o the htmlscrubber, and won't survive the scrubber.
+
+ -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
+
+ikiwiki (1.26) unstable; urgency=low
+
+  * Add a missing -n to tla undo call.
+  * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
+    writes before consuming its whole stdin. Avoid this deadlock.
+  * Fix alt tags for outline checkboxes.
+
+ -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
+
+ikiwiki (1.25) unstable; urgency=low
 
   * Add proper waitpid calls for open2ed processes throughout to avoid
     zombies; this hit htmltidy especially badly.
   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
     subversion repos and fixing some other issues.
-  * Add support for tla, contributed by Clint Adama. Closes: #385936
+  * Add support for tla, contributed by Clint Adams. Closes: #385936
+  * Add support for mercurial, contributed by Emanuele Aina.
+  * Include <link rel> tag for RSS feeds, used by some aggregators and
+    firefox to find the feed.
+  * Add a linkmap plugin (requires graphviz).
 
- -- Joey Hess <joeyh@debian.org>  Mon,  4 Sep 2006 01:33:17 -0400
+ -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
 
 ikiwiki (1.24) unstable; urgency=low