(no commit message)
[ikiwiki.git] / doc / news / openid / discussion.mdwn
index 1c5929274c4b55b1b29fa33102d76122a8048ce2..58bac1ae40b7d15808fe8ef10ef167ffc6d90ffb 100644 (file)
@@ -15,6 +15,8 @@ as well. Also have I just created an account on this wiki as well?
 > can configure it to eg, subscribe your email address to changes to pages.
 > --[[Joey]]
 
+OK, my openid login works too. One question though, is there a setup parameter which controls whether new registrations are permitted at all? For instance, I'm thinking that I'd like to use the wiki format for content, but I don't want it editable by anyone who isn't already set up. Does this work?
+
 ----
 
 # How to ban an IP address?
@@ -35,3 +37,46 @@ only Apache/iptables rules for this? Maybe it's related to
 >> Qatar Wikipedia pages and the admins of Wikipedia had to ban all
 >> IP addresses of that country (fortunately Qatar has only one ISP).
 >> --[[PaweĊ‚|ptecza]]
+
+----
+
+## Error voting
+
+> Error: /srv/web/ikiwiki.info/todo/Configurable_minimum_length_of_log_message_for_web_edits/index.html independently created, not overwriting with version from todo/Configurable_minimum_length_of_log_message_for_web_edits
+
+[[users/jon]]
+
+----
+
+### Logging Out
+
+If I've logged in by OpenID, how do I log out?  I don't see any logout
+button anywhere on IkiWiki.  (is it because I hit "forever" for my OpenID authorization duration?)
+> No, it's because it's on the preferences page!  That's somewhat non-obvious...
+
+>> This is a problem with having a static wiki. If I just put "Logout" as
+>> an action on every page, that will look weird if you're not logged in.
+>> --[[Joey]]
+
+Even if IkiWiki does let me log out, how do I *stay* logged out?  Let's say I'm using a kiosk.  What's to prevent someone else from hitting my OpenID service right after I've walked away?  My OpenID service will just auth the login again, won't it? --[[sabr]]   (behavior seems to vary...  does it depend on the OpenID service?  guess I have some docs to read.)
+
+> If you're at a kiosk, you'll need to log out of your openid provider too.
+> Or use a provider that doesn't use cookies to keep you logged in. (Or
+> don't check the box that makes your provider set a cookie when you log in.)
+> 
+> AFAIK openid doesn't have single signoff capabilities yet. --[[Joey]]
+
+I'm having a problem using my preferred openid. I have
+http://thewordnerd.info configured as a delegate to
+thewordnerd.myopenid.com. It works fine on Lighthouse, Slicehost and
+everywhere else I've used it. Here, though, if I use the delegate I'm sent
+to my openid identity URL on myopenid.com. If I use the identity URL
+directly, I get the verification page.
+
+Is my delegation broken in some way that works for all these other apps but
+which fails here? Or is something broken in Ikiwiki's implementation?
+
+> I guess this is the same issue filed by you at
+> [[bugs/OpenID_delegation_fails_on_my_server]] --[[Joey]]
+
+Yes. I'd only recently set up my server as a delegate under wordpress, so still thought that perhaps the issue was on my end. But I'd since used my delegate successfully elsewhere, so I filed it as a bug against ikiwiki.