web commit by tschwinge: I'm running Debian unstable, not testing.
[ikiwiki.git] / doc / plugins / search / discussion.mdwn
index 1b57284e2437cde7f59b15efe7b0b419e6226940..494d0a38ac5f2241baeed3521cdbf6ee1cd2e823 100644 (file)
@@ -9,3 +9,36 @@ every time I refresh or rebuild the wiki:
 Nevertheless, searching for pages works as expected, as far as I can tell.
 
 --[[tschwinge]]
+
+Have you upgraded hyperestradier since setting up the wiki? Apparently it
+breaks a lot when it's upgraded, I find I often have to re-run ikiwiki
+-setup after upgrading hyperestradier to force it to rebuilt its database,
+then incremental updates work again for a while. This is one of the reasons
+I want to change to a different search backend. --[[Joey]]
+
+It was a completely fresh, completely untouched, unconfigured installation
+of hyperestrainer (Debian unstable on hurd-i386).
+Even when running an `ikiwiki --setup [...] --rebuild` I get this:
+
+    [...]
+    rendering templates/note.mdwn
+    rendering templates/popup.mdwn
+    updating hyperestraier search index
+    estcmd: ERROR: /home/wiki/wiki/.ikiwiki/hyperestraier: database problem
+    estcmd gather -cm -bc -cl -sd -cl /home/wiki/wiki/.ikiwiki/hyperestraier - exited nonzero: 256
+    done
+
+Now I did a `rm -rf ~wiki/wiki/.ikiwiki/hyperestraier` and re-ran
+`ikiwiki --setup [...] --rebuild`:
+
+    [...]
+    rendering templates/note.mdwn
+    rendering templates/popup.mdwn
+    updating hyperestraier search index
+    estcmd: ERROR: /home/wiki/wiki/.ikiwiki/hyperestraier: database problem
+    $ echo $?
+    141
+
+`--rebuild`ing once more, I'm back to the previous error message.
+
+--[[tschwinge]]