]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/changelog
implement aggregate_locking design
[ikiwiki.git] / debian / changelog
index d5117d867d1915226e870f096a49a9ea49ea8a55..1266666e3b4a40b7c062e037944137b87f7d92db 100644 (file)
-ikiwiki (2.20) UNRELEASED; urgency=low
+ikiwiki (2.31) UNRELEASED; urgency=low
+
+  * Revert preservation of input file modification times in output files,
+    since this leads to too many problems with web caching, especially with
+    inlined pages. Properly solving this would involve tracking every page
+    that contributes to a page's content and using the youngest of them all,
+    as well as special cases for things like the version plugin, and it's just
+    too complex to do.
+  * aggregate: Forking a child broke the one state that mattered: Forcing
+    the aggregating page to be rebuilt. Fix this.
+  * cgi hooks are now run before ikiwiki state is loaded.
+  * This allows locking the wiki before loading state, which avoids some
+    tricky locking code when saving a web edit.
+  * poll: This plugin turns out to have edited pages w/o doing any locking.
+    Oops. Convert it from a cgi to a sessioncgi hook, which will work
+    much better.
+  * recentchanges: Improve handling of links on the very static changes pages
+    by thunking to the CGI, which can redirect to the page, or allow it to be
+    created if it doesn't exist.
+  * recentchanges: Exipre all *._change pages, even if the directory
+    they're in has changed.
+  * aggregate: Lots of changes; aggregation can now run without locking the
+    wiki, and there is a separate aggregatelock to prevent multiple concurrent
+    aggregation runs.
+
+ -- Joey Hess <joeyh@debian.org>  Sat, 02 Feb 2008 23:36:31 -0500
+
+ikiwiki (2.30) unstable; urgency=low
+
+  [ Joey Hess ]
+  * Old versions of git-init don't support --git-dir or GIT_DIR with
+    --bare. Change ikiwiki-makerepo to use a method that should work with
+    those older versions too.
+  * aggregate: Don't let feeds set creation times for pages in the future.
+  * Add full parser for git diff-tree output (Brian Downing)
+  * aggregate: Fork a child process to handle the aggregation. This simplifies
+    the code, since that process can change internal state as needed, and
+    it will automatically be cleaned up for the parent process, which proceeds
+    to render the changes.
+
+  [ Josh Triplett ]
+  * Add trailing comma to commented-out umask in sample ikiwiki.setup, so
+    that uncommenting it does not break the setup file.
+
+  [ Joey Hess ]
+  * inline: The template can check for FIRST and LAST, which will be
+    set for the first and last inlined page. Useful for templates that build
+    tables and the like.
+  * prettydate,ddate: Don't ignore time formats passed to displaytime
+    function.
+  * Pages with extensions starting with "_" are internal-use, and will
+    not be rendered or web-edited, or matched by normal pagespecs.
+  * Add "internal()" pagespec that matches internal-use pages.
+  * RecentChanges is now a static html page, that's updated whenever a commit
+    is made to the wiki. It's built as a blog using inline, so it can have
+    an rss feed that users can subscribe to.
+  * Removed support for sending commit notification mails. Along with it went
+    the svnrepo and notify settings, though both will be ignored if left in
+    setup files. Also gone with it is the "user()" pagespec.
+  * Add refresh hook.
+  * meta: Add pagespec functions to match against title, author, authorurl,
+    license, and copyright. This can be used to create custom RecentChanges.
+  * meta: To support the pagespec functions, metadata about pages has to be
+    retained as pagestate.
+  * Fix encoding bug when pagestate values contained spaces.
+  * Add support for bzr, written by Jelmer Vernooij. Thanks also to bma for
+    his independent work on bzr support.
+  * Copyright file updates.
+
+ -- Joey Hess <joeyh@debian.org>  Sat, 02 Feb 2008 17:41:57 -0500
+
+ikiwiki (2.20) unstable; urgency=low
 
   * inline: Add copyright/license info on a per-post basis to atom
     feeds if available. (rss doesn't allow such info on a per-post basis)
+  * Also include overall copyright/license and author info in atom feeds if
+    available.
   * meta: Allow copyright/license metadata to contain arbitrary markup.
-
- -- Joey Hess <joeyh@debian.org>  Wed, 09 Jan 2008 00:34:46 -0500
+  * Call preprocessor hooks in void context during the scan pass. This allows
+    the hook to determine if it's just scanning, and avoid expensive
+    operations.
+  * img: Detect scan mode and avoid generating and writing the image file
+    during it, for a 2x speedup.
+  * meta: Run in scan mode again (more intelligently) and re-add support for
+    meta link.
+  * Fix support for the case where metadata appears after an inline directive
+    that needs to use it. This was broken in version 2.16.
+  * template: Remove bogus htmlize pass added in 2.16.
+  * template: Htmlize template variables, but also provide a raw version
+    via `<TMPL_VAR raw_variable>`.
+  * When htmlizing text, if the input is a single line with no newline,
+    and the htmlizer (such as markdown and textile) generates a html
+    paragraph, remove it. This allows removing several hacks from other
+    plugins that htmlize fragements of pages.
+  * In preferences, allow the subscriptions and email fields to be cleared.
+  * teximg: Fix to support the same formula on multiple pages.
+
+ -- Joey Hess <joeyh@debian.org>  Thu, 10 Jan 2008 14:52:57 -0500
 
 ikiwiki (2.19) unstable; urgency=low