]> sipb.mit.edu Git - ikiwiki.git/blobdiff - doc/forum/google_openid_broken__63__.mdwn
Add some more reasoning. Split out unrelated issue.
[ikiwiki.git] / doc / forum / google_openid_broken__63__.mdwn
index 890bba4d94d698337e3456f62a5a8599933936c9..1be9d0487d6a04467ff1ced7a02ddec6737f0461 100644 (file)
@@ -8,3 +8,23 @@ Any idea how to fix this??
 > and it's not clear to me that they intend regular openid to work at all.
 > What is your google openid URL so I can take a look at the data they are
 > providing? --[[Joey]] 
+
+
+http://openid-provider.appspot.com/larrylud
+
+> I've debugged this some and filed
+> <https://rt.cpan.org/Ticket/Display.html?id=48728> on the Openid perl
+> module. It's a pretty easy fix, so I hope upstream will fix it quickly.
+> --[[Joey]] 
+
+>> A little more information here:  I'm using that same openid provider at the moment.  Note that
+>> that provider isn't google - it is someone using the google API to authenticate.  I normally have it
+>> set up as a redirect from my home page (which means I can change providers easily).
+
+    <link rel="openid.server" href="http://openid-provider.appspot.com/will.uther">
+    <link rel="openid.delegate" href="http://openid-provider.appspot.com/will.uther">
+
+>> In that mode it works (I used it to log in to make this edit).  However, when I try the openid
+>> URL directly, it doesn't work.  I think there is something weird with re-direction.  I hope this
+>> isn't a more general security hole.
+>> -- [[Will]]