]> sipb.mit.edu Git - ikiwiki.git/blobdiff - debian/rules
Merge branch 'master' of ssh://git.ikiwiki.info/srv/git/ikiwiki.info
[ikiwiki.git] / debian / rules
index 25b1f57b6a636ffe170efaf6b208bb61346ef9b9..0a7ce7a267e43c0999d6e468f7e6844abbc8d660 100755 (executable)
@@ -1,44 +1,19 @@
 #!/usr/bin/make -f
+%:
+       dh $@
 
-build: build-stamp
-build-stamp:
-       dh_testdir
-       perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor
-       $(MAKE) -C po
-       $(MAKE)
-       $(MAKE) test
-       touch build-stamp
+override_dh_auto_configure:
+       # keeps it out of /usr/local
+       dh_auto_configure -- PREFIX=/usr
 
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-       perl Makefile.PL
-       if [ -e Makefile ]; then $(MAKE) realclean; fi
-       dh_clean
-
-binary-arch: build
+override_dh_compress:
+       # avoid compressing files in the doc wiki
+       dh_compress -Xhtml
 
-binary-indep: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       $(MAKE) pure_install DESTDIR=$(shell pwd)/debian/ikiwiki
-       dh_installdocs html
-       dh_installexamples doc/examples/*
-       dh_link usr/share/common-licenses/GPL-2 usr/share/doc/ikiwiki/html/GPL
-       dh_installchangelogs
-       dh_compress -X html
-       dh_fixperms
-       dh_perl
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
+override_dh_auto_clean:
+       # distclean moans about MANIFEST, this is quieter
+       if [ -e Makefile ]; then $(MAKE) realclean; fi
 
 # Not intended for use by anyone except the author.
 announcedir:
        @echo ${HOME}/src/ikiwiki/doc/news
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary