response
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>
Tue, 20 Feb 2007 03:05:04 +0000 (03:05 +0000)
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>
Tue, 20 Feb 2007 03:05:04 +0000 (03:05 +0000)
doc/bugs/xgettext_issue.mdwn

index 5e225aec853631bb3017586c55bd4e85642cb1cd..19ac816424dde361059dd41b43d28ce848e81579 100644 (file)
@@ -35,4 +35,9 @@ to make and make test just fine. --HarleyPig
 
 >>>> FWIW, I get the same error when building manually from SVN trunk on Ubuntu Edgy. I'm also using xgettext 0.15, because it's the latest version that's in the repos. However,
 >>>> I don't think that's the sole problem because I can build fine on another (Debian) box which is running _0.14.4_... I know very little about `gettext`, but could this be
 
 >>>> FWIW, I get the same error when building manually from SVN trunk on Ubuntu Edgy. I'm also using xgettext 0.15, because it's the latest version that's in the repos. However,
 >>>> I don't think that's the sole problem because I can build fine on another (Debian) box which is running _0.14.4_... I know very little about `gettext`, but could this be
->>>> related to my language settings? On the Edgy box I have `LANGUAGE=en_GB:en` and `LANG=en_GB.UTF-8`. The `ikiwiki` package installs on Edgy with no problems. --Ben
\ No newline at end of file
+>>>> related to my language settings? On the Edgy box I have `LANGUAGE=en_GB:en` and `LANG=en_GB.UTF-8`. The `ikiwiki` package installs on Edgy with no problems. --Ben
+
+>>>>> You'll only see the problem if it needs to rebuild po/ikiwiki.pot,
+>>>>> which it generally doesn't if you're just building the package. If
+>>>>> you edit files and build, it will rebuilt the pot and then fail with
+>>>>> older gettexts. --[[Joey]]