Migrate escaped directives (\[[) in doc/bugs to have \[[! prefix
authorSimon McVittie <smcv@ http://smcv.pseudorandom.co.uk/>
Mon, 21 Jul 2008 11:46:47 +0000 (12:46 +0100)
committerSimon McVittie <smcv@ http://smcv.pseudorandom.co.uk/>
Mon, 21 Jul 2008 11:46:47 +0000 (12:46 +0100)
doc/bugs/Map_sorts_subtags_under_a_different_tag.mdwn
doc/bugs/Toc_map_and_template_plugins_do_not_play_well_together.mdwn
doc/bugs/debbug_shortcut_should_expand_differently.mdwn
doc/bugs/img_plugin_causes_taint_failure.mdwn
doc/bugs/iniline_breaks_toc_plugin.mdwn
doc/bugs/map_doesn__39__t_calculate___34__common__95__prefix__34___correctly.mdwn
doc/bugs/special_characters_in_tag_names_need_manual_escaping.mdwn
doc/bugs/wiki_formatting_does_not_work_between_toc_and_an_inline.mdwn
doc/bugs/wikilink_in_table.mdwn

index 444de431b8bbf58229defab80485b973f69303d1..fe634e9c115733cc519cc249f37806128854d32a 100644 (file)
@@ -16,7 +16,7 @@ I have a few tags starting with `a` (abridged list):
 
 In `wiki-wc/factors/tag.mdwn`, I have a map for these tags:
 
 
 In `wiki-wc/factors/tag.mdwn`, I have a map for these tags:
 
-    \[[map pages="factors/tag/*"]]
+    \[[!map pages="factors/tag/*"]]
 
 and this works, except that for *whatever* reason, it actually sorts the three
 `affects/*` tags under `active`:
 
 and this works, except that for *whatever* reason, it actually sorts the three
 `affects/*` tags under `active`:
index 8c64dfa04d72e50a06d28228a20c0a7cbd187cc1..4849edd63c65e3a369a54cddc786bc0d3596d756 100644 (file)
@@ -8,7 +8,7 @@ The following renders incorrectly:
 
        # header2
 
 
        # header2
 
-       \[[map pages="sandbox"]]
+       \[[!map pages="sandbox"]]
 
 
 Removing the `\[[!toc]]` directive or moving it at the end of the page
 
 
 Removing the `\[[!toc]]` directive or moving it at the end of the page
index 22a1c149c1aa4b0ff02b2303cb0d3303a02c9e2c..d34c40244f56874afbad6dc9ce16541b815a1f3b 100644 (file)
@@ -1,4 +1,4 @@
-`\[[debbug 123456]]` expands to "bug #123456", which is hyperlinked. Could you please drop the leading "bug", for two reasons?
+`\[[!debbug 123456]]` expands to "bug #123456", which is hyperlinked. Could you please drop the leading "bug", for two reasons?
 
 First, #123456 is not a bug, it's a bug report. And second, #123456 suffices, doesn't it? By hardcoding the "bug" in there, you make it impossible to start a sentence with a bug number, e.g.:
 
 
 First, #123456 is not a bug, it's a bug report. And second, #123456 suffices, doesn't it? By hardcoding the "bug" in there, you make it impossible to start a sentence with a bug number, e.g.:
 
index e2b85e4983e32133a049d6bfd7f152ee27a49348..14de1755784327a0a7cefa75740c081b901ce2a8 100644 (file)
@@ -1,6 +1,6 @@
 The img plugin causes a taint failure if one tries to link a scaled image, e.g.
 
 The img plugin causes a taint failure if one tries to link a scaled image, e.g.
 
-    \[[img foo.png size=64x64]]
+    \[[!img foo.png size=64x64]]
 
     .ikiwiki.setup: Insecure dependency in mkdir while running with -T switch at /usr/lib/perl5/vendor_perl/5.8.8/IkiWiki.pm line 360.
     BEGIN failed--compilation aborted at (eval 5) line 109.
 
     .ikiwiki.setup: Insecure dependency in mkdir while running with -T switch at /usr/lib/perl5/vendor_perl/5.8.8/IkiWiki.pm line 360.
     BEGIN failed--compilation aborted at (eval 5) line 109.
index dcf975caf95384de372c2fa02ce9fd2e6833a5f6..a99f8d6dafae60f0fd02157a4a7faaaba7849e55 100644 (file)
@@ -1,7 +1,7 @@
 Hi, I try to make an example to reproduce some bug with inline and toc plugins.
 My friend uses
 
 Hi, I try to make an example to reproduce some bug with inline and toc plugins.
 My friend uses
 
-    \[[inline pages="users/joey" raw="yes"]]
+    \[[!inline pages="users/joey" raw="yes"]]
 
 to include common snippets in various pages, and it works as advertised, but if toc plugin is used, page is messed up.
 
 
 to include common snippets in various pages, and it works as advertised, but if toc plugin is used, page is messed up.
 
index d6923605d157fce7551959874191c4d5277aaeba..df00621d8459241af07f04ef364a21b39cbcc22f 100644 (file)
@@ -4,7 +4,7 @@ Problem with [[plugins/map]]:
 
 ## given map:
 
 
 ## given map:
 
-\[[map pages="blog/tags/*"]]
+\[[!map pages="blog/tags/*"]]
 
 ## received map:
 
 
 ## received map:
 
index 1a43ec3fcea98ef5583af48ae03ca515960f2913..4ff6763a33c21890958e7e7ce6952b2f615e0d01 100644 (file)
@@ -1,3 +1,3 @@
-Having read i18n_characters_in_post_title, I have a page named `St John's` in a file named `St_John__39__s.mdwn`.  Regular wikilinks like `\\[[St_John's]]` successfully point to that page.  However, if I tag a page with `\[[tag St_John's]]`, that link is shown as pointing to a non-existant page.  Modify the tag to read `\[[tag St_John__39__s]]` works around the problem.
+Having read i18n_characters_in_post_title, I have a page named `St John's` in a file named `St_John__39__s.mdwn`.  Regular wikilinks like `\\[[St_John's]]` successfully point to that page.  However, if I tag a page with `\[[!tag St_John's]]`, that link is shown as pointing to a non-existant page.  Modify the tag to read `\[[!tag St_John__39__s]]` works around the problem.
 
 [[done]] in 1.49 --[[Joey]]
 
 [[done]] in 1.49 --[[Joey]]
index a362fdf55876f01d00d15e73a3e117834d168943..29e03f2d61f12a5ce2212ff1a6247ea1fc62390e 100644 (file)
@@ -1,4 +1,4 @@
-Wiki formatting between `\[[toc ]]` and an inline fails to render.  The
+Wiki formatting between `\[[!toc ]]` and an inline fails to render.  The
 problem does not seem to trigger if the inline uses the titlepage template,
 or if it doesn't match any pages.  See example below; also reproducible
 with a single-file wiki containing the text below, rendered via `ikiwiki
 problem does not seem to trigger if the inline uses the titlepage template,
 or if it doesn't match any pages.  See example below; also reproducible
 with a single-file wiki containing the text below, rendered via `ikiwiki
index f0dc13eaf57db1b108f8be7b1a2c8b0b7f77987a..cca01718c124d494566d8a1364a079377fe63142 100644 (file)
@@ -1,6 +1,6 @@
 I try to create wikilink in table. But it does not work. Here is example:
 
 I try to create wikilink in table. But it does not work. Here is example:
 
-       \[[table class=table1 data="""
+       \[[!table class=table1 data="""
        \[[wikilink_test|index]]
        \[[wikilink_test\|index]]
        [wikilink test](/servers/webmail1)
        \[[wikilink_test|index]]
        \[[wikilink_test\|index]]
        [wikilink test](/servers/webmail1)
@@ -21,7 +21,7 @@ What exactly is a difference between wikilink and URL reference to the same page
 
 Trying to report this I found something weird. I changed in the example [[ with || because wiki renders something wrongly. You can see what I tried originally here:
 
 
 Trying to report this I found something weird. I changed in the example [[ with || because wiki renders something wrongly. You can see what I tried originally here:
 
-       \[[table class=table1 data="""
+       \[[!table class=table1 data="""
        \[[wikilink_test|servers/webmail1]]
        \[[wikilink_test|servers/webmail1]]
        [wikilink test](/servers/webmail1)
        \[[wikilink_test|servers/webmail1]]
        \[[wikilink_test|servers/webmail1]]
        [wikilink test](/servers/webmail1)