]> sipb.mit.edu Git - ikiwiki.git/commitdiff
some notes about the security (or lack thereof) of plugins
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>
Sun, 22 Oct 2006 21:12:21 +0000 (21:12 +0000)
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>
Sun, 22 Oct 2006 21:12:21 +0000 (21:12 +0000)
doc/security.mdwn

index fea0eb727d655fe2c7452174b08e3d718e7aae40..723c01863ea9a3bc291464dec7553b6bc91c625a 100644 (file)
@@ -158,6 +158,20 @@ allowed, so that's not a problem.)
 
 ----
 
+# Plugins
+
+The security of [[plugins]] depends on how well they're written and what
+external tools they use. The plugins included in ikiwiki are all held to
+the same standards as the rest of ikiwiki, but with that said, here are
+some security notes for them.
+
+* The [[plugins/img]] plugin assumes that imagemagick/perlmagick are secure
+  from malformed image attacks. Imagemagick has had security holes in the
+  past. To be able to exploit such a hole, a user would need to be able to
+  upload images to the wiki.
+
+----
+
 # Fixed holes
 
 _(Unless otherwise noted, these were discovered and immediately fixed by the