]> sipb.mit.edu Git - ikiwiki.git/commitdiff
* If Net::OpenID::Consumer is not available, the openid module will quietly
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>
Mon, 30 Apr 2007 04:41:53 +0000 (04:41 +0000)
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>
Mon, 30 Apr 2007 04:41:53 +0000 (04:41 +0000)
   disable itself, this avoids needing a hard dependency on the perl module.

IkiWiki/Plugin/openid.pm
debian/NEWS
debian/changelog
debian/control

index fcd53ee71c4973ffafc0f2a9e6871fed997eb97c..ab9fc560b3e415da3206a297f9645690fe9678ba 100644 (file)
@@ -26,6 +26,14 @@ sub formbuilder_setup (@) { #{{{
        my $form=$params{form};
        my $session=$params{session};
        my $cgi=$params{cgi};
+       
+       # Give up if module is unavailable to avoid needing to depend on
+       # it.
+       eval q{use Net::OpenID::Consumer};
+       if ($@) {
+               debug("unable to load Net::OpenID::Consumer, not enabling OpenID login");
+               return;
+       }
 
        if ($form->title eq "signin") {
                # This avoids it displaying a redundant label for the
index b2419673218f0be0730168ed2874cb269af12331..e66872b425fe89afe39f4165b714d0a6e1f878d4 100644 (file)
@@ -9,10 +9,10 @@ ikiwiki (2.00) unstable; urgency=low
     or edit your setup file to turn usedirs off:
        usedirs => 0,
 
-  * OpenID logins are now enabled by default. So ikiwiki now depends on the
-    Net::OpenID::Consumer perl module. Password logins are also still on by
-    default. If you like, you can turn either OpenID or password logins off
-    via the 'disable_plugins' setting.
+  * OpenID logins are now enabled by default, if the Net::OpenID::Consumer
+    perl module is available. Password logins are also still enabled
+    by default. If you like, you can turn either OpenID or password logins
+    off via the 'disable_plugins' setting.
 
  -- Joey Hess <joeyh@debian.org>  Sun, 29 Apr 2007 19:00:43 -0400
 
index aa7e086e6a638420720dff0b961fa074f2b6acc1..ae633075de7e1fa31d95fbd5d04472ee52e88cab 100644 (file)
@@ -1,4 +1,4 @@
-ikiwiki (2.00) UNRELEASED; urgency=low
+ikiwiki (2.00) unstable; urgency=low
 
   [ Josh Triplett ]
   * Avoid using GNU extensions to cp during "make install", which did
@@ -16,7 +16,11 @@ ikiwiki (2.00) UNRELEASED; urgency=low
   * fieldset support appeared in CGI::FormBuilder 3.05, so increase
     version in Depends on libcgi-formbuilder-perl to 3.05
 
- -- Josh Triplett <josh@freedesktop.org>  Sun, 29 Apr 2007 19:52:16 -0700
+  [ Joey Hess ]
+  * If Net::OpenID::Consumer is not available, the openid module will quietly
+    disable itself, this avoids needing a hard dependency on the perl module.
+
+ -- Joey Hess <joeyh@debian.org>  Mon, 30 Apr 2007 00:43:02 -0400
 
 ikiwiki (1.51) unstable; urgency=low
 
index 35f409ec61c2179e7d1c289944c235c83579f887..2ec114d679716a6ec8458de6b91e149bddf91d41 100644 (file)
@@ -11,8 +11,8 @@ XS-Vcs-Browser: http://ikiwiki.info/cgi-bin/viewvc.cgi/trunk/?root=ikiwiki
 
 Package: ikiwiki
 Architecture: all
-Depends: ${perl:Depends}, libxml-simple-perl, markdown, libtimedate-perl, libhtml-template-perl, libhtml-scrubber-perl, libcgi-formbuilder-perl (>= 3.05), libtime-duration-perl, libcgi-session-perl (>= 4.14-1), libmail-sendmail-perl | libnet-openid-consumer-perl, gcc | c-compiler, libc6-dev | libc-dev, libhtml-parser-perl, liburi-perl
-Recommends: subversion | git-core | tla | mercurial, hyperestraier
+Depends: ${perl:Depends}, libxml-simple-perl, markdown, libtimedate-perl, libhtml-template-perl, libhtml-scrubber-perl, libcgi-formbuilder-perl (>= 3.05), libtime-duration-perl, libcgi-session-perl (>= 4.14-1), libmail-sendmail-perl, gcc | c-compiler, libc6-dev | libc-dev, libhtml-parser-perl, liburi-perl
+Recommends: subversion | git-core | tla | mercurial, hyperestraier, libnet-openid-consumer-perl
 Suggests: viewvc | viewcvs, librpc-xml-perl, libtext-wikiformat-perl, python-docutils, polygen, tidy, libxml-feed-perl, libmailtools-perl, perlmagick, libfile-mimeinfo-perl, libcrypt-ssleay-perl, liblocale-gettext-perl (>= 1.05-1), libtext-typography-perl, libtext-csv-perl, libdigest-sha1-perl, graphviz
 Conflicts: ikiwiki-plugin-table
 Replaces: ikiwiki-plugin-table