this patch doesn't make the situation worse, actually
authorhttps://id.koumbit.net/anarcat <https://id.koumbit.net/anarcat@web>
Mon, 15 Sep 2014 20:30:44 +0000 (16:30 -0400)
committeradmin <admin@branchable.com>
Mon, 15 Sep 2014 20:30:44 +0000 (16:30 -0400)
doc/bugs/notifyemail_fails_with_some_openid_providers.mdwn

index 91aeda453b88d27c2c265b0f34aaa676dc08bf63..c4542c8d02357952b1eea3f7c45b287a0f263ae9 100644 (file)
@@ -93,3 +93,5 @@ Any other ideas? --[[anarcat]]
 >>>> hmm... true, that is a problem, especially for hostile wikis. but then any hostile site could send you such garbage - they would be spammers then. otherwise, you could ask the site manager to disable that account...
 >>>>
 >>>> this doesn't seem to be a very big security issue that would merit implementing a new verification mechanism, especially since we don't verify email addresses on accounts right now. what we could do however is allow password authentication on openid accounts, and allow those users to actually change settings like their email addresses. however, I don't think this should be blocking that functionality right now. --[[anarcat]]
+>>>>
+>>>> besides, the patch I am proposing doesn't make the vulnerability worse at all, it exists right now without the patch. my patch only allows users that **don't** have an email set (likely because their openid provider is more discreet) to set one... --[[anarcat]]