move the release template to the softwaresite example
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>
Wed, 14 Feb 2007 01:22:32 +0000 (01:22 +0000)
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>
Wed, 14 Feb 2007 01:22:32 +0000 (01:22 +0000)
doc/examples/softwaresite/templates/release.mdwn [moved from doc/templates/release.mdwn with 77% similarity]
doc/examples/softwaresite/templates/release/discussion.mdwn [moved from doc/templates/release/discussion.mdwn with 86% similarity]
doc/news/version_1.40.mdwn
doc/news/version_1.41.mdwn
doc/news/version_1.42.mdwn

similarity index 77%
rename from doc/templates/release.mdwn
rename to doc/examples/softwaresite/templates/release.mdwn
index e9abd1ada7cd485b0a8c471e97ddd2a5d7d52b25..b8b0abffcc4e006f2b2e6f0339dccce0a0300352 100644 (file)
@@ -1,4 +1,4 @@
-<TMPL_IF news>News for ikiwiki <TMPL_VAR version>:
+<TMPL_IF news>News for FooBar <TMPL_VAR version>:
 
 <TMPL_VAR news>
 
 
 <TMPL_VAR news>
 
similarity index 86%
rename from doc/templates/release/discussion.mdwn
rename to doc/examples/softwaresite/templates/release/discussion.mdwn
index a0fe4aeeb909bccdc5f70810f64232245757dc07..f1794d8bf72588651a15a4c91e50b7fc1b335e63 100644 (file)
@@ -10,3 +10,6 @@ I'd rather not use a template for my release announcements, because these announ
 > you have already done so, then could you post a link to them?
 >
 > --[[JoshTriplett]]
 > you have already done so, then could you post a link to them?
 >
 > --[[JoshTriplett]]
+
+>> No problem. My release script is here:
+>> <http://svn.kitenet.net/trunk/bin/wikiannounce> --[[Joey]]
index d595ff7de713b6562cc760e5eba04d3df589a82c..c3455c3f291946929430cfea3076f617162e5f63 100644 (file)
@@ -1,5 +1,5 @@
-[[template id=release version="1.40" changelog="""
+ikiwiki 1.40 released with [[toggle text="these changes"]]
+[[toggleable text="""
    * Fix missing categories in RSS/Atom feeds.
    * Add French translation by Jean-Luc Coulon. Closes: #[406881](http://bugs.debian.org/406881)
    * Fix missing categories in RSS/Atom feeds.
    * Add French translation by Jean-Luc Coulon. Closes: #[406881](http://bugs.debian.org/406881)
-   * Fix bogus use of CDATA in Atom feeds. Closes: #[406898](http://bugs.debian.org/406898)
-"""]]
+   * Fix bogus use of CDATA in atom feeds. Closes: #[406898](http://bugs.debian.org/406898)"""]]
index 25dc574fb21dd3ea72e26c01a5afb8a6a8c57e35..70d1eb53372d66c8b53fea28648170cf2de4e94e 100644 (file)
@@ -1,4 +1,5 @@
-[[template id=release version="1.41" changelog="""
+ikiwiki 1.41 released with [[toggle text="these changes"]]
+[[toggleable text="""
    * Gettext 1.04 or up is needed for the OO interface that ikiwiki needs,
      if an older version is installed, just don't gettext strings, instead of
      crashing.
    * Gettext 1.04 or up is needed for the OO interface that ikiwiki needs,
      if an older version is installed, just don't gettext strings, instead of
      crashing.
@@ -20,5 +21,4 @@
    * More gettext fun.
    * Fix openid signin secret generation code. This fixes the bug that made
      all openid signins fail the first time, and then succeed the second
    * More gettext fun.
    * Fix openid signin secret generation code. This fixes the bug that made
      all openid signins fail the first time, and then succeed the second
-     time.
-"""]]
+     time."""]]
index 7ba2a51724c693482a0dbf05cea93de541de549b..fcbf117cab4f6c048119c13b4bfa17e9d64c792d 100644 (file)
@@ -1,4 +1,5 @@
-[[template id=release version="1.42" news="""
+News for ikiwiki 1.42:
+
 The `anonok` setting in config files has been removed. To enable anonymous
 edits on your wiki, you should now enable the [[anonok_plugin|plugins/anonok]]
 instead.
 The `anonok` setting in config files has been removed. To enable anonymous
 edits on your wiki, you should now enable the [[anonok_plugin|plugins/anonok]]
 instead.
@@ -6,7 +7,9 @@ instead.
 [[Third-party_plugins|plugins/contrib]] that use `pagespec_match()` should be
 updated to pass the new third parameter `from` to that function. This is
 needed for the new relative glob matching to work.
 [[Third-party_plugins|plugins/contrib]] that use `pagespec_match()` should be
 updated to pass the new third parameter `from` to that function. This is
 needed for the new relative glob matching to work.
-""" changelog="""
+
+ikiwiki 1.42 released with [[toggle text="these changes"]]
+[[toggleable text="""
    * Fix several more missing translations of Discussion.
    * Fix for missing `backlinks()` in [[pagestats_plugin|plugins/pagestats]].
    * Add `canedit` hook, allowing arbitrary controls over when a page can be
    * Fix several more missing translations of Discussion.
    * Fix for missing `backlinks()` in [[pagestats_plugin|plugins/pagestats]].
    * Add `canedit` hook, allowing arbitrary controls over when a page can be
@@ -39,5 +42,4 @@ needed for the new relative glob matching to work.
      to exist in the wiki, and the web user would need to somehow use the web
      based editor to replace it with malicious content.
      (Sorry Josh, this means you can't edit style.css directly anymore,
      to exist in the wiki, and the web user would need to somehow use the web
      based editor to replace it with malicious content.
      (Sorry Josh, this means you can't edit style.css directly anymore,
-     although I do appreciate your fixes, actually..)
-"""]]
+     although I do appreciate your fixes, actually..)"""]]