Explicitly depend on CGI.pm, which is no longer in Perl core
authorSimon McVittie <smcv@debian.org>
Thu, 16 Oct 2014 08:45:36 +0000 (09:45 +0100)
committerSimon McVittie <smcv@debian.org>
Thu, 16 Oct 2014 21:24:48 +0000 (22:24 +0100)
I was going to depend on the version that has CGI->param_fetch,
but that has been supported since 2.37, which is older than oldstable.

debian/control

index 5b9d55c4d60aebbfe1d2ad7e3efce4597b86f688..88d783981d2dd692e5b1ac7a2acc28a958462a2f 100644 (file)
@@ -27,7 +27,7 @@ Recommends: gcc | c-compiler,
   libc6-dev | libc-dev,
   git (>= 1:1.7) | git-core (>= 1:1.5.0) | subversion | tla | bzr (>= 0.91) | mercurial | monotone (>= 0.38) | darcs,
   libxml-simple-perl, libnet-openid-consumer-perl, libcrypt-ssleay-perl,
   libc6-dev | libc-dev,
   git (>= 1:1.7) | git-core (>= 1:1.5.0) | subversion | tla | bzr (>= 0.91) | mercurial | monotone (>= 0.38) | darcs,
   libxml-simple-perl, libnet-openid-consumer-perl, libcrypt-ssleay-perl,
-  liblwpx-paranoidagent-perl, libtimedate-perl,
+  liblwpx-paranoidagent-perl, libtimedate-perl, libcgi-pm-perl,
   libcgi-formbuilder-perl (>= 3.05), libcgi-session-perl (>= 4.14-1),
   libmail-sendmail-perl, libauthen-passphrase-perl, libterm-readline-gnu-perl,
   libgravatar-url-perl, librpc-xml-perl,
   libcgi-formbuilder-perl (>= 3.05), libcgi-session-perl (>= 4.14-1),
   libmail-sendmail-perl, libauthen-passphrase-perl, libterm-readline-gnu-perl,
   libgravatar-url-perl, librpc-xml-perl,