]> sipb.mit.edu Git - ikiwiki.git/commitdiff
sanitise them, like any other page type.
authorjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>
Tue, 4 Jul 2006 00:21:48 +0000 (00:21 +0000)
committerjoey <joey@0fa5a96a-9a0e-0410-b3b2-a0fd24251071>
Tue, 4 Jul 2006 00:21:48 +0000 (00:21 +0000)
* Rebuilding wrappers is necessary on upgrade to this version.

debian/NEWS
debian/changelog
debian/postinst

index 858894e052a8e4f3712ec404475ae5dff69b62c3..80cb489be295ec3d320cefd7721f8a899049f02b 100644 (file)
@@ -4,16 +4,21 @@ ikiwiki (1.8) unstable; urgency=low
   stop setting the "plugin" list directly, and instead add or remove plugins
   via the add_plugins and disable_plugins lines. For example, if you had:
 
-  plugin => [qw{inline smiley search}],
+       plugin => [qw{inline smiley search}],
 
   Change it to these lines, which disables the default htmlscrubber plugin
   and adds the two additional plugins:
 
-  add_plugins => [qw{smiley search}],
-  disable_plugins => [qw{htmlscrubber}],
+       add_plugins => [qw{smiley search}],
+       disable_plugins => [qw{htmlscrubber}],
 
   Making this change makes your ikiwiki setup file more future-proof since
   new default plugins will be automatically used.
+  
+  You will need to rebuild your wiki when upgrading to this version.
+  If you listed your wiki in /etc/ikiwiki/wikilist this will be done
+  automatically when the Debian package is upgraded. Or use
+  ikiiki-mass-rebuild to force a rebuild.
 
  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 16:59:29 -0400
 
index b95b6b7681ea98669cff7cd13c068e662ba6a14d..1e5739e58538fc925cee5c5cd0964c76dca84d6a 100644 (file)
@@ -33,7 +33,8 @@ ikiwiki (1.8) UNRELEASED; urgency=low
     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
     defaults to not processing .html files, since w/o this plugin they would
     be copied unsanitised. With this plugin, it will process, and html
-    sanitise, them like any other page type.
+    sanitise them, like any other page type.
+  * Rebuilding wrappers is necessary on upgrade to this version.
 
  -- Joey Hess <joeyh@debian.org>  Mon,  3 Jul 2006 18:15:30 -0400
 
index 72b457716af6434e74b45994bc4c23d42b647df6..fbfc60045d55609cffdf25a520e5a700c54621d5 100755 (executable)
@@ -4,7 +4,7 @@ set -e
 
 # Change this when some incompatible change is made that requires
 # rebuilding all wikis.
-firstcompat=1.4
+firstcompat=1.8
 
 if [ "$1" = configure ] && \
    dpkg --compare-versions "$2" lt "$firstcompat"; then