]> sipb.mit.edu Git - ikiwiki.git/commitdiff
how important is perl 5.10?
authorJon Dowland <jmtd@debian.org>
Fri, 23 Apr 2010 15:29:05 +0000 (16:29 +0100)
committerJon Dowland <jmtd@debian.org>
Fri, 23 Apr 2010 15:29:05 +0000 (16:29 +0100)
doc/setup/discussion.mdwn

index b71263dae42580f7cf8f32fa6e87d131d0fe47f3..2000c5dfb70286eb2f5e749671c68cd0314f943b 100644 (file)
@@ -245,3 +245,12 @@ Thank you! I'm not a Perl programmer, so what's your opinion: is this behavior a
 
 I am experiencing the same problem "/etc/ikiwiki/custom: failed to set up the repository with ikiwiki-makerepo
 " on Debian squeeze with perl5.10.0. Upgrading to ikiwiki 3.10 fixes it. -- [Albert](http://www.docunext.com/)
+
+----
+
+Just a note, perl 5.10 isn't packaged as part of RHEL or thus CentOS nor EPEL,
+so it's not especially trivial to satisfy that requirement for ikiwiki on
+those platforms, without backporting it from Fedora or building from source.
+However, I have an ikiwiki 3.20100403 running on RHEL-4 supplied 5.8.8 without
+(seemingly too much) complaint.  How strong is the 5.10 requirement? what
+precicely breaks without it? -- [[Jon]]