I hope pkgsrc also no longer has these problems
authorAmitai Schlair <schmonz-web-ikiwiki@schmonz.com>
Wed, 17 Sep 2014 22:53:45 +0000 (18:53 -0400)
committerAmitai Schlair <schmonz-web-ikiwiki@schmonz.com>
Wed, 17 Sep 2014 22:53:45 +0000 (18:53 -0400)
doc/plugins/openid/troubleshooting.mdwn

index a3637a26f79e95a82e22c9f5a284959e078643b9..40c3e5c8c34d8c0226cbe465e18516ada6e09361 100644 (file)
@@ -142,6 +142,11 @@ module.
 > To be clear, these are patches to [[!cpan LWPx::ParanoidAgent]].
 > Debian's `liblwpx-paranoidagent-perl (>= 1.10-3)` appears to
 > have those two patches. --[[smcv]]
+>
+> Irrelevant to this ikiwiki instance, perhaps relevant to others:
+> I've added these patches to [pkgsrc](http://www.pkgsrc.org)'s
+> `www/p5-LWPx-ParanoidAgent` and they'll be included in the
+> soon-to-be-cut 2014Q3 branch. --[[schmonz]]
 
 ## Still naive_verify_failed_network, new improved reason
 
@@ -219,6 +224,8 @@ yet.
 
 > Also in Debian's `liblwpx-paranoidagent-perl (>= 1.10-3)`, for the record.
 > --[[smcv]]
+>
+> And now in pkgsrc's `www/p5-LWPx-ParanoidAgent`, FWIW. --[[schmonz]]
 
 Only that still doesn't end the story, because that hand didn't know what
 [this hand](https://github.com/noxxi/p5-io-socket-ssl/commit/4f83a3cd85458bd2141f0a9f22f787174d51d587#diff-1)
@@ -247,6 +254,10 @@ server name for SNI:
 > (which is where ikiwiki.info's supporting packages come from).
 > Please report it upstream too, if the Debian maintainer doesn't
 > get there first. --[[smcv]]
+> 
+> Applied in pkgsrc. I haven't attempted to conduct before-and-after
+> test odysseys, but here's hoping your travails save others some
+> time and effort. --[[schmonz]]
 
 # Success!!