]> sipb.mit.edu Git - ikiwiki.git/commitdiff
Add conflict with libyaml-libyaml-perl, since that library does not support utf8...
authorJoey Hess <joey@kitenet.net>
Fri, 6 May 2011 18:38:27 +0000 (14:38 -0400)
committerJoey Hess <joey@kitenet.net>
Fri, 6 May 2011 18:38:27 +0000 (14:38 -0400)
debian/changelog
debian/control
doc/bugs/yaml_setup_file_does_not_support_UTF-8_if_XS_is_installed.mdwn

index bb9f9d2f87fcf5a89973f0330915e3fe6c12a3dd..fc8fafc708c4ce8e971e512b74703005184ba92c 100644 (file)
@@ -3,6 +3,9 @@ ikiwiki (3.20110431) UNRELEASED; urgency=low
   * Danish translation update. Closes: #625721
   * Danish underlay translation update. Closes: #625765
     (Thanks, Jonas Smedegaard)
+  * Add conflict with libyaml-libyaml-perl, since that library does
+    not support utf8. Closes: #625713
+    (see https://rt.cpan.org/Public/Bug/Display.html?id=54683)
 
  -- Joey Hess <joeyh@debian.org>  Thu, 05 May 2011 13:02:19 -0400
 
index eaf67a37cd700ac66ea6b57f311263f41dccf2a3..616963216eddb8da1c621aa046b5c0806f4f604c 100644 (file)
@@ -39,7 +39,7 @@ Suggests: viewvc | gitweb | viewcvs, libsearch-xapian-perl,
   libsparkline-php, texlive, dvipng, libtext-wikicreole-perl,
   libsort-naturally-perl, libtext-textile-perl, libhighlight-perl,
   po4a (>= 0.35-1), gettext
-Conflicts: ikiwiki-plugin-table
+Conflicts: ikiwiki-plugin-table, libyaml-libyaml-perl
 Replaces: ikiwiki-plugin-table
 Provides: ikiwiki-plugin-table
 Description: a wiki compiler
index 349464844b798bf280100aa1a53d0331316dbaf0..11032cde21651368649085f1989314a012e9e367 100644 (file)
@@ -62,4 +62,7 @@ preferred one?
 >>> these will anyway be kinda ugly, so...
 
 >>>> I was wrong: I just experienced that bug with YAML::XS 0.34-1
->>>> too. Seems like [[!cpanrt 54683]]. --[[intrigeri]]
+>>>> too. Seems like [[!cpanrt 54683]]. --[[intrigeri]]a
+
+>>>>> Yes, [[!debbug 625713]] reports this also affects debian unstable.
+>>>>> So, I will add a conflict I guess. [[done]] --[[Joey]]