]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
web commit by StefanoZacchiroli
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.27) UNRELEASED; urgency=low
2
3   * Add a googlecalendar plugin. A bit special-purpose, but it shows
4     one way to to deal with user-supplied content that could cause XSS
5     issues w/o the htmlscrubber, and won't survive the scrubber.
6   * Work on firming up the plugin interface:
7     - Plugins should not need to load IkiWiki::Render to get commonly
8       used functions, so moved some functions from there to IkiWiki.
9     - Picked out the set of functions and variables that most plugins
10       use, documented them, and made IkiWiki export them by default,
11       like a proper perl module should.
12     - Use the other functions at your own risk.
13     - This is not quite complete, I still have to decide whether to
14       export some other things.
15   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16     referring to stuff now exported by the IkiWiki module.
17   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18     to declare which version of the interface your plugin needs.
19   * Anyone with a third-party ikiwiki plugin is strongly encouraged
20     to make like changes to it and avoid use of non-exported symboles from
21     "IkiWiki::".
22   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23   * Support hyperestradier version 1.4.2, which adds a new required phraseform
24     setting.
25   * If an inlined page has a permalink, link the page title to that.
26   * Patch from Recai to use utf8 when reading the setup file, so that
27     utf8 wikinames from there will be used properly.
28   * Patch from Recai to kill utf-8 on the wiki name when generating the
29     session cookie.
30   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31   * Fix a baseurl problem in hyperestradier search results.
32   * Add a stub local.css to avoid problems with 404's.
33   * Patch from Recai to fix a wide character warning from the search plugin
34     during setup if the wikiname contains utf8.
35   * Yet another fix for those poor case-insensative `OSX users.
36   * pagetemplate hooks are now also called when generating cgi pages.
37   * Add a favicon plugin, which simply adds a link tag for an icon to each
38     page (and cgis).
39   * Patch from James Westby to deal with the case where you're editing a
40     new page, hit cancel, and need to be redirected to somewhere sane.
41   * Various documentation improvements by various wiki users.
42   * Support Text::Markdown from CPAN, which has a different interface from
43     the original markdown or the one in Debian.
44   * Version the libcgi-session-perl dependency, some features that need
45     the new version are used in some cases (sslcookie).
46   * Numerous tla fixes from Clint.
47   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
48     a multi-resolution favicon.ico.
49   * README.Debian: typo Closes: #388110
50   * chomp trailing newline at the end of templates read in by the template
51     plugin, to allow use of the template preprocessor directive in
52     whitespace-sensative situations. Closes: #387073
53   * Patch from James Westby to make the location of the estseek.cgi script
54     configurable.
55
56  -- Joey Hess <joeyh@debian.org>  Mon, 18 Sep 2006 16:43:10 -0400
57
58 ikiwiki (1.26) unstable; urgency=low
59
60   * Add a missing -n to tla undo call.
61   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
62     writes before consuming its whole stdin. Avoid this deadlock.
63   * Fix alt tags for outline checkboxes.
64
65  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
66
67 ikiwiki (1.25) unstable; urgency=low
68
69   * Add proper waitpid calls for open2ed processes throughout to avoid
70     zombies; this hit htmltidy especially badly.
71   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
72     subversion repos and fixing some other issues.
73   * Add support for tla, contributed by Clint Adams. Closes: #385936
74   * Add support for mercurial, contributed by Emanuele Aina.
75   * Include <link rel> tag for RSS feeds, used by some aggregators and
76     firefox to find the feed.
77   * Add a linkmap plugin (requires graphviz).
78
79  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
80
81 ikiwiki (1.24) unstable; urgency=low
82
83   * Simplify the data structure returned by rcs_recentchanges to avoid
84     each rcs plugin needing to form complex strings on its own.
85   * Fix another destpage issue in the inline directive. Closes: #385512
86     again.
87
88  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
89
90 ikiwiki (1.23) unstable; urgency=low
91
92   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
93
94  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
95
96 ikiwiki (1.22) unstable; urgency=low
97
98   * Change how the stylesheet url is determined in the templates: Remove
99     STYLEURL and add BASEURL to all templates (some already had it). This
100     new more general variable can be used to link to other things (eg, images)
101     from the template, as well as stylesheets.
102   * Fix a bug introduced last version to do with nested inlines.
103   * Allow preprocessor directives to span multiple lines, both to make
104     long ones with lots of values easier to write, and to allow for ones with
105     multi-line quoted values.
106   * Allow preprocessor directives to contain python-like triple-quoted
107     text blocks, for easy nesting of quotes inside.
108   * Add a template plugin.
109   * Make pagespec merge code smarter about merging duplicate pagespecs.
110   * Patch from Jordà Polo to make Setup::Standard support hashes in config
111     files.
112   * Change order of linkify and preprocess; first preprocess and then linkify.
113     This allows passing a wikilink inside a parameter to a preprocessor
114     directive without it being expanded to html, and leaking out of the
115     parameter, which had required some non-obvious use of triple-quoting
116     to avoid. Note that any preprocessor plugins that output something
117     that looks like a wikilink will now have it treated as such; AFAIK
118     this doesn't change any behavior though except for the template plugin.
119   * Enable preprocessor directives when previewing an edit.
120   * Make all pages pull in a local.css style sheet, if present. This won't
121     be included in ikiwiki, but can be created to make local styling changes
122     w/o needing to merge in every new change to the distributed style.css.
123   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
124   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
125     from a different directory.
126   * Generalised preprocesser loop protection code.
127   * Patch from James Westby to allow a description to be set for rss feeds.
128   * Patch from James Westby to add a template for the search form.
129   * Added a ddate plugin.
130   * Patch from James Westby to add a --sslcookie switch, which forces
131     cookies to only be sent over ssl connections to avoid interception.
132   * Fix preferences page on anonok wikis; still need to sign in to get
133     to the preferences page.
134   * Add toc (table of contents) plugin.
135   * Change htmlize, format, and sanitize hooks to use named parameters.
136   * Patch from James Westby to add an actions option to inline; this
137     adds Edit and Discussion links at the end of blog entries.
138   * Due to some css changes, you'll want to rebuild your wiki on upgrade
139     to this version. Will be handled automatically by the deb.
140   * Add processed date to aggregate preprocessor directive status output.
141
142  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
143
144 ikiwiki (1.21) unstable; urgency=low
145
146   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
147   * If a page links to itself, mark up the link text in a span with
148     class="selflink" so that it can be styled. I don't have a useful style
149     defined for that though.
150   * Call filter hooks on inlined page content.
151   * Support inlining pages raw, rather than creating a blog.
152   * Clean up yes/no parameter parsing in inline plugin.
153   * Implemented better cycle detection in the inline plugin; nested inlines
154     will now work.
155   * Add a map plugin contributed by Alessandro Dotti Contra.
156   * Add otl format plugin, which handles files as created by vimoutliner.
157   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
158   * Add first draft at a Restructured Text (rst) plugin, by Sergio
159     Talens-Oliag. Note that this has many known issues -- see the caveats on
160     the plugin's page.
161   * Credit everyone who wrote a plugin on the plugins' wiki pages.
162   * Fix utf-8 in blog post form.
163
164  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
165
166 ikiwiki (1.20) unstable; urgency=low
167
168   * Relicense the templates and basewiki under the 2-clause BSD license.
169     Since these can easily become part of other people's websites, they
170     should be under as permissive a license as possible.
171   * Add --syslog config option, to log to the syslog.
172   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
173     transient failure to fork (which I've seen happen in the wild).
174   * Fix a bug in the aggregator introduced last version that caused all
175     aggregator state to be lost during a non-aggregating build.
176
177  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
178
179 ikiwiki (1.19) unstable; urgency=low
180
181   * Fix several related bugs in page type determination during online editing.
182   * Add some locking to prevent 2 aggregators from running at once.
183   * Fix an infinite loop in the aggregator when finding a unique filename.
184
185  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
186
187 ikiwiki (1.18) unstable; urgency=low
188
189   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
190   * Add --version.
191   * Man page format fixups.
192   * If the meta plugin overides the page title, set a title_overridden
193     variable in the template to true. This allows doing things with the
194     templates conditional on the title being overriden.
195   * Add a %pagecase which maps lower-case page names to the actual case
196     used in the filename. Use this in bestlinks calculation instead of
197     forcing the link to lowercase.
198   * Also use %pagecase in various other places that want to check if a page
199     with a given name exists.
200   * This means that links to pages with mixed case names will now work,
201     even if the link is in some other case mixture, and mixed case pages
202     should be fully supported throughout ikiwiki.
203   * Recommend rebuilding wikis on upgrade to this version.
204
205  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
206
207 ikiwiki (1.17) unstable; urgency=low
208
209   * Disable tidy generator tag.
210   * Move tidy back to sanitize hook, found out how to only show body.
211   * Turn off tidy indentation too.
212   * Turn on HTML::Template loop_context_vars; not actually used in stock
213     templates but can be useful for things like making comma-delimited lists
214     of tags or what have you.
215   * Remove <br> from end of aggregate preprocessor directive output.
216   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
217     case-sensative filesystems like OSX.
218   * Improve markdown loading. First, try to load it as a proper perl module,
219     in case it was installed as one. Then fall back to trying
220     /usr/bin/markdown.
221   * Document in install page how to install markdown, since it has no
222     installation procedure in the upstream tarball.
223   * Set die_on_bad_params => 0 for all templates, to allow users to modify
224     them without annoyances.
225   * Suck in the page content when generating an inline archive page, to work
226     around the meta plugin's lack of caching of title metadata across runs.
227
228  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
229
230 ikiwiki (1.16) unstable; urgency=low
231
232   * Try to handle relative links in aggregated feeds. However,
233     the current support is a crude hack due to limitations of XML::Feed:
234     xml:base is not supported, neither is Content-Location. And of course,
235     relative links in RSS feeds are ill-undefined..
236   * Make aggregator save permalinks and author name to pages as metadata.
237   * Add permalink and author support to meta plugin, affecting RSS feeds
238     and blog pages.
239   * Various CSS and formatting changes.
240   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
241   * Add xhtml files to the default prune regexp.
242   * Also generate rel=bookmark links for permalinks.
243   * Fix the htmltidy plugin, which wasn't working due my breaking it when
244     I added it..
245   * Don't run tidy with -xml as that fails if the input is not well-formed.
246     Run it with -asxhtml instead, so it will output well-formed xhtml no
247     matter what the input.
248   * Disable tidy warnings too.
249   * Add a new format hook, and make tidy use it, since tidy can really only
250     operate on and output complete html documents, not the body chunks
251     that sanitise gets.
252   * Fix dates in rss feeds if running localised, so they're still rfc 822.
253
254  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
255
256 ikiwiki (1.15) unstable; urgency=low
257
258   * Remove CDPATH and other env vars perl taint checking doesn't like.
259     Closes: #381279
260   * Added created_before and created_after PageSpec limits.
261
262  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
263
264 ikiwiki (1.14) unstable; urgency=low
265
266   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
267     by 10% or so.
268   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
269   * Added many unit tests for pagespec_match.
270
271  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
272
273 ikiwiki (1.13) unstable; urgency=low
274
275   * ikiwiki can now download and aggregate feeds with its new aggregate
276     plugin, so it's possible to implement a Planet using ikiwiki!
277   * Add a run_hooks function for the common task of running all hooks of a
278     given type.
279   * Add a savestate hook.
280   * Don't put blog post forms on pages if there's no cgiurl set.
281   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
282     --wrappers to do that.
283   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
284     to update pages that haven't changed on disk.
285   * Change meta tags to use html entity-escaped text for values, so that
286     quotes and such can be represented in title tags.
287   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
288     for the above.
289   * Make --rebuild also cause --aggregate to re-download and write aggregated
290     pages.
291   * Avoid outputting duplicate meta info.
292   * Include title metadata on aggregated posts for capitalised and un-munged
293     titles.
294   * Title metadata of inlined pages now shows up in blogs and rss feeds.
295   * Fix issue with unicode filenames and updating the hyper estradier search
296     index. (Aka Please Please Please, let that be the last one.)
297   * Patch from Roland Mas to support an rss=no parameter to inline directives.
298     Closes: #380743
299   * Renamed GlobLists to PageSpecs.
300   * PageSpecs can now include nested parens, "and", and "or". This remains
301     backwards compatible to the old GlobList format. It's implemented by
302     treating the GlobList as a very limited microlanguage that is transformed
303     to perl code that does the matching.
304   * The old GlobList format is deprecated, and I encourage users to switch to
305     using the new PageSpec format. Compatability with the old format will be
306     removed at some point, possibly by 2.0.
307   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
308   * Add support for creation_month and creation_year to PageSpec.
309     Closes: #380680
310   * Changes to index file encoding.
311
312  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
313
314 ikiwiki (1.12) unstable; urgency=low
315
316   "Viva l'Italia!"
317   * New pagestats plugin from Enrico, which can generate a table counting
318     the backlinks for each page, or a del.icio.us style cloud.
319   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
320     the wikiformat plugin works. Thanks, Emanuele Aina.
321   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
322     display, running them through pagetitle. This removes ugly underscores and
323     other gunk from the display, much nicer. You may want to rebuild your wiki
324     when upgrading to get the cleanup globally.
325   * Polygen plugin from Enrico.
326   * htmltidy plugin from Faidon.
327   * Locale patch from Faidon:
328     - Adds a locale setting to setup files.
329     - Proper local time, if the locale configuration option is used.
330     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
331       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
332       impossible.
333   * Add getopt hook type, this allows plugins to add new command-line options.
334   * Add --tagbase option to tag plugin.
335   * Add exclude option in setup files, works same as --exclude.
336   * Put categories in rss feeds for tagged items.
337   * Allow preprocessor directives to be expanded in inlined blog pages.
338     However, to avoid inlining loops etc, don't expand inline directives in
339     inlined pages.
340   * fortune plugin (trivial)
341   * Tag plugins according to type.
342
343  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
344
345 ikiwiki (1.11) unstable; urgency=low
346
347   * Patch from Enrico that
348     - Adds a tag plugin that allows more easily tagging pages.
349       The meta plugin can also still be used for that, but the tag plugin
350       also lists a page's tags at the bottom of the page.
351     - Allows preprocessor directives to have parameters with no specified
352       value.
353     - Fixes preprocessor directive parameter parsing so that
354       foo=bar baz now means "foo=bar" and a "baz" with no value.
355   * Run pagetemplate hooks when inlining pages so that inlined pages also
356     list their tags.
357   * Make all plugins with pagetemplate hooks check that variables exist
358     on the template before setting them, for robustness.
359   * Switch pagetemplate hooks to using named parameters.
360   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
361     This will be the page that a source page will be part of, which is
362     different than the source page for inlined pages.
363   * Audited all plugins to endure they pass (page, destpage) to htmllink
364     appropriatly. This means inlining of various plugins will not work
365     properly, with correct links generated.
366
367  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
368
369 ikiwiki (1.10) unstable; urgency=low
370
371   * Run page through any relevant filters when generating a page preview.
372   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
373     default throughout the wiki, not only on wikitext pages. Decided to call
374     this a feature, and split the camelcase support out into a separate plugin
375     that is independant of wikitext.
376   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
377
378  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
379
380 ikiwiki (1.9) unstable; urgency=low
381
382   * Improve display of parentlinks and page title of toplevel index page.
383   * Patch from Faidon to use svn --limit when possible for recentchanges,
384     speeds up recentchanges a lot for wikis with more history.
385   * Patch from Recai to fix utf8 issues in git backend.
386   * Add wikitext markup plugin, which supports ".wiki" pages written in the
387     original wiki syntax, CamelCase links and all.
388   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
389     support, to edit pages etc without a web server.
390   * Display CGI processing errors if present.
391   * Fix from Faidon for a XML parser issue that breaks utf-8 for
392     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
393     area, and also way slow.
394   * Match 'web commit from' in SVN and git, these are web commits too.
395     (Faidon)
396   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
397     readable and avoid future mistakes. The patch seems to work and for the
398     first time I have a UTF-8 username ;-) (Faidon)
399   * Use form->field consistently, not form->param.
400   * Patch from Recai to allow selection of page type when creating a new page.
401     Default page type is inherited from the link clicked on to create the new
402     page.
403
404  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
405
406 ikiwiki (1.8) unstable; urgency=low
407
408   * Fix orphans plugin to not count a link to a nonexistant page as a reason
409     for a page not being an orphan.
410   * Support pinging services such as Technorati using XML-RPC to notify them
411     about changes to rss feeds.
412   * Parse svn log as xml for improved utf8 and security. Note that this makes
413     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
414   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
415     flagged string even if the locale causes it to generate utf8 output,
416     so make sure to let perl know it should be handled as utf8. Also,
417     the optimised version used for standard time formats won't work if the
418     user has changed locale, so drop it. Thanks, Faidon Liambotis.
419   * Fix re-encoding of the comments field to utf8 if a commit fails
420     due to a conflict. Thanks, Faidon Liambotis.
421   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
422     Liambotis.
423   * Add insane double encode/decode to utf8 around call to markdown.
424     This works around a truely strange bug, which is apparently a bug in
425     perl, #376329. Also added a test case for it.
426   * Improve layout of edit page so formatting help link is always visible w/o
427     getting in the way of the preview.
428   * Centralised all calls to HTML::Template and force all the templates
429     to be read as utf8.
430   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
431   * Introduce add_plugins and disable_plugins config options in setup files.
432     This allows adding or removing plugins w/o overriding the whole list of
433     default plugins, which makes it easier to upgrade when new default plugins
434     are added.
435   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
436     default (of course!). Based on a patch by Faidon Liambotis.
437   * Add a html plugin, which can be used to write wikis in raw html,
438     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
439     defaults to not processing .html files, since w/o this plugin they would
440     be copied unsanitised. With this plugin, it will process and html
441     sanitise them, like any other page type.
442   * Rebuilding wrappers is necessary on upgrade to this version.
443   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
444     will be automatically done on all upgrades.
445   * Don't send pings if the wiki is being rebuilt.
446   * Work around very innefficient behavior in File::Spec::abs2rel. Result
447     is a savings of 2 pointless fork/execs per link calculation, which
448     results in ~25% speedup of ikiwiki building its own doc wiki, and
449     about 35% speedup displaying RecentChanges!
450   * Make RecentChanges use a table and some CSS, should be much more readable.
451     No code changes involved.
452   * Encode & in diffurl in examples, to conform to pedantic rules.
453   * Speed up RecentChanges by another 40% or so with some memoization.
454   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
455     in time to build the doc wiki.
456
457  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
458
459 ikiwiki (1.7) unstable; urgency=low
460
461   * Updated logo from Recai with some kerning and alingment tuning.
462   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
463     changed some output.
464   * Copyright update.
465
466  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
467
468 ikiwiki (1.6) unstable; urgency=low
469
470   * YA utf-8 patch from Recai, this time to fix previewing a page so that
471     the text in the input box is re-encoded back to utf-8.
472   * -CSD does not affect modules, so readfile() was not using the utf-8 input
473     layer, which led to lots of problems; make it force read files as utf-8.
474     Closes: #373203
475   * Note that as a consequence, this version of ikiwiki will actually try to
476     parse utf8 in source files for the first time, which may expose broken
477     utf8 in wiki sources that was hidden before. Most common will be
478     perl warnings like "utf8 "\xE9" does not map to Unicode"
479   * writefile() likewise needs to use the utf8 output layer.
480   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
481     there.
482   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
483     given the readfile fix.
484   * Add utf-8 testcases for readfile and htmlize.
485   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
486     safe.
487   * More utf-8 fixes from Recai, partly to things I broke above:
488     - The serious problem is that writefile() saves the content in undecoded
489       format in CGI, hence all (non-ascii) chars are corrupted permanently.
490     - Comment field in edit page is not decoded and all the non-ascii chars in
491       this field are corrupted as the result.  We should decode it as we do it
492       for the content.
493     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
494       character in print.
495   * New SVG logo from Recai.
496
497  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
498
499 ikiwiki (1.5) unstable; urgency=low
500
501   * Add --timeformat config option to allow changing how dates are displayed.
502     Note that as a side effect, dates will now be displayed using the local
503     timezone, not as GMT.
504   * More security review.
505   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
506     for some handy stuff like:
507     - Using links as a kind of tag; creating blog pages that list all pages
508       containing a given tag/link or not containing some other tag.
509     - Subscribing to mail notifications whenever a change is made to a page
510       that is a backlink of page foo. Ie, "Please notify me of changes in all
511       pages that link to my home page in the wiki"
512     - Locking any pages that are linked to from a particular page, so that
513       lists of locks can be exposed in the wiki.
514   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
515     when a todo item is done, instead of the previous moving it to a different
516     subdir.
517   * Allow pagetemplate plugins to override *anything* in the template.
518   * Add a meta plugin, which allows specifying various metadata about pages,
519     like license and author. It also allows for inserting html link and meta
520     tags into html, overriding the title, and adding hidden WikiLinks, which
521     can be useful when using link-based globbing for page categorisation.
522   * Remove preprocessor directives from inlined pages.
523   * Allow simple preprocessor directive values to be specified w/o quotes.
524   * Add support for using git instead of subversion as the RCS backend,
525     tremendous thanks to Recai Oktaş for this.
526   * Doc updates for git.
527   * Fix absolute url munging in rss generation to support https, ftp, etc urls
528     not just http urls.
529   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
530     utf-8 for edit and other fields, and for recentchanges. There may still
531     be utf-8 issues with the preferences page though.
532
533  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
534
535 ikiwiki (1.4) unstable; urgency=low
536
537   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
538     very strange way of enabling proper XHTML <br /> type tags. Output html
539     should be always valid again now.
540   * The page name and parent links has switched from using a <h1> to a styled
541     <span>, so pages can use <h1> internally instead of needing to use <h2>.
542   * Updated all of ikiwiki's own wiki pages for that.
543   * Add pagetemplate hook, which can be used by plugins that want to mess
544     around with adding new stuff to the page template.
545   * Remove headercontent; the search plugin now adds the search box to the
546     header by registering a pagetemplate hook, and other plugins should do
547     similarly.
548   * Rebuilding on upgrade to this version is recommended.
549   * Add a html validity check to the test suite, using the wdg-html-validator,
550     if available.
551   * Make the html valid when there is nothing in the actions list.
552   * Reordered some function call parameters for consistency.
553   * Enable full utf-8 support for page input and output.
554   * Add a workaround for markdown, which does not work well with utf-8
555     strings.
556   * --getctime had bitrotted (well I only ever used it the once so far..),
557     fix and make it a bit more flexible
558   * rcs_getctime is changed, now rather than needing to loop over all pages,
559     it should just use the rcs to get the ctime of the passed file.
560   * When inlining a page in another one, links from the inlined page are now
561     expanded the same as they are when rendering the inlined page as a
562     standalone page. So rather than being expanded from the POV of the
563     inlining page, they are expanded from the POV of the inlined page.
564
565     For example, a link from blog/foo to "bar" will now link to blog/bar
566     if it exists. Previously this needed to be a link explicitly to
567     "blog/bar"; such links will also continue to work.
568
569     (This was slightly complex to do as the link still has to be constructed
570     relative to the inlining page.)
571   * Make page edit textarea resize to fit browser window.
572   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
573     do not need a full rebuild, in order to update any basewiki pages.
574
575  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
576
577 ikiwiki (1.3) unstable; urgency=low
578
579   * Fix the preinst introduced in the last version. Closes: #367458
580
581  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
582
583 ikiwiki (1.2) unstable; urgency=low
584
585   * Remove dups from the brokenlinks list.
586   * Add libc6-dev to dependencies, needed to build wrappers.
587   * Install wikilist in correct location. Closes: #367371
588
589  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
590
591 ikiwiki (1.1) unstable; urgency=low
592
593   * Rename inlinepage to depends, so that it can be used to refer to more
594     dependency relationships than just inlining. This will require a rebuild
595     on upgrade to this version.
596   * Move the rss link, put it in the blogpost form if there is one and at the
597     top if not. This is both nicer because easier to find, and it cleans up
598     the code which had used inlinepage as a flag for adding the link later.
599   * Allow the depends GlobList to be built up from multiple sources (such as
600     plugins) during a page render.
601   * Which means that more than one blog is now supported to appear on a
602     single page. (With some limitations, like only the last one getting an
603     rss file.)
604   * Added a plugin system.
605   * Added a pagecount plugin, enabled by default.
606   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
607   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
608     backlinks when the backlinks hadn't really changed.
609   * Moved inline page support, rss generation etc into the inline plugin,
610     enabled by default.
611   * Added brokenlinks plugin, not enabled by default, but rather handy.
612   * Fix several broken links in the doc wiki.
613   * Smarter behavior when creating a page and a page of the same name (but
614     different location) already exists.
615   * Add an orphans plugin for finding pages that nothing links to.
616   * Removed backlinks page, which it turns out nothing used.
617   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
618     it, this will allow for adding a unit test suite.
619   * Add unit tests for several core functions, including globlist_match,
620     dirname, basename, bestlink, linkify, pagetitle, titlepage.
621   * Smart globlist merging.
622   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
623     to pave the way for adding other RCS support. This also changes the
624     setup files, where before they had svn => 1 or svn => 0, now they have
625     rcs => "svn" or rcs => "".
626   * Add a debian/NEWS file with upgrade notes.
627   * Load whatever rcs module is specified, so new ones can be just dropped in
628     as plugins and work. (Well, in theory.)
629   * Add some basic docs about writing RCS modules.
630   * Broke search capability out into a plugin, removed the --hyperestraier
631     switch.
632   * Added smiley plugin, nicely controlled and documented by the smileys page.
633   * Copied in some smileys from Moin Moin.
634   * Allow links of the form [[some page|page]], with whitespace in the link
635     text.
636   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
637     and --disable-plugin htmlscrubber.
638   * Allow discussion links on pages to be turned off with --no-discussion.
639   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
640   * Add some new config items to the estseek.conf template, which are needed
641     by hyperestraier 1.2.3.
642
643  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
644
645 ikiwiki (1.0) unstable; urgency=low
646
647   * First official release.
648
649  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400