]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
web commit by http://joey.kitenet.net/: the "JamesWestby must hate all these commits...
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Add an openid plugin to support logging in using OpenID.
4   * Web commits by OpenID users will record the full OpenID url for the user,
5     but in recentchanges, these urls will be converted to a simplified display
6     form+link.
7   * Modified svn, git, tla backends to recognise such web commits.
8   * Move httpauth support to a plugin.
9   * Add openidsignup config option.
10   * Make the openid plugin support the callbacks from myopenid.com via its
11     affiliate program.
12   * Add toggle plugin.
13   * Introduce the nicebundle. This is a kind of plugin, that just enables
14     many other plugins. It's an easy way to boost ikiwiki from its default,
15     basic wiki, to a full-featured wiki, without manually picking the right
16     set of plugins. New plugins will be added to the nicebundle from time to
17     time.
18   * Change how post signin actions are propigated through the signin process;
19     they're now stored in the session.
20   * Add optional "desc" parameter to shortcut definitions.
21   * Avoid locking the wiki at all when handling some basic cgi stuff
22     (searches, recentchanges).
23   * Add "last" parameter to hook function. Very basic ordering, and hopefully
24     nothing more spohisticated will be needed.
25   * Add formbuilder_setup and formbuilder hooks.
26   * Split out a passwordauth module, that holds all the traditional password
27     based authentication etc code. It's enabled by default, but can be disabled
28     if you want only openid or some other auth method.
29   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
30   * Add some code to the build system that tries to determine if the
31     lib installation directory is in @INC. If it's not, munge ikiwiki
32     to hardcode the path to the lib directory. This should allow installing
33     ikiwiki in nonstandard locations, including home directories, by just
34     setting PREFIX at build time.
35   * Fix nested examples directory in deb.
36   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
37   * Add a test suite for the svn backend.
38   * Daemonize before sending RPC pings, since that can take a while
39     and/or hang.
40   * Daemonize before sending commit mails, as that can also take a long
41     time/hang if the mail server is unhappy.
42   * Factor out commit mail sending code into new function.
43
44  -- Joey Hess <joeyh@debian.org>  Tue, 21 Nov 2006 19:25:14 -0500
45
46 ikiwiki (1.33) unstable; urgency=low
47
48   * Fix issue with aggregate plugin updating expired pages.
49   * Avoid syntax errors in templates used by the template plugin crashing
50     ikiwiki.
51   * Enable utf8 file IO in aggregate plugin.
52   * Fix some issues with the new registration form.
53   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
54   * Make sure to check for errors from every eval.
55   * Fix img plugin's handling of adding dependencies for images that do not
56     yet exist.
57   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
58     FORM-SUBMIT unusable on customised formbuilder templates. For now,
59     hardcode the submit buttons in editpage.tmpl instead of using the
60     template variable, which is ok, since the buttons are static.
61   * Work with hyperestraier 1.4.9.
62
63  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
64
65 ikiwiki (1.32) unstable; urgency=low
66
67   * Add a separate pass to find page links, and only render each page once,
68     instead of over and over. Typical speedup is ~4x. Max possible speedup:
69     8x.
70   * Add "scan" parameter to hook(), which is used to make the hook be called
71     during the scanning pass, as well as the render pass. The meta and tag
72     plugins need to use the new scan parameter, so will any others that modify
73     %links.
74   * Now that links are calculated in a separate pass, it can also
75     precalculate backlinks in one pass, which is O(N^2) instead of the
76     previous code that was O(N^3). A very nice speedup for wikis with lots
77     (thousands) of pages.
78   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
79     Erdem.
80   * Add a default stylesheet entry for the pagecloud.
81   * Add examples page with some examples of things that can be done using
82     ikiwiki, like a weblog. The examples can be copied into a user's wiki
83     for a quick start, without needing to learn everything about how to put
84     them together.
85   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
86   * Add perlmagick to build-depends so syntax check of img plugin works.
87     Closes: #396702
88   * Improve login/register process, the login dialog has only name and
89     password fields, which allows more web browsers to regognise it as a login
90     field, and is less confusing.
91   * Implemented expiry options for aggregate plugin.
92   * Use precalculated backlinks info when determining if files need an update
93     due to a page they link to being added/removed. Mostly significant if
94     there are lots of pages.
95   * Remove duplicate link info when saving index. In some cases it could
96     pile up rather badly. (Probably not the best way to deal with this
97     problem.)
98   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
99     or what have you, by creating enclosures for non-page items that are
100     included in feeds.
101
102  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
103
104 ikiwiki (1.31) unstable; urgency=low
105
106   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
107   * Change the rss feed title from the wikiname to the page title, with
108     an exception for the wiki's toplevel index page, which will still use the
109     wikiname as the feed title.
110     Overriding the page title with meta title already overrode the rss feed
111     tittle.
112   * Add an img plugin, based on Christian Mock's img plugin, but stripped
113     down to the bare essentials. Useful for handling large images on websites.
114   * Sanitize possibly problimatic characters out of the polygen grammar names,
115     just in case. Should not be exploitable anyway, since it only tries to run
116     polygen after finding the specified grammar file.
117   * Add missing dependency on the URI perl module.
118   * Add basic spam fighting tool for admins: An admin's prefs page now allows
119     editing a list of banned users.
120
121  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
122
123 ikiwiki (1.30) unstable; urgency=low
124
125   * Add no_override parameter to hook().
126   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
127     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
128     can be configured using a page in wiki.
129   * Fix support for --pingurl at the command line.
130   * Fix a subtle bug in will_render that broke some builds, by only clearing
131     items from renderedfiles the first time per build.
132   * Wrap entire technortati ping operation in an eval to catch all possible
133     failure modes, after I observed a simple ->value crashing ikiwiki when
134     a ping failed.
135
136  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
137
138 ikiwiki (1.29) unstable; urgency=low
139
140   * Patch from Paul Tötterman to use CP in the Makefile.
141   * Patch from Alec Berryman adding a http_auth config item that allows
142     using HTTP Authentication instead of ikiwiki's built in authentication.
143     Useful for eg, large sites with their own previously existing user auth
144     setup. Closes: #384534
145   * Change %renderedfiles to store an array of files rendered from a given
146     source file, to allow tracking of extra rendered files like rss feeds.
147   * Note that plugins that accessed this variable will need to be updated!
148     The plugin interface has been increased to version 1.01 for this change.
149     As few plugins use %renderedfiles I haven't done anything else to ensure
150     compatability of old plugins.
151   * Add will_render function to the plugin interface, used to register that a
152     page renders a destination file, and do some security checks. Previously
153     but no longer rendered files will be cleaned up.
154   * Use will_render in the inline and linkmap plugins.
155   * You will need to rebuild your wiki on upgrade to this version.
156   * Atom feed support based on a patch by Clint Adams.
157   * Add feeds=no option to inline preprocessor directive to turn off all types
158     of feeds.
159   * $IkiWiki::version now holds the program version, and is accessible to
160     plugins.
161   * Make the aggregate plugin emphasize error messages.
162   * Patch from Recai to limit recentchanges to displaying max 10 files for a
163     given changeset (to avoid large number of file changes excessively
164     bloating the page).
165
166  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
167
168 ikiwiki (1.28) unstable; urgency=low
169
170   * inline: Add ability to sort by page name, based on a patch from
171     Benjamin A'Lee.
172   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
173     braindead interface. Closes: #389383
174   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
175     and b) those poor Mac OSX users and their case insensative files!
176   * Don't fail syntax check if Text::Typography isn't installed.
177     Closes: #389406
178
179  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
180
181 ikiwiki (1.27) unstable; urgency=low
182
183   * Work on firming up the plugin interface:
184     - Plugins should not need to load IkiWiki::Render to get commonly
185       used functions, so moved some functions from there to IkiWiki.
186     - Picked out the set of functions and variables that most plugins
187       use, documented them, and made IkiWiki export them by default,
188       like a proper perl module should.
189     - Use the other functions at your own risk.
190     - This is not quite complete, I still have to decide whether to
191       export some other things.
192   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
193     referring to stuff now exported by the IkiWiki module.
194   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
195     to declare which version of the interface your plugin needs.
196   * Anyone with a third-party ikiwiki plugin is strongly encouraged
197     to make like changes to it and avoid use of non-exported symbols from
198     "IkiWiki::".
199   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
200   * Support hyperestradier version 1.4.2, which adds a new required phraseform
201     setting.
202   * If an inlined page has a permalink, link the page title to that.
203   * Patch from Recai to use utf8 when reading the setup file, so that
204     utf8 wikinames from there will be used properly.
205   * Patch from Recai to kill utf-8 on the wiki name when generating the
206     session cookie.
207   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
208   * Fix a baseurl problem in hyperestradier search results.
209   * Add a stub local.css to avoid problems with 404's.
210   * Patch from Recai to fix a wide character warning from the search plugin
211     during setup if the wikiname contains utf8.
212   * Yet another fix for those poor case-insensative OS X users.
213   * pagetemplate hooks are now also called when generating cgi pages.
214   * Add a favicon plugin, which simply adds a link tag for an icon to each
215     page (and cgis).
216   * Patch from James Westby to deal with the case where you're editing a
217     new page, hit cancel, and need to be redirected to somewhere sane.
218   * Various documentation improvements by various wiki users.
219   * Support Text::Markdown from CPAN, which has a different interface from
220     the original markdown or the one in Debian.
221   * Version the libcgi-session-perl dependency, some features that need
222     the new version are used in some cases (sslcookie).
223   * Numerous tla fixes from Clint.
224   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
225     a multi-resolution favicon.ico.
226   * README.Debian: typo Closes: #388110
227   * chomp trailing newline at the end of templates read in by the template
228     plugin, to allow use of the template preprocessor directive in
229     whitespace-sensative situations. Closes: #387073
230   * Patch from James Westby to make the location of the estseek.cgi script
231     configurable.
232   * Add typography (SmartyPants) plugin by Recai.
233   * Add --render mode, which can be used to preview an edit at the command
234     line by test rendering a single page.
235   * Add a googlecalendar plugin. A bit special-purpose, but it shows
236     one way to to deal with user-supplied content that could cause XSS
237     issues w/o the htmlscrubber, and won't survive the scrubber.
238
239  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
240
241 ikiwiki (1.26) unstable; urgency=low
242
243   * Add a missing -n to tla undo call.
244   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
245     writes before consuming its whole stdin. Avoid this deadlock.
246   * Fix alt tags for outline checkboxes.
247
248  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
249
250 ikiwiki (1.25) unstable; urgency=low
251
252   * Add proper waitpid calls for open2ed processes throughout to avoid
253     zombies; this hit htmltidy especially badly.
254   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
255     subversion repos and fixing some other issues.
256   * Add support for tla, contributed by Clint Adams. Closes: #385936
257   * Add support for mercurial, contributed by Emanuele Aina.
258   * Include <link rel> tag for RSS feeds, used by some aggregators and
259     firefox to find the feed.
260   * Add a linkmap plugin (requires graphviz).
261
262  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
263
264 ikiwiki (1.24) unstable; urgency=low
265
266   * Simplify the data structure returned by rcs_recentchanges to avoid
267     each rcs plugin needing to form complex strings on its own.
268   * Fix another destpage issue in the inline directive. Closes: #385512
269     again.
270
271  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
272
273 ikiwiki (1.23) unstable; urgency=low
274
275   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
276
277  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
278
279 ikiwiki (1.22) unstable; urgency=low
280
281   * Change how the stylesheet url is determined in the templates: Remove
282     STYLEURL and add BASEURL to all templates (some already had it). This
283     new more general variable can be used to link to other things (eg, images)
284     from the template, as well as stylesheets.
285   * Fix a bug introduced last version to do with nested inlines.
286   * Allow preprocessor directives to span multiple lines, both to make
287     long ones with lots of values easier to write, and to allow for ones with
288     multi-line quoted values.
289   * Allow preprocessor directives to contain python-like triple-quoted
290     text blocks, for easy nesting of quotes inside.
291   * Add a template plugin.
292   * Make pagespec merge code smarter about merging duplicate pagespecs.
293   * Patch from Jordà Polo to make Setup::Standard support hashes in config
294     files.
295   * Change order of linkify and preprocess; first preprocess and then linkify.
296     This allows passing a wikilink inside a parameter to a preprocessor
297     directive without it being expanded to html, and leaking out of the
298     parameter, which had required some non-obvious use of triple-quoting
299     to avoid. Note that any preprocessor plugins that output something
300     that looks like a wikilink will now have it treated as such; AFAIK
301     this doesn't change any behavior though except for the template plugin.
302   * Enable preprocessor directives when previewing an edit.
303   * Make all pages pull in a local.css style sheet, if present. This won't
304     be included in ikiwiki, but can be created to make local styling changes
305     w/o needing to merge in every new change to the distributed style.css.
306   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
307   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
308     from a different directory.
309   * Generalised preprocesser loop protection code.
310   * Patch from James Westby to allow a description to be set for rss feeds.
311   * Patch from James Westby to add a template for the search form.
312   * Added a ddate plugin.
313   * Patch from James Westby to add a --sslcookie switch, which forces
314     cookies to only be sent over ssl connections to avoid interception.
315   * Fix preferences page on anonok wikis; still need to sign in to get
316     to the preferences page.
317   * Add toc (table of contents) plugin.
318   * Change htmlize, format, and sanitize hooks to use named parameters.
319   * Patch from James Westby to add an actions option to inline; this
320     adds Edit and Discussion links at the end of blog entries.
321   * Due to some css changes, you'll want to rebuild your wiki on upgrade
322     to this version. Will be handled automatically by the deb.
323   * Add processed date to aggregate preprocessor directive status output.
324
325  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
326
327 ikiwiki (1.21) unstable; urgency=low
328
329   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
330   * If a page links to itself, mark up the link text in a span with
331     class="selflink" so that it can be styled. I don't have a useful style
332     defined for that though.
333   * Call filter hooks on inlined page content.
334   * Support inlining pages raw, rather than creating a blog.
335   * Clean up yes/no parameter parsing in inline plugin.
336   * Implemented better cycle detection in the inline plugin; nested inlines
337     will now work.
338   * Add a map plugin contributed by Alessandro Dotti Contra.
339   * Add otl format plugin, which handles files as created by vimoutliner.
340   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
341   * Add first draft at a Restructured Text (rst) plugin, by Sergio
342     Talens-Oliag. Note that this has many known issues -- see the caveats on
343     the plugin's page.
344   * Credit everyone who wrote a plugin on the plugins' wiki pages.
345   * Fix utf-8 in blog post form.
346
347  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
348
349 ikiwiki (1.20) unstable; urgency=low
350
351   * Relicense the templates and basewiki under the 2-clause BSD license.
352     Since these can easily become part of other people's websites, they
353     should be under as permissive a license as possible.
354   * Add --syslog config option, to log to the syslog.
355   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
356     transient failure to fork (which I've seen happen in the wild).
357   * Fix a bug in the aggregator introduced last version that caused all
358     aggregator state to be lost during a non-aggregating build.
359
360  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
361
362 ikiwiki (1.19) unstable; urgency=low
363
364   * Fix several related bugs in page type determination during online editing.
365   * Add some locking to prevent 2 aggregators from running at once.
366   * Fix an infinite loop in the aggregator when finding a unique filename.
367
368  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
369
370 ikiwiki (1.18) unstable; urgency=low
371
372   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
373   * Add --version.
374   * Man page format fixups.
375   * If the meta plugin overides the page title, set a title_overridden
376     variable in the template to true. This allows doing things with the
377     templates conditional on the title being overriden.
378   * Add a %pagecase which maps lower-case page names to the actual case
379     used in the filename. Use this in bestlinks calculation instead of
380     forcing the link to lowercase.
381   * Also use %pagecase in various other places that want to check if a page
382     with a given name exists.
383   * This means that links to pages with mixed case names will now work,
384     even if the link is in some other case mixture, and mixed case pages
385     should be fully supported throughout ikiwiki.
386   * Recommend rebuilding wikis on upgrade to this version.
387
388  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
389
390 ikiwiki (1.17) unstable; urgency=low
391
392   * Disable tidy generator tag.
393   * Move tidy back to sanitize hook, found out how to only show body.
394   * Turn off tidy indentation too.
395   * Turn on HTML::Template loop_context_vars; not actually used in stock
396     templates but can be useful for things like making comma-delimited lists
397     of tags or what have you.
398   * Remove <br> from end of aggregate preprocessor directive output.
399   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
400     case-sensative filesystems like OSX.
401   * Improve markdown loading. First, try to load it as a proper perl module,
402     in case it was installed as one. Then fall back to trying
403     /usr/bin/markdown.
404   * Document in install page how to install markdown, since it has no
405     installation procedure in the upstream tarball.
406   * Set die_on_bad_params => 0 for all templates, to allow users to modify
407     them without annoyances.
408   * Suck in the page content when generating an inline archive page, to work
409     around the meta plugin's lack of caching of title metadata across runs.
410
411  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
412
413 ikiwiki (1.16) unstable; urgency=low
414
415   * Try to handle relative links in aggregated feeds. However,
416     the current support is a crude hack due to limitations of XML::Feed:
417     xml:base is not supported, neither is Content-Location. And of course,
418     relative links in RSS feeds are ill-undefined..
419   * Make aggregator save permalinks and author name to pages as metadata.
420   * Add permalink and author support to meta plugin, affecting RSS feeds
421     and blog pages.
422   * Various CSS and formatting changes.
423   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
424   * Add xhtml files to the default prune regexp.
425   * Also generate rel=bookmark links for permalinks.
426   * Fix the htmltidy plugin, which wasn't working due my breaking it when
427     I added it..
428   * Don't run tidy with -xml as that fails if the input is not well-formed.
429     Run it with -asxhtml instead, so it will output well-formed xhtml no
430     matter what the input.
431   * Disable tidy warnings too.
432   * Add a new format hook, and make tidy use it, since tidy can really only
433     operate on and output complete html documents, not the body chunks
434     that sanitise gets.
435   * Fix dates in rss feeds if running localised, so they're still rfc 822.
436
437  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
438
439 ikiwiki (1.15) unstable; urgency=low
440
441   * Remove CDPATH and other env vars perl taint checking doesn't like.
442     Closes: #381279
443   * Added created_before and created_after PageSpec limits.
444
445  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
446
447 ikiwiki (1.14) unstable; urgency=low
448
449   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
450     by 10% or so.
451   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
452   * Added many unit tests for pagespec_match.
453
454  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
455
456 ikiwiki (1.13) unstable; urgency=low
457
458   * ikiwiki can now download and aggregate feeds with its new aggregate
459     plugin, so it's possible to implement a Planet using ikiwiki!
460   * Add a run_hooks function for the common task of running all hooks of a
461     given type.
462   * Add a savestate hook.
463   * Don't put blog post forms on pages if there's no cgiurl set.
464   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
465     --wrappers to do that.
466   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
467     to update pages that haven't changed on disk.
468   * Change meta tags to use html entity-escaped text for values, so that
469     quotes and such can be represented in title tags.
470   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
471     for the above.
472   * Make --rebuild also cause --aggregate to re-download and write aggregated
473     pages.
474   * Avoid outputting duplicate meta info.
475   * Include title metadata on aggregated posts for capitalised and un-munged
476     titles.
477   * Title metadata of inlined pages now shows up in blogs and rss feeds.
478   * Fix issue with unicode filenames and updating the hyper estradier search
479     index. (Aka Please Please Please, let that be the last one.)
480   * Patch from Roland Mas to support an rss=no parameter to inline directives.
481     Closes: #380743
482   * Renamed GlobLists to PageSpecs.
483   * PageSpecs can now include nested parens, "and", and "or". This remains
484     backwards compatible to the old GlobList format. It's implemented by
485     treating the GlobList as a very limited microlanguage that is transformed
486     to perl code that does the matching.
487   * The old GlobList format is deprecated, and I encourage users to switch to
488     using the new PageSpec format. Compatability with the old format will be
489     removed at some point, possibly by 2.0.
490   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
491   * Add support for creation_month and creation_year to PageSpec.
492     Closes: #380680
493   * Changes to index file encoding.
494
495  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
496
497 ikiwiki (1.12) unstable; urgency=low
498
499   "Viva l'Italia!"
500   * New pagestats plugin from Enrico, which can generate a table counting
501     the backlinks for each page, or a del.icio.us style cloud.
502   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
503     the wikiformat plugin works. Thanks, Emanuele Aina.
504   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
505     display, running them through pagetitle. This removes ugly underscores and
506     other gunk from the display, much nicer. You may want to rebuild your wiki
507     when upgrading to get the cleanup globally.
508   * Polygen plugin from Enrico.
509   * htmltidy plugin from Faidon.
510   * Locale patch from Faidon:
511     - Adds a locale setting to setup files.
512     - Proper local time, if the locale configuration option is used.
513     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
514       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
515       impossible.
516   * Add getopt hook type, this allows plugins to add new command-line options.
517   * Add --tagbase option to tag plugin.
518   * Add exclude option in setup files, works same as --exclude.
519   * Put categories in rss feeds for tagged items.
520   * Allow preprocessor directives to be expanded in inlined blog pages.
521     However, to avoid inlining loops etc, don't expand inline directives in
522     inlined pages.
523   * fortune plugin (trivial)
524   * Tag plugins according to type.
525
526  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
527
528 ikiwiki (1.11) unstable; urgency=low
529
530   * Patch from Enrico that
531     - Adds a tag plugin that allows more easily tagging pages.
532       The meta plugin can also still be used for that, but the tag plugin
533       also lists a page's tags at the bottom of the page.
534     - Allows preprocessor directives to have parameters with no specified
535       value.
536     - Fixes preprocessor directive parameter parsing so that
537       foo=bar baz now means "foo=bar" and a "baz" with no value.
538   * Run pagetemplate hooks when inlining pages so that inlined pages also
539     list their tags.
540   * Make all plugins with pagetemplate hooks check that variables exist
541     on the template before setting them, for robustness.
542   * Switch pagetemplate hooks to using named parameters.
543   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
544     This will be the page that a source page will be part of, which is
545     different than the source page for inlined pages.
546   * Audited all plugins to endure they pass (page, destpage) to htmllink
547     appropriatly. This means inlining of various plugins will not work
548     properly, with correct links generated.
549
550  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
551
552 ikiwiki (1.10) unstable; urgency=low
553
554   * Run page through any relevant filters when generating a page preview.
555   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
556     default throughout the wiki, not only on wikitext pages. Decided to call
557     this a feature, and split the camelcase support out into a separate plugin
558     that is independant of wikitext.
559   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
560
561  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
562
563 ikiwiki (1.9) unstable; urgency=low
564
565   * Improve display of parentlinks and page title of toplevel index page.
566   * Patch from Faidon to use svn --limit when possible for recentchanges,
567     speeds up recentchanges a lot for wikis with more history.
568   * Patch from Recai to fix utf8 issues in git backend.
569   * Add wikitext markup plugin, which supports ".wiki" pages written in the
570     original wiki syntax, CamelCase links and all.
571   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
572     support, to edit pages etc without a web server.
573   * Display CGI processing errors if present.
574   * Fix from Faidon for a XML parser issue that breaks utf-8 for
575     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
576     area, and also way slow.
577   * Match 'web commit from' in SVN and git, these are web commits too.
578     (Faidon)
579   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
580     readable and avoid future mistakes. The patch seems to work and for the
581     first time I have a UTF-8 username ;-) (Faidon)
582   * Use form->field consistently, not form->param.
583   * Patch from Recai to allow selection of page type when creating a new page.
584     Default page type is inherited from the link clicked on to create the new
585     page.
586
587  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
588
589 ikiwiki (1.8) unstable; urgency=low
590
591   * Fix orphans plugin to not count a link to a nonexistant page as a reason
592     for a page not being an orphan.
593   * Support pinging services such as Technorati using XML-RPC to notify them
594     about changes to rss feeds.
595   * Parse svn log as xml for improved utf8 and security. Note that this makes
596     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
597   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
598     flagged string even if the locale causes it to generate utf8 output,
599     so make sure to let perl know it should be handled as utf8. Also,
600     the optimised version used for standard time formats won't work if the
601     user has changed locale, so drop it. Thanks, Faidon Liambotis.
602   * Fix re-encoding of the comments field to utf8 if a commit fails
603     due to a conflict. Thanks, Faidon Liambotis.
604   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
605     Liambotis.
606   * Add insane double encode/decode to utf8 around call to markdown.
607     This works around a truely strange bug, which is apparently a bug in
608     perl, #376329. Also added a test case for it.
609   * Improve layout of edit page so formatting help link is always visible w/o
610     getting in the way of the preview.
611   * Centralised all calls to HTML::Template and force all the templates
612     to be read as utf8.
613   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
614   * Introduce add_plugins and disable_plugins config options in setup files.
615     This allows adding or removing plugins w/o overriding the whole list of
616     default plugins, which makes it easier to upgrade when new default plugins
617     are added.
618   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
619     default (of course!). Based on a patch by Faidon Liambotis.
620   * Add a html plugin, which can be used to write wikis in raw html,
621     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
622     defaults to not processing .html files, since w/o this plugin they would
623     be copied unsanitised. With this plugin, it will process and html
624     sanitise them, like any other page type.
625   * Rebuilding wrappers is necessary on upgrade to this version.
626   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
627     will be automatically done on all upgrades.
628   * Don't send pings if the wiki is being rebuilt.
629   * Work around very innefficient behavior in File::Spec::abs2rel. Result
630     is a savings of 2 pointless fork/execs per link calculation, which
631     results in ~25% speedup of ikiwiki building its own doc wiki, and
632     about 35% speedup displaying RecentChanges!
633   * Make RecentChanges use a table and some CSS, should be much more readable.
634     No code changes involved.
635   * Encode & in diffurl in examples, to conform to pedantic rules.
636   * Speed up RecentChanges by another 40% or so with some memoization.
637   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
638     in time to build the doc wiki.
639
640  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
641
642 ikiwiki (1.7) unstable; urgency=low
643
644   * Updated logo from Recai with some kerning and alingment tuning.
645   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
646     changed some output.
647   * Copyright update.
648
649  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
650
651 ikiwiki (1.6) unstable; urgency=low
652
653   * YA utf-8 patch from Recai, this time to fix previewing a page so that
654     the text in the input box is re-encoded back to utf-8.
655   * -CSD does not affect modules, so readfile() was not using the utf-8 input
656     layer, which led to lots of problems; make it force read files as utf-8.
657     Closes: #373203
658   * Note that as a consequence, this version of ikiwiki will actually try to
659     parse utf8 in source files for the first time, which may expose broken
660     utf8 in wiki sources that was hidden before. Most common will be
661     perl warnings like "utf8 "\xE9" does not map to Unicode"
662   * writefile() likewise needs to use the utf8 output layer.
663   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
664     there.
665   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
666     given the readfile fix.
667   * Add utf-8 testcases for readfile and htmlize.
668   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
669     safe.
670   * More utf-8 fixes from Recai, partly to things I broke above:
671     - The serious problem is that writefile() saves the content in undecoded
672       format in CGI, hence all (non-ascii) chars are corrupted permanently.
673     - Comment field in edit page is not decoded and all the non-ascii chars in
674       this field are corrupted as the result.  We should decode it as we do it
675       for the content.
676     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
677       character in print.
678   * New SVG logo from Recai.
679
680  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
681
682 ikiwiki (1.5) unstable; urgency=low
683
684   * Add --timeformat config option to allow changing how dates are displayed.
685     Note that as a side effect, dates will now be displayed using the local
686     timezone, not as GMT.
687   * More security review.
688   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
689     for some handy stuff like:
690     - Using links as a kind of tag; creating blog pages that list all pages
691       containing a given tag/link or not containing some other tag.
692     - Subscribing to mail notifications whenever a change is made to a page
693       that is a backlink of page foo. Ie, "Please notify me of changes in all
694       pages that link to my home page in the wiki"
695     - Locking any pages that are linked to from a particular page, so that
696       lists of locks can be exposed in the wiki.
697   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
698     when a todo item is done, instead of the previous moving it to a different
699     subdir.
700   * Allow pagetemplate plugins to override *anything* in the template.
701   * Add a meta plugin, which allows specifying various metadata about pages,
702     like license and author. It also allows for inserting html link and meta
703     tags into html, overriding the title, and adding hidden WikiLinks, which
704     can be useful when using link-based globbing for page categorisation.
705   * Remove preprocessor directives from inlined pages.
706   * Allow simple preprocessor directive values to be specified w/o quotes.
707   * Add support for using git instead of subversion as the RCS backend,
708     tremendous thanks to Recai Oktaş for this.
709   * Doc updates for git.
710   * Fix absolute url munging in rss generation to support https, ftp, etc urls
711     not just http urls.
712   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
713     utf-8 for edit and other fields, and for recentchanges. There may still
714     be utf-8 issues with the preferences page though.
715
716  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
717
718 ikiwiki (1.4) unstable; urgency=low
719
720   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
721     very strange way of enabling proper XHTML <br /> type tags. Output html
722     should be always valid again now.
723   * The page name and parent links has switched from using a <h1> to a styled
724     <span>, so pages can use <h1> internally instead of needing to use <h2>.
725   * Updated all of ikiwiki's own wiki pages for that.
726   * Add pagetemplate hook, which can be used by plugins that want to mess
727     around with adding new stuff to the page template.
728   * Remove headercontent; the search plugin now adds the search box to the
729     header by registering a pagetemplate hook, and other plugins should do
730     similarly.
731   * Rebuilding on upgrade to this version is recommended.
732   * Add a html validity check to the test suite, using the wdg-html-validator,
733     if available.
734   * Make the html valid when there is nothing in the actions list.
735   * Reordered some function call parameters for consistency.
736   * Enable full utf-8 support for page input and output.
737   * Add a workaround for markdown, which does not work well with utf-8
738     strings.
739   * --getctime had bitrotted (well I only ever used it the once so far..),
740     fix and make it a bit more flexible
741   * rcs_getctime is changed, now rather than needing to loop over all pages,
742     it should just use the rcs to get the ctime of the passed file.
743   * When inlining a page in another one, links from the inlined page are now
744     expanded the same as they are when rendering the inlined page as a
745     standalone page. So rather than being expanded from the POV of the
746     inlining page, they are expanded from the POV of the inlined page.
747
748     For example, a link from blog/foo to "bar" will now link to blog/bar
749     if it exists. Previously this needed to be a link explicitly to
750     "blog/bar"; such links will also continue to work.
751
752     (This was slightly complex to do as the link still has to be constructed
753     relative to the inlining page.)
754   * Make page edit textarea resize to fit browser window.
755   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
756     do not need a full rebuild, in order to update any basewiki pages.
757
758  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
759
760 ikiwiki (1.3) unstable; urgency=low
761
762   * Fix the preinst introduced in the last version. Closes: #367458
763
764  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
765
766 ikiwiki (1.2) unstable; urgency=low
767
768   * Remove dups from the brokenlinks list.
769   * Add libc6-dev to dependencies, needed to build wrappers.
770   * Install wikilist in correct location. Closes: #367371
771
772  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
773
774 ikiwiki (1.1) unstable; urgency=low
775
776   * Rename inlinepage to depends, so that it can be used to refer to more
777     dependency relationships than just inlining. This will require a rebuild
778     on upgrade to this version.
779   * Move the rss link, put it in the blogpost form if there is one and at the
780     top if not. This is both nicer because easier to find, and it cleans up
781     the code which had used inlinepage as a flag for adding the link later.
782   * Allow the depends GlobList to be built up from multiple sources (such as
783     plugins) during a page render.
784   * Which means that more than one blog is now supported to appear on a
785     single page. (With some limitations, like only the last one getting an
786     rss file.)
787   * Added a plugin system.
788   * Added a pagecount plugin, enabled by default.
789   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
790   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
791     backlinks when the backlinks hadn't really changed.
792   * Moved inline page support, rss generation etc into the inline plugin,
793     enabled by default.
794   * Added brokenlinks plugin, not enabled by default, but rather handy.
795   * Fix several broken links in the doc wiki.
796   * Smarter behavior when creating a page and a page of the same name (but
797     different location) already exists.
798   * Add an orphans plugin for finding pages that nothing links to.
799   * Removed backlinks page, which it turns out nothing used.
800   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
801     it, this will allow for adding a unit test suite.
802   * Add unit tests for several core functions, including globlist_match,
803     dirname, basename, bestlink, linkify, pagetitle, titlepage.
804   * Smart globlist merging.
805   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
806     to pave the way for adding other RCS support. This also changes the
807     setup files, where before they had svn => 1 or svn => 0, now they have
808     rcs => "svn" or rcs => "".
809   * Add a debian/NEWS file with upgrade notes.
810   * Load whatever rcs module is specified, so new ones can be just dropped in
811     as plugins and work. (Well, in theory.)
812   * Add some basic docs about writing RCS modules.
813   * Broke search capability out into a plugin, removed the --hyperestraier
814     switch.
815   * Added smiley plugin, nicely controlled and documented by the smileys page.
816   * Copied in some smileys from Moin Moin.
817   * Allow links of the form [[some page|page]], with whitespace in the link
818     text.
819   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
820     and --disable-plugin htmlscrubber.
821   * Allow discussion links on pages to be turned off with --no-discussion.
822   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
823   * Add some new config items to the estseek.conf template, which are needed
824     by hyperestraier 1.2.3.
825
826  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
827
828 ikiwiki (1.0) unstable; urgency=low
829
830   * First official release.
831
832  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400