]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
update
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.33) UNRELEASED; urgency=low
2
3   * Fix issue with aggregate plugin updating expired pages.
4   * Avoid syntax errors in templates used by the template plugin crashing
5     ikiwiki.
6   * Enable utf8 file IO in aggregate plugin.
7   * Fix some issues with the new registration form.
8   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
9
10  -- Joey Hess <joeyh@debian.org>  Wed,  8 Nov 2006 15:39:16 -0500
11
12 ikiwiki (1.32) unstable; urgency=low
13
14   * Add a separate pass to find page links, and only render each page once,
15     instead of over and over. Typical speedup is ~4x. Max possible speedup:
16     8x.
17   * Add "scan" parameter to hook(), which is used to make the hook be called
18     during the scanning pass, as well as the render pass. The meta and tag
19     plugins need to use the new scan parameter, so will any others that modify
20     %links.
21   * Now that links are calculated in a separate pass, it can also
22     precalculate backlinks in one pass, which is O(N^2) instead of the
23     previous code that was O(N^3). A very nice speedup for wikis with lots
24     (thousands) of pages.
25   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
26     Erdem.
27   * Add a default stylesheet entry for the pagecloud.
28   * Add examples page with some examples of things that can be done using
29     ikiwiki, like a weblog. The examples can be copied into a user's wiki
30     for a quick start, without needing to learn everything about how to put
31     them together.
32   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
33   * Add perlmagick to build-depends so syntax check of img plugin works.
34     Closes: #396702
35   * Improve login/register process, the login dialog has only name and
36     password fields, which allows more web browsers to regognise it as a login
37     field, and is less confusing.
38   * Implemented expiry options for aggregate plugin.
39   * Use precalculated backlinks info when determining if files need an update
40     due to a page they link to being added/removed. Mostly significant if
41     there are lots of pages.
42   * Remove duplicate link info when saving index. In some cases it could
43     pile up rather badly. (Probably not the best way to deal with this
44     problem.)
45   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
46     or what have you, by creating enclosures for non-page items that are
47     included in feeds.
48
49  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
50
51 ikiwiki (1.31) unstable; urgency=low
52
53   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
54   * Change the rss feed title from the wikiname to the page title, with
55     an exception for the wiki's toplevel index page, which will still use the
56     wikiname as the feed title.
57     Overriding the page title with meta title already overrode the rss feed
58     tittle.
59   * Add an img plugin, based on Christian Mock's img plugin, but stripped
60     down to the bare essentials. Useful for handling large images on websites.
61   * Sanitize possibly problimatic characters out of the polygen grammar names,
62     just in case. Should not be exploitable anyway, since it only tries to run
63     polygen after finding the specified grammar file.
64   * Add missing dependency on the URI perl module.
65   * Add basic spam fighting tool for admins: An admin's prefs page now allows
66     editing a list of banned users.
67
68  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
69
70 ikiwiki (1.30) unstable; urgency=low
71
72   * Add no_override parameter to hook().
73   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
74     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
75     can be configured using a page in wiki.
76   * Fix support for --pingurl at the command line.
77   * Fix a subtle bug in will_render that broke some builds, by only clearing
78     items from renderedfiles the first time per build.
79   * Wrap entire technortati ping operation in an eval to catch all possible
80     failure modes, after I observed a simple ->value crashing ikiwiki when
81     a ping failed.
82
83  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
84
85 ikiwiki (1.29) unstable; urgency=low
86
87   * Patch from Paul Tötterman to use CP in the Makefile.
88   * Patch from Alec Berryman adding a http_auth config item that allows
89     using HTTP Authentication instead of ikiwiki's built in authentication.
90     Useful for eg, large sites with their own previously existing user auth
91     setup. Closes: #384534
92   * Change %renderedfiles to store an array of files rendered from a given
93     source file, to allow tracking of extra rendered files like rss feeds.
94   * Note that plugins that accessed this variable will need to be updated!
95     The plugin interface has been increased to version 1.01 for this change.
96     As few plugins use %renderedfiles I haven't done anything else to ensure
97     compatability of old plugins.
98   * Add will_render function to the plugin interface, used to register that a
99     page renders a destination file, and do some security checks. Previously
100     but no longer rendered files will be cleaned up.
101   * Use will_render in the inline and linkmap plugins.
102   * You will need to rebuild your wiki on upgrade to this version.
103   * Atom feed support based on a patch by Clint Adams.
104   * Add feeds=no option to inline preprocessor directive to turn off all types
105     of feeds.
106   * $IkiWiki::version now holds the program version, and is accessible to
107     plugins.
108   * Make the aggregate plugin emphasize error messages.
109   * Patch from Recai to limit recentchanges to displaying max 10 files for a
110     given changeset (to avoid large number of file changes excessively
111     bloating the page).
112
113  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
114
115 ikiwiki (1.28) unstable; urgency=low
116
117   * inline: Add ability to sort by page name, based on a patch from
118     Benjamin A'Lee.
119   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
120     braindead interface. Closes: #389383
121   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
122     and b) those poor Mac OSX users and their case insensative files!
123   * Don't fail syntax check if Text::Typography isn't installed.
124     Closes: #389406
125
126  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
127
128 ikiwiki (1.27) unstable; urgency=low
129
130   * Work on firming up the plugin interface:
131     - Plugins should not need to load IkiWiki::Render to get commonly
132       used functions, so moved some functions from there to IkiWiki.
133     - Picked out the set of functions and variables that most plugins
134       use, documented them, and made IkiWiki export them by default,
135       like a proper perl module should.
136     - Use the other functions at your own risk.
137     - This is not quite complete, I still have to decide whether to
138       export some other things.
139   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
140     referring to stuff now exported by the IkiWiki module.
141   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
142     to declare which version of the interface your plugin needs.
143   * Anyone with a third-party ikiwiki plugin is strongly encouraged
144     to make like changes to it and avoid use of non-exported symbols from
145     "IkiWiki::".
146   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
147   * Support hyperestradier version 1.4.2, which adds a new required phraseform
148     setting.
149   * If an inlined page has a permalink, link the page title to that.
150   * Patch from Recai to use utf8 when reading the setup file, so that
151     utf8 wikinames from there will be used properly.
152   * Patch from Recai to kill utf-8 on the wiki name when generating the
153     session cookie.
154   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
155   * Fix a baseurl problem in hyperestradier search results.
156   * Add a stub local.css to avoid problems with 404's.
157   * Patch from Recai to fix a wide character warning from the search plugin
158     during setup if the wikiname contains utf8.
159   * Yet another fix for those poor case-insensative OS X users.
160   * pagetemplate hooks are now also called when generating cgi pages.
161   * Add a favicon plugin, which simply adds a link tag for an icon to each
162     page (and cgis).
163   * Patch from James Westby to deal with the case where you're editing a
164     new page, hit cancel, and need to be redirected to somewhere sane.
165   * Various documentation improvements by various wiki users.
166   * Support Text::Markdown from CPAN, which has a different interface from
167     the original markdown or the one in Debian.
168   * Version the libcgi-session-perl dependency, some features that need
169     the new version are used in some cases (sslcookie).
170   * Numerous tla fixes from Clint.
171   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
172     a multi-resolution favicon.ico.
173   * README.Debian: typo Closes: #388110
174   * chomp trailing newline at the end of templates read in by the template
175     plugin, to allow use of the template preprocessor directive in
176     whitespace-sensative situations. Closes: #387073
177   * Patch from James Westby to make the location of the estseek.cgi script
178     configurable.
179   * Add typography (SmartyPants) plugin by Recai.
180   * Add --render mode, which can be used to preview an edit at the command
181     line by test rendering a single page.
182   * Add a googlecalendar plugin. A bit special-purpose, but it shows
183     one way to to deal with user-supplied content that could cause XSS
184     issues w/o the htmlscrubber, and won't survive the scrubber.
185
186  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
187
188 ikiwiki (1.26) unstable; urgency=low
189
190   * Add a missing -n to tla undo call.
191   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
192     writes before consuming its whole stdin. Avoid this deadlock.
193   * Fix alt tags for outline checkboxes.
194
195  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
196
197 ikiwiki (1.25) unstable; urgency=low
198
199   * Add proper waitpid calls for open2ed processes throughout to avoid
200     zombies; this hit htmltidy especially badly.
201   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
202     subversion repos and fixing some other issues.
203   * Add support for tla, contributed by Clint Adams. Closes: #385936
204   * Add support for mercurial, contributed by Emanuele Aina.
205   * Include <link rel> tag for RSS feeds, used by some aggregators and
206     firefox to find the feed.
207   * Add a linkmap plugin (requires graphviz).
208
209  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
210
211 ikiwiki (1.24) unstable; urgency=low
212
213   * Simplify the data structure returned by rcs_recentchanges to avoid
214     each rcs plugin needing to form complex strings on its own.
215   * Fix another destpage issue in the inline directive. Closes: #385512
216     again.
217
218  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
219
220 ikiwiki (1.23) unstable; urgency=low
221
222   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
223
224  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
225
226 ikiwiki (1.22) unstable; urgency=low
227
228   * Change how the stylesheet url is determined in the templates: Remove
229     STYLEURL and add BASEURL to all templates (some already had it). This
230     new more general variable can be used to link to other things (eg, images)
231     from the template, as well as stylesheets.
232   * Fix a bug introduced last version to do with nested inlines.
233   * Allow preprocessor directives to span multiple lines, both to make
234     long ones with lots of values easier to write, and to allow for ones with
235     multi-line quoted values.
236   * Allow preprocessor directives to contain python-like triple-quoted
237     text blocks, for easy nesting of quotes inside.
238   * Add a template plugin.
239   * Make pagespec merge code smarter about merging duplicate pagespecs.
240   * Patch from Jordà Polo to make Setup::Standard support hashes in config
241     files.
242   * Change order of linkify and preprocess; first preprocess and then linkify.
243     This allows passing a wikilink inside a parameter to a preprocessor
244     directive without it being expanded to html, and leaking out of the
245     parameter, which had required some non-obvious use of triple-quoting
246     to avoid. Note that any preprocessor plugins that output something
247     that looks like a wikilink will now have it treated as such; AFAIK
248     this doesn't change any behavior though except for the template plugin.
249   * Enable preprocessor directives when previewing an edit.
250   * Make all pages pull in a local.css style sheet, if present. This won't
251     be included in ikiwiki, but can be created to make local styling changes
252     w/o needing to merge in every new change to the distributed style.css.
253   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
254   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
255     from a different directory.
256   * Generalised preprocesser loop protection code.
257   * Patch from James Westby to allow a description to be set for rss feeds.
258   * Patch from James Westby to add a template for the search form.
259   * Added a ddate plugin.
260   * Patch from James Westby to add a --sslcookie switch, which forces
261     cookies to only be sent over ssl connections to avoid interception.
262   * Fix preferences page on anonok wikis; still need to sign in to get
263     to the preferences page.
264   * Add toc (table of contents) plugin.
265   * Change htmlize, format, and sanitize hooks to use named parameters.
266   * Patch from James Westby to add an actions option to inline; this
267     adds Edit and Discussion links at the end of blog entries.
268   * Due to some css changes, you'll want to rebuild your wiki on upgrade
269     to this version. Will be handled automatically by the deb.
270   * Add processed date to aggregate preprocessor directive status output.
271
272  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
273
274 ikiwiki (1.21) unstable; urgency=low
275
276   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
277   * If a page links to itself, mark up the link text in a span with
278     class="selflink" so that it can be styled. I don't have a useful style
279     defined for that though.
280   * Call filter hooks on inlined page content.
281   * Support inlining pages raw, rather than creating a blog.
282   * Clean up yes/no parameter parsing in inline plugin.
283   * Implemented better cycle detection in the inline plugin; nested inlines
284     will now work.
285   * Add a map plugin contributed by Alessandro Dotti Contra.
286   * Add otl format plugin, which handles files as created by vimoutliner.
287   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
288   * Add first draft at a Restructured Text (rst) plugin, by Sergio
289     Talens-Oliag. Note that this has many known issues -- see the caveats on
290     the plugin's page.
291   * Credit everyone who wrote a plugin on the plugins' wiki pages.
292   * Fix utf-8 in blog post form.
293
294  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
295
296 ikiwiki (1.20) unstable; urgency=low
297
298   * Relicense the templates and basewiki under the 2-clause BSD license.
299     Since these can easily become part of other people's websites, they
300     should be under as permissive a license as possible.
301   * Add --syslog config option, to log to the syslog.
302   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
303     transient failure to fork (which I've seen happen in the wild).
304   * Fix a bug in the aggregator introduced last version that caused all
305     aggregator state to be lost during a non-aggregating build.
306
307  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
308
309 ikiwiki (1.19) unstable; urgency=low
310
311   * Fix several related bugs in page type determination during online editing.
312   * Add some locking to prevent 2 aggregators from running at once.
313   * Fix an infinite loop in the aggregator when finding a unique filename.
314
315  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
316
317 ikiwiki (1.18) unstable; urgency=low
318
319   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
320   * Add --version.
321   * Man page format fixups.
322   * If the meta plugin overides the page title, set a title_overridden
323     variable in the template to true. This allows doing things with the
324     templates conditional on the title being overriden.
325   * Add a %pagecase which maps lower-case page names to the actual case
326     used in the filename. Use this in bestlinks calculation instead of
327     forcing the link to lowercase.
328   * Also use %pagecase in various other places that want to check if a page
329     with a given name exists.
330   * This means that links to pages with mixed case names will now work,
331     even if the link is in some other case mixture, and mixed case pages
332     should be fully supported throughout ikiwiki.
333   * Recommend rebuilding wikis on upgrade to this version.
334
335  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
336
337 ikiwiki (1.17) unstable; urgency=low
338
339   * Disable tidy generator tag.
340   * Move tidy back to sanitize hook, found out how to only show body.
341   * Turn off tidy indentation too.
342   * Turn on HTML::Template loop_context_vars; not actually used in stock
343     templates but can be useful for things like making comma-delimited lists
344     of tags or what have you.
345   * Remove <br> from end of aggregate preprocessor directive output.
346   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
347     case-sensative filesystems like OSX.
348   * Improve markdown loading. First, try to load it as a proper perl module,
349     in case it was installed as one. Then fall back to trying
350     /usr/bin/markdown.
351   * Document in install page how to install markdown, since it has no
352     installation procedure in the upstream tarball.
353   * Set die_on_bad_params => 0 for all templates, to allow users to modify
354     them without annoyances.
355   * Suck in the page content when generating an inline archive page, to work
356     around the meta plugin's lack of caching of title metadata across runs.
357
358  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
359
360 ikiwiki (1.16) unstable; urgency=low
361
362   * Try to handle relative links in aggregated feeds. However,
363     the current support is a crude hack due to limitations of XML::Feed:
364     xml:base is not supported, neither is Content-Location. And of course,
365     relative links in RSS feeds are ill-undefined..
366   * Make aggregator save permalinks and author name to pages as metadata.
367   * Add permalink and author support to meta plugin, affecting RSS feeds
368     and blog pages.
369   * Various CSS and formatting changes.
370   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
371   * Add xhtml files to the default prune regexp.
372   * Also generate rel=bookmark links for permalinks.
373   * Fix the htmltidy plugin, which wasn't working due my breaking it when
374     I added it..
375   * Don't run tidy with -xml as that fails if the input is not well-formed.
376     Run it with -asxhtml instead, so it will output well-formed xhtml no
377     matter what the input.
378   * Disable tidy warnings too.
379   * Add a new format hook, and make tidy use it, since tidy can really only
380     operate on and output complete html documents, not the body chunks
381     that sanitise gets.
382   * Fix dates in rss feeds if running localised, so they're still rfc 822.
383
384  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
385
386 ikiwiki (1.15) unstable; urgency=low
387
388   * Remove CDPATH and other env vars perl taint checking doesn't like.
389     Closes: #381279
390   * Added created_before and created_after PageSpec limits.
391
392  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
393
394 ikiwiki (1.14) unstable; urgency=low
395
396   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
397     by 10% or so.
398   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
399   * Added many unit tests for pagespec_match.
400
401  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
402
403 ikiwiki (1.13) unstable; urgency=low
404
405   * ikiwiki can now download and aggregate feeds with its new aggregate
406     plugin, so it's possible to implement a Planet using ikiwiki!
407   * Add a run_hooks function for the common task of running all hooks of a
408     given type.
409   * Add a savestate hook.
410   * Don't put blog post forms on pages if there's no cgiurl set.
411   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
412     --wrappers to do that.
413   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
414     to update pages that haven't changed on disk.
415   * Change meta tags to use html entity-escaped text for values, so that
416     quotes and such can be represented in title tags.
417   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
418     for the above.
419   * Make --rebuild also cause --aggregate to re-download and write aggregated
420     pages.
421   * Avoid outputting duplicate meta info.
422   * Include title metadata on aggregated posts for capitalised and un-munged
423     titles.
424   * Title metadata of inlined pages now shows up in blogs and rss feeds.
425   * Fix issue with unicode filenames and updating the hyper estradier search
426     index. (Aka Please Please Please, let that be the last one.)
427   * Patch from Roland Mas to support an rss=no parameter to inline directives.
428     Closes: #380743
429   * Renamed GlobLists to PageSpecs.
430   * PageSpecs can now include nested parens, "and", and "or". This remains
431     backwards compatible to the old GlobList format. It's implemented by
432     treating the GlobList as a very limited microlanguage that is transformed
433     to perl code that does the matching.
434   * The old GlobList format is deprecated, and I encourage users to switch to
435     using the new PageSpec format. Compatability with the old format will be
436     removed at some point, possibly by 2.0.
437   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
438   * Add support for creation_month and creation_year to PageSpec.
439     Closes: #380680
440   * Changes to index file encoding.
441
442  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
443
444 ikiwiki (1.12) unstable; urgency=low
445
446   "Viva l'Italia!"
447   * New pagestats plugin from Enrico, which can generate a table counting
448     the backlinks for each page, or a del.icio.us style cloud.
449   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
450     the wikiformat plugin works. Thanks, Emanuele Aina.
451   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
452     display, running them through pagetitle. This removes ugly underscores and
453     other gunk from the display, much nicer. You may want to rebuild your wiki
454     when upgrading to get the cleanup globally.
455   * Polygen plugin from Enrico.
456   * htmltidy plugin from Faidon.
457   * Locale patch from Faidon:
458     - Adds a locale setting to setup files.
459     - Proper local time, if the locale configuration option is used.
460     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
461       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
462       impossible.
463   * Add getopt hook type, this allows plugins to add new command-line options.
464   * Add --tagbase option to tag plugin.
465   * Add exclude option in setup files, works same as --exclude.
466   * Put categories in rss feeds for tagged items.
467   * Allow preprocessor directives to be expanded in inlined blog pages.
468     However, to avoid inlining loops etc, don't expand inline directives in
469     inlined pages.
470   * fortune plugin (trivial)
471   * Tag plugins according to type.
472
473  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
474
475 ikiwiki (1.11) unstable; urgency=low
476
477   * Patch from Enrico that
478     - Adds a tag plugin that allows more easily tagging pages.
479       The meta plugin can also still be used for that, but the tag plugin
480       also lists a page's tags at the bottom of the page.
481     - Allows preprocessor directives to have parameters with no specified
482       value.
483     - Fixes preprocessor directive parameter parsing so that
484       foo=bar baz now means "foo=bar" and a "baz" with no value.
485   * Run pagetemplate hooks when inlining pages so that inlined pages also
486     list their tags.
487   * Make all plugins with pagetemplate hooks check that variables exist
488     on the template before setting them, for robustness.
489   * Switch pagetemplate hooks to using named parameters.
490   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
491     This will be the page that a source page will be part of, which is
492     different than the source page for inlined pages.
493   * Audited all plugins to endure they pass (page, destpage) to htmllink
494     appropriatly. This means inlining of various plugins will not work
495     properly, with correct links generated.
496
497  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
498
499 ikiwiki (1.10) unstable; urgency=low
500
501   * Run page through any relevant filters when generating a page preview.
502   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
503     default throughout the wiki, not only on wikitext pages. Decided to call
504     this a feature, and split the camelcase support out into a separate plugin
505     that is independant of wikitext.
506   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
507
508  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
509
510 ikiwiki (1.9) unstable; urgency=low
511
512   * Improve display of parentlinks and page title of toplevel index page.
513   * Patch from Faidon to use svn --limit when possible for recentchanges,
514     speeds up recentchanges a lot for wikis with more history.
515   * Patch from Recai to fix utf8 issues in git backend.
516   * Add wikitext markup plugin, which supports ".wiki" pages written in the
517     original wiki syntax, CamelCase links and all.
518   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
519     support, to edit pages etc without a web server.
520   * Display CGI processing errors if present.
521   * Fix from Faidon for a XML parser issue that breaks utf-8 for
522     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
523     area, and also way slow.
524   * Match 'web commit from' in SVN and git, these are web commits too.
525     (Faidon)
526   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
527     readable and avoid future mistakes. The patch seems to work and for the
528     first time I have a UTF-8 username ;-) (Faidon)
529   * Use form->field consistently, not form->param.
530   * Patch from Recai to allow selection of page type when creating a new page.
531     Default page type is inherited from the link clicked on to create the new
532     page.
533
534  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
535
536 ikiwiki (1.8) unstable; urgency=low
537
538   * Fix orphans plugin to not count a link to a nonexistant page as a reason
539     for a page not being an orphan.
540   * Support pinging services such as Technorati using XML-RPC to notify them
541     about changes to rss feeds.
542   * Parse svn log as xml for improved utf8 and security. Note that this makes
543     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
544   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
545     flagged string even if the locale causes it to generate utf8 output,
546     so make sure to let perl know it should be handled as utf8. Also,
547     the optimised version used for standard time formats won't work if the
548     user has changed locale, so drop it. Thanks, Faidon Liambotis.
549   * Fix re-encoding of the comments field to utf8 if a commit fails
550     due to a conflict. Thanks, Faidon Liambotis.
551   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
552     Liambotis.
553   * Add insane double encode/decode to utf8 around call to markdown.
554     This works around a truely strange bug, which is apparently a bug in
555     perl, #376329. Also added a test case for it.
556   * Improve layout of edit page so formatting help link is always visible w/o
557     getting in the way of the preview.
558   * Centralised all calls to HTML::Template and force all the templates
559     to be read as utf8.
560   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
561   * Introduce add_plugins and disable_plugins config options in setup files.
562     This allows adding or removing plugins w/o overriding the whole list of
563     default plugins, which makes it easier to upgrade when new default plugins
564     are added.
565   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
566     default (of course!). Based on a patch by Faidon Liambotis.
567   * Add a html plugin, which can be used to write wikis in raw html,
568     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
569     defaults to not processing .html files, since w/o this plugin they would
570     be copied unsanitised. With this plugin, it will process and html
571     sanitise them, like any other page type.
572   * Rebuilding wrappers is necessary on upgrade to this version.
573   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
574     will be automatically done on all upgrades.
575   * Don't send pings if the wiki is being rebuilt.
576   * Work around very innefficient behavior in File::Spec::abs2rel. Result
577     is a savings of 2 pointless fork/execs per link calculation, which
578     results in ~25% speedup of ikiwiki building its own doc wiki, and
579     about 35% speedup displaying RecentChanges!
580   * Make RecentChanges use a table and some CSS, should be much more readable.
581     No code changes involved.
582   * Encode & in diffurl in examples, to conform to pedantic rules.
583   * Speed up RecentChanges by another 40% or so with some memoization.
584   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
585     in time to build the doc wiki.
586
587  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
588
589 ikiwiki (1.7) unstable; urgency=low
590
591   * Updated logo from Recai with some kerning and alingment tuning.
592   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
593     changed some output.
594   * Copyright update.
595
596  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
597
598 ikiwiki (1.6) unstable; urgency=low
599
600   * YA utf-8 patch from Recai, this time to fix previewing a page so that
601     the text in the input box is re-encoded back to utf-8.
602   * -CSD does not affect modules, so readfile() was not using the utf-8 input
603     layer, which led to lots of problems; make it force read files as utf-8.
604     Closes: #373203
605   * Note that as a consequence, this version of ikiwiki will actually try to
606     parse utf8 in source files for the first time, which may expose broken
607     utf8 in wiki sources that was hidden before. Most common will be
608     perl warnings like "utf8 "\xE9" does not map to Unicode"
609   * writefile() likewise needs to use the utf8 output layer.
610   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
611     there.
612   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
613     given the readfile fix.
614   * Add utf-8 testcases for readfile and htmlize.
615   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
616     safe.
617   * More utf-8 fixes from Recai, partly to things I broke above:
618     - The serious problem is that writefile() saves the content in undecoded
619       format in CGI, hence all (non-ascii) chars are corrupted permanently.
620     - Comment field in edit page is not decoded and all the non-ascii chars in
621       this field are corrupted as the result.  We should decode it as we do it
622       for the content.
623     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
624       character in print.
625   * New SVG logo from Recai.
626
627  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
628
629 ikiwiki (1.5) unstable; urgency=low
630
631   * Add --timeformat config option to allow changing how dates are displayed.
632     Note that as a side effect, dates will now be displayed using the local
633     timezone, not as GMT.
634   * More security review.
635   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
636     for some handy stuff like:
637     - Using links as a kind of tag; creating blog pages that list all pages
638       containing a given tag/link or not containing some other tag.
639     - Subscribing to mail notifications whenever a change is made to a page
640       that is a backlink of page foo. Ie, "Please notify me of changes in all
641       pages that link to my home page in the wiki"
642     - Locking any pages that are linked to from a particular page, so that
643       lists of locks can be exposed in the wiki.
644   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
645     when a todo item is done, instead of the previous moving it to a different
646     subdir.
647   * Allow pagetemplate plugins to override *anything* in the template.
648   * Add a meta plugin, which allows specifying various metadata about pages,
649     like license and author. It also allows for inserting html link and meta
650     tags into html, overriding the title, and adding hidden WikiLinks, which
651     can be useful when using link-based globbing for page categorisation.
652   * Remove preprocessor directives from inlined pages.
653   * Allow simple preprocessor directive values to be specified w/o quotes.
654   * Add support for using git instead of subversion as the RCS backend,
655     tremendous thanks to Recai Oktaş for this.
656   * Doc updates for git.
657   * Fix absolute url munging in rss generation to support https, ftp, etc urls
658     not just http urls.
659   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
660     utf-8 for edit and other fields, and for recentchanges. There may still
661     be utf-8 issues with the preferences page though.
662
663  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
664
665 ikiwiki (1.4) unstable; urgency=low
666
667   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
668     very strange way of enabling proper XHTML <br /> type tags. Output html
669     should be always valid again now.
670   * The page name and parent links has switched from using a <h1> to a styled
671     <span>, so pages can use <h1> internally instead of needing to use <h2>.
672   * Updated all of ikiwiki's own wiki pages for that.
673   * Add pagetemplate hook, which can be used by plugins that want to mess
674     around with adding new stuff to the page template.
675   * Remove headercontent; the search plugin now adds the search box to the
676     header by registering a pagetemplate hook, and other plugins should do
677     similarly.
678   * Rebuilding on upgrade to this version is recommended.
679   * Add a html validity check to the test suite, using the wdg-html-validator,
680     if available.
681   * Make the html valid when there is nothing in the actions list.
682   * Reordered some function call parameters for consistency.
683   * Enable full utf-8 support for page input and output.
684   * Add a workaround for markdown, which does not work well with utf-8
685     strings.
686   * --getctime had bitrotted (well I only ever used it the once so far..),
687     fix and make it a bit more flexible
688   * rcs_getctime is changed, now rather than needing to loop over all pages,
689     it should just use the rcs to get the ctime of the passed file.
690   * When inlining a page in another one, links from the inlined page are now
691     expanded the same as they are when rendering the inlined page as a
692     standalone page. So rather than being expanded from the POV of the
693     inlining page, they are expanded from the POV of the inlined page.
694
695     For example, a link from blog/foo to "bar" will now link to blog/bar
696     if it exists. Previously this needed to be a link explicitly to
697     "blog/bar"; such links will also continue to work.
698
699     (This was slightly complex to do as the link still has to be constructed
700     relative to the inlining page.)
701   * Make page edit textarea resize to fit browser window.
702   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
703     do not need a full rebuild, in order to update any basewiki pages.
704
705  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
706
707 ikiwiki (1.3) unstable; urgency=low
708
709   * Fix the preinst introduced in the last version. Closes: #367458
710
711  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
712
713 ikiwiki (1.2) unstable; urgency=low
714
715   * Remove dups from the brokenlinks list.
716   * Add libc6-dev to dependencies, needed to build wrappers.
717   * Install wikilist in correct location. Closes: #367371
718
719  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
720
721 ikiwiki (1.1) unstable; urgency=low
722
723   * Rename inlinepage to depends, so that it can be used to refer to more
724     dependency relationships than just inlining. This will require a rebuild
725     on upgrade to this version.
726   * Move the rss link, put it in the blogpost form if there is one and at the
727     top if not. This is both nicer because easier to find, and it cleans up
728     the code which had used inlinepage as a flag for adding the link later.
729   * Allow the depends GlobList to be built up from multiple sources (such as
730     plugins) during a page render.
731   * Which means that more than one blog is now supported to appear on a
732     single page. (With some limitations, like only the last one getting an
733     rss file.)
734   * Added a plugin system.
735   * Added a pagecount plugin, enabled by default.
736   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
737   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
738     backlinks when the backlinks hadn't really changed.
739   * Moved inline page support, rss generation etc into the inline plugin,
740     enabled by default.
741   * Added brokenlinks plugin, not enabled by default, but rather handy.
742   * Fix several broken links in the doc wiki.
743   * Smarter behavior when creating a page and a page of the same name (but
744     different location) already exists.
745   * Add an orphans plugin for finding pages that nothing links to.
746   * Removed backlinks page, which it turns out nothing used.
747   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
748     it, this will allow for adding a unit test suite.
749   * Add unit tests for several core functions, including globlist_match,
750     dirname, basename, bestlink, linkify, pagetitle, titlepage.
751   * Smart globlist merging.
752   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
753     to pave the way for adding other RCS support. This also changes the
754     setup files, where before they had svn => 1 or svn => 0, now they have
755     rcs => "svn" or rcs => "".
756   * Add a debian/NEWS file with upgrade notes.
757   * Load whatever rcs module is specified, so new ones can be just dropped in
758     as plugins and work. (Well, in theory.)
759   * Add some basic docs about writing RCS modules.
760   * Broke search capability out into a plugin, removed the --hyperestraier
761     switch.
762   * Added smiley plugin, nicely controlled and documented by the smileys page.
763   * Copied in some smileys from Moin Moin.
764   * Allow links of the form [[some page|page]], with whitespace in the link
765     text.
766   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
767     and --disable-plugin htmlscrubber.
768   * Allow discussion links on pages to be turned off with --no-discussion.
769   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
770   * Add some new config items to the estseek.conf template, which are needed
771     by hyperestraier 1.2.3.
772
773  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
774
775 ikiwiki (1.0) unstable; urgency=low
776
777   * First official release.
778
779  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400