]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
use quick mode for archives
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Add an openid plugin to support logging in using OpenID.
4   * Web commits by OpenID users will record the full OpenID url for the user,
5     but in recentchanges, these urls will be converted to a simplified display
6     form+link.
7   * Modified svn, git, tla backends to recognise such web commits.
8   * Move httpauth support to a plugin.
9   * Add openidsignup config option.
10   * Make the openid plugin support the callbacks from myopenid.com via its
11     affiliate program.
12   * Add toggle plugin.
13   * Add a poll plugin.
14   * Add quick mode for archive page generation.
15   * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
16     many other plugins. It's an easy way to boost ikiwiki from its default,
17     basic wiki, to a full-featured wiki, without manually picking the right
18     set of plugins. New plugins will be added to goodstuff from time to
19     time.
20   * Change how post signin actions are propigated through the signin process;
21     they're now stored in the session.
22   * Add optional "desc" parameter to shortcut definitions.
23   * Avoid locking the wiki at all when handling some basic cgi stuff
24     (searches, recentchanges).
25   * Add "last" parameter to hook function. Very basic ordering, and hopefully
26     nothing more spohisticated will be needed.
27   * Add formbuilder_setup and formbuilder hooks.
28   * Split out a passwordauth module, that holds all the traditional password
29     based authentication etc code. It's enabled by default, but can be disabled
30     if you want only openid or some other auth method.
31   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
32   * Add some code to the build system that tries to determine if the
33     lib installation directory is in @INC. If it's not, munge ikiwiki
34     to hardcode the path to the lib directory. This should allow installing
35     ikiwiki in nonstandard locations, including home directories, by just
36     setting PREFIX at build time.
37   * Fix nested examples directory in deb.
38   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
39   * Add a test suite for the svn backend.
40   * Add a test suite for the git backend, from Recai 
41   * Daemonize before sending RPC pings, since that can take a while
42     and/or hang.
43   * Daemonize before sending commit mails, as that can also take a long
44     time/hang if the mail server is unhappy.
45   * Factor out commit mail sending code into new function.
46   * Change rcs_commit, it is now passed the name of the user doing the commit
47     and their IP address, and needs to construct its own commit message
48     containing them, or do something more appropriate for the given RCS.
49   * Add softwaresite example.
50   * Mercurial backend improvements, including --get-ctime support. (Emanuele
51     Aina)
52   * Git backend improvements, including bug fixes and better robustness,
53     from Recai.
54
55  -- Joey Hess <joeyh@debian.org>  Sun, 26 Nov 2006 15:01:14 -0500
56
57 ikiwiki (1.33) unstable; urgency=low
58
59   * Fix issue with aggregate plugin updating expired pages.
60   * Avoid syntax errors in templates used by the template plugin crashing
61     ikiwiki.
62   * Enable utf8 file IO in aggregate plugin.
63   * Fix some issues with the new registration form.
64   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
65   * Make sure to check for errors from every eval.
66   * Fix img plugin's handling of adding dependencies for images that do not
67     yet exist.
68   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
69     FORM-SUBMIT unusable on customised formbuilder templates. For now,
70     hardcode the submit buttons in editpage.tmpl instead of using the
71     template variable, which is ok, since the buttons are static.
72   * Work with hyperestraier 1.4.9.
73
74  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
75
76 ikiwiki (1.32) unstable; urgency=low
77
78   * Add a separate pass to find page links, and only render each page once,
79     instead of over and over. Typical speedup is ~4x. Max possible speedup:
80     8x.
81   * Add "scan" parameter to hook(), which is used to make the hook be called
82     during the scanning pass, as well as the render pass. The meta and tag
83     plugins need to use the new scan parameter, so will any others that modify
84     %links.
85   * Now that links are calculated in a separate pass, it can also
86     precalculate backlinks in one pass, which is O(N^2) instead of the
87     previous code that was O(N^3). A very nice speedup for wikis with lots
88     (thousands) of pages.
89   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
90     Erdem.
91   * Add a default stylesheet entry for the pagecloud.
92   * Add examples page with some examples of things that can be done using
93     ikiwiki, like a weblog. The examples can be copied into a user's wiki
94     for a quick start, without needing to learn everything about how to put
95     them together.
96   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
97   * Add perlmagick to build-depends so syntax check of img plugin works.
98     Closes: #396702
99   * Improve login/register process, the login dialog has only name and
100     password fields, which allows more web browsers to regognise it as a login
101     field, and is less confusing.
102   * Implemented expiry options for aggregate plugin.
103   * Use precalculated backlinks info when determining if files need an update
104     due to a page they link to being added/removed. Mostly significant if
105     there are lots of pages.
106   * Remove duplicate link info when saving index. In some cases it could
107     pile up rather badly. (Probably not the best way to deal with this
108     problem.)
109   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
110     or what have you, by creating enclosures for non-page items that are
111     included in feeds.
112
113  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
114
115 ikiwiki (1.31) unstable; urgency=low
116
117   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
118   * Change the rss feed title from the wikiname to the page title, with
119     an exception for the wiki's toplevel index page, which will still use the
120     wikiname as the feed title.
121     Overriding the page title with meta title already overrode the rss feed
122     tittle.
123   * Add an img plugin, based on Christian Mock's img plugin, but stripped
124     down to the bare essentials. Useful for handling large images on websites.
125   * Sanitize possibly problimatic characters out of the polygen grammar names,
126     just in case. Should not be exploitable anyway, since it only tries to run
127     polygen after finding the specified grammar file.
128   * Add missing dependency on the URI perl module.
129   * Add basic spam fighting tool for admins: An admin's prefs page now allows
130     editing a list of banned users.
131
132  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
133
134 ikiwiki (1.30) unstable; urgency=low
135
136   * Add no_override parameter to hook().
137   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
138     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
139     can be configured using a page in wiki.
140   * Fix support for --pingurl at the command line.
141   * Fix a subtle bug in will_render that broke some builds, by only clearing
142     items from renderedfiles the first time per build.
143   * Wrap entire technortati ping operation in an eval to catch all possible
144     failure modes, after I observed a simple ->value crashing ikiwiki when
145     a ping failed.
146
147  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
148
149 ikiwiki (1.29) unstable; urgency=low
150
151   * Patch from Paul Tötterman to use CP in the Makefile.
152   * Patch from Alec Berryman adding a http_auth config item that allows
153     using HTTP Authentication instead of ikiwiki's built in authentication.
154     Useful for eg, large sites with their own previously existing user auth
155     setup. Closes: #384534
156   * Change %renderedfiles to store an array of files rendered from a given
157     source file, to allow tracking of extra rendered files like rss feeds.
158   * Note that plugins that accessed this variable will need to be updated!
159     The plugin interface has been increased to version 1.01 for this change.
160     As few plugins use %renderedfiles I haven't done anything else to ensure
161     compatability of old plugins.
162   * Add will_render function to the plugin interface, used to register that a
163     page renders a destination file, and do some security checks. Previously
164     but no longer rendered files will be cleaned up.
165   * Use will_render in the inline and linkmap plugins.
166   * You will need to rebuild your wiki on upgrade to this version.
167   * Atom feed support based on a patch by Clint Adams.
168   * Add feeds=no option to inline preprocessor directive to turn off all types
169     of feeds.
170   * $IkiWiki::version now holds the program version, and is accessible to
171     plugins.
172   * Make the aggregate plugin emphasize error messages.
173   * Patch from Recai to limit recentchanges to displaying max 10 files for a
174     given changeset (to avoid large number of file changes excessively
175     bloating the page).
176
177  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
178
179 ikiwiki (1.28) unstable; urgency=low
180
181   * inline: Add ability to sort by page name, based on a patch from
182     Benjamin A'Lee.
183   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
184     braindead interface. Closes: #389383
185   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
186     and b) those poor Mac OSX users and their case insensative files!
187   * Don't fail syntax check if Text::Typography isn't installed.
188     Closes: #389406
189
190  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
191
192 ikiwiki (1.27) unstable; urgency=low
193
194   * Work on firming up the plugin interface:
195     - Plugins should not need to load IkiWiki::Render to get commonly
196       used functions, so moved some functions from there to IkiWiki.
197     - Picked out the set of functions and variables that most plugins
198       use, documented them, and made IkiWiki export them by default,
199       like a proper perl module should.
200     - Use the other functions at your own risk.
201     - This is not quite complete, I still have to decide whether to
202       export some other things.
203   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
204     referring to stuff now exported by the IkiWiki module.
205   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
206     to declare which version of the interface your plugin needs.
207   * Anyone with a third-party ikiwiki plugin is strongly encouraged
208     to make like changes to it and avoid use of non-exported symbols from
209     "IkiWiki::".
210   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
211   * Support hyperestradier version 1.4.2, which adds a new required phraseform
212     setting.
213   * If an inlined page has a permalink, link the page title to that.
214   * Patch from Recai to use utf8 when reading the setup file, so that
215     utf8 wikinames from there will be used properly.
216   * Patch from Recai to kill utf-8 on the wiki name when generating the
217     session cookie.
218   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
219   * Fix a baseurl problem in hyperestradier search results.
220   * Add a stub local.css to avoid problems with 404's.
221   * Patch from Recai to fix a wide character warning from the search plugin
222     during setup if the wikiname contains utf8.
223   * Yet another fix for those poor case-insensative OS X users.
224   * pagetemplate hooks are now also called when generating cgi pages.
225   * Add a favicon plugin, which simply adds a link tag for an icon to each
226     page (and cgis).
227   * Patch from James Westby to deal with the case where you're editing a
228     new page, hit cancel, and need to be redirected to somewhere sane.
229   * Various documentation improvements by various wiki users.
230   * Support Text::Markdown from CPAN, which has a different interface from
231     the original markdown or the one in Debian.
232   * Version the libcgi-session-perl dependency, some features that need
233     the new version are used in some cases (sslcookie).
234   * Numerous tla fixes from Clint.
235   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
236     a multi-resolution favicon.ico.
237   * README.Debian: typo Closes: #388110
238   * chomp trailing newline at the end of templates read in by the template
239     plugin, to allow use of the template preprocessor directive in
240     whitespace-sensative situations. Closes: #387073
241   * Patch from James Westby to make the location of the estseek.cgi script
242     configurable.
243   * Add typography (SmartyPants) plugin by Recai.
244   * Add --render mode, which can be used to preview an edit at the command
245     line by test rendering a single page.
246   * Add a googlecalendar plugin. A bit special-purpose, but it shows
247     one way to to deal with user-supplied content that could cause XSS
248     issues w/o the htmlscrubber, and won't survive the scrubber.
249
250  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
251
252 ikiwiki (1.26) unstable; urgency=low
253
254   * Add a missing -n to tla undo call.
255   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
256     writes before consuming its whole stdin. Avoid this deadlock.
257   * Fix alt tags for outline checkboxes.
258
259  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
260
261 ikiwiki (1.25) unstable; urgency=low
262
263   * Add proper waitpid calls for open2ed processes throughout to avoid
264     zombies; this hit htmltidy especially badly.
265   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
266     subversion repos and fixing some other issues.
267   * Add support for tla, contributed by Clint Adams. Closes: #385936
268   * Add support for mercurial, contributed by Emanuele Aina.
269   * Include <link rel> tag for RSS feeds, used by some aggregators and
270     firefox to find the feed.
271   * Add a linkmap plugin (requires graphviz).
272
273  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
274
275 ikiwiki (1.24) unstable; urgency=low
276
277   * Simplify the data structure returned by rcs_recentchanges to avoid
278     each rcs plugin needing to form complex strings on its own.
279   * Fix another destpage issue in the inline directive. Closes: #385512
280     again.
281
282  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
283
284 ikiwiki (1.23) unstable; urgency=low
285
286   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
287
288  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
289
290 ikiwiki (1.22) unstable; urgency=low
291
292   * Change how the stylesheet url is determined in the templates: Remove
293     STYLEURL and add BASEURL to all templates (some already had it). This
294     new more general variable can be used to link to other things (eg, images)
295     from the template, as well as stylesheets.
296   * Fix a bug introduced last version to do with nested inlines.
297   * Allow preprocessor directives to span multiple lines, both to make
298     long ones with lots of values easier to write, and to allow for ones with
299     multi-line quoted values.
300   * Allow preprocessor directives to contain python-like triple-quoted
301     text blocks, for easy nesting of quotes inside.
302   * Add a template plugin.
303   * Make pagespec merge code smarter about merging duplicate pagespecs.
304   * Patch from Jordà Polo to make Setup::Standard support hashes in config
305     files.
306   * Change order of linkify and preprocess; first preprocess and then linkify.
307     This allows passing a wikilink inside a parameter to a preprocessor
308     directive without it being expanded to html, and leaking out of the
309     parameter, which had required some non-obvious use of triple-quoting
310     to avoid. Note that any preprocessor plugins that output something
311     that looks like a wikilink will now have it treated as such; AFAIK
312     this doesn't change any behavior though except for the template plugin.
313   * Enable preprocessor directives when previewing an edit.
314   * Make all pages pull in a local.css style sheet, if present. This won't
315     be included in ikiwiki, but can be created to make local styling changes
316     w/o needing to merge in every new change to the distributed style.css.
317   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
318   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
319     from a different directory.
320   * Generalised preprocesser loop protection code.
321   * Patch from James Westby to allow a description to be set for rss feeds.
322   * Patch from James Westby to add a template for the search form.
323   * Added a ddate plugin.
324   * Patch from James Westby to add a --sslcookie switch, which forces
325     cookies to only be sent over ssl connections to avoid interception.
326   * Fix preferences page on anonok wikis; still need to sign in to get
327     to the preferences page.
328   * Add toc (table of contents) plugin.
329   * Change htmlize, format, and sanitize hooks to use named parameters.
330   * Patch from James Westby to add an actions option to inline; this
331     adds Edit and Discussion links at the end of blog entries.
332   * Due to some css changes, you'll want to rebuild your wiki on upgrade
333     to this version. Will be handled automatically by the deb.
334   * Add processed date to aggregate preprocessor directive status output.
335
336  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
337
338 ikiwiki (1.21) unstable; urgency=low
339
340   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
341   * If a page links to itself, mark up the link text in a span with
342     class="selflink" so that it can be styled. I don't have a useful style
343     defined for that though.
344   * Call filter hooks on inlined page content.
345   * Support inlining pages raw, rather than creating a blog.
346   * Clean up yes/no parameter parsing in inline plugin.
347   * Implemented better cycle detection in the inline plugin; nested inlines
348     will now work.
349   * Add a map plugin contributed by Alessandro Dotti Contra.
350   * Add otl format plugin, which handles files as created by vimoutliner.
351   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
352   * Add first draft at a Restructured Text (rst) plugin, by Sergio
353     Talens-Oliag. Note that this has many known issues -- see the caveats on
354     the plugin's page.
355   * Credit everyone who wrote a plugin on the plugins' wiki pages.
356   * Fix utf-8 in blog post form.
357
358  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
359
360 ikiwiki (1.20) unstable; urgency=low
361
362   * Relicense the templates and basewiki under the 2-clause BSD license.
363     Since these can easily become part of other people's websites, they
364     should be under as permissive a license as possible.
365   * Add --syslog config option, to log to the syslog.
366   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
367     transient failure to fork (which I've seen happen in the wild).
368   * Fix a bug in the aggregator introduced last version that caused all
369     aggregator state to be lost during a non-aggregating build.
370
371  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
372
373 ikiwiki (1.19) unstable; urgency=low
374
375   * Fix several related bugs in page type determination during online editing.
376   * Add some locking to prevent 2 aggregators from running at once.
377   * Fix an infinite loop in the aggregator when finding a unique filename.
378
379  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
380
381 ikiwiki (1.18) unstable; urgency=low
382
383   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
384   * Add --version.
385   * Man page format fixups.
386   * If the meta plugin overides the page title, set a title_overridden
387     variable in the template to true. This allows doing things with the
388     templates conditional on the title being overriden.
389   * Add a %pagecase which maps lower-case page names to the actual case
390     used in the filename. Use this in bestlinks calculation instead of
391     forcing the link to lowercase.
392   * Also use %pagecase in various other places that want to check if a page
393     with a given name exists.
394   * This means that links to pages with mixed case names will now work,
395     even if the link is in some other case mixture, and mixed case pages
396     should be fully supported throughout ikiwiki.
397   * Recommend rebuilding wikis on upgrade to this version.
398
399  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
400
401 ikiwiki (1.17) unstable; urgency=low
402
403   * Disable tidy generator tag.
404   * Move tidy back to sanitize hook, found out how to only show body.
405   * Turn off tidy indentation too.
406   * Turn on HTML::Template loop_context_vars; not actually used in stock
407     templates but can be useful for things like making comma-delimited lists
408     of tags or what have you.
409   * Remove <br> from end of aggregate preprocessor directive output.
410   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
411     case-sensative filesystems like OSX.
412   * Improve markdown loading. First, try to load it as a proper perl module,
413     in case it was installed as one. Then fall back to trying
414     /usr/bin/markdown.
415   * Document in install page how to install markdown, since it has no
416     installation procedure in the upstream tarball.
417   * Set die_on_bad_params => 0 for all templates, to allow users to modify
418     them without annoyances.
419   * Suck in the page content when generating an inline archive page, to work
420     around the meta plugin's lack of caching of title metadata across runs.
421
422  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
423
424 ikiwiki (1.16) unstable; urgency=low
425
426   * Try to handle relative links in aggregated feeds. However,
427     the current support is a crude hack due to limitations of XML::Feed:
428     xml:base is not supported, neither is Content-Location. And of course,
429     relative links in RSS feeds are ill-undefined..
430   * Make aggregator save permalinks and author name to pages as metadata.
431   * Add permalink and author support to meta plugin, affecting RSS feeds
432     and blog pages.
433   * Various CSS and formatting changes.
434   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
435   * Add xhtml files to the default prune regexp.
436   * Also generate rel=bookmark links for permalinks.
437   * Fix the htmltidy plugin, which wasn't working due my breaking it when
438     I added it..
439   * Don't run tidy with -xml as that fails if the input is not well-formed.
440     Run it with -asxhtml instead, so it will output well-formed xhtml no
441     matter what the input.
442   * Disable tidy warnings too.
443   * Add a new format hook, and make tidy use it, since tidy can really only
444     operate on and output complete html documents, not the body chunks
445     that sanitise gets.
446   * Fix dates in rss feeds if running localised, so they're still rfc 822.
447
448  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
449
450 ikiwiki (1.15) unstable; urgency=low
451
452   * Remove CDPATH and other env vars perl taint checking doesn't like.
453     Closes: #381279
454   * Added created_before and created_after PageSpec limits.
455
456  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
457
458 ikiwiki (1.14) unstable; urgency=low
459
460   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
461     by 10% or so.
462   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
463   * Added many unit tests for pagespec_match.
464
465  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
466
467 ikiwiki (1.13) unstable; urgency=low
468
469   * ikiwiki can now download and aggregate feeds with its new aggregate
470     plugin, so it's possible to implement a Planet using ikiwiki!
471   * Add a run_hooks function for the common task of running all hooks of a
472     given type.
473   * Add a savestate hook.
474   * Don't put blog post forms on pages if there's no cgiurl set.
475   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
476     --wrappers to do that.
477   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
478     to update pages that haven't changed on disk.
479   * Change meta tags to use html entity-escaped text for values, so that
480     quotes and such can be represented in title tags.
481   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
482     for the above.
483   * Make --rebuild also cause --aggregate to re-download and write aggregated
484     pages.
485   * Avoid outputting duplicate meta info.
486   * Include title metadata on aggregated posts for capitalised and un-munged
487     titles.
488   * Title metadata of inlined pages now shows up in blogs and rss feeds.
489   * Fix issue with unicode filenames and updating the hyper estradier search
490     index. (Aka Please Please Please, let that be the last one.)
491   * Patch from Roland Mas to support an rss=no parameter to inline directives.
492     Closes: #380743
493   * Renamed GlobLists to PageSpecs.
494   * PageSpecs can now include nested parens, "and", and "or". This remains
495     backwards compatible to the old GlobList format. It's implemented by
496     treating the GlobList as a very limited microlanguage that is transformed
497     to perl code that does the matching.
498   * The old GlobList format is deprecated, and I encourage users to switch to
499     using the new PageSpec format. Compatability with the old format will be
500     removed at some point, possibly by 2.0.
501   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
502   * Add support for creation_month and creation_year to PageSpec.
503     Closes: #380680
504   * Changes to index file encoding.
505
506  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
507
508 ikiwiki (1.12) unstable; urgency=low
509
510   "Viva l'Italia!"
511   * New pagestats plugin from Enrico, which can generate a table counting
512     the backlinks for each page, or a del.icio.us style cloud.
513   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
514     the wikiformat plugin works. Thanks, Emanuele Aina.
515   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
516     display, running them through pagetitle. This removes ugly underscores and
517     other gunk from the display, much nicer. You may want to rebuild your wiki
518     when upgrading to get the cleanup globally.
519   * Polygen plugin from Enrico.
520   * htmltidy plugin from Faidon.
521   * Locale patch from Faidon:
522     - Adds a locale setting to setup files.
523     - Proper local time, if the locale configuration option is used.
524     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
525       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
526       impossible.
527   * Add getopt hook type, this allows plugins to add new command-line options.
528   * Add --tagbase option to tag plugin.
529   * Add exclude option in setup files, works same as --exclude.
530   * Put categories in rss feeds for tagged items.
531   * Allow preprocessor directives to be expanded in inlined blog pages.
532     However, to avoid inlining loops etc, don't expand inline directives in
533     inlined pages.
534   * fortune plugin (trivial)
535   * Tag plugins according to type.
536
537  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
538
539 ikiwiki (1.11) unstable; urgency=low
540
541   * Patch from Enrico that
542     - Adds a tag plugin that allows more easily tagging pages.
543       The meta plugin can also still be used for that, but the tag plugin
544       also lists a page's tags at the bottom of the page.
545     - Allows preprocessor directives to have parameters with no specified
546       value.
547     - Fixes preprocessor directive parameter parsing so that
548       foo=bar baz now means "foo=bar" and a "baz" with no value.
549   * Run pagetemplate hooks when inlining pages so that inlined pages also
550     list their tags.
551   * Make all plugins with pagetemplate hooks check that variables exist
552     on the template before setting them, for robustness.
553   * Switch pagetemplate hooks to using named parameters.
554   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
555     This will be the page that a source page will be part of, which is
556     different than the source page for inlined pages.
557   * Audited all plugins to endure they pass (page, destpage) to htmllink
558     appropriatly. This means inlining of various plugins will not work
559     properly, with correct links generated.
560
561  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
562
563 ikiwiki (1.10) unstable; urgency=low
564
565   * Run page through any relevant filters when generating a page preview.
566   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
567     default throughout the wiki, not only on wikitext pages. Decided to call
568     this a feature, and split the camelcase support out into a separate plugin
569     that is independant of wikitext.
570   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
571
572  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
573
574 ikiwiki (1.9) unstable; urgency=low
575
576   * Improve display of parentlinks and page title of toplevel index page.
577   * Patch from Faidon to use svn --limit when possible for recentchanges,
578     speeds up recentchanges a lot for wikis with more history.
579   * Patch from Recai to fix utf8 issues in git backend.
580   * Add wikitext markup plugin, which supports ".wiki" pages written in the
581     original wiki syntax, CamelCase links and all.
582   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
583     support, to edit pages etc without a web server.
584   * Display CGI processing errors if present.
585   * Fix from Faidon for a XML parser issue that breaks utf-8 for
586     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
587     area, and also way slow.
588   * Match 'web commit from' in SVN and git, these are web commits too.
589     (Faidon)
590   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
591     readable and avoid future mistakes. The patch seems to work and for the
592     first time I have a UTF-8 username ;-) (Faidon)
593   * Use form->field consistently, not form->param.
594   * Patch from Recai to allow selection of page type when creating a new page.
595     Default page type is inherited from the link clicked on to create the new
596     page.
597
598  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
599
600 ikiwiki (1.8) unstable; urgency=low
601
602   * Fix orphans plugin to not count a link to a nonexistant page as a reason
603     for a page not being an orphan.
604   * Support pinging services such as Technorati using XML-RPC to notify them
605     about changes to rss feeds.
606   * Parse svn log as xml for improved utf8 and security. Note that this makes
607     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
608   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
609     flagged string even if the locale causes it to generate utf8 output,
610     so make sure to let perl know it should be handled as utf8. Also,
611     the optimised version used for standard time formats won't work if the
612     user has changed locale, so drop it. Thanks, Faidon Liambotis.
613   * Fix re-encoding of the comments field to utf8 if a commit fails
614     due to a conflict. Thanks, Faidon Liambotis.
615   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
616     Liambotis.
617   * Add insane double encode/decode to utf8 around call to markdown.
618     This works around a truely strange bug, which is apparently a bug in
619     perl, #376329. Also added a test case for it.
620   * Improve layout of edit page so formatting help link is always visible w/o
621     getting in the way of the preview.
622   * Centralised all calls to HTML::Template and force all the templates
623     to be read as utf8.
624   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
625   * Introduce add_plugins and disable_plugins config options in setup files.
626     This allows adding or removing plugins w/o overriding the whole list of
627     default plugins, which makes it easier to upgrade when new default plugins
628     are added.
629   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
630     default (of course!). Based on a patch by Faidon Liambotis.
631   * Add a html plugin, which can be used to write wikis in raw html,
632     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
633     defaults to not processing .html files, since w/o this plugin they would
634     be copied unsanitised. With this plugin, it will process and html
635     sanitise them, like any other page type.
636   * Rebuilding wrappers is necessary on upgrade to this version.
637   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
638     will be automatically done on all upgrades.
639   * Don't send pings if the wiki is being rebuilt.
640   * Work around very innefficient behavior in File::Spec::abs2rel. Result
641     is a savings of 2 pointless fork/execs per link calculation, which
642     results in ~25% speedup of ikiwiki building its own doc wiki, and
643     about 35% speedup displaying RecentChanges!
644   * Make RecentChanges use a table and some CSS, should be much more readable.
645     No code changes involved.
646   * Encode & in diffurl in examples, to conform to pedantic rules.
647   * Speed up RecentChanges by another 40% or so with some memoization.
648   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
649     in time to build the doc wiki.
650
651  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
652
653 ikiwiki (1.7) unstable; urgency=low
654
655   * Updated logo from Recai with some kerning and alingment tuning.
656   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
657     changed some output.
658   * Copyright update.
659
660  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
661
662 ikiwiki (1.6) unstable; urgency=low
663
664   * YA utf-8 patch from Recai, this time to fix previewing a page so that
665     the text in the input box is re-encoded back to utf-8.
666   * -CSD does not affect modules, so readfile() was not using the utf-8 input
667     layer, which led to lots of problems; make it force read files as utf-8.
668     Closes: #373203
669   * Note that as a consequence, this version of ikiwiki will actually try to
670     parse utf8 in source files for the first time, which may expose broken
671     utf8 in wiki sources that was hidden before. Most common will be
672     perl warnings like "utf8 "\xE9" does not map to Unicode"
673   * writefile() likewise needs to use the utf8 output layer.
674   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
675     there.
676   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
677     given the readfile fix.
678   * Add utf-8 testcases for readfile and htmlize.
679   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
680     safe.
681   * More utf-8 fixes from Recai, partly to things I broke above:
682     - The serious problem is that writefile() saves the content in undecoded
683       format in CGI, hence all (non-ascii) chars are corrupted permanently.
684     - Comment field in edit page is not decoded and all the non-ascii chars in
685       this field are corrupted as the result.  We should decode it as we do it
686       for the content.
687     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
688       character in print.
689   * New SVG logo from Recai.
690
691  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
692
693 ikiwiki (1.5) unstable; urgency=low
694
695   * Add --timeformat config option to allow changing how dates are displayed.
696     Note that as a side effect, dates will now be displayed using the local
697     timezone, not as GMT.
698   * More security review.
699   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
700     for some handy stuff like:
701     - Using links as a kind of tag; creating blog pages that list all pages
702       containing a given tag/link or not containing some other tag.
703     - Subscribing to mail notifications whenever a change is made to a page
704       that is a backlink of page foo. Ie, "Please notify me of changes in all
705       pages that link to my home page in the wiki"
706     - Locking any pages that are linked to from a particular page, so that
707       lists of locks can be exposed in the wiki.
708   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
709     when a todo item is done, instead of the previous moving it to a different
710     subdir.
711   * Allow pagetemplate plugins to override *anything* in the template.
712   * Add a meta plugin, which allows specifying various metadata about pages,
713     like license and author. It also allows for inserting html link and meta
714     tags into html, overriding the title, and adding hidden WikiLinks, which
715     can be useful when using link-based globbing for page categorisation.
716   * Remove preprocessor directives from inlined pages.
717   * Allow simple preprocessor directive values to be specified w/o quotes.
718   * Add support for using git instead of subversion as the RCS backend,
719     tremendous thanks to Recai Oktaş for this.
720   * Doc updates for git.
721   * Fix absolute url munging in rss generation to support https, ftp, etc urls
722     not just http urls.
723   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
724     utf-8 for edit and other fields, and for recentchanges. There may still
725     be utf-8 issues with the preferences page though.
726
727  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
728
729 ikiwiki (1.4) unstable; urgency=low
730
731   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
732     very strange way of enabling proper XHTML <br /> type tags. Output html
733     should be always valid again now.
734   * The page name and parent links has switched from using a <h1> to a styled
735     <span>, so pages can use <h1> internally instead of needing to use <h2>.
736   * Updated all of ikiwiki's own wiki pages for that.
737   * Add pagetemplate hook, which can be used by plugins that want to mess
738     around with adding new stuff to the page template.
739   * Remove headercontent; the search plugin now adds the search box to the
740     header by registering a pagetemplate hook, and other plugins should do
741     similarly.
742   * Rebuilding on upgrade to this version is recommended.
743   * Add a html validity check to the test suite, using the wdg-html-validator,
744     if available.
745   * Make the html valid when there is nothing in the actions list.
746   * Reordered some function call parameters for consistency.
747   * Enable full utf-8 support for page input and output.
748   * Add a workaround for markdown, which does not work well with utf-8
749     strings.
750   * --getctime had bitrotted (well I only ever used it the once so far..),
751     fix and make it a bit more flexible
752   * rcs_getctime is changed, now rather than needing to loop over all pages,
753     it should just use the rcs to get the ctime of the passed file.
754   * When inlining a page in another one, links from the inlined page are now
755     expanded the same as they are when rendering the inlined page as a
756     standalone page. So rather than being expanded from the POV of the
757     inlining page, they are expanded from the POV of the inlined page.
758
759     For example, a link from blog/foo to "bar" will now link to blog/bar
760     if it exists. Previously this needed to be a link explicitly to
761     "blog/bar"; such links will also continue to work.
762
763     (This was slightly complex to do as the link still has to be constructed
764     relative to the inlining page.)
765   * Make page edit textarea resize to fit browser window.
766   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
767     do not need a full rebuild, in order to update any basewiki pages.
768
769  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
770
771 ikiwiki (1.3) unstable; urgency=low
772
773   * Fix the preinst introduced in the last version. Closes: #367458
774
775  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
776
777 ikiwiki (1.2) unstable; urgency=low
778
779   * Remove dups from the brokenlinks list.
780   * Add libc6-dev to dependencies, needed to build wrappers.
781   * Install wikilist in correct location. Closes: #367371
782
783  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
784
785 ikiwiki (1.1) unstable; urgency=low
786
787   * Rename inlinepage to depends, so that it can be used to refer to more
788     dependency relationships than just inlining. This will require a rebuild
789     on upgrade to this version.
790   * Move the rss link, put it in the blogpost form if there is one and at the
791     top if not. This is both nicer because easier to find, and it cleans up
792     the code which had used inlinepage as a flag for adding the link later.
793   * Allow the depends GlobList to be built up from multiple sources (such as
794     plugins) during a page render.
795   * Which means that more than one blog is now supported to appear on a
796     single page. (With some limitations, like only the last one getting an
797     rss file.)
798   * Added a plugin system.
799   * Added a pagecount plugin, enabled by default.
800   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
801   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
802     backlinks when the backlinks hadn't really changed.
803   * Moved inline page support, rss generation etc into the inline plugin,
804     enabled by default.
805   * Added brokenlinks plugin, not enabled by default, but rather handy.
806   * Fix several broken links in the doc wiki.
807   * Smarter behavior when creating a page and a page of the same name (but
808     different location) already exists.
809   * Add an orphans plugin for finding pages that nothing links to.
810   * Removed backlinks page, which it turns out nothing used.
811   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
812     it, this will allow for adding a unit test suite.
813   * Add unit tests for several core functions, including globlist_match,
814     dirname, basename, bestlink, linkify, pagetitle, titlepage.
815   * Smart globlist merging.
816   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
817     to pave the way for adding other RCS support. This also changes the
818     setup files, where before they had svn => 1 or svn => 0, now they have
819     rcs => "svn" or rcs => "".
820   * Add a debian/NEWS file with upgrade notes.
821   * Load whatever rcs module is specified, so new ones can be just dropped in
822     as plugins and work. (Well, in theory.)
823   * Add some basic docs about writing RCS modules.
824   * Broke search capability out into a plugin, removed the --hyperestraier
825     switch.
826   * Added smiley plugin, nicely controlled and documented by the smileys page.
827   * Copied in some smileys from Moin Moin.
828   * Allow links of the form [[some page|page]], with whitespace in the link
829     text.
830   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
831     and --disable-plugin htmlscrubber.
832   * Allow discussion links on pages to be turned off with --no-discussion.
833   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
834   * Add some new config items to the estseek.conf template, which are needed
835     by hyperestraier 1.2.3.
836
837  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
838
839 ikiwiki (1.0) unstable; urgency=low
840
841   * First official release.
842
843  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400