]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
* Avoid syntax errors in templates used by the template plugin crashing
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.33) UNRELEASED; urgency=low
2
3   * Fix issue with aggregate plugin updating expired pages.
4   * Avoid syntax errors in templates used by the template plugin crashing
5     ikiwiki.
6
7  -- Joey Hess <joeyh@debian.org>  Sun,  5 Nov 2006 18:41:06 -0500
8
9 ikiwiki (1.32) unstable; urgency=low
10
11   * Add a separate pass to find page links, and only render each page once,
12     instead of over and over. Typical speedup is ~4x. Max possible speedup:
13     8x.
14   * Add "scan" parameter to hook(), which is used to make the hook be called
15     during the scanning pass, as well as the render pass. The meta and tag
16     plugins need to use the new scan parameter, so will any others that modify
17     %links.
18   * Now that links are calculated in a separate pass, it can also
19     precalculate backlinks in one pass, which is O(N^2) instead of the
20     previous code that was O(N^3). A very nice speedup for wikis with lots
21     (thousands) of pages.
22   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
23     Erdem.
24   * Add a default stylesheet entry for the pagecloud.
25   * Add examples page with some examples of things that can be done using
26     ikiwiki, like a weblog. The examples can be copied into a user's wiki
27     for a quick start, without needing to learn everything about how to put
28     them together.
29   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
30   * Add perlmagick to build-depends so syntax check of img plugin works.
31     Closes: #396702
32   * Improve login/register process, the login dialog has only name and
33     password fields, which allows more web browsers to regognise it as a login
34     field, and is less confusing.
35   * Implemented expiry options for aggregate plugin.
36   * Use precalculated backlinks info when determining if files need an update
37     due to a page they link to being added/removed. Mostly significant if
38     there are lots of pages.
39   * Remove duplicate link info when saving index. In some cases it could
40     pile up rather badly. (Probably not the best way to deal with this
41     problem.)
42   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
43     or what have you, by creating enclosures for non-page items that are
44     included in feeds.
45
46  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
47
48 ikiwiki (1.31) unstable; urgency=low
49
50   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
51   * Change the rss feed title from the wikiname to the page title, with
52     an exception for the wiki's toplevel index page, which will still use the
53     wikiname as the feed title.
54     Overriding the page title with meta title already overrode the rss feed
55     tittle.
56   * Add an img plugin, based on Christian Mock's img plugin, but stripped
57     down to the bare essentials. Useful for handling large images on websites.
58   * Sanitize possibly problimatic characters out of the polygen grammar names,
59     just in case. Should not be exploitable anyway, since it only tries to run
60     polygen after finding the specified grammar file.
61   * Add missing dependency on the URI perl module.
62   * Add basic spam fighting tool for admins: An admin's prefs page now allows
63     editing a list of banned users.
64
65  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
66
67 ikiwiki (1.30) unstable; urgency=low
68
69   * Add no_override parameter to hook().
70   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
71     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
72     can be configured using a page in wiki.
73   * Fix support for --pingurl at the command line.
74   * Fix a subtle bug in will_render that broke some builds, by only clearing
75     items from renderedfiles the first time per build.
76   * Wrap entire technortati ping operation in an eval to catch all possible
77     failure modes, after I observed a simple ->value crashing ikiwiki when
78     a ping failed.
79
80  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
81
82 ikiwiki (1.29) unstable; urgency=low
83
84   * Patch from Paul Tötterman to use CP in the Makefile.
85   * Patch from Alec Berryman adding a http_auth config item that allows
86     using HTTP Authentication instead of ikiwiki's built in authentication.
87     Useful for eg, large sites with their own previously existing user auth
88     setup. Closes: #384534
89   * Change %renderedfiles to store an array of files rendered from a given
90     source file, to allow tracking of extra rendered files like rss feeds.
91   * Note that plugins that accessed this variable will need to be updated!
92     The plugin interface has been increased to version 1.01 for this change.
93     As few plugins use %renderedfiles I haven't done anything else to ensure
94     compatability of old plugins.
95   * Add will_render function to the plugin interface, used to register that a
96     page renders a destination file, and do some security checks. Previously
97     but no longer rendered files will be cleaned up.
98   * Use will_render in the inline and linkmap plugins.
99   * You will need to rebuild your wiki on upgrade to this version.
100   * Atom feed support based on a patch by Clint Adams.
101   * Add feeds=no option to inline preprocessor directive to turn off all types
102     of feeds.
103   * $IkiWiki::version now holds the program version, and is accessible to
104     plugins.
105   * Make the aggregate plugin emphasize error messages.
106   * Patch from Recai to limit recentchanges to displaying max 10 files for a
107     given changeset (to avoid large number of file changes excessively
108     bloating the page).
109
110  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
111
112 ikiwiki (1.28) unstable; urgency=low
113
114   * inline: Add ability to sort by page name, based on a patch from
115     Benjamin A'Lee.
116   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
117     braindead interface. Closes: #389383
118   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
119     and b) those poor Mac OSX users and their case insensative files!
120   * Don't fail syntax check if Text::Typography isn't installed.
121     Closes: #389406
122
123  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
124
125 ikiwiki (1.27) unstable; urgency=low
126
127   * Work on firming up the plugin interface:
128     - Plugins should not need to load IkiWiki::Render to get commonly
129       used functions, so moved some functions from there to IkiWiki.
130     - Picked out the set of functions and variables that most plugins
131       use, documented them, and made IkiWiki export them by default,
132       like a proper perl module should.
133     - Use the other functions at your own risk.
134     - This is not quite complete, I still have to decide whether to
135       export some other things.
136   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
137     referring to stuff now exported by the IkiWiki module.
138   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
139     to declare which version of the interface your plugin needs.
140   * Anyone with a third-party ikiwiki plugin is strongly encouraged
141     to make like changes to it and avoid use of non-exported symbols from
142     "IkiWiki::".
143   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
144   * Support hyperestradier version 1.4.2, which adds a new required phraseform
145     setting.
146   * If an inlined page has a permalink, link the page title to that.
147   * Patch from Recai to use utf8 when reading the setup file, so that
148     utf8 wikinames from there will be used properly.
149   * Patch from Recai to kill utf-8 on the wiki name when generating the
150     session cookie.
151   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
152   * Fix a baseurl problem in hyperestradier search results.
153   * Add a stub local.css to avoid problems with 404's.
154   * Patch from Recai to fix a wide character warning from the search plugin
155     during setup if the wikiname contains utf8.
156   * Yet another fix for those poor case-insensative OS X users.
157   * pagetemplate hooks are now also called when generating cgi pages.
158   * Add a favicon plugin, which simply adds a link tag for an icon to each
159     page (and cgis).
160   * Patch from James Westby to deal with the case where you're editing a
161     new page, hit cancel, and need to be redirected to somewhere sane.
162   * Various documentation improvements by various wiki users.
163   * Support Text::Markdown from CPAN, which has a different interface from
164     the original markdown or the one in Debian.
165   * Version the libcgi-session-perl dependency, some features that need
166     the new version are used in some cases (sslcookie).
167   * Numerous tla fixes from Clint.
168   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
169     a multi-resolution favicon.ico.
170   * README.Debian: typo Closes: #388110
171   * chomp trailing newline at the end of templates read in by the template
172     plugin, to allow use of the template preprocessor directive in
173     whitespace-sensative situations. Closes: #387073
174   * Patch from James Westby to make the location of the estseek.cgi script
175     configurable.
176   * Add typography (SmartyPants) plugin by Recai.
177   * Add --render mode, which can be used to preview an edit at the command
178     line by test rendering a single page.
179   * Add a googlecalendar plugin. A bit special-purpose, but it shows
180     one way to to deal with user-supplied content that could cause XSS
181     issues w/o the htmlscrubber, and won't survive the scrubber.
182
183  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
184
185 ikiwiki (1.26) unstable; urgency=low
186
187   * Add a missing -n to tla undo call.
188   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
189     writes before consuming its whole stdin. Avoid this deadlock.
190   * Fix alt tags for outline checkboxes.
191
192  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
193
194 ikiwiki (1.25) unstable; urgency=low
195
196   * Add proper waitpid calls for open2ed processes throughout to avoid
197     zombies; this hit htmltidy especially badly.
198   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
199     subversion repos and fixing some other issues.
200   * Add support for tla, contributed by Clint Adams. Closes: #385936
201   * Add support for mercurial, contributed by Emanuele Aina.
202   * Include <link rel> tag for RSS feeds, used by some aggregators and
203     firefox to find the feed.
204   * Add a linkmap plugin (requires graphviz).
205
206  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
207
208 ikiwiki (1.24) unstable; urgency=low
209
210   * Simplify the data structure returned by rcs_recentchanges to avoid
211     each rcs plugin needing to form complex strings on its own.
212   * Fix another destpage issue in the inline directive. Closes: #385512
213     again.
214
215  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
216
217 ikiwiki (1.23) unstable; urgency=low
218
219   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
220
221  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
222
223 ikiwiki (1.22) unstable; urgency=low
224
225   * Change how the stylesheet url is determined in the templates: Remove
226     STYLEURL and add BASEURL to all templates (some already had it). This
227     new more general variable can be used to link to other things (eg, images)
228     from the template, as well as stylesheets.
229   * Fix a bug introduced last version to do with nested inlines.
230   * Allow preprocessor directives to span multiple lines, both to make
231     long ones with lots of values easier to write, and to allow for ones with
232     multi-line quoted values.
233   * Allow preprocessor directives to contain python-like triple-quoted
234     text blocks, for easy nesting of quotes inside.
235   * Add a template plugin.
236   * Make pagespec merge code smarter about merging duplicate pagespecs.
237   * Patch from Jordà Polo to make Setup::Standard support hashes in config
238     files.
239   * Change order of linkify and preprocess; first preprocess and then linkify.
240     This allows passing a wikilink inside a parameter to a preprocessor
241     directive without it being expanded to html, and leaking out of the
242     parameter, which had required some non-obvious use of triple-quoting
243     to avoid. Note that any preprocessor plugins that output something
244     that looks like a wikilink will now have it treated as such; AFAIK
245     this doesn't change any behavior though except for the template plugin.
246   * Enable preprocessor directives when previewing an edit.
247   * Make all pages pull in a local.css style sheet, if present. This won't
248     be included in ikiwiki, but can be created to make local styling changes
249     w/o needing to merge in every new change to the distributed style.css.
250   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
251   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
252     from a different directory.
253   * Generalised preprocesser loop protection code.
254   * Patch from James Westby to allow a description to be set for rss feeds.
255   * Patch from James Westby to add a template for the search form.
256   * Added a ddate plugin.
257   * Patch from James Westby to add a --sslcookie switch, which forces
258     cookies to only be sent over ssl connections to avoid interception.
259   * Fix preferences page on anonok wikis; still need to sign in to get
260     to the preferences page.
261   * Add toc (table of contents) plugin.
262   * Change htmlize, format, and sanitize hooks to use named parameters.
263   * Patch from James Westby to add an actions option to inline; this
264     adds Edit and Discussion links at the end of blog entries.
265   * Due to some css changes, you'll want to rebuild your wiki on upgrade
266     to this version. Will be handled automatically by the deb.
267   * Add processed date to aggregate preprocessor directive status output.
268
269  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
270
271 ikiwiki (1.21) unstable; urgency=low
272
273   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
274   * If a page links to itself, mark up the link text in a span with
275     class="selflink" so that it can be styled. I don't have a useful style
276     defined for that though.
277   * Call filter hooks on inlined page content.
278   * Support inlining pages raw, rather than creating a blog.
279   * Clean up yes/no parameter parsing in inline plugin.
280   * Implemented better cycle detection in the inline plugin; nested inlines
281     will now work.
282   * Add a map plugin contributed by Alessandro Dotti Contra.
283   * Add otl format plugin, which handles files as created by vimoutliner.
284   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
285   * Add first draft at a Restructured Text (rst) plugin, by Sergio
286     Talens-Oliag. Note that this has many known issues -- see the caveats on
287     the plugin's page.
288   * Credit everyone who wrote a plugin on the plugins' wiki pages.
289   * Fix utf-8 in blog post form.
290
291  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
292
293 ikiwiki (1.20) unstable; urgency=low
294
295   * Relicense the templates and basewiki under the 2-clause BSD license.
296     Since these can easily become part of other people's websites, they
297     should be under as permissive a license as possible.
298   * Add --syslog config option, to log to the syslog.
299   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
300     transient failure to fork (which I've seen happen in the wild).
301   * Fix a bug in the aggregator introduced last version that caused all
302     aggregator state to be lost during a non-aggregating build.
303
304  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
305
306 ikiwiki (1.19) unstable; urgency=low
307
308   * Fix several related bugs in page type determination during online editing.
309   * Add some locking to prevent 2 aggregators from running at once.
310   * Fix an infinite loop in the aggregator when finding a unique filename.
311
312  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
313
314 ikiwiki (1.18) unstable; urgency=low
315
316   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
317   * Add --version.
318   * Man page format fixups.
319   * If the meta plugin overides the page title, set a title_overridden
320     variable in the template to true. This allows doing things with the
321     templates conditional on the title being overriden.
322   * Add a %pagecase which maps lower-case page names to the actual case
323     used in the filename. Use this in bestlinks calculation instead of
324     forcing the link to lowercase.
325   * Also use %pagecase in various other places that want to check if a page
326     with a given name exists.
327   * This means that links to pages with mixed case names will now work,
328     even if the link is in some other case mixture, and mixed case pages
329     should be fully supported throughout ikiwiki.
330   * Recommend rebuilding wikis on upgrade to this version.
331
332  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
333
334 ikiwiki (1.17) unstable; urgency=low
335
336   * Disable tidy generator tag.
337   * Move tidy back to sanitize hook, found out how to only show body.
338   * Turn off tidy indentation too.
339   * Turn on HTML::Template loop_context_vars; not actually used in stock
340     templates but can be useful for things like making comma-delimited lists
341     of tags or what have you.
342   * Remove <br> from end of aggregate preprocessor directive output.
343   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
344     case-sensative filesystems like OSX.
345   * Improve markdown loading. First, try to load it as a proper perl module,
346     in case it was installed as one. Then fall back to trying
347     /usr/bin/markdown.
348   * Document in install page how to install markdown, since it has no
349     installation procedure in the upstream tarball.
350   * Set die_on_bad_params => 0 for all templates, to allow users to modify
351     them without annoyances.
352   * Suck in the page content when generating an inline archive page, to work
353     around the meta plugin's lack of caching of title metadata across runs.
354
355  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
356
357 ikiwiki (1.16) unstable; urgency=low
358
359   * Try to handle relative links in aggregated feeds. However,
360     the current support is a crude hack due to limitations of XML::Feed:
361     xml:base is not supported, neither is Content-Location. And of course,
362     relative links in RSS feeds are ill-undefined..
363   * Make aggregator save permalinks and author name to pages as metadata.
364   * Add permalink and author support to meta plugin, affecting RSS feeds
365     and blog pages.
366   * Various CSS and formatting changes.
367   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
368   * Add xhtml files to the default prune regexp.
369   * Also generate rel=bookmark links for permalinks.
370   * Fix the htmltidy plugin, which wasn't working due my breaking it when
371     I added it..
372   * Don't run tidy with -xml as that fails if the input is not well-formed.
373     Run it with -asxhtml instead, so it will output well-formed xhtml no
374     matter what the input.
375   * Disable tidy warnings too.
376   * Add a new format hook, and make tidy use it, since tidy can really only
377     operate on and output complete html documents, not the body chunks
378     that sanitise gets.
379   * Fix dates in rss feeds if running localised, so they're still rfc 822.
380
381  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
382
383 ikiwiki (1.15) unstable; urgency=low
384
385   * Remove CDPATH and other env vars perl taint checking doesn't like.
386     Closes: #381279
387   * Added created_before and created_after PageSpec limits.
388
389  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
390
391 ikiwiki (1.14) unstable; urgency=low
392
393   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
394     by 10% or so.
395   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
396   * Added many unit tests for pagespec_match.
397
398  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
399
400 ikiwiki (1.13) unstable; urgency=low
401
402   * ikiwiki can now download and aggregate feeds with its new aggregate
403     plugin, so it's possible to implement a Planet using ikiwiki!
404   * Add a run_hooks function for the common task of running all hooks of a
405     given type.
406   * Add a savestate hook.
407   * Don't put blog post forms on pages if there's no cgiurl set.
408   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
409     --wrappers to do that.
410   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
411     to update pages that haven't changed on disk.
412   * Change meta tags to use html entity-escaped text for values, so that
413     quotes and such can be represented in title tags.
414   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
415     for the above.
416   * Make --rebuild also cause --aggregate to re-download and write aggregated
417     pages.
418   * Avoid outputting duplicate meta info.
419   * Include title metadata on aggregated posts for capitalised and un-munged
420     titles.
421   * Title metadata of inlined pages now shows up in blogs and rss feeds.
422   * Fix issue with unicode filenames and updating the hyper estradier search
423     index. (Aka Please Please Please, let that be the last one.)
424   * Patch from Roland Mas to support an rss=no parameter to inline directives.
425     Closes: #380743
426   * Renamed GlobLists to PageSpecs.
427   * PageSpecs can now include nested parens, "and", and "or". This remains
428     backwards compatible to the old GlobList format. It's implemented by
429     treating the GlobList as a very limited microlanguage that is transformed
430     to perl code that does the matching.
431   * The old GlobList format is deprecated, and I encourage users to switch to
432     using the new PageSpec format. Compatability with the old format will be
433     removed at some point, possibly by 2.0.
434   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
435   * Add support for creation_month and creation_year to PageSpec.
436     Closes: #380680
437   * Changes to index file encoding.
438
439  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
440
441 ikiwiki (1.12) unstable; urgency=low
442
443   "Viva l'Italia!"
444   * New pagestats plugin from Enrico, which can generate a table counting
445     the backlinks for each page, or a del.icio.us style cloud.
446   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
447     the wikiformat plugin works. Thanks, Emanuele Aina.
448   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
449     display, running them through pagetitle. This removes ugly underscores and
450     other gunk from the display, much nicer. You may want to rebuild your wiki
451     when upgrading to get the cleanup globally.
452   * Polygen plugin from Enrico.
453   * htmltidy plugin from Faidon.
454   * Locale patch from Faidon:
455     - Adds a locale setting to setup files.
456     - Proper local time, if the locale configuration option is used.
457     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
458       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
459       impossible.
460   * Add getopt hook type, this allows plugins to add new command-line options.
461   * Add --tagbase option to tag plugin.
462   * Add exclude option in setup files, works same as --exclude.
463   * Put categories in rss feeds for tagged items.
464   * Allow preprocessor directives to be expanded in inlined blog pages.
465     However, to avoid inlining loops etc, don't expand inline directives in
466     inlined pages.
467   * fortune plugin (trivial)
468   * Tag plugins according to type.
469
470  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
471
472 ikiwiki (1.11) unstable; urgency=low
473
474   * Patch from Enrico that
475     - Adds a tag plugin that allows more easily tagging pages.
476       The meta plugin can also still be used for that, but the tag plugin
477       also lists a page's tags at the bottom of the page.
478     - Allows preprocessor directives to have parameters with no specified
479       value.
480     - Fixes preprocessor directive parameter parsing so that
481       foo=bar baz now means "foo=bar" and a "baz" with no value.
482   * Run pagetemplate hooks when inlining pages so that inlined pages also
483     list their tags.
484   * Make all plugins with pagetemplate hooks check that variables exist
485     on the template before setting them, for robustness.
486   * Switch pagetemplate hooks to using named parameters.
487   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
488     This will be the page that a source page will be part of, which is
489     different than the source page for inlined pages.
490   * Audited all plugins to endure they pass (page, destpage) to htmllink
491     appropriatly. This means inlining of various plugins will not work
492     properly, with correct links generated.
493
494  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
495
496 ikiwiki (1.10) unstable; urgency=low
497
498   * Run page through any relevant filters when generating a page preview.
499   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
500     default throughout the wiki, not only on wikitext pages. Decided to call
501     this a feature, and split the camelcase support out into a separate plugin
502     that is independant of wikitext.
503   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
504
505  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
506
507 ikiwiki (1.9) unstable; urgency=low
508
509   * Improve display of parentlinks and page title of toplevel index page.
510   * Patch from Faidon to use svn --limit when possible for recentchanges,
511     speeds up recentchanges a lot for wikis with more history.
512   * Patch from Recai to fix utf8 issues in git backend.
513   * Add wikitext markup plugin, which supports ".wiki" pages written in the
514     original wiki syntax, CamelCase links and all.
515   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
516     support, to edit pages etc without a web server.
517   * Display CGI processing errors if present.
518   * Fix from Faidon for a XML parser issue that breaks utf-8 for
519     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
520     area, and also way slow.
521   * Match 'web commit from' in SVN and git, these are web commits too.
522     (Faidon)
523   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
524     readable and avoid future mistakes. The patch seems to work and for the
525     first time I have a UTF-8 username ;-) (Faidon)
526   * Use form->field consistently, not form->param.
527   * Patch from Recai to allow selection of page type when creating a new page.
528     Default page type is inherited from the link clicked on to create the new
529     page.
530
531  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
532
533 ikiwiki (1.8) unstable; urgency=low
534
535   * Fix orphans plugin to not count a link to a nonexistant page as a reason
536     for a page not being an orphan.
537   * Support pinging services such as Technorati using XML-RPC to notify them
538     about changes to rss feeds.
539   * Parse svn log as xml for improved utf8 and security. Note that this makes
540     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
541   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
542     flagged string even if the locale causes it to generate utf8 output,
543     so make sure to let perl know it should be handled as utf8. Also,
544     the optimised version used for standard time formats won't work if the
545     user has changed locale, so drop it. Thanks, Faidon Liambotis.
546   * Fix re-encoding of the comments field to utf8 if a commit fails
547     due to a conflict. Thanks, Faidon Liambotis.
548   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
549     Liambotis.
550   * Add insane double encode/decode to utf8 around call to markdown.
551     This works around a truely strange bug, which is apparently a bug in
552     perl, #376329. Also added a test case for it.
553   * Improve layout of edit page so formatting help link is always visible w/o
554     getting in the way of the preview.
555   * Centralised all calls to HTML::Template and force all the templates
556     to be read as utf8.
557   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
558   * Introduce add_plugins and disable_plugins config options in setup files.
559     This allows adding or removing plugins w/o overriding the whole list of
560     default plugins, which makes it easier to upgrade when new default plugins
561     are added.
562   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
563     default (of course!). Based on a patch by Faidon Liambotis.
564   * Add a html plugin, which can be used to write wikis in raw html,
565     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
566     defaults to not processing .html files, since w/o this plugin they would
567     be copied unsanitised. With this plugin, it will process and html
568     sanitise them, like any other page type.
569   * Rebuilding wrappers is necessary on upgrade to this version.
570   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
571     will be automatically done on all upgrades.
572   * Don't send pings if the wiki is being rebuilt.
573   * Work around very innefficient behavior in File::Spec::abs2rel. Result
574     is a savings of 2 pointless fork/execs per link calculation, which
575     results in ~25% speedup of ikiwiki building its own doc wiki, and
576     about 35% speedup displaying RecentChanges!
577   * Make RecentChanges use a table and some CSS, should be much more readable.
578     No code changes involved.
579   * Encode & in diffurl in examples, to conform to pedantic rules.
580   * Speed up RecentChanges by another 40% or so with some memoization.
581   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
582     in time to build the doc wiki.
583
584  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
585
586 ikiwiki (1.7) unstable; urgency=low
587
588   * Updated logo from Recai with some kerning and alingment tuning.
589   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
590     changed some output.
591   * Copyright update.
592
593  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
594
595 ikiwiki (1.6) unstable; urgency=low
596
597   * YA utf-8 patch from Recai, this time to fix previewing a page so that
598     the text in the input box is re-encoded back to utf-8.
599   * -CSD does not affect modules, so readfile() was not using the utf-8 input
600     layer, which led to lots of problems; make it force read files as utf-8.
601     Closes: #373203
602   * Note that as a consequence, this version of ikiwiki will actually try to
603     parse utf8 in source files for the first time, which may expose broken
604     utf8 in wiki sources that was hidden before. Most common will be
605     perl warnings like "utf8 "\xE9" does not map to Unicode"
606   * writefile() likewise needs to use the utf8 output layer.
607   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
608     there.
609   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
610     given the readfile fix.
611   * Add utf-8 testcases for readfile and htmlize.
612   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
613     safe.
614   * More utf-8 fixes from Recai, partly to things I broke above:
615     - The serious problem is that writefile() saves the content in undecoded
616       format in CGI, hence all (non-ascii) chars are corrupted permanently.
617     - Comment field in edit page is not decoded and all the non-ascii chars in
618       this field are corrupted as the result.  We should decode it as we do it
619       for the content.
620     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
621       character in print.
622   * New SVG logo from Recai.
623
624  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
625
626 ikiwiki (1.5) unstable; urgency=low
627
628   * Add --timeformat config option to allow changing how dates are displayed.
629     Note that as a side effect, dates will now be displayed using the local
630     timezone, not as GMT.
631   * More security review.
632   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
633     for some handy stuff like:
634     - Using links as a kind of tag; creating blog pages that list all pages
635       containing a given tag/link or not containing some other tag.
636     - Subscribing to mail notifications whenever a change is made to a page
637       that is a backlink of page foo. Ie, "Please notify me of changes in all
638       pages that link to my home page in the wiki"
639     - Locking any pages that are linked to from a particular page, so that
640       lists of locks can be exposed in the wiki.
641   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
642     when a todo item is done, instead of the previous moving it to a different
643     subdir.
644   * Allow pagetemplate plugins to override *anything* in the template.
645   * Add a meta plugin, which allows specifying various metadata about pages,
646     like license and author. It also allows for inserting html link and meta
647     tags into html, overriding the title, and adding hidden WikiLinks, which
648     can be useful when using link-based globbing for page categorisation.
649   * Remove preprocessor directives from inlined pages.
650   * Allow simple preprocessor directive values to be specified w/o quotes.
651   * Add support for using git instead of subversion as the RCS backend,
652     tremendous thanks to Recai Oktaş for this.
653   * Doc updates for git.
654   * Fix absolute url munging in rss generation to support https, ftp, etc urls
655     not just http urls.
656   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
657     utf-8 for edit and other fields, and for recentchanges. There may still
658     be utf-8 issues with the preferences page though.
659
660  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
661
662 ikiwiki (1.4) unstable; urgency=low
663
664   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
665     very strange way of enabling proper XHTML <br /> type tags. Output html
666     should be always valid again now.
667   * The page name and parent links has switched from using a <h1> to a styled
668     <span>, so pages can use <h1> internally instead of needing to use <h2>.
669   * Updated all of ikiwiki's own wiki pages for that.
670   * Add pagetemplate hook, which can be used by plugins that want to mess
671     around with adding new stuff to the page template.
672   * Remove headercontent; the search plugin now adds the search box to the
673     header by registering a pagetemplate hook, and other plugins should do
674     similarly.
675   * Rebuilding on upgrade to this version is recommended.
676   * Add a html validity check to the test suite, using the wdg-html-validator,
677     if available.
678   * Make the html valid when there is nothing in the actions list.
679   * Reordered some function call parameters for consistency.
680   * Enable full utf-8 support for page input and output.
681   * Add a workaround for markdown, which does not work well with utf-8
682     strings.
683   * --getctime had bitrotted (well I only ever used it the once so far..),
684     fix and make it a bit more flexible
685   * rcs_getctime is changed, now rather than needing to loop over all pages,
686     it should just use the rcs to get the ctime of the passed file.
687   * When inlining a page in another one, links from the inlined page are now
688     expanded the same as they are when rendering the inlined page as a
689     standalone page. So rather than being expanded from the POV of the
690     inlining page, they are expanded from the POV of the inlined page.
691
692     For example, a link from blog/foo to "bar" will now link to blog/bar
693     if it exists. Previously this needed to be a link explicitly to
694     "blog/bar"; such links will also continue to work.
695
696     (This was slightly complex to do as the link still has to be constructed
697     relative to the inlining page.)
698   * Make page edit textarea resize to fit browser window.
699   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
700     do not need a full rebuild, in order to update any basewiki pages.
701
702  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
703
704 ikiwiki (1.3) unstable; urgency=low
705
706   * Fix the preinst introduced in the last version. Closes: #367458
707
708  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
709
710 ikiwiki (1.2) unstable; urgency=low
711
712   * Remove dups from the brokenlinks list.
713   * Add libc6-dev to dependencies, needed to build wrappers.
714   * Install wikilist in correct location. Closes: #367371
715
716  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
717
718 ikiwiki (1.1) unstable; urgency=low
719
720   * Rename inlinepage to depends, so that it can be used to refer to more
721     dependency relationships than just inlining. This will require a rebuild
722     on upgrade to this version.
723   * Move the rss link, put it in the blogpost form if there is one and at the
724     top if not. This is both nicer because easier to find, and it cleans up
725     the code which had used inlinepage as a flag for adding the link later.
726   * Allow the depends GlobList to be built up from multiple sources (such as
727     plugins) during a page render.
728   * Which means that more than one blog is now supported to appear on a
729     single page. (With some limitations, like only the last one getting an
730     rss file.)
731   * Added a plugin system.
732   * Added a pagecount plugin, enabled by default.
733   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
734   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
735     backlinks when the backlinks hadn't really changed.
736   * Moved inline page support, rss generation etc into the inline plugin,
737     enabled by default.
738   * Added brokenlinks plugin, not enabled by default, but rather handy.
739   * Fix several broken links in the doc wiki.
740   * Smarter behavior when creating a page and a page of the same name (but
741     different location) already exists.
742   * Add an orphans plugin for finding pages that nothing links to.
743   * Removed backlinks page, which it turns out nothing used.
744   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
745     it, this will allow for adding a unit test suite.
746   * Add unit tests for several core functions, including globlist_match,
747     dirname, basename, bestlink, linkify, pagetitle, titlepage.
748   * Smart globlist merging.
749   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
750     to pave the way for adding other RCS support. This also changes the
751     setup files, where before they had svn => 1 or svn => 0, now they have
752     rcs => "svn" or rcs => "".
753   * Add a debian/NEWS file with upgrade notes.
754   * Load whatever rcs module is specified, so new ones can be just dropped in
755     as plugins and work. (Well, in theory.)
756   * Add some basic docs about writing RCS modules.
757   * Broke search capability out into a plugin, removed the --hyperestraier
758     switch.
759   * Added smiley plugin, nicely controlled and documented by the smileys page.
760   * Copied in some smileys from Moin Moin.
761   * Allow links of the form [[some page|page]], with whitespace in the link
762     text.
763   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
764     and --disable-plugin htmlscrubber.
765   * Allow discussion links on pages to be turned off with --no-discussion.
766   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
767   * Add some new config items to the estseek.conf template, which are needed
768     by hyperestraier 1.2.3.
769
770  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
771
772 ikiwiki (1.0) unstable; urgency=low
773
774   * First official release.
775
776  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400