]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
web commit from 66.249.66.172: poll vote
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.34.1) unstable; urgency=low
2
3   * Add libtime-duraiton-perl to build deps, as it's used by the svn module
4     which is now tested at build.
5
6  -- Joey Hess <joeyh@debian.org>  Mon, 27 Nov 2006 12:26:12 -0500
7
8 ikiwiki (1.34) unstable; urgency=low
9
10   * Add an openid plugin to support logging in using OpenID.
11   * Web commits by OpenID users will record the full OpenID url for the user,
12     but in recentchanges, these urls will be converted to a simplified display
13     form+link.
14   * Modified svn, git, tla backends to recognise such web commits.
15   * Move httpauth support to a plugin.
16   * Add openidsignup config option.
17   * Make the openid plugin support the callbacks from myopenid.com via its
18     affiliate program.
19   * Add toggle plugin.
20   * Add a poll plugin.
21   * Add quick mode for archive page generation.
22   * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
23     many other plugins. It's an easy way to boost ikiwiki from its default,
24     basic wiki, to a full-featured wiki, without manually picking the right
25     set of plugins. New plugins will be added to goodstuff from time to
26     time.
27   * Change how post signin actions are propigated through the signin process;
28     they're now stored in the session.
29   * Add optional "desc" parameter to shortcut definitions.
30   * Avoid locking the wiki at all when handling some basic cgi stuff
31     (searches, recentchanges).
32   * Add "last" parameter to hook function. Very basic ordering, and hopefully
33     nothing more spohisticated will be needed.
34   * Add formbuilder_setup and formbuilder hooks.
35   * Split out a passwordauth module, that holds all the traditional password
36     based authentication etc code. It's enabled by default, but can be disabled
37     if you want only openid or some other auth method.
38   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
39   * Add some code to the build system that tries to determine if the
40     lib installation directory is in @INC. If it's not, munge ikiwiki
41     to hardcode the path to the lib directory. This should allow installing
42     ikiwiki in nonstandard locations, including home directories, by just
43     setting PREFIX at build time.
44   * Fix nested examples directory in deb.
45   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
46   * Add a test suite for the svn backend.
47   * Add a test suite for the git backend, from Recai
48   * Daemonize before sending RPC pings, since that can take a while
49     and/or hang.
50   * Daemonize before sending commit mails, as that can also take a long
51     time/hang if the mail server is unhappy.
52   * Factor out commit mail sending code into new function.
53   * Change rcs_commit, it is now passed the name of the user doing the commit
54     and their IP address, and needs to construct its own commit message
55     containing them, or do something more appropriate for the given RCS.
56   * Add softwaresite example.
57   * Mercurial backend improvements, including --get-ctime support. (Emanuele
58     Aina)
59   * Git backend improvements, including bug fixes and better robustness,
60     from Recai.
61
62  -- Joey Hess <joeyh@debian.org>  Sun, 26 Nov 2006 20:46:56 -0500
63
64 ikiwiki (1.33) unstable; urgency=low
65
66   * Fix issue with aggregate plugin updating expired pages.
67   * Avoid syntax errors in templates used by the template plugin crashing
68     ikiwiki.
69   * Enable utf8 file IO in aggregate plugin.
70   * Fix some issues with the new registration form.
71   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
72   * Make sure to check for errors from every eval.
73   * Fix img plugin's handling of adding dependencies for images that do not
74     yet exist.
75   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
76     FORM-SUBMIT unusable on customised formbuilder templates. For now,
77     hardcode the submit buttons in editpage.tmpl instead of using the
78     template variable, which is ok, since the buttons are static.
79   * Work with hyperestraier 1.4.9.
80
81  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
82
83 ikiwiki (1.32) unstable; urgency=low
84
85   * Add a separate pass to find page links, and only render each page once,
86     instead of over and over. Typical speedup is ~4x. Max possible speedup:
87     8x.
88   * Add "scan" parameter to hook(), which is used to make the hook be called
89     during the scanning pass, as well as the render pass. The meta and tag
90     plugins need to use the new scan parameter, so will any others that modify
91     %links.
92   * Now that links are calculated in a separate pass, it can also
93     precalculate backlinks in one pass, which is O(N^2) instead of the
94     previous code that was O(N^3). A very nice speedup for wikis with lots
95     (thousands) of pages.
96   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
97     Erdem.
98   * Add a default stylesheet entry for the pagecloud.
99   * Add examples page with some examples of things that can be done using
100     ikiwiki, like a weblog. The examples can be copied into a user's wiki
101     for a quick start, without needing to learn everything about how to put
102     them together.
103   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
104   * Add perlmagick to build-depends so syntax check of img plugin works.
105     Closes: #396702
106   * Improve login/register process, the login dialog has only name and
107     password fields, which allows more web browsers to regognise it as a login
108     field, and is less confusing.
109   * Implemented expiry options for aggregate plugin.
110   * Use precalculated backlinks info when determining if files need an update
111     due to a page they link to being added/removed. Mostly significant if
112     there are lots of pages.
113   * Remove duplicate link info when saving index. In some cases it could
114     pile up rather badly. (Probably not the best way to deal with this
115     problem.)
116   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
117     or what have you, by creating enclosures for non-page items that are
118     included in feeds.
119
120  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
121
122 ikiwiki (1.31) unstable; urgency=low
123
124   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
125   * Change the rss feed title from the wikiname to the page title, with
126     an exception for the wiki's toplevel index page, which will still use the
127     wikiname as the feed title.
128     Overriding the page title with meta title already overrode the rss feed
129     tittle.
130   * Add an img plugin, based on Christian Mock's img plugin, but stripped
131     down to the bare essentials. Useful for handling large images on websites.
132   * Sanitize possibly problimatic characters out of the polygen grammar names,
133     just in case. Should not be exploitable anyway, since it only tries to run
134     polygen after finding the specified grammar file.
135   * Add missing dependency on the URI perl module.
136   * Add basic spam fighting tool for admins: An admin's prefs page now allows
137     editing a list of banned users.
138
139  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
140
141 ikiwiki (1.30) unstable; urgency=low
142
143   * Add no_override parameter to hook().
144   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
145     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
146     can be configured using a page in wiki.
147   * Fix support for --pingurl at the command line.
148   * Fix a subtle bug in will_render that broke some builds, by only clearing
149     items from renderedfiles the first time per build.
150   * Wrap entire technortati ping operation in an eval to catch all possible
151     failure modes, after I observed a simple ->value crashing ikiwiki when
152     a ping failed.
153
154  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
155
156 ikiwiki (1.29) unstable; urgency=low
157
158   * Patch from Paul Tötterman to use CP in the Makefile.
159   * Patch from Alec Berryman adding a http_auth config item that allows
160     using HTTP Authentication instead of ikiwiki's built in authentication.
161     Useful for eg, large sites with their own previously existing user auth
162     setup. Closes: #384534
163   * Change %renderedfiles to store an array of files rendered from a given
164     source file, to allow tracking of extra rendered files like rss feeds.
165   * Note that plugins that accessed this variable will need to be updated!
166     The plugin interface has been increased to version 1.01 for this change.
167     As few plugins use %renderedfiles I haven't done anything else to ensure
168     compatability of old plugins.
169   * Add will_render function to the plugin interface, used to register that a
170     page renders a destination file, and do some security checks. Previously
171     but no longer rendered files will be cleaned up.
172   * Use will_render in the inline and linkmap plugins.
173   * You will need to rebuild your wiki on upgrade to this version.
174   * Atom feed support based on a patch by Clint Adams.
175   * Add feeds=no option to inline preprocessor directive to turn off all types
176     of feeds.
177   * $IkiWiki::version now holds the program version, and is accessible to
178     plugins.
179   * Make the aggregate plugin emphasize error messages.
180   * Patch from Recai to limit recentchanges to displaying max 10 files for a
181     given changeset (to avoid large number of file changes excessively
182     bloating the page).
183
184  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
185
186 ikiwiki (1.28) unstable; urgency=low
187
188   * inline: Add ability to sort by page name, based on a patch from
189     Benjamin A'Lee.
190   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
191     braindead interface. Closes: #389383
192   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
193     and b) those poor Mac OSX users and their case insensative files!
194   * Don't fail syntax check if Text::Typography isn't installed.
195     Closes: #389406
196
197  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
198
199 ikiwiki (1.27) unstable; urgency=low
200
201   * Work on firming up the plugin interface:
202     - Plugins should not need to load IkiWiki::Render to get commonly
203       used functions, so moved some functions from there to IkiWiki.
204     - Picked out the set of functions and variables that most plugins
205       use, documented them, and made IkiWiki export them by default,
206       like a proper perl module should.
207     - Use the other functions at your own risk.
208     - This is not quite complete, I still have to decide whether to
209       export some other things.
210   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
211     referring to stuff now exported by the IkiWiki module.
212   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
213     to declare which version of the interface your plugin needs.
214   * Anyone with a third-party ikiwiki plugin is strongly encouraged
215     to make like changes to it and avoid use of non-exported symbols from
216     "IkiWiki::".
217   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
218   * Support hyperestradier version 1.4.2, which adds a new required phraseform
219     setting.
220   * If an inlined page has a permalink, link the page title to that.
221   * Patch from Recai to use utf8 when reading the setup file, so that
222     utf8 wikinames from there will be used properly.
223   * Patch from Recai to kill utf-8 on the wiki name when generating the
224     session cookie.
225   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
226   * Fix a baseurl problem in hyperestradier search results.
227   * Add a stub local.css to avoid problems with 404's.
228   * Patch from Recai to fix a wide character warning from the search plugin
229     during setup if the wikiname contains utf8.
230   * Yet another fix for those poor case-insensative OS X users.
231   * pagetemplate hooks are now also called when generating cgi pages.
232   * Add a favicon plugin, which simply adds a link tag for an icon to each
233     page (and cgis).
234   * Patch from James Westby to deal with the case where you're editing a
235     new page, hit cancel, and need to be redirected to somewhere sane.
236   * Various documentation improvements by various wiki users.
237   * Support Text::Markdown from CPAN, which has a different interface from
238     the original markdown or the one in Debian.
239   * Version the libcgi-session-perl dependency, some features that need
240     the new version are used in some cases (sslcookie).
241   * Numerous tla fixes from Clint.
242   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
243     a multi-resolution favicon.ico.
244   * README.Debian: typo Closes: #388110
245   * chomp trailing newline at the end of templates read in by the template
246     plugin, to allow use of the template preprocessor directive in
247     whitespace-sensative situations. Closes: #387073
248   * Patch from James Westby to make the location of the estseek.cgi script
249     configurable.
250   * Add typography (SmartyPants) plugin by Recai.
251   * Add --render mode, which can be used to preview an edit at the command
252     line by test rendering a single page.
253   * Add a googlecalendar plugin. A bit special-purpose, but it shows
254     one way to to deal with user-supplied content that could cause XSS
255     issues w/o the htmlscrubber, and won't survive the scrubber.
256
257  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
258
259 ikiwiki (1.26) unstable; urgency=low
260
261   * Add a missing -n to tla undo call.
262   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
263     writes before consuming its whole stdin. Avoid this deadlock.
264   * Fix alt tags for outline checkboxes.
265
266  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
267
268 ikiwiki (1.25) unstable; urgency=low
269
270   * Add proper waitpid calls for open2ed processes throughout to avoid
271     zombies; this hit htmltidy especially badly.
272   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
273     subversion repos and fixing some other issues.
274   * Add support for tla, contributed by Clint Adams. Closes: #385936
275   * Add support for mercurial, contributed by Emanuele Aina.
276   * Include <link rel> tag for RSS feeds, used by some aggregators and
277     firefox to find the feed.
278   * Add a linkmap plugin (requires graphviz).
279
280  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
281
282 ikiwiki (1.24) unstable; urgency=low
283
284   * Simplify the data structure returned by rcs_recentchanges to avoid
285     each rcs plugin needing to form complex strings on its own.
286   * Fix another destpage issue in the inline directive. Closes: #385512
287     again.
288
289  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
290
291 ikiwiki (1.23) unstable; urgency=low
292
293   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
294
295  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
296
297 ikiwiki (1.22) unstable; urgency=low
298
299   * Change how the stylesheet url is determined in the templates: Remove
300     STYLEURL and add BASEURL to all templates (some already had it). This
301     new more general variable can be used to link to other things (eg, images)
302     from the template, as well as stylesheets.
303   * Fix a bug introduced last version to do with nested inlines.
304   * Allow preprocessor directives to span multiple lines, both to make
305     long ones with lots of values easier to write, and to allow for ones with
306     multi-line quoted values.
307   * Allow preprocessor directives to contain python-like triple-quoted
308     text blocks, for easy nesting of quotes inside.
309   * Add a template plugin.
310   * Make pagespec merge code smarter about merging duplicate pagespecs.
311   * Patch from Jordà Polo to make Setup::Standard support hashes in config
312     files.
313   * Change order of linkify and preprocess; first preprocess and then linkify.
314     This allows passing a wikilink inside a parameter to a preprocessor
315     directive without it being expanded to html, and leaking out of the
316     parameter, which had required some non-obvious use of triple-quoting
317     to avoid. Note that any preprocessor plugins that output something
318     that looks like a wikilink will now have it treated as such; AFAIK
319     this doesn't change any behavior though except for the template plugin.
320   * Enable preprocessor directives when previewing an edit.
321   * Make all pages pull in a local.css style sheet, if present. This won't
322     be included in ikiwiki, but can be created to make local styling changes
323     w/o needing to merge in every new change to the distributed style.css.
324   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
325   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
326     from a different directory.
327   * Generalised preprocesser loop protection code.
328   * Patch from James Westby to allow a description to be set for rss feeds.
329   * Patch from James Westby to add a template for the search form.
330   * Added a ddate plugin.
331   * Patch from James Westby to add a --sslcookie switch, which forces
332     cookies to only be sent over ssl connections to avoid interception.
333   * Fix preferences page on anonok wikis; still need to sign in to get
334     to the preferences page.
335   * Add toc (table of contents) plugin.
336   * Change htmlize, format, and sanitize hooks to use named parameters.
337   * Patch from James Westby to add an actions option to inline; this
338     adds Edit and Discussion links at the end of blog entries.
339   * Due to some css changes, you'll want to rebuild your wiki on upgrade
340     to this version. Will be handled automatically by the deb.
341   * Add processed date to aggregate preprocessor directive status output.
342
343  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
344
345 ikiwiki (1.21) unstable; urgency=low
346
347   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
348   * If a page links to itself, mark up the link text in a span with
349     class="selflink" so that it can be styled. I don't have a useful style
350     defined for that though.
351   * Call filter hooks on inlined page content.
352   * Support inlining pages raw, rather than creating a blog.
353   * Clean up yes/no parameter parsing in inline plugin.
354   * Implemented better cycle detection in the inline plugin; nested inlines
355     will now work.
356   * Add a map plugin contributed by Alessandro Dotti Contra.
357   * Add otl format plugin, which handles files as created by vimoutliner.
358   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
359   * Add first draft at a Restructured Text (rst) plugin, by Sergio
360     Talens-Oliag. Note that this has many known issues -- see the caveats on
361     the plugin's page.
362   * Credit everyone who wrote a plugin on the plugins' wiki pages.
363   * Fix utf-8 in blog post form.
364
365  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
366
367 ikiwiki (1.20) unstable; urgency=low
368
369   * Relicense the templates and basewiki under the 2-clause BSD license.
370     Since these can easily become part of other people's websites, they
371     should be under as permissive a license as possible.
372   * Add --syslog config option, to log to the syslog.
373   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
374     transient failure to fork (which I've seen happen in the wild).
375   * Fix a bug in the aggregator introduced last version that caused all
376     aggregator state to be lost during a non-aggregating build.
377
378  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
379
380 ikiwiki (1.19) unstable; urgency=low
381
382   * Fix several related bugs in page type determination during online editing.
383   * Add some locking to prevent 2 aggregators from running at once.
384   * Fix an infinite loop in the aggregator when finding a unique filename.
385
386  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
387
388 ikiwiki (1.18) unstable; urgency=low
389
390   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
391   * Add --version.
392   * Man page format fixups.
393   * If the meta plugin overides the page title, set a title_overridden
394     variable in the template to true. This allows doing things with the
395     templates conditional on the title being overriden.
396   * Add a %pagecase which maps lower-case page names to the actual case
397     used in the filename. Use this in bestlinks calculation instead of
398     forcing the link to lowercase.
399   * Also use %pagecase in various other places that want to check if a page
400     with a given name exists.
401   * This means that links to pages with mixed case names will now work,
402     even if the link is in some other case mixture, and mixed case pages
403     should be fully supported throughout ikiwiki.
404   * Recommend rebuilding wikis on upgrade to this version.
405
406  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
407
408 ikiwiki (1.17) unstable; urgency=low
409
410   * Disable tidy generator tag.
411   * Move tidy back to sanitize hook, found out how to only show body.
412   * Turn off tidy indentation too.
413   * Turn on HTML::Template loop_context_vars; not actually used in stock
414     templates but can be useful for things like making comma-delimited lists
415     of tags or what have you.
416   * Remove <br> from end of aggregate preprocessor directive output.
417   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
418     case-sensative filesystems like OSX.
419   * Improve markdown loading. First, try to load it as a proper perl module,
420     in case it was installed as one. Then fall back to trying
421     /usr/bin/markdown.
422   * Document in install page how to install markdown, since it has no
423     installation procedure in the upstream tarball.
424   * Set die_on_bad_params => 0 for all templates, to allow users to modify
425     them without annoyances.
426   * Suck in the page content when generating an inline archive page, to work
427     around the meta plugin's lack of caching of title metadata across runs.
428
429  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
430
431 ikiwiki (1.16) unstable; urgency=low
432
433   * Try to handle relative links in aggregated feeds. However,
434     the current support is a crude hack due to limitations of XML::Feed:
435     xml:base is not supported, neither is Content-Location. And of course,
436     relative links in RSS feeds are ill-undefined..
437   * Make aggregator save permalinks and author name to pages as metadata.
438   * Add permalink and author support to meta plugin, affecting RSS feeds
439     and blog pages.
440   * Various CSS and formatting changes.
441   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
442   * Add xhtml files to the default prune regexp.
443   * Also generate rel=bookmark links for permalinks.
444   * Fix the htmltidy plugin, which wasn't working due my breaking it when
445     I added it..
446   * Don't run tidy with -xml as that fails if the input is not well-formed.
447     Run it with -asxhtml instead, so it will output well-formed xhtml no
448     matter what the input.
449   * Disable tidy warnings too.
450   * Add a new format hook, and make tidy use it, since tidy can really only
451     operate on and output complete html documents, not the body chunks
452     that sanitise gets.
453   * Fix dates in rss feeds if running localised, so they're still rfc 822.
454
455  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
456
457 ikiwiki (1.15) unstable; urgency=low
458
459   * Remove CDPATH and other env vars perl taint checking doesn't like.
460     Closes: #381279
461   * Added created_before and created_after PageSpec limits.
462
463  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
464
465 ikiwiki (1.14) unstable; urgency=low
466
467   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
468     by 10% or so.
469   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
470   * Added many unit tests for pagespec_match.
471
472  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
473
474 ikiwiki (1.13) unstable; urgency=low
475
476   * ikiwiki can now download and aggregate feeds with its new aggregate
477     plugin, so it's possible to implement a Planet using ikiwiki!
478   * Add a run_hooks function for the common task of running all hooks of a
479     given type.
480   * Add a savestate hook.
481   * Don't put blog post forms on pages if there's no cgiurl set.
482   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
483     --wrappers to do that.
484   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
485     to update pages that haven't changed on disk.
486   * Change meta tags to use html entity-escaped text for values, so that
487     quotes and such can be represented in title tags.
488   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
489     for the above.
490   * Make --rebuild also cause --aggregate to re-download and write aggregated
491     pages.
492   * Avoid outputting duplicate meta info.
493   * Include title metadata on aggregated posts for capitalised and un-munged
494     titles.
495   * Title metadata of inlined pages now shows up in blogs and rss feeds.
496   * Fix issue with unicode filenames and updating the hyper estradier search
497     index. (Aka Please Please Please, let that be the last one.)
498   * Patch from Roland Mas to support an rss=no parameter to inline directives.
499     Closes: #380743
500   * Renamed GlobLists to PageSpecs.
501   * PageSpecs can now include nested parens, "and", and "or". This remains
502     backwards compatible to the old GlobList format. It's implemented by
503     treating the GlobList as a very limited microlanguage that is transformed
504     to perl code that does the matching.
505   * The old GlobList format is deprecated, and I encourage users to switch to
506     using the new PageSpec format. Compatability with the old format will be
507     removed at some point, possibly by 2.0.
508   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
509   * Add support for creation_month and creation_year to PageSpec.
510     Closes: #380680
511   * Changes to index file encoding.
512
513  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
514
515 ikiwiki (1.12) unstable; urgency=low
516
517   "Viva l'Italia!"
518   * New pagestats plugin from Enrico, which can generate a table counting
519     the backlinks for each page, or a del.icio.us style cloud.
520   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
521     the wikiformat plugin works. Thanks, Emanuele Aina.
522   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
523     display, running them through pagetitle. This removes ugly underscores and
524     other gunk from the display, much nicer. You may want to rebuild your wiki
525     when upgrading to get the cleanup globally.
526   * Polygen plugin from Enrico.
527   * htmltidy plugin from Faidon.
528   * Locale patch from Faidon:
529     - Adds a locale setting to setup files.
530     - Proper local time, if the locale configuration option is used.
531     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
532       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
533       impossible.
534   * Add getopt hook type, this allows plugins to add new command-line options.
535   * Add --tagbase option to tag plugin.
536   * Add exclude option in setup files, works same as --exclude.
537   * Put categories in rss feeds for tagged items.
538   * Allow preprocessor directives to be expanded in inlined blog pages.
539     However, to avoid inlining loops etc, don't expand inline directives in
540     inlined pages.
541   * fortune plugin (trivial)
542   * Tag plugins according to type.
543
544  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
545
546 ikiwiki (1.11) unstable; urgency=low
547
548   * Patch from Enrico that
549     - Adds a tag plugin that allows more easily tagging pages.
550       The meta plugin can also still be used for that, but the tag plugin
551       also lists a page's tags at the bottom of the page.
552     - Allows preprocessor directives to have parameters with no specified
553       value.
554     - Fixes preprocessor directive parameter parsing so that
555       foo=bar baz now means "foo=bar" and a "baz" with no value.
556   * Run pagetemplate hooks when inlining pages so that inlined pages also
557     list their tags.
558   * Make all plugins with pagetemplate hooks check that variables exist
559     on the template before setting them, for robustness.
560   * Switch pagetemplate hooks to using named parameters.
561   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
562     This will be the page that a source page will be part of, which is
563     different than the source page for inlined pages.
564   * Audited all plugins to endure they pass (page, destpage) to htmllink
565     appropriatly. This means inlining of various plugins will not work
566     properly, with correct links generated.
567
568  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
569
570 ikiwiki (1.10) unstable; urgency=low
571
572   * Run page through any relevant filters when generating a page preview.
573   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
574     default throughout the wiki, not only on wikitext pages. Decided to call
575     this a feature, and split the camelcase support out into a separate plugin
576     that is independant of wikitext.
577   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
578
579  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
580
581 ikiwiki (1.9) unstable; urgency=low
582
583   * Improve display of parentlinks and page title of toplevel index page.
584   * Patch from Faidon to use svn --limit when possible for recentchanges,
585     speeds up recentchanges a lot for wikis with more history.
586   * Patch from Recai to fix utf8 issues in git backend.
587   * Add wikitext markup plugin, which supports ".wiki" pages written in the
588     original wiki syntax, CamelCase links and all.
589   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
590     support, to edit pages etc without a web server.
591   * Display CGI processing errors if present.
592   * Fix from Faidon for a XML parser issue that breaks utf-8 for
593     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
594     area, and also way slow.
595   * Match 'web commit from' in SVN and git, these are web commits too.
596     (Faidon)
597   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
598     readable and avoid future mistakes. The patch seems to work and for the
599     first time I have a UTF-8 username ;-) (Faidon)
600   * Use form->field consistently, not form->param.
601   * Patch from Recai to allow selection of page type when creating a new page.
602     Default page type is inherited from the link clicked on to create the new
603     page.
604
605  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
606
607 ikiwiki (1.8) unstable; urgency=low
608
609   * Fix orphans plugin to not count a link to a nonexistant page as a reason
610     for a page not being an orphan.
611   * Support pinging services such as Technorati using XML-RPC to notify them
612     about changes to rss feeds.
613   * Parse svn log as xml for improved utf8 and security. Note that this makes
614     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
615   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
616     flagged string even if the locale causes it to generate utf8 output,
617     so make sure to let perl know it should be handled as utf8. Also,
618     the optimised version used for standard time formats won't work if the
619     user has changed locale, so drop it. Thanks, Faidon Liambotis.
620   * Fix re-encoding of the comments field to utf8 if a commit fails
621     due to a conflict. Thanks, Faidon Liambotis.
622   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
623     Liambotis.
624   * Add insane double encode/decode to utf8 around call to markdown.
625     This works around a truely strange bug, which is apparently a bug in
626     perl, #376329. Also added a test case for it.
627   * Improve layout of edit page so formatting help link is always visible w/o
628     getting in the way of the preview.
629   * Centralised all calls to HTML::Template and force all the templates
630     to be read as utf8.
631   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
632   * Introduce add_plugins and disable_plugins config options in setup files.
633     This allows adding or removing plugins w/o overriding the whole list of
634     default plugins, which makes it easier to upgrade when new default plugins
635     are added.
636   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
637     default (of course!). Based on a patch by Faidon Liambotis.
638   * Add a html plugin, which can be used to write wikis in raw html,
639     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
640     defaults to not processing .html files, since w/o this plugin they would
641     be copied unsanitised. With this plugin, it will process and html
642     sanitise them, like any other page type.
643   * Rebuilding wrappers is necessary on upgrade to this version.
644   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
645     will be automatically done on all upgrades.
646   * Don't send pings if the wiki is being rebuilt.
647   * Work around very innefficient behavior in File::Spec::abs2rel. Result
648     is a savings of 2 pointless fork/execs per link calculation, which
649     results in ~25% speedup of ikiwiki building its own doc wiki, and
650     about 35% speedup displaying RecentChanges!
651   * Make RecentChanges use a table and some CSS, should be much more readable.
652     No code changes involved.
653   * Encode & in diffurl in examples, to conform to pedantic rules.
654   * Speed up RecentChanges by another 40% or so with some memoization.
655   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
656     in time to build the doc wiki.
657
658  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
659
660 ikiwiki (1.7) unstable; urgency=low
661
662   * Updated logo from Recai with some kerning and alingment tuning.
663   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
664     changed some output.
665   * Copyright update.
666
667  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
668
669 ikiwiki (1.6) unstable; urgency=low
670
671   * YA utf-8 patch from Recai, this time to fix previewing a page so that
672     the text in the input box is re-encoded back to utf-8.
673   * -CSD does not affect modules, so readfile() was not using the utf-8 input
674     layer, which led to lots of problems; make it force read files as utf-8.
675     Closes: #373203
676   * Note that as a consequence, this version of ikiwiki will actually try to
677     parse utf8 in source files for the first time, which may expose broken
678     utf8 in wiki sources that was hidden before. Most common will be
679     perl warnings like "utf8 "\xE9" does not map to Unicode"
680   * writefile() likewise needs to use the utf8 output layer.
681   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
682     there.
683   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
684     given the readfile fix.
685   * Add utf-8 testcases for readfile and htmlize.
686   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
687     safe.
688   * More utf-8 fixes from Recai, partly to things I broke above:
689     - The serious problem is that writefile() saves the content in undecoded
690       format in CGI, hence all (non-ascii) chars are corrupted permanently.
691     - Comment field in edit page is not decoded and all the non-ascii chars in
692       this field are corrupted as the result.  We should decode it as we do it
693       for the content.
694     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
695       character in print.
696   * New SVG logo from Recai.
697
698  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
699
700 ikiwiki (1.5) unstable; urgency=low
701
702   * Add --timeformat config option to allow changing how dates are displayed.
703     Note that as a side effect, dates will now be displayed using the local
704     timezone, not as GMT.
705   * More security review.
706   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
707     for some handy stuff like:
708     - Using links as a kind of tag; creating blog pages that list all pages
709       containing a given tag/link or not containing some other tag.
710     - Subscribing to mail notifications whenever a change is made to a page
711       that is a backlink of page foo. Ie, "Please notify me of changes in all
712       pages that link to my home page in the wiki"
713     - Locking any pages that are linked to from a particular page, so that
714       lists of locks can be exposed in the wiki.
715   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
716     when a todo item is done, instead of the previous moving it to a different
717     subdir.
718   * Allow pagetemplate plugins to override *anything* in the template.
719   * Add a meta plugin, which allows specifying various metadata about pages,
720     like license and author. It also allows for inserting html link and meta
721     tags into html, overriding the title, and adding hidden WikiLinks, which
722     can be useful when using link-based globbing for page categorisation.
723   * Remove preprocessor directives from inlined pages.
724   * Allow simple preprocessor directive values to be specified w/o quotes.
725   * Add support for using git instead of subversion as the RCS backend,
726     tremendous thanks to Recai Oktaş for this.
727   * Doc updates for git.
728   * Fix absolute url munging in rss generation to support https, ftp, etc urls
729     not just http urls.
730   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
731     utf-8 for edit and other fields, and for recentchanges. There may still
732     be utf-8 issues with the preferences page though.
733
734  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
735
736 ikiwiki (1.4) unstable; urgency=low
737
738   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
739     very strange way of enabling proper XHTML <br /> type tags. Output html
740     should be always valid again now.
741   * The page name and parent links has switched from using a <h1> to a styled
742     <span>, so pages can use <h1> internally instead of needing to use <h2>.
743   * Updated all of ikiwiki's own wiki pages for that.
744   * Add pagetemplate hook, which can be used by plugins that want to mess
745     around with adding new stuff to the page template.
746   * Remove headercontent; the search plugin now adds the search box to the
747     header by registering a pagetemplate hook, and other plugins should do
748     similarly.
749   * Rebuilding on upgrade to this version is recommended.
750   * Add a html validity check to the test suite, using the wdg-html-validator,
751     if available.
752   * Make the html valid when there is nothing in the actions list.
753   * Reordered some function call parameters for consistency.
754   * Enable full utf-8 support for page input and output.
755   * Add a workaround for markdown, which does not work well with utf-8
756     strings.
757   * --getctime had bitrotted (well I only ever used it the once so far..),
758     fix and make it a bit more flexible
759   * rcs_getctime is changed, now rather than needing to loop over all pages,
760     it should just use the rcs to get the ctime of the passed file.
761   * When inlining a page in another one, links from the inlined page are now
762     expanded the same as they are when rendering the inlined page as a
763     standalone page. So rather than being expanded from the POV of the
764     inlining page, they are expanded from the POV of the inlined page.
765
766     For example, a link from blog/foo to "bar" will now link to blog/bar
767     if it exists. Previously this needed to be a link explicitly to
768     "blog/bar"; such links will also continue to work.
769
770     (This was slightly complex to do as the link still has to be constructed
771     relative to the inlining page.)
772   * Make page edit textarea resize to fit browser window.
773   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
774     do not need a full rebuild, in order to update any basewiki pages.
775
776  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
777
778 ikiwiki (1.3) unstable; urgency=low
779
780   * Fix the preinst introduced in the last version. Closes: #367458
781
782  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
783
784 ikiwiki (1.2) unstable; urgency=low
785
786   * Remove dups from the brokenlinks list.
787   * Add libc6-dev to dependencies, needed to build wrappers.
788   * Install wikilist in correct location. Closes: #367371
789
790  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
791
792 ikiwiki (1.1) unstable; urgency=low
793
794   * Rename inlinepage to depends, so that it can be used to refer to more
795     dependency relationships than just inlining. This will require a rebuild
796     on upgrade to this version.
797   * Move the rss link, put it in the blogpost form if there is one and at the
798     top if not. This is both nicer because easier to find, and it cleans up
799     the code which had used inlinepage as a flag for adding the link later.
800   * Allow the depends GlobList to be built up from multiple sources (such as
801     plugins) during a page render.
802   * Which means that more than one blog is now supported to appear on a
803     single page. (With some limitations, like only the last one getting an
804     rss file.)
805   * Added a plugin system.
806   * Added a pagecount plugin, enabled by default.
807   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
808   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
809     backlinks when the backlinks hadn't really changed.
810   * Moved inline page support, rss generation etc into the inline plugin,
811     enabled by default.
812   * Added brokenlinks plugin, not enabled by default, but rather handy.
813   * Fix several broken links in the doc wiki.
814   * Smarter behavior when creating a page and a page of the same name (but
815     different location) already exists.
816   * Add an orphans plugin for finding pages that nothing links to.
817   * Removed backlinks page, which it turns out nothing used.
818   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
819     it, this will allow for adding a unit test suite.
820   * Add unit tests for several core functions, including globlist_match,
821     dirname, basename, bestlink, linkify, pagetitle, titlepage.
822   * Smart globlist merging.
823   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
824     to pave the way for adding other RCS support. This also changes the
825     setup files, where before they had svn => 1 or svn => 0, now they have
826     rcs => "svn" or rcs => "".
827   * Add a debian/NEWS file with upgrade notes.
828   * Load whatever rcs module is specified, so new ones can be just dropped in
829     as plugins and work. (Well, in theory.)
830   * Add some basic docs about writing RCS modules.
831   * Broke search capability out into a plugin, removed the --hyperestraier
832     switch.
833   * Added smiley plugin, nicely controlled and documented by the smileys page.
834   * Copied in some smileys from Moin Moin.
835   * Allow links of the form [[some page|page]], with whitespace in the link
836     text.
837   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
838     and --disable-plugin htmlscrubber.
839   * Allow discussion links on pages to be turned off with --no-discussion.
840   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
841   * Add some new config items to the estseek.conf template, which are needed
842     by hyperestraier 1.2.3.
843
844  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
845
846 ikiwiki (1.0) unstable; urgency=low
847
848   * First official release.
849
850  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400