]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
web commit by EthanGlasserCamp: more demanding, unreasonable thoughts about this...
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.28) unstable; urgency=low
2
3   * inline: Add ability to sort by page name, based on a patch from
4     Benjamin A'Lee.
5   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
6     braindead interface. Closes: #389383
7   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
8     and b) those poor Mac OSX users and their case insensative files!
9   * Don't fail syntax check if Text::Typography isn't installed.
10     Closes: #389406
11
12  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
13
14 ikiwiki (1.27) unstable; urgency=low
15
16   * Work on firming up the plugin interface:
17     - Plugins should not need to load IkiWiki::Render to get commonly
18       used functions, so moved some functions from there to IkiWiki.
19     - Picked out the set of functions and variables that most plugins
20       use, documented them, and made IkiWiki export them by default,
21       like a proper perl module should.
22     - Use the other functions at your own risk.
23     - This is not quite complete, I still have to decide whether to
24       export some other things.
25   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
26     referring to stuff now exported by the IkiWiki module.
27   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
28     to declare which version of the interface your plugin needs.
29   * Anyone with a third-party ikiwiki plugin is strongly encouraged
30     to make like changes to it and avoid use of non-exported symbols from
31     "IkiWiki::".
32   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
33   * Support hyperestradier version 1.4.2, which adds a new required phraseform
34     setting.
35   * If an inlined page has a permalink, link the page title to that.
36   * Patch from Recai to use utf8 when reading the setup file, so that
37     utf8 wikinames from there will be used properly.
38   * Patch from Recai to kill utf-8 on the wiki name when generating the
39     session cookie.
40   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
41   * Fix a baseurl problem in hyperestradier search results.
42   * Add a stub local.css to avoid problems with 404's.
43   * Patch from Recai to fix a wide character warning from the search plugin
44     during setup if the wikiname contains utf8.
45   * Yet another fix for those poor case-insensative OS X users.
46   * pagetemplate hooks are now also called when generating cgi pages.
47   * Add a favicon plugin, which simply adds a link tag for an icon to each
48     page (and cgis).
49   * Patch from James Westby to deal with the case where you're editing a
50     new page, hit cancel, and need to be redirected to somewhere sane.
51   * Various documentation improvements by various wiki users.
52   * Support Text::Markdown from CPAN, which has a different interface from
53     the original markdown or the one in Debian.
54   * Version the libcgi-session-perl dependency, some features that need
55     the new version are used in some cases (sslcookie).
56   * Numerous tla fixes from Clint.
57   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
58     a multi-resolution favicon.ico.
59   * README.Debian: typo Closes: #388110
60   * chomp trailing newline at the end of templates read in by the template
61     plugin, to allow use of the template preprocessor directive in
62     whitespace-sensative situations. Closes: #387073
63   * Patch from James Westby to make the location of the estseek.cgi script
64     configurable.
65   * Add typography (SmartyPants) plugin by Recai.
66   * Add --render mode, which can be used to preview an edit at the command
67     line by test rendering a single page.
68   * Add a googlecalendar plugin. A bit special-purpose, but it shows
69     one way to to deal with user-supplied content that could cause XSS
70     issues w/o the htmlscrubber, and won't survive the scrubber.
71
72  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
73
74 ikiwiki (1.26) unstable; urgency=low
75
76   * Add a missing -n to tla undo call.
77   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
78     writes before consuming its whole stdin. Avoid this deadlock.
79   * Fix alt tags for outline checkboxes.
80
81  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
82
83 ikiwiki (1.25) unstable; urgency=low
84
85   * Add proper waitpid calls for open2ed processes throughout to avoid
86     zombies; this hit htmltidy especially badly.
87   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
88     subversion repos and fixing some other issues.
89   * Add support for tla, contributed by Clint Adams. Closes: #385936
90   * Add support for mercurial, contributed by Emanuele Aina.
91   * Include <link rel> tag for RSS feeds, used by some aggregators and
92     firefox to find the feed.
93   * Add a linkmap plugin (requires graphviz).
94
95  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
96
97 ikiwiki (1.24) unstable; urgency=low
98
99   * Simplify the data structure returned by rcs_recentchanges to avoid
100     each rcs plugin needing to form complex strings on its own.
101   * Fix another destpage issue in the inline directive. Closes: #385512
102     again.
103
104  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
105
106 ikiwiki (1.23) unstable; urgency=low
107
108   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
109
110  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
111
112 ikiwiki (1.22) unstable; urgency=low
113
114   * Change how the stylesheet url is determined in the templates: Remove
115     STYLEURL and add BASEURL to all templates (some already had it). This
116     new more general variable can be used to link to other things (eg, images)
117     from the template, as well as stylesheets.
118   * Fix a bug introduced last version to do with nested inlines.
119   * Allow preprocessor directives to span multiple lines, both to make
120     long ones with lots of values easier to write, and to allow for ones with
121     multi-line quoted values.
122   * Allow preprocessor directives to contain python-like triple-quoted
123     text blocks, for easy nesting of quotes inside.
124   * Add a template plugin.
125   * Make pagespec merge code smarter about merging duplicate pagespecs.
126   * Patch from Jordà Polo to make Setup::Standard support hashes in config
127     files.
128   * Change order of linkify and preprocess; first preprocess and then linkify.
129     This allows passing a wikilink inside a parameter to a preprocessor
130     directive without it being expanded to html, and leaking out of the
131     parameter, which had required some non-obvious use of triple-quoting
132     to avoid. Note that any preprocessor plugins that output something
133     that looks like a wikilink will now have it treated as such; AFAIK
134     this doesn't change any behavior though except for the template plugin.
135   * Enable preprocessor directives when previewing an edit.
136   * Make all pages pull in a local.css style sheet, if present. This won't
137     be included in ikiwiki, but can be created to make local styling changes
138     w/o needing to merge in every new change to the distributed style.css.
139   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
140   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
141     from a different directory.
142   * Generalised preprocesser loop protection code.
143   * Patch from James Westby to allow a description to be set for rss feeds.
144   * Patch from James Westby to add a template for the search form.
145   * Added a ddate plugin.
146   * Patch from James Westby to add a --sslcookie switch, which forces
147     cookies to only be sent over ssl connections to avoid interception.
148   * Fix preferences page on anonok wikis; still need to sign in to get
149     to the preferences page.
150   * Add toc (table of contents) plugin.
151   * Change htmlize, format, and sanitize hooks to use named parameters.
152   * Patch from James Westby to add an actions option to inline; this
153     adds Edit and Discussion links at the end of blog entries.
154   * Due to some css changes, you'll want to rebuild your wiki on upgrade
155     to this version. Will be handled automatically by the deb.
156   * Add processed date to aggregate preprocessor directive status output.
157
158  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
159
160 ikiwiki (1.21) unstable; urgency=low
161
162   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
163   * If a page links to itself, mark up the link text in a span with
164     class="selflink" so that it can be styled. I don't have a useful style
165     defined for that though.
166   * Call filter hooks on inlined page content.
167   * Support inlining pages raw, rather than creating a blog.
168   * Clean up yes/no parameter parsing in inline plugin.
169   * Implemented better cycle detection in the inline plugin; nested inlines
170     will now work.
171   * Add a map plugin contributed by Alessandro Dotti Contra.
172   * Add otl format plugin, which handles files as created by vimoutliner.
173   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
174   * Add first draft at a Restructured Text (rst) plugin, by Sergio
175     Talens-Oliag. Note that this has many known issues -- see the caveats on
176     the plugin's page.
177   * Credit everyone who wrote a plugin on the plugins' wiki pages.
178   * Fix utf-8 in blog post form.
179
180  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
181
182 ikiwiki (1.20) unstable; urgency=low
183
184   * Relicense the templates and basewiki under the 2-clause BSD license.
185     Since these can easily become part of other people's websites, they
186     should be under as permissive a license as possible.
187   * Add --syslog config option, to log to the syslog.
188   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
189     transient failure to fork (which I've seen happen in the wild).
190   * Fix a bug in the aggregator introduced last version that caused all
191     aggregator state to be lost during a non-aggregating build.
192
193  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
194
195 ikiwiki (1.19) unstable; urgency=low
196
197   * Fix several related bugs in page type determination during online editing.
198   * Add some locking to prevent 2 aggregators from running at once.
199   * Fix an infinite loop in the aggregator when finding a unique filename.
200
201  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
202
203 ikiwiki (1.18) unstable; urgency=low
204
205   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
206   * Add --version.
207   * Man page format fixups.
208   * If the meta plugin overides the page title, set a title_overridden
209     variable in the template to true. This allows doing things with the
210     templates conditional on the title being overriden.
211   * Add a %pagecase which maps lower-case page names to the actual case
212     used in the filename. Use this in bestlinks calculation instead of
213     forcing the link to lowercase.
214   * Also use %pagecase in various other places that want to check if a page
215     with a given name exists.
216   * This means that links to pages with mixed case names will now work,
217     even if the link is in some other case mixture, and mixed case pages
218     should be fully supported throughout ikiwiki.
219   * Recommend rebuilding wikis on upgrade to this version.
220
221  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
222
223 ikiwiki (1.17) unstable; urgency=low
224
225   * Disable tidy generator tag.
226   * Move tidy back to sanitize hook, found out how to only show body.
227   * Turn off tidy indentation too.
228   * Turn on HTML::Template loop_context_vars; not actually used in stock
229     templates but can be useful for things like making comma-delimited lists
230     of tags or what have you.
231   * Remove <br> from end of aggregate preprocessor directive output.
232   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
233     case-sensative filesystems like OSX.
234   * Improve markdown loading. First, try to load it as a proper perl module,
235     in case it was installed as one. Then fall back to trying
236     /usr/bin/markdown.
237   * Document in install page how to install markdown, since it has no
238     installation procedure in the upstream tarball.
239   * Set die_on_bad_params => 0 for all templates, to allow users to modify
240     them without annoyances.
241   * Suck in the page content when generating an inline archive page, to work
242     around the meta plugin's lack of caching of title metadata across runs.
243
244  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
245
246 ikiwiki (1.16) unstable; urgency=low
247
248   * Try to handle relative links in aggregated feeds. However,
249     the current support is a crude hack due to limitations of XML::Feed:
250     xml:base is not supported, neither is Content-Location. And of course,
251     relative links in RSS feeds are ill-undefined..
252   * Make aggregator save permalinks and author name to pages as metadata.
253   * Add permalink and author support to meta plugin, affecting RSS feeds
254     and blog pages.
255   * Various CSS and formatting changes.
256   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
257   * Add xhtml files to the default prune regexp.
258   * Also generate rel=bookmark links for permalinks.
259   * Fix the htmltidy plugin, which wasn't working due my breaking it when
260     I added it..
261   * Don't run tidy with -xml as that fails if the input is not well-formed.
262     Run it with -asxhtml instead, so it will output well-formed xhtml no
263     matter what the input.
264   * Disable tidy warnings too.
265   * Add a new format hook, and make tidy use it, since tidy can really only
266     operate on and output complete html documents, not the body chunks
267     that sanitise gets.
268   * Fix dates in rss feeds if running localised, so they're still rfc 822.
269
270  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
271
272 ikiwiki (1.15) unstable; urgency=low
273
274   * Remove CDPATH and other env vars perl taint checking doesn't like.
275     Closes: #381279
276   * Added created_before and created_after PageSpec limits.
277
278  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
279
280 ikiwiki (1.14) unstable; urgency=low
281
282   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
283     by 10% or so.
284   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
285   * Added many unit tests for pagespec_match.
286
287  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
288
289 ikiwiki (1.13) unstable; urgency=low
290
291   * ikiwiki can now download and aggregate feeds with its new aggregate
292     plugin, so it's possible to implement a Planet using ikiwiki!
293   * Add a run_hooks function for the common task of running all hooks of a
294     given type.
295   * Add a savestate hook.
296   * Don't put blog post forms on pages if there's no cgiurl set.
297   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
298     --wrappers to do that.
299   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
300     to update pages that haven't changed on disk.
301   * Change meta tags to use html entity-escaped text for values, so that
302     quotes and such can be represented in title tags.
303   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
304     for the above.
305   * Make --rebuild also cause --aggregate to re-download and write aggregated
306     pages.
307   * Avoid outputting duplicate meta info.
308   * Include title metadata on aggregated posts for capitalised and un-munged
309     titles.
310   * Title metadata of inlined pages now shows up in blogs and rss feeds.
311   * Fix issue with unicode filenames and updating the hyper estradier search
312     index. (Aka Please Please Please, let that be the last one.)
313   * Patch from Roland Mas to support an rss=no parameter to inline directives.
314     Closes: #380743
315   * Renamed GlobLists to PageSpecs.
316   * PageSpecs can now include nested parens, "and", and "or". This remains
317     backwards compatible to the old GlobList format. It's implemented by
318     treating the GlobList as a very limited microlanguage that is transformed
319     to perl code that does the matching.
320   * The old GlobList format is deprecated, and I encourage users to switch to
321     using the new PageSpec format. Compatability with the old format will be
322     removed at some point, possibly by 2.0.
323   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
324   * Add support for creation_month and creation_year to PageSpec.
325     Closes: #380680
326   * Changes to index file encoding.
327
328  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
329
330 ikiwiki (1.12) unstable; urgency=low
331
332   "Viva l'Italia!"
333   * New pagestats plugin from Enrico, which can generate a table counting
334     the backlinks for each page, or a del.icio.us style cloud.
335   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
336     the wikiformat plugin works. Thanks, Emanuele Aina.
337   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
338     display, running them through pagetitle. This removes ugly underscores and
339     other gunk from the display, much nicer. You may want to rebuild your wiki
340     when upgrading to get the cleanup globally.
341   * Polygen plugin from Enrico.
342   * htmltidy plugin from Faidon.
343   * Locale patch from Faidon:
344     - Adds a locale setting to setup files.
345     - Proper local time, if the locale configuration option is used.
346     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
347       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
348       impossible.
349   * Add getopt hook type, this allows plugins to add new command-line options.
350   * Add --tagbase option to tag plugin.
351   * Add exclude option in setup files, works same as --exclude.
352   * Put categories in rss feeds for tagged items.
353   * Allow preprocessor directives to be expanded in inlined blog pages.
354     However, to avoid inlining loops etc, don't expand inline directives in
355     inlined pages.
356   * fortune plugin (trivial)
357   * Tag plugins according to type.
358
359  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
360
361 ikiwiki (1.11) unstable; urgency=low
362
363   * Patch from Enrico that
364     - Adds a tag plugin that allows more easily tagging pages.
365       The meta plugin can also still be used for that, but the tag plugin
366       also lists a page's tags at the bottom of the page.
367     - Allows preprocessor directives to have parameters with no specified
368       value.
369     - Fixes preprocessor directive parameter parsing so that
370       foo=bar baz now means "foo=bar" and a "baz" with no value.
371   * Run pagetemplate hooks when inlining pages so that inlined pages also
372     list their tags.
373   * Make all plugins with pagetemplate hooks check that variables exist
374     on the template before setting them, for robustness.
375   * Switch pagetemplate hooks to using named parameters.
376   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
377     This will be the page that a source page will be part of, which is
378     different than the source page for inlined pages.
379   * Audited all plugins to endure they pass (page, destpage) to htmllink
380     appropriatly. This means inlining of various plugins will not work
381     properly, with correct links generated.
382
383  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
384
385 ikiwiki (1.10) unstable; urgency=low
386
387   * Run page through any relevant filters when generating a page preview.
388   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
389     default throughout the wiki, not only on wikitext pages. Decided to call
390     this a feature, and split the camelcase support out into a separate plugin
391     that is independant of wikitext.
392   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
393
394  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
395
396 ikiwiki (1.9) unstable; urgency=low
397
398   * Improve display of parentlinks and page title of toplevel index page.
399   * Patch from Faidon to use svn --limit when possible for recentchanges,
400     speeds up recentchanges a lot for wikis with more history.
401   * Patch from Recai to fix utf8 issues in git backend.
402   * Add wikitext markup plugin, which supports ".wiki" pages written in the
403     original wiki syntax, CamelCase links and all.
404   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
405     support, to edit pages etc without a web server.
406   * Display CGI processing errors if present.
407   * Fix from Faidon for a XML parser issue that breaks utf-8 for
408     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
409     area, and also way slow.
410   * Match 'web commit from' in SVN and git, these are web commits too.
411     (Faidon)
412   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
413     readable and avoid future mistakes. The patch seems to work and for the
414     first time I have a UTF-8 username ;-) (Faidon)
415   * Use form->field consistently, not form->param.
416   * Patch from Recai to allow selection of page type when creating a new page.
417     Default page type is inherited from the link clicked on to create the new
418     page.
419
420  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
421
422 ikiwiki (1.8) unstable; urgency=low
423
424   * Fix orphans plugin to not count a link to a nonexistant page as a reason
425     for a page not being an orphan.
426   * Support pinging services such as Technorati using XML-RPC to notify them
427     about changes to rss feeds.
428   * Parse svn log as xml for improved utf8 and security. Note that this makes
429     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
430   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
431     flagged string even if the locale causes it to generate utf8 output,
432     so make sure to let perl know it should be handled as utf8. Also,
433     the optimised version used for standard time formats won't work if the
434     user has changed locale, so drop it. Thanks, Faidon Liambotis.
435   * Fix re-encoding of the comments field to utf8 if a commit fails
436     due to a conflict. Thanks, Faidon Liambotis.
437   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
438     Liambotis.
439   * Add insane double encode/decode to utf8 around call to markdown.
440     This works around a truely strange bug, which is apparently a bug in
441     perl, #376329. Also added a test case for it.
442   * Improve layout of edit page so formatting help link is always visible w/o
443     getting in the way of the preview.
444   * Centralised all calls to HTML::Template and force all the templates
445     to be read as utf8.
446   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
447   * Introduce add_plugins and disable_plugins config options in setup files.
448     This allows adding or removing plugins w/o overriding the whole list of
449     default plugins, which makes it easier to upgrade when new default plugins
450     are added.
451   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
452     default (of course!). Based on a patch by Faidon Liambotis.
453   * Add a html plugin, which can be used to write wikis in raw html,
454     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
455     defaults to not processing .html files, since w/o this plugin they would
456     be copied unsanitised. With this plugin, it will process and html
457     sanitise them, like any other page type.
458   * Rebuilding wrappers is necessary on upgrade to this version.
459   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
460     will be automatically done on all upgrades.
461   * Don't send pings if the wiki is being rebuilt.
462   * Work around very innefficient behavior in File::Spec::abs2rel. Result
463     is a savings of 2 pointless fork/execs per link calculation, which
464     results in ~25% speedup of ikiwiki building its own doc wiki, and
465     about 35% speedup displaying RecentChanges!
466   * Make RecentChanges use a table and some CSS, should be much more readable.
467     No code changes involved.
468   * Encode & in diffurl in examples, to conform to pedantic rules.
469   * Speed up RecentChanges by another 40% or so with some memoization.
470   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
471     in time to build the doc wiki.
472
473  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
474
475 ikiwiki (1.7) unstable; urgency=low
476
477   * Updated logo from Recai with some kerning and alingment tuning.
478   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
479     changed some output.
480   * Copyright update.
481
482  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
483
484 ikiwiki (1.6) unstable; urgency=low
485
486   * YA utf-8 patch from Recai, this time to fix previewing a page so that
487     the text in the input box is re-encoded back to utf-8.
488   * -CSD does not affect modules, so readfile() was not using the utf-8 input
489     layer, which led to lots of problems; make it force read files as utf-8.
490     Closes: #373203
491   * Note that as a consequence, this version of ikiwiki will actually try to
492     parse utf8 in source files for the first time, which may expose broken
493     utf8 in wiki sources that was hidden before. Most common will be
494     perl warnings like "utf8 "\xE9" does not map to Unicode"
495   * writefile() likewise needs to use the utf8 output layer.
496   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
497     there.
498   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
499     given the readfile fix.
500   * Add utf-8 testcases for readfile and htmlize.
501   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
502     safe.
503   * More utf-8 fixes from Recai, partly to things I broke above:
504     - The serious problem is that writefile() saves the content in undecoded
505       format in CGI, hence all (non-ascii) chars are corrupted permanently.
506     - Comment field in edit page is not decoded and all the non-ascii chars in
507       this field are corrupted as the result.  We should decode it as we do it
508       for the content.
509     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
510       character in print.
511   * New SVG logo from Recai.
512
513  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
514
515 ikiwiki (1.5) unstable; urgency=low
516
517   * Add --timeformat config option to allow changing how dates are displayed.
518     Note that as a side effect, dates will now be displayed using the local
519     timezone, not as GMT.
520   * More security review.
521   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
522     for some handy stuff like:
523     - Using links as a kind of tag; creating blog pages that list all pages
524       containing a given tag/link or not containing some other tag.
525     - Subscribing to mail notifications whenever a change is made to a page
526       that is a backlink of page foo. Ie, "Please notify me of changes in all
527       pages that link to my home page in the wiki"
528     - Locking any pages that are linked to from a particular page, so that
529       lists of locks can be exposed in the wiki.
530   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
531     when a todo item is done, instead of the previous moving it to a different
532     subdir.
533   * Allow pagetemplate plugins to override *anything* in the template.
534   * Add a meta plugin, which allows specifying various metadata about pages,
535     like license and author. It also allows for inserting html link and meta
536     tags into html, overriding the title, and adding hidden WikiLinks, which
537     can be useful when using link-based globbing for page categorisation.
538   * Remove preprocessor directives from inlined pages.
539   * Allow simple preprocessor directive values to be specified w/o quotes.
540   * Add support for using git instead of subversion as the RCS backend,
541     tremendous thanks to Recai Oktaş for this.
542   * Doc updates for git.
543   * Fix absolute url munging in rss generation to support https, ftp, etc urls
544     not just http urls.
545   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
546     utf-8 for edit and other fields, and for recentchanges. There may still
547     be utf-8 issues with the preferences page though.
548
549  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
550
551 ikiwiki (1.4) unstable; urgency=low
552
553   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
554     very strange way of enabling proper XHTML <br /> type tags. Output html
555     should be always valid again now.
556   * The page name and parent links has switched from using a <h1> to a styled
557     <span>, so pages can use <h1> internally instead of needing to use <h2>.
558   * Updated all of ikiwiki's own wiki pages for that.
559   * Add pagetemplate hook, which can be used by plugins that want to mess
560     around with adding new stuff to the page template.
561   * Remove headercontent; the search plugin now adds the search box to the
562     header by registering a pagetemplate hook, and other plugins should do
563     similarly.
564   * Rebuilding on upgrade to this version is recommended.
565   * Add a html validity check to the test suite, using the wdg-html-validator,
566     if available.
567   * Make the html valid when there is nothing in the actions list.
568   * Reordered some function call parameters for consistency.
569   * Enable full utf-8 support for page input and output.
570   * Add a workaround for markdown, which does not work well with utf-8
571     strings.
572   * --getctime had bitrotted (well I only ever used it the once so far..),
573     fix and make it a bit more flexible
574   * rcs_getctime is changed, now rather than needing to loop over all pages,
575     it should just use the rcs to get the ctime of the passed file.
576   * When inlining a page in another one, links from the inlined page are now
577     expanded the same as they are when rendering the inlined page as a
578     standalone page. So rather than being expanded from the POV of the
579     inlining page, they are expanded from the POV of the inlined page.
580
581     For example, a link from blog/foo to "bar" will now link to blog/bar
582     if it exists. Previously this needed to be a link explicitly to
583     "blog/bar"; such links will also continue to work.
584
585     (This was slightly complex to do as the link still has to be constructed
586     relative to the inlining page.)
587   * Make page edit textarea resize to fit browser window.
588   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
589     do not need a full rebuild, in order to update any basewiki pages.
590
591  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
592
593 ikiwiki (1.3) unstable; urgency=low
594
595   * Fix the preinst introduced in the last version. Closes: #367458
596
597  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
598
599 ikiwiki (1.2) unstable; urgency=low
600
601   * Remove dups from the brokenlinks list.
602   * Add libc6-dev to dependencies, needed to build wrappers.
603   * Install wikilist in correct location. Closes: #367371
604
605  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
606
607 ikiwiki (1.1) unstable; urgency=low
608
609   * Rename inlinepage to depends, so that it can be used to refer to more
610     dependency relationships than just inlining. This will require a rebuild
611     on upgrade to this version.
612   * Move the rss link, put it in the blogpost form if there is one and at the
613     top if not. This is both nicer because easier to find, and it cleans up
614     the code which had used inlinepage as a flag for adding the link later.
615   * Allow the depends GlobList to be built up from multiple sources (such as
616     plugins) during a page render.
617   * Which means that more than one blog is now supported to appear on a
618     single page. (With some limitations, like only the last one getting an
619     rss file.)
620   * Added a plugin system.
621   * Added a pagecount plugin, enabled by default.
622   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
623   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
624     backlinks when the backlinks hadn't really changed.
625   * Moved inline page support, rss generation etc into the inline plugin,
626     enabled by default.
627   * Added brokenlinks plugin, not enabled by default, but rather handy.
628   * Fix several broken links in the doc wiki.
629   * Smarter behavior when creating a page and a page of the same name (but
630     different location) already exists.
631   * Add an orphans plugin for finding pages that nothing links to.
632   * Removed backlinks page, which it turns out nothing used.
633   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
634     it, this will allow for adding a unit test suite.
635   * Add unit tests for several core functions, including globlist_match,
636     dirname, basename, bestlink, linkify, pagetitle, titlepage.
637   * Smart globlist merging.
638   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
639     to pave the way for adding other RCS support. This also changes the
640     setup files, where before they had svn => 1 or svn => 0, now they have
641     rcs => "svn" or rcs => "".
642   * Add a debian/NEWS file with upgrade notes.
643   * Load whatever rcs module is specified, so new ones can be just dropped in
644     as plugins and work. (Well, in theory.)
645   * Add some basic docs about writing RCS modules.
646   * Broke search capability out into a plugin, removed the --hyperestraier
647     switch.
648   * Added smiley plugin, nicely controlled and documented by the smileys page.
649   * Copied in some smileys from Moin Moin.
650   * Allow links of the form [[some page|page]], with whitespace in the link
651     text.
652   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
653     and --disable-plugin htmlscrubber.
654   * Allow discussion links on pages to be turned off with --no-discussion.
655   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
656   * Add some new config items to the estseek.conf template, which are needed
657     by hyperestraier 1.2.3.
658
659  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
660
661 ikiwiki (1.0) unstable; urgency=low
662
663   * First official release.
664
665  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400