]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
web commit by EthanGlasserCamp: This is probably better.
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.33) UNRELEASED; urgency=low
2
3   * Fix issue with aggregate plugin updating expired pages.
4   * Avoid syntax errors in templates used by the template plugin crashing
5     ikiwiki.
6   * Enable utf8 file IO in aggregate plugin.
7   * Fix some issues with the new registration form.
8
9  -- Joey Hess <joeyh@debian.org>  Wed,  8 Nov 2006 15:13:40 -0500
10
11 ikiwiki (1.32) unstable; urgency=low
12
13   * Add a separate pass to find page links, and only render each page once,
14     instead of over and over. Typical speedup is ~4x. Max possible speedup:
15     8x.
16   * Add "scan" parameter to hook(), which is used to make the hook be called
17     during the scanning pass, as well as the render pass. The meta and tag
18     plugins need to use the new scan parameter, so will any others that modify
19     %links.
20   * Now that links are calculated in a separate pass, it can also
21     precalculate backlinks in one pass, which is O(N^2) instead of the
22     previous code that was O(N^3). A very nice speedup for wikis with lots
23     (thousands) of pages.
24   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
25     Erdem.
26   * Add a default stylesheet entry for the pagecloud.
27   * Add examples page with some examples of things that can be done using
28     ikiwiki, like a weblog. The examples can be copied into a user's wiki
29     for a quick start, without needing to learn everything about how to put
30     them together.
31   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
32   * Add perlmagick to build-depends so syntax check of img plugin works.
33     Closes: #396702
34   * Improve login/register process, the login dialog has only name and
35     password fields, which allows more web browsers to regognise it as a login
36     field, and is less confusing.
37   * Implemented expiry options for aggregate plugin.
38   * Use precalculated backlinks info when determining if files need an update
39     due to a page they link to being added/removed. Mostly significant if
40     there are lots of pages.
41   * Remove duplicate link info when saving index. In some cases it could
42     pile up rather badly. (Probably not the best way to deal with this
43     problem.)
44   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
45     or what have you, by creating enclosures for non-page items that are
46     included in feeds.
47
48  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
49
50 ikiwiki (1.31) unstable; urgency=low
51
52   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
53   * Change the rss feed title from the wikiname to the page title, with
54     an exception for the wiki's toplevel index page, which will still use the
55     wikiname as the feed title.
56     Overriding the page title with meta title already overrode the rss feed
57     tittle.
58   * Add an img plugin, based on Christian Mock's img plugin, but stripped
59     down to the bare essentials. Useful for handling large images on websites.
60   * Sanitize possibly problimatic characters out of the polygen grammar names,
61     just in case. Should not be exploitable anyway, since it only tries to run
62     polygen after finding the specified grammar file.
63   * Add missing dependency on the URI perl module.
64   * Add basic spam fighting tool for admins: An admin's prefs page now allows
65     editing a list of banned users.
66
67  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
68
69 ikiwiki (1.30) unstable; urgency=low
70
71   * Add no_override parameter to hook().
72   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
73     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
74     can be configured using a page in wiki.
75   * Fix support for --pingurl at the command line.
76   * Fix a subtle bug in will_render that broke some builds, by only clearing
77     items from renderedfiles the first time per build.
78   * Wrap entire technortati ping operation in an eval to catch all possible
79     failure modes, after I observed a simple ->value crashing ikiwiki when
80     a ping failed.
81
82  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
83
84 ikiwiki (1.29) unstable; urgency=low
85
86   * Patch from Paul Tötterman to use CP in the Makefile.
87   * Patch from Alec Berryman adding a http_auth config item that allows
88     using HTTP Authentication instead of ikiwiki's built in authentication.
89     Useful for eg, large sites with their own previously existing user auth
90     setup. Closes: #384534
91   * Change %renderedfiles to store an array of files rendered from a given
92     source file, to allow tracking of extra rendered files like rss feeds.
93   * Note that plugins that accessed this variable will need to be updated!
94     The plugin interface has been increased to version 1.01 for this change.
95     As few plugins use %renderedfiles I haven't done anything else to ensure
96     compatability of old plugins.
97   * Add will_render function to the plugin interface, used to register that a
98     page renders a destination file, and do some security checks. Previously
99     but no longer rendered files will be cleaned up.
100   * Use will_render in the inline and linkmap plugins.
101   * You will need to rebuild your wiki on upgrade to this version.
102   * Atom feed support based on a patch by Clint Adams.
103   * Add feeds=no option to inline preprocessor directive to turn off all types
104     of feeds.
105   * $IkiWiki::version now holds the program version, and is accessible to
106     plugins.
107   * Make the aggregate plugin emphasize error messages.
108   * Patch from Recai to limit recentchanges to displaying max 10 files for a
109     given changeset (to avoid large number of file changes excessively
110     bloating the page).
111
112  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
113
114 ikiwiki (1.28) unstable; urgency=low
115
116   * inline: Add ability to sort by page name, based on a patch from
117     Benjamin A'Lee.
118   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
119     braindead interface. Closes: #389383
120   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
121     and b) those poor Mac OSX users and their case insensative files!
122   * Don't fail syntax check if Text::Typography isn't installed.
123     Closes: #389406
124
125  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
126
127 ikiwiki (1.27) unstable; urgency=low
128
129   * Work on firming up the plugin interface:
130     - Plugins should not need to load IkiWiki::Render to get commonly
131       used functions, so moved some functions from there to IkiWiki.
132     - Picked out the set of functions and variables that most plugins
133       use, documented them, and made IkiWiki export them by default,
134       like a proper perl module should.
135     - Use the other functions at your own risk.
136     - This is not quite complete, I still have to decide whether to
137       export some other things.
138   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
139     referring to stuff now exported by the IkiWiki module.
140   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
141     to declare which version of the interface your plugin needs.
142   * Anyone with a third-party ikiwiki plugin is strongly encouraged
143     to make like changes to it and avoid use of non-exported symbols from
144     "IkiWiki::".
145   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
146   * Support hyperestradier version 1.4.2, which adds a new required phraseform
147     setting.
148   * If an inlined page has a permalink, link the page title to that.
149   * Patch from Recai to use utf8 when reading the setup file, so that
150     utf8 wikinames from there will be used properly.
151   * Patch from Recai to kill utf-8 on the wiki name when generating the
152     session cookie.
153   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
154   * Fix a baseurl problem in hyperestradier search results.
155   * Add a stub local.css to avoid problems with 404's.
156   * Patch from Recai to fix a wide character warning from the search plugin
157     during setup if the wikiname contains utf8.
158   * Yet another fix for those poor case-insensative OS X users.
159   * pagetemplate hooks are now also called when generating cgi pages.
160   * Add a favicon plugin, which simply adds a link tag for an icon to each
161     page (and cgis).
162   * Patch from James Westby to deal with the case where you're editing a
163     new page, hit cancel, and need to be redirected to somewhere sane.
164   * Various documentation improvements by various wiki users.
165   * Support Text::Markdown from CPAN, which has a different interface from
166     the original markdown or the one in Debian.
167   * Version the libcgi-session-perl dependency, some features that need
168     the new version are used in some cases (sslcookie).
169   * Numerous tla fixes from Clint.
170   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
171     a multi-resolution favicon.ico.
172   * README.Debian: typo Closes: #388110
173   * chomp trailing newline at the end of templates read in by the template
174     plugin, to allow use of the template preprocessor directive in
175     whitespace-sensative situations. Closes: #387073
176   * Patch from James Westby to make the location of the estseek.cgi script
177     configurable.
178   * Add typography (SmartyPants) plugin by Recai.
179   * Add --render mode, which can be used to preview an edit at the command
180     line by test rendering a single page.
181   * Add a googlecalendar plugin. A bit special-purpose, but it shows
182     one way to to deal with user-supplied content that could cause XSS
183     issues w/o the htmlscrubber, and won't survive the scrubber.
184
185  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
186
187 ikiwiki (1.26) unstable; urgency=low
188
189   * Add a missing -n to tla undo call.
190   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
191     writes before consuming its whole stdin. Avoid this deadlock.
192   * Fix alt tags for outline checkboxes.
193
194  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
195
196 ikiwiki (1.25) unstable; urgency=low
197
198   * Add proper waitpid calls for open2ed processes throughout to avoid
199     zombies; this hit htmltidy especially badly.
200   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
201     subversion repos and fixing some other issues.
202   * Add support for tla, contributed by Clint Adams. Closes: #385936
203   * Add support for mercurial, contributed by Emanuele Aina.
204   * Include <link rel> tag for RSS feeds, used by some aggregators and
205     firefox to find the feed.
206   * Add a linkmap plugin (requires graphviz).
207
208  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
209
210 ikiwiki (1.24) unstable; urgency=low
211
212   * Simplify the data structure returned by rcs_recentchanges to avoid
213     each rcs plugin needing to form complex strings on its own.
214   * Fix another destpage issue in the inline directive. Closes: #385512
215     again.
216
217  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
218
219 ikiwiki (1.23) unstable; urgency=low
220
221   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
222
223  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
224
225 ikiwiki (1.22) unstable; urgency=low
226
227   * Change how the stylesheet url is determined in the templates: Remove
228     STYLEURL and add BASEURL to all templates (some already had it). This
229     new more general variable can be used to link to other things (eg, images)
230     from the template, as well as stylesheets.
231   * Fix a bug introduced last version to do with nested inlines.
232   * Allow preprocessor directives to span multiple lines, both to make
233     long ones with lots of values easier to write, and to allow for ones with
234     multi-line quoted values.
235   * Allow preprocessor directives to contain python-like triple-quoted
236     text blocks, for easy nesting of quotes inside.
237   * Add a template plugin.
238   * Make pagespec merge code smarter about merging duplicate pagespecs.
239   * Patch from Jordà Polo to make Setup::Standard support hashes in config
240     files.
241   * Change order of linkify and preprocess; first preprocess and then linkify.
242     This allows passing a wikilink inside a parameter to a preprocessor
243     directive without it being expanded to html, and leaking out of the
244     parameter, which had required some non-obvious use of triple-quoting
245     to avoid. Note that any preprocessor plugins that output something
246     that looks like a wikilink will now have it treated as such; AFAIK
247     this doesn't change any behavior though except for the template plugin.
248   * Enable preprocessor directives when previewing an edit.
249   * Make all pages pull in a local.css style sheet, if present. This won't
250     be included in ikiwiki, but can be created to make local styling changes
251     w/o needing to merge in every new change to the distributed style.css.
252   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
253   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
254     from a different directory.
255   * Generalised preprocesser loop protection code.
256   * Patch from James Westby to allow a description to be set for rss feeds.
257   * Patch from James Westby to add a template for the search form.
258   * Added a ddate plugin.
259   * Patch from James Westby to add a --sslcookie switch, which forces
260     cookies to only be sent over ssl connections to avoid interception.
261   * Fix preferences page on anonok wikis; still need to sign in to get
262     to the preferences page.
263   * Add toc (table of contents) plugin.
264   * Change htmlize, format, and sanitize hooks to use named parameters.
265   * Patch from James Westby to add an actions option to inline; this
266     adds Edit and Discussion links at the end of blog entries.
267   * Due to some css changes, you'll want to rebuild your wiki on upgrade
268     to this version. Will be handled automatically by the deb.
269   * Add processed date to aggregate preprocessor directive status output.
270
271  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
272
273 ikiwiki (1.21) unstable; urgency=low
274
275   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
276   * If a page links to itself, mark up the link text in a span with
277     class="selflink" so that it can be styled. I don't have a useful style
278     defined for that though.
279   * Call filter hooks on inlined page content.
280   * Support inlining pages raw, rather than creating a blog.
281   * Clean up yes/no parameter parsing in inline plugin.
282   * Implemented better cycle detection in the inline plugin; nested inlines
283     will now work.
284   * Add a map plugin contributed by Alessandro Dotti Contra.
285   * Add otl format plugin, which handles files as created by vimoutliner.
286   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
287   * Add first draft at a Restructured Text (rst) plugin, by Sergio
288     Talens-Oliag. Note that this has many known issues -- see the caveats on
289     the plugin's page.
290   * Credit everyone who wrote a plugin on the plugins' wiki pages.
291   * Fix utf-8 in blog post form.
292
293  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
294
295 ikiwiki (1.20) unstable; urgency=low
296
297   * Relicense the templates and basewiki under the 2-clause BSD license.
298     Since these can easily become part of other people's websites, they
299     should be under as permissive a license as possible.
300   * Add --syslog config option, to log to the syslog.
301   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
302     transient failure to fork (which I've seen happen in the wild).
303   * Fix a bug in the aggregator introduced last version that caused all
304     aggregator state to be lost during a non-aggregating build.
305
306  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
307
308 ikiwiki (1.19) unstable; urgency=low
309
310   * Fix several related bugs in page type determination during online editing.
311   * Add some locking to prevent 2 aggregators from running at once.
312   * Fix an infinite loop in the aggregator when finding a unique filename.
313
314  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
315
316 ikiwiki (1.18) unstable; urgency=low
317
318   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
319   * Add --version.
320   * Man page format fixups.
321   * If the meta plugin overides the page title, set a title_overridden
322     variable in the template to true. This allows doing things with the
323     templates conditional on the title being overriden.
324   * Add a %pagecase which maps lower-case page names to the actual case
325     used in the filename. Use this in bestlinks calculation instead of
326     forcing the link to lowercase.
327   * Also use %pagecase in various other places that want to check if a page
328     with a given name exists.
329   * This means that links to pages with mixed case names will now work,
330     even if the link is in some other case mixture, and mixed case pages
331     should be fully supported throughout ikiwiki.
332   * Recommend rebuilding wikis on upgrade to this version.
333
334  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
335
336 ikiwiki (1.17) unstable; urgency=low
337
338   * Disable tidy generator tag.
339   * Move tidy back to sanitize hook, found out how to only show body.
340   * Turn off tidy indentation too.
341   * Turn on HTML::Template loop_context_vars; not actually used in stock
342     templates but can be useful for things like making comma-delimited lists
343     of tags or what have you.
344   * Remove <br> from end of aggregate preprocessor directive output.
345   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
346     case-sensative filesystems like OSX.
347   * Improve markdown loading. First, try to load it as a proper perl module,
348     in case it was installed as one. Then fall back to trying
349     /usr/bin/markdown.
350   * Document in install page how to install markdown, since it has no
351     installation procedure in the upstream tarball.
352   * Set die_on_bad_params => 0 for all templates, to allow users to modify
353     them without annoyances.
354   * Suck in the page content when generating an inline archive page, to work
355     around the meta plugin's lack of caching of title metadata across runs.
356
357  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
358
359 ikiwiki (1.16) unstable; urgency=low
360
361   * Try to handle relative links in aggregated feeds. However,
362     the current support is a crude hack due to limitations of XML::Feed:
363     xml:base is not supported, neither is Content-Location. And of course,
364     relative links in RSS feeds are ill-undefined..
365   * Make aggregator save permalinks and author name to pages as metadata.
366   * Add permalink and author support to meta plugin, affecting RSS feeds
367     and blog pages.
368   * Various CSS and formatting changes.
369   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
370   * Add xhtml files to the default prune regexp.
371   * Also generate rel=bookmark links for permalinks.
372   * Fix the htmltidy plugin, which wasn't working due my breaking it when
373     I added it..
374   * Don't run tidy with -xml as that fails if the input is not well-formed.
375     Run it with -asxhtml instead, so it will output well-formed xhtml no
376     matter what the input.
377   * Disable tidy warnings too.
378   * Add a new format hook, and make tidy use it, since tidy can really only
379     operate on and output complete html documents, not the body chunks
380     that sanitise gets.
381   * Fix dates in rss feeds if running localised, so they're still rfc 822.
382
383  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
384
385 ikiwiki (1.15) unstable; urgency=low
386
387   * Remove CDPATH and other env vars perl taint checking doesn't like.
388     Closes: #381279
389   * Added created_before and created_after PageSpec limits.
390
391  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
392
393 ikiwiki (1.14) unstable; urgency=low
394
395   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
396     by 10% or so.
397   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
398   * Added many unit tests for pagespec_match.
399
400  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
401
402 ikiwiki (1.13) unstable; urgency=low
403
404   * ikiwiki can now download and aggregate feeds with its new aggregate
405     plugin, so it's possible to implement a Planet using ikiwiki!
406   * Add a run_hooks function for the common task of running all hooks of a
407     given type.
408   * Add a savestate hook.
409   * Don't put blog post forms on pages if there's no cgiurl set.
410   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
411     --wrappers to do that.
412   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
413     to update pages that haven't changed on disk.
414   * Change meta tags to use html entity-escaped text for values, so that
415     quotes and such can be represented in title tags.
416   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
417     for the above.
418   * Make --rebuild also cause --aggregate to re-download and write aggregated
419     pages.
420   * Avoid outputting duplicate meta info.
421   * Include title metadata on aggregated posts for capitalised and un-munged
422     titles.
423   * Title metadata of inlined pages now shows up in blogs and rss feeds.
424   * Fix issue with unicode filenames and updating the hyper estradier search
425     index. (Aka Please Please Please, let that be the last one.)
426   * Patch from Roland Mas to support an rss=no parameter to inline directives.
427     Closes: #380743
428   * Renamed GlobLists to PageSpecs.
429   * PageSpecs can now include nested parens, "and", and "or". This remains
430     backwards compatible to the old GlobList format. It's implemented by
431     treating the GlobList as a very limited microlanguage that is transformed
432     to perl code that does the matching.
433   * The old GlobList format is deprecated, and I encourage users to switch to
434     using the new PageSpec format. Compatability with the old format will be
435     removed at some point, possibly by 2.0.
436   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
437   * Add support for creation_month and creation_year to PageSpec.
438     Closes: #380680
439   * Changes to index file encoding.
440
441  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
442
443 ikiwiki (1.12) unstable; urgency=low
444
445   "Viva l'Italia!"
446   * New pagestats plugin from Enrico, which can generate a table counting
447     the backlinks for each page, or a del.icio.us style cloud.
448   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
449     the wikiformat plugin works. Thanks, Emanuele Aina.
450   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
451     display, running them through pagetitle. This removes ugly underscores and
452     other gunk from the display, much nicer. You may want to rebuild your wiki
453     when upgrading to get the cleanup globally.
454   * Polygen plugin from Enrico.
455   * htmltidy plugin from Faidon.
456   * Locale patch from Faidon:
457     - Adds a locale setting to setup files.
458     - Proper local time, if the locale configuration option is used.
459     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
460       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
461       impossible.
462   * Add getopt hook type, this allows plugins to add new command-line options.
463   * Add --tagbase option to tag plugin.
464   * Add exclude option in setup files, works same as --exclude.
465   * Put categories in rss feeds for tagged items.
466   * Allow preprocessor directives to be expanded in inlined blog pages.
467     However, to avoid inlining loops etc, don't expand inline directives in
468     inlined pages.
469   * fortune plugin (trivial)
470   * Tag plugins according to type.
471
472  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
473
474 ikiwiki (1.11) unstable; urgency=low
475
476   * Patch from Enrico that
477     - Adds a tag plugin that allows more easily tagging pages.
478       The meta plugin can also still be used for that, but the tag plugin
479       also lists a page's tags at the bottom of the page.
480     - Allows preprocessor directives to have parameters with no specified
481       value.
482     - Fixes preprocessor directive parameter parsing so that
483       foo=bar baz now means "foo=bar" and a "baz" with no value.
484   * Run pagetemplate hooks when inlining pages so that inlined pages also
485     list their tags.
486   * Make all plugins with pagetemplate hooks check that variables exist
487     on the template before setting them, for robustness.
488   * Switch pagetemplate hooks to using named parameters.
489   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
490     This will be the page that a source page will be part of, which is
491     different than the source page for inlined pages.
492   * Audited all plugins to endure they pass (page, destpage) to htmllink
493     appropriatly. This means inlining of various plugins will not work
494     properly, with correct links generated.
495
496  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
497
498 ikiwiki (1.10) unstable; urgency=low
499
500   * Run page through any relevant filters when generating a page preview.
501   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
502     default throughout the wiki, not only on wikitext pages. Decided to call
503     this a feature, and split the camelcase support out into a separate plugin
504     that is independant of wikitext.
505   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
506
507  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
508
509 ikiwiki (1.9) unstable; urgency=low
510
511   * Improve display of parentlinks and page title of toplevel index page.
512   * Patch from Faidon to use svn --limit when possible for recentchanges,
513     speeds up recentchanges a lot for wikis with more history.
514   * Patch from Recai to fix utf8 issues in git backend.
515   * Add wikitext markup plugin, which supports ".wiki" pages written in the
516     original wiki syntax, CamelCase links and all.
517   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
518     support, to edit pages etc without a web server.
519   * Display CGI processing errors if present.
520   * Fix from Faidon for a XML parser issue that breaks utf-8 for
521     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
522     area, and also way slow.
523   * Match 'web commit from' in SVN and git, these are web commits too.
524     (Faidon)
525   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
526     readable and avoid future mistakes. The patch seems to work and for the
527     first time I have a UTF-8 username ;-) (Faidon)
528   * Use form->field consistently, not form->param.
529   * Patch from Recai to allow selection of page type when creating a new page.
530     Default page type is inherited from the link clicked on to create the new
531     page.
532
533  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
534
535 ikiwiki (1.8) unstable; urgency=low
536
537   * Fix orphans plugin to not count a link to a nonexistant page as a reason
538     for a page not being an orphan.
539   * Support pinging services such as Technorati using XML-RPC to notify them
540     about changes to rss feeds.
541   * Parse svn log as xml for improved utf8 and security. Note that this makes
542     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
543   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
544     flagged string even if the locale causes it to generate utf8 output,
545     so make sure to let perl know it should be handled as utf8. Also,
546     the optimised version used for standard time formats won't work if the
547     user has changed locale, so drop it. Thanks, Faidon Liambotis.
548   * Fix re-encoding of the comments field to utf8 if a commit fails
549     due to a conflict. Thanks, Faidon Liambotis.
550   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
551     Liambotis.
552   * Add insane double encode/decode to utf8 around call to markdown.
553     This works around a truely strange bug, which is apparently a bug in
554     perl, #376329. Also added a test case for it.
555   * Improve layout of edit page so formatting help link is always visible w/o
556     getting in the way of the preview.
557   * Centralised all calls to HTML::Template and force all the templates
558     to be read as utf8.
559   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
560   * Introduce add_plugins and disable_plugins config options in setup files.
561     This allows adding or removing plugins w/o overriding the whole list of
562     default plugins, which makes it easier to upgrade when new default plugins
563     are added.
564   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
565     default (of course!). Based on a patch by Faidon Liambotis.
566   * Add a html plugin, which can be used to write wikis in raw html,
567     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
568     defaults to not processing .html files, since w/o this plugin they would
569     be copied unsanitised. With this plugin, it will process and html
570     sanitise them, like any other page type.
571   * Rebuilding wrappers is necessary on upgrade to this version.
572   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
573     will be automatically done on all upgrades.
574   * Don't send pings if the wiki is being rebuilt.
575   * Work around very innefficient behavior in File::Spec::abs2rel. Result
576     is a savings of 2 pointless fork/execs per link calculation, which
577     results in ~25% speedup of ikiwiki building its own doc wiki, and
578     about 35% speedup displaying RecentChanges!
579   * Make RecentChanges use a table and some CSS, should be much more readable.
580     No code changes involved.
581   * Encode & in diffurl in examples, to conform to pedantic rules.
582   * Speed up RecentChanges by another 40% or so with some memoization.
583   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
584     in time to build the doc wiki.
585
586  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
587
588 ikiwiki (1.7) unstable; urgency=low
589
590   * Updated logo from Recai with some kerning and alingment tuning.
591   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
592     changed some output.
593   * Copyright update.
594
595  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
596
597 ikiwiki (1.6) unstable; urgency=low
598
599   * YA utf-8 patch from Recai, this time to fix previewing a page so that
600     the text in the input box is re-encoded back to utf-8.
601   * -CSD does not affect modules, so readfile() was not using the utf-8 input
602     layer, which led to lots of problems; make it force read files as utf-8.
603     Closes: #373203
604   * Note that as a consequence, this version of ikiwiki will actually try to
605     parse utf8 in source files for the first time, which may expose broken
606     utf8 in wiki sources that was hidden before. Most common will be
607     perl warnings like "utf8 "\xE9" does not map to Unicode"
608   * writefile() likewise needs to use the utf8 output layer.
609   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
610     there.
611   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
612     given the readfile fix.
613   * Add utf-8 testcases for readfile and htmlize.
614   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
615     safe.
616   * More utf-8 fixes from Recai, partly to things I broke above:
617     - The serious problem is that writefile() saves the content in undecoded
618       format in CGI, hence all (non-ascii) chars are corrupted permanently.
619     - Comment field in edit page is not decoded and all the non-ascii chars in
620       this field are corrupted as the result.  We should decode it as we do it
621       for the content.
622     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
623       character in print.
624   * New SVG logo from Recai.
625
626  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
627
628 ikiwiki (1.5) unstable; urgency=low
629
630   * Add --timeformat config option to allow changing how dates are displayed.
631     Note that as a side effect, dates will now be displayed using the local
632     timezone, not as GMT.
633   * More security review.
634   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
635     for some handy stuff like:
636     - Using links as a kind of tag; creating blog pages that list all pages
637       containing a given tag/link or not containing some other tag.
638     - Subscribing to mail notifications whenever a change is made to a page
639       that is a backlink of page foo. Ie, "Please notify me of changes in all
640       pages that link to my home page in the wiki"
641     - Locking any pages that are linked to from a particular page, so that
642       lists of locks can be exposed in the wiki.
643   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
644     when a todo item is done, instead of the previous moving it to a different
645     subdir.
646   * Allow pagetemplate plugins to override *anything* in the template.
647   * Add a meta plugin, which allows specifying various metadata about pages,
648     like license and author. It also allows for inserting html link and meta
649     tags into html, overriding the title, and adding hidden WikiLinks, which
650     can be useful when using link-based globbing for page categorisation.
651   * Remove preprocessor directives from inlined pages.
652   * Allow simple preprocessor directive values to be specified w/o quotes.
653   * Add support for using git instead of subversion as the RCS backend,
654     tremendous thanks to Recai Oktaş for this.
655   * Doc updates for git.
656   * Fix absolute url munging in rss generation to support https, ftp, etc urls
657     not just http urls.
658   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
659     utf-8 for edit and other fields, and for recentchanges. There may still
660     be utf-8 issues with the preferences page though.
661
662  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
663
664 ikiwiki (1.4) unstable; urgency=low
665
666   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
667     very strange way of enabling proper XHTML <br /> type tags. Output html
668     should be always valid again now.
669   * The page name and parent links has switched from using a <h1> to a styled
670     <span>, so pages can use <h1> internally instead of needing to use <h2>.
671   * Updated all of ikiwiki's own wiki pages for that.
672   * Add pagetemplate hook, which can be used by plugins that want to mess
673     around with adding new stuff to the page template.
674   * Remove headercontent; the search plugin now adds the search box to the
675     header by registering a pagetemplate hook, and other plugins should do
676     similarly.
677   * Rebuilding on upgrade to this version is recommended.
678   * Add a html validity check to the test suite, using the wdg-html-validator,
679     if available.
680   * Make the html valid when there is nothing in the actions list.
681   * Reordered some function call parameters for consistency.
682   * Enable full utf-8 support for page input and output.
683   * Add a workaround for markdown, which does not work well with utf-8
684     strings.
685   * --getctime had bitrotted (well I only ever used it the once so far..),
686     fix and make it a bit more flexible
687   * rcs_getctime is changed, now rather than needing to loop over all pages,
688     it should just use the rcs to get the ctime of the passed file.
689   * When inlining a page in another one, links from the inlined page are now
690     expanded the same as they are when rendering the inlined page as a
691     standalone page. So rather than being expanded from the POV of the
692     inlining page, they are expanded from the POV of the inlined page.
693
694     For example, a link from blog/foo to "bar" will now link to blog/bar
695     if it exists. Previously this needed to be a link explicitly to
696     "blog/bar"; such links will also continue to work.
697
698     (This was slightly complex to do as the link still has to be constructed
699     relative to the inlining page.)
700   * Make page edit textarea resize to fit browser window.
701   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
702     do not need a full rebuild, in order to update any basewiki pages.
703
704  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
705
706 ikiwiki (1.3) unstable; urgency=low
707
708   * Fix the preinst introduced in the last version. Closes: #367458
709
710  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
711
712 ikiwiki (1.2) unstable; urgency=low
713
714   * Remove dups from the brokenlinks list.
715   * Add libc6-dev to dependencies, needed to build wrappers.
716   * Install wikilist in correct location. Closes: #367371
717
718  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
719
720 ikiwiki (1.1) unstable; urgency=low
721
722   * Rename inlinepage to depends, so that it can be used to refer to more
723     dependency relationships than just inlining. This will require a rebuild
724     on upgrade to this version.
725   * Move the rss link, put it in the blogpost form if there is one and at the
726     top if not. This is both nicer because easier to find, and it cleans up
727     the code which had used inlinepage as a flag for adding the link later.
728   * Allow the depends GlobList to be built up from multiple sources (such as
729     plugins) during a page render.
730   * Which means that more than one blog is now supported to appear on a
731     single page. (With some limitations, like only the last one getting an
732     rss file.)
733   * Added a plugin system.
734   * Added a pagecount plugin, enabled by default.
735   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
736   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
737     backlinks when the backlinks hadn't really changed.
738   * Moved inline page support, rss generation etc into the inline plugin,
739     enabled by default.
740   * Added brokenlinks plugin, not enabled by default, but rather handy.
741   * Fix several broken links in the doc wiki.
742   * Smarter behavior when creating a page and a page of the same name (but
743     different location) already exists.
744   * Add an orphans plugin for finding pages that nothing links to.
745   * Removed backlinks page, which it turns out nothing used.
746   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
747     it, this will allow for adding a unit test suite.
748   * Add unit tests for several core functions, including globlist_match,
749     dirname, basename, bestlink, linkify, pagetitle, titlepage.
750   * Smart globlist merging.
751   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
752     to pave the way for adding other RCS support. This also changes the
753     setup files, where before they had svn => 1 or svn => 0, now they have
754     rcs => "svn" or rcs => "".
755   * Add a debian/NEWS file with upgrade notes.
756   * Load whatever rcs module is specified, so new ones can be just dropped in
757     as plugins and work. (Well, in theory.)
758   * Add some basic docs about writing RCS modules.
759   * Broke search capability out into a plugin, removed the --hyperestraier
760     switch.
761   * Added smiley plugin, nicely controlled and documented by the smileys page.
762   * Copied in some smileys from Moin Moin.
763   * Allow links of the form [[some page|page]], with whitespace in the link
764     text.
765   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
766     and --disable-plugin htmlscrubber.
767   * Allow discussion links on pages to be turned off with --no-discussion.
768   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
769   * Add some new config items to the estseek.conf template, which are needed
770     by hyperestraier 1.2.3.
771
772  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
773
774 ikiwiki (1.0) unstable; urgency=low
775
776   * First official release.
777
778  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400