]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
web commit by joey
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.27) UNRELEASED; urgency=low
2
3   * Add a googlecalendar plugin. A bit special-purpose, but it shows
4     one way to to deal with user-supplied content that could cause XSS
5     issues w/o the htmlscrubber, and won't survive the scrubber.
6   * Work on firming up the plugin interface:
7     - Plugins should not need to load IkiWiki::Render to get commonly
8       used functions, so moved some functions from there to IkiWiki.
9     - Picked out the set of functions and variables that most plugins
10       use, documented them, and made IkiWiki export them by default,
11       like a proper perl module should.
12     - Use the other functions at your own risk.
13     - This is not quite complete, I still have to decide whether to
14       export some other things.
15   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16     referring to stuff now exported by the IkiWiki module.
17   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18     to declare which version of the interface your plugin needs.
19   * Anyone with a third-party ikiwiki plugin is strongly encouraged
20     to make like changes to it and avoid use of non-exported symboles from
21     "IkiWiki::".
22   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23   * Support hyperestradier version 1.4.2, which adds a new required phraseform
24     setting.
25   * If an inlined page has a permalink, link the page title to that.
26   * Patch from Recai to use utf8 when reading the setup file, so that
27     utf8 wikinames from there will be used properly.
28   * Patch from Recai to kill utf-8 on the wiki name when generating the
29     session cookie.
30   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31   * Fix a baseurl problem in hyperestradier search results.
32   * Add a stub local.css to avoid problems with 404's.
33   * Patch from Recai to fix a wide character warning from the search plugin
34     during setup if the wikiname contains utf8.
35   * Yet another fix for those poor case-insensative `OSX users.
36   * pagetemplate hooks are now also called when generating cgi pages.
37   * Add a favicon plugin, which simply adds a link tag for an icon to each
38     page (and cgis).
39   * Patch from James Westby to deal with the case where you're editing a
40     new page, hit cancel, and need to be redirected to somewhere sane.
41   * Various documentation improvements by various wiki users.
42   * Support Text::Markdown from CPAN, which has a different interface from
43     the original markdown or the one in Debian.
44   * Version the libcgi-session-perl dependency, some features that need
45     the new version are used in some cases (sslcookie).
46   * Numerous tla fixes from Clint.
47   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
48     a multi-resolution favicon.ico.
49   * README.Debian: typo Closes: #388110
50   * chomp trailing newline at the end of templates read in by the template
51     plugin, to allow use of the template preprocessor directive in
52     whitespace-sensative situations. Closes: #387073
53   * Patch from James Westby to make the location of the estseek.cgi script
54     configurable.
55   * Add typography (SmartyPants) plugin by Recai.
56
57  -- Joey Hess <joeyh@debian.org>  Thu, 21 Sep 2006 16:27:44 -0400
58
59 ikiwiki (1.26) unstable; urgency=low
60
61   * Add a missing -n to tla undo call.
62   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
63     writes before consuming its whole stdin. Avoid this deadlock.
64   * Fix alt tags for outline checkboxes.
65
66  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
67
68 ikiwiki (1.25) unstable; urgency=low
69
70   * Add proper waitpid calls for open2ed processes throughout to avoid
71     zombies; this hit htmltidy especially badly.
72   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
73     subversion repos and fixing some other issues.
74   * Add support for tla, contributed by Clint Adams. Closes: #385936
75   * Add support for mercurial, contributed by Emanuele Aina.
76   * Include <link rel> tag for RSS feeds, used by some aggregators and
77     firefox to find the feed.
78   * Add a linkmap plugin (requires graphviz).
79
80  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
81
82 ikiwiki (1.24) unstable; urgency=low
83
84   * Simplify the data structure returned by rcs_recentchanges to avoid
85     each rcs plugin needing to form complex strings on its own.
86   * Fix another destpage issue in the inline directive. Closes: #385512
87     again.
88
89  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
90
91 ikiwiki (1.23) unstable; urgency=low
92
93   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
94
95  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
96
97 ikiwiki (1.22) unstable; urgency=low
98
99   * Change how the stylesheet url is determined in the templates: Remove
100     STYLEURL and add BASEURL to all templates (some already had it). This
101     new more general variable can be used to link to other things (eg, images)
102     from the template, as well as stylesheets.
103   * Fix a bug introduced last version to do with nested inlines.
104   * Allow preprocessor directives to span multiple lines, both to make
105     long ones with lots of values easier to write, and to allow for ones with
106     multi-line quoted values.
107   * Allow preprocessor directives to contain python-like triple-quoted
108     text blocks, for easy nesting of quotes inside.
109   * Add a template plugin.
110   * Make pagespec merge code smarter about merging duplicate pagespecs.
111   * Patch from Jordà Polo to make Setup::Standard support hashes in config
112     files.
113   * Change order of linkify and preprocess; first preprocess and then linkify.
114     This allows passing a wikilink inside a parameter to a preprocessor
115     directive without it being expanded to html, and leaking out of the
116     parameter, which had required some non-obvious use of triple-quoting
117     to avoid. Note that any preprocessor plugins that output something
118     that looks like a wikilink will now have it treated as such; AFAIK
119     this doesn't change any behavior though except for the template plugin.
120   * Enable preprocessor directives when previewing an edit.
121   * Make all pages pull in a local.css style sheet, if present. This won't
122     be included in ikiwiki, but can be created to make local styling changes
123     w/o needing to merge in every new change to the distributed style.css.
124   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
125   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
126     from a different directory.
127   * Generalised preprocesser loop protection code.
128   * Patch from James Westby to allow a description to be set for rss feeds.
129   * Patch from James Westby to add a template for the search form.
130   * Added a ddate plugin.
131   * Patch from James Westby to add a --sslcookie switch, which forces
132     cookies to only be sent over ssl connections to avoid interception.
133   * Fix preferences page on anonok wikis; still need to sign in to get
134     to the preferences page.
135   * Add toc (table of contents) plugin.
136   * Change htmlize, format, and sanitize hooks to use named parameters.
137   * Patch from James Westby to add an actions option to inline; this
138     adds Edit and Discussion links at the end of blog entries.
139   * Due to some css changes, you'll want to rebuild your wiki on upgrade
140     to this version. Will be handled automatically by the deb.
141   * Add processed date to aggregate preprocessor directive status output.
142
143  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
144
145 ikiwiki (1.21) unstable; urgency=low
146
147   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
148   * If a page links to itself, mark up the link text in a span with
149     class="selflink" so that it can be styled. I don't have a useful style
150     defined for that though.
151   * Call filter hooks on inlined page content.
152   * Support inlining pages raw, rather than creating a blog.
153   * Clean up yes/no parameter parsing in inline plugin.
154   * Implemented better cycle detection in the inline plugin; nested inlines
155     will now work.
156   * Add a map plugin contributed by Alessandro Dotti Contra.
157   * Add otl format plugin, which handles files as created by vimoutliner.
158   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
159   * Add first draft at a Restructured Text (rst) plugin, by Sergio
160     Talens-Oliag. Note that this has many known issues -- see the caveats on
161     the plugin's page.
162   * Credit everyone who wrote a plugin on the plugins' wiki pages.
163   * Fix utf-8 in blog post form.
164
165  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
166
167 ikiwiki (1.20) unstable; urgency=low
168
169   * Relicense the templates and basewiki under the 2-clause BSD license.
170     Since these can easily become part of other people's websites, they
171     should be under as permissive a license as possible.
172   * Add --syslog config option, to log to the syslog.
173   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
174     transient failure to fork (which I've seen happen in the wild).
175   * Fix a bug in the aggregator introduced last version that caused all
176     aggregator state to be lost during a non-aggregating build.
177
178  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
179
180 ikiwiki (1.19) unstable; urgency=low
181
182   * Fix several related bugs in page type determination during online editing.
183   * Add some locking to prevent 2 aggregators from running at once.
184   * Fix an infinite loop in the aggregator when finding a unique filename.
185
186  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
187
188 ikiwiki (1.18) unstable; urgency=low
189
190   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
191   * Add --version.
192   * Man page format fixups.
193   * If the meta plugin overides the page title, set a title_overridden
194     variable in the template to true. This allows doing things with the
195     templates conditional on the title being overriden.
196   * Add a %pagecase which maps lower-case page names to the actual case
197     used in the filename. Use this in bestlinks calculation instead of
198     forcing the link to lowercase.
199   * Also use %pagecase in various other places that want to check if a page
200     with a given name exists.
201   * This means that links to pages with mixed case names will now work,
202     even if the link is in some other case mixture, and mixed case pages
203     should be fully supported throughout ikiwiki.
204   * Recommend rebuilding wikis on upgrade to this version.
205
206  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
207
208 ikiwiki (1.17) unstable; urgency=low
209
210   * Disable tidy generator tag.
211   * Move tidy back to sanitize hook, found out how to only show body.
212   * Turn off tidy indentation too.
213   * Turn on HTML::Template loop_context_vars; not actually used in stock
214     templates but can be useful for things like making comma-delimited lists
215     of tags or what have you.
216   * Remove <br> from end of aggregate preprocessor directive output.
217   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
218     case-sensative filesystems like OSX.
219   * Improve markdown loading. First, try to load it as a proper perl module,
220     in case it was installed as one. Then fall back to trying
221     /usr/bin/markdown.
222   * Document in install page how to install markdown, since it has no
223     installation procedure in the upstream tarball.
224   * Set die_on_bad_params => 0 for all templates, to allow users to modify
225     them without annoyances.
226   * Suck in the page content when generating an inline archive page, to work
227     around the meta plugin's lack of caching of title metadata across runs.
228
229  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
230
231 ikiwiki (1.16) unstable; urgency=low
232
233   * Try to handle relative links in aggregated feeds. However,
234     the current support is a crude hack due to limitations of XML::Feed:
235     xml:base is not supported, neither is Content-Location. And of course,
236     relative links in RSS feeds are ill-undefined..
237   * Make aggregator save permalinks and author name to pages as metadata.
238   * Add permalink and author support to meta plugin, affecting RSS feeds
239     and blog pages.
240   * Various CSS and formatting changes.
241   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
242   * Add xhtml files to the default prune regexp.
243   * Also generate rel=bookmark links for permalinks.
244   * Fix the htmltidy plugin, which wasn't working due my breaking it when
245     I added it..
246   * Don't run tidy with -xml as that fails if the input is not well-formed.
247     Run it with -asxhtml instead, so it will output well-formed xhtml no
248     matter what the input.
249   * Disable tidy warnings too.
250   * Add a new format hook, and make tidy use it, since tidy can really only
251     operate on and output complete html documents, not the body chunks
252     that sanitise gets.
253   * Fix dates in rss feeds if running localised, so they're still rfc 822.
254
255  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
256
257 ikiwiki (1.15) unstable; urgency=low
258
259   * Remove CDPATH and other env vars perl taint checking doesn't like.
260     Closes: #381279
261   * Added created_before and created_after PageSpec limits.
262
263  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
264
265 ikiwiki (1.14) unstable; urgency=low
266
267   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
268     by 10% or so.
269   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
270   * Added many unit tests for pagespec_match.
271
272  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
273
274 ikiwiki (1.13) unstable; urgency=low
275
276   * ikiwiki can now download and aggregate feeds with its new aggregate
277     plugin, so it's possible to implement a Planet using ikiwiki!
278   * Add a run_hooks function for the common task of running all hooks of a
279     given type.
280   * Add a savestate hook.
281   * Don't put blog post forms on pages if there's no cgiurl set.
282   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
283     --wrappers to do that.
284   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
285     to update pages that haven't changed on disk.
286   * Change meta tags to use html entity-escaped text for values, so that
287     quotes and such can be represented in title tags.
288   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
289     for the above.
290   * Make --rebuild also cause --aggregate to re-download and write aggregated
291     pages.
292   * Avoid outputting duplicate meta info.
293   * Include title metadata on aggregated posts for capitalised and un-munged
294     titles.
295   * Title metadata of inlined pages now shows up in blogs and rss feeds.
296   * Fix issue with unicode filenames and updating the hyper estradier search
297     index. (Aka Please Please Please, let that be the last one.)
298   * Patch from Roland Mas to support an rss=no parameter to inline directives.
299     Closes: #380743
300   * Renamed GlobLists to PageSpecs.
301   * PageSpecs can now include nested parens, "and", and "or". This remains
302     backwards compatible to the old GlobList format. It's implemented by
303     treating the GlobList as a very limited microlanguage that is transformed
304     to perl code that does the matching.
305   * The old GlobList format is deprecated, and I encourage users to switch to
306     using the new PageSpec format. Compatability with the old format will be
307     removed at some point, possibly by 2.0.
308   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
309   * Add support for creation_month and creation_year to PageSpec.
310     Closes: #380680
311   * Changes to index file encoding.
312
313  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
314
315 ikiwiki (1.12) unstable; urgency=low
316
317   "Viva l'Italia!"
318   * New pagestats plugin from Enrico, which can generate a table counting
319     the backlinks for each page, or a del.icio.us style cloud.
320   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
321     the wikiformat plugin works. Thanks, Emanuele Aina.
322   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
323     display, running them through pagetitle. This removes ugly underscores and
324     other gunk from the display, much nicer. You may want to rebuild your wiki
325     when upgrading to get the cleanup globally.
326   * Polygen plugin from Enrico.
327   * htmltidy plugin from Faidon.
328   * Locale patch from Faidon:
329     - Adds a locale setting to setup files.
330     - Proper local time, if the locale configuration option is used.
331     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
332       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
333       impossible.
334   * Add getopt hook type, this allows plugins to add new command-line options.
335   * Add --tagbase option to tag plugin.
336   * Add exclude option in setup files, works same as --exclude.
337   * Put categories in rss feeds for tagged items.
338   * Allow preprocessor directives to be expanded in inlined blog pages.
339     However, to avoid inlining loops etc, don't expand inline directives in
340     inlined pages.
341   * fortune plugin (trivial)
342   * Tag plugins according to type.
343
344  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
345
346 ikiwiki (1.11) unstable; urgency=low
347
348   * Patch from Enrico that
349     - Adds a tag plugin that allows more easily tagging pages.
350       The meta plugin can also still be used for that, but the tag plugin
351       also lists a page's tags at the bottom of the page.
352     - Allows preprocessor directives to have parameters with no specified
353       value.
354     - Fixes preprocessor directive parameter parsing so that
355       foo=bar baz now means "foo=bar" and a "baz" with no value.
356   * Run pagetemplate hooks when inlining pages so that inlined pages also
357     list their tags.
358   * Make all plugins with pagetemplate hooks check that variables exist
359     on the template before setting them, for robustness.
360   * Switch pagetemplate hooks to using named parameters.
361   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
362     This will be the page that a source page will be part of, which is
363     different than the source page for inlined pages.
364   * Audited all plugins to endure they pass (page, destpage) to htmllink
365     appropriatly. This means inlining of various plugins will not work
366     properly, with correct links generated.
367
368  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
369
370 ikiwiki (1.10) unstable; urgency=low
371
372   * Run page through any relevant filters when generating a page preview.
373   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
374     default throughout the wiki, not only on wikitext pages. Decided to call
375     this a feature, and split the camelcase support out into a separate plugin
376     that is independant of wikitext.
377   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
378
379  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
380
381 ikiwiki (1.9) unstable; urgency=low
382
383   * Improve display of parentlinks and page title of toplevel index page.
384   * Patch from Faidon to use svn --limit when possible for recentchanges,
385     speeds up recentchanges a lot for wikis with more history.
386   * Patch from Recai to fix utf8 issues in git backend.
387   * Add wikitext markup plugin, which supports ".wiki" pages written in the
388     original wiki syntax, CamelCase links and all.
389   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
390     support, to edit pages etc without a web server.
391   * Display CGI processing errors if present.
392   * Fix from Faidon for a XML parser issue that breaks utf-8 for
393     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
394     area, and also way slow.
395   * Match 'web commit from' in SVN and git, these are web commits too.
396     (Faidon)
397   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
398     readable and avoid future mistakes. The patch seems to work and for the
399     first time I have a UTF-8 username ;-) (Faidon)
400   * Use form->field consistently, not form->param.
401   * Patch from Recai to allow selection of page type when creating a new page.
402     Default page type is inherited from the link clicked on to create the new
403     page.
404
405  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
406
407 ikiwiki (1.8) unstable; urgency=low
408
409   * Fix orphans plugin to not count a link to a nonexistant page as a reason
410     for a page not being an orphan.
411   * Support pinging services such as Technorati using XML-RPC to notify them
412     about changes to rss feeds.
413   * Parse svn log as xml for improved utf8 and security. Note that this makes
414     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
415   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
416     flagged string even if the locale causes it to generate utf8 output,
417     so make sure to let perl know it should be handled as utf8. Also,
418     the optimised version used for standard time formats won't work if the
419     user has changed locale, so drop it. Thanks, Faidon Liambotis.
420   * Fix re-encoding of the comments field to utf8 if a commit fails
421     due to a conflict. Thanks, Faidon Liambotis.
422   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
423     Liambotis.
424   * Add insane double encode/decode to utf8 around call to markdown.
425     This works around a truely strange bug, which is apparently a bug in
426     perl, #376329. Also added a test case for it.
427   * Improve layout of edit page so formatting help link is always visible w/o
428     getting in the way of the preview.
429   * Centralised all calls to HTML::Template and force all the templates
430     to be read as utf8.
431   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
432   * Introduce add_plugins and disable_plugins config options in setup files.
433     This allows adding or removing plugins w/o overriding the whole list of
434     default plugins, which makes it easier to upgrade when new default plugins
435     are added.
436   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
437     default (of course!). Based on a patch by Faidon Liambotis.
438   * Add a html plugin, which can be used to write wikis in raw html,
439     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
440     defaults to not processing .html files, since w/o this plugin they would
441     be copied unsanitised. With this plugin, it will process and html
442     sanitise them, like any other page type.
443   * Rebuilding wrappers is necessary on upgrade to this version.
444   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
445     will be automatically done on all upgrades.
446   * Don't send pings if the wiki is being rebuilt.
447   * Work around very innefficient behavior in File::Spec::abs2rel. Result
448     is a savings of 2 pointless fork/execs per link calculation, which
449     results in ~25% speedup of ikiwiki building its own doc wiki, and
450     about 35% speedup displaying RecentChanges!
451   * Make RecentChanges use a table and some CSS, should be much more readable.
452     No code changes involved.
453   * Encode & in diffurl in examples, to conform to pedantic rules.
454   * Speed up RecentChanges by another 40% or so with some memoization.
455   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
456     in time to build the doc wiki.
457
458  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
459
460 ikiwiki (1.7) unstable; urgency=low
461
462   * Updated logo from Recai with some kerning and alingment tuning.
463   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
464     changed some output.
465   * Copyright update.
466
467  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
468
469 ikiwiki (1.6) unstable; urgency=low
470
471   * YA utf-8 patch from Recai, this time to fix previewing a page so that
472     the text in the input box is re-encoded back to utf-8.
473   * -CSD does not affect modules, so readfile() was not using the utf-8 input
474     layer, which led to lots of problems; make it force read files as utf-8.
475     Closes: #373203
476   * Note that as a consequence, this version of ikiwiki will actually try to
477     parse utf8 in source files for the first time, which may expose broken
478     utf8 in wiki sources that was hidden before. Most common will be
479     perl warnings like "utf8 "\xE9" does not map to Unicode"
480   * writefile() likewise needs to use the utf8 output layer.
481   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
482     there.
483   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
484     given the readfile fix.
485   * Add utf-8 testcases for readfile and htmlize.
486   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
487     safe.
488   * More utf-8 fixes from Recai, partly to things I broke above:
489     - The serious problem is that writefile() saves the content in undecoded
490       format in CGI, hence all (non-ascii) chars are corrupted permanently.
491     - Comment field in edit page is not decoded and all the non-ascii chars in
492       this field are corrupted as the result.  We should decode it as we do it
493       for the content.
494     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
495       character in print.
496   * New SVG logo from Recai.
497
498  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
499
500 ikiwiki (1.5) unstable; urgency=low
501
502   * Add --timeformat config option to allow changing how dates are displayed.
503     Note that as a side effect, dates will now be displayed using the local
504     timezone, not as GMT.
505   * More security review.
506   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
507     for some handy stuff like:
508     - Using links as a kind of tag; creating blog pages that list all pages
509       containing a given tag/link or not containing some other tag.
510     - Subscribing to mail notifications whenever a change is made to a page
511       that is a backlink of page foo. Ie, "Please notify me of changes in all
512       pages that link to my home page in the wiki"
513     - Locking any pages that are linked to from a particular page, so that
514       lists of locks can be exposed in the wiki.
515   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
516     when a todo item is done, instead of the previous moving it to a different
517     subdir.
518   * Allow pagetemplate plugins to override *anything* in the template.
519   * Add a meta plugin, which allows specifying various metadata about pages,
520     like license and author. It also allows for inserting html link and meta
521     tags into html, overriding the title, and adding hidden WikiLinks, which
522     can be useful when using link-based globbing for page categorisation.
523   * Remove preprocessor directives from inlined pages.
524   * Allow simple preprocessor directive values to be specified w/o quotes.
525   * Add support for using git instead of subversion as the RCS backend,
526     tremendous thanks to Recai Oktaş for this.
527   * Doc updates for git.
528   * Fix absolute url munging in rss generation to support https, ftp, etc urls
529     not just http urls.
530   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
531     utf-8 for edit and other fields, and for recentchanges. There may still
532     be utf-8 issues with the preferences page though.
533
534  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
535
536 ikiwiki (1.4) unstable; urgency=low
537
538   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
539     very strange way of enabling proper XHTML <br /> type tags. Output html
540     should be always valid again now.
541   * The page name and parent links has switched from using a <h1> to a styled
542     <span>, so pages can use <h1> internally instead of needing to use <h2>.
543   * Updated all of ikiwiki's own wiki pages for that.
544   * Add pagetemplate hook, which can be used by plugins that want to mess
545     around with adding new stuff to the page template.
546   * Remove headercontent; the search plugin now adds the search box to the
547     header by registering a pagetemplate hook, and other plugins should do
548     similarly.
549   * Rebuilding on upgrade to this version is recommended.
550   * Add a html validity check to the test suite, using the wdg-html-validator,
551     if available.
552   * Make the html valid when there is nothing in the actions list.
553   * Reordered some function call parameters for consistency.
554   * Enable full utf-8 support for page input and output.
555   * Add a workaround for markdown, which does not work well with utf-8
556     strings.
557   * --getctime had bitrotted (well I only ever used it the once so far..),
558     fix and make it a bit more flexible
559   * rcs_getctime is changed, now rather than needing to loop over all pages,
560     it should just use the rcs to get the ctime of the passed file.
561   * When inlining a page in another one, links from the inlined page are now
562     expanded the same as they are when rendering the inlined page as a
563     standalone page. So rather than being expanded from the POV of the
564     inlining page, they are expanded from the POV of the inlined page.
565
566     For example, a link from blog/foo to "bar" will now link to blog/bar
567     if it exists. Previously this needed to be a link explicitly to
568     "blog/bar"; such links will also continue to work.
569
570     (This was slightly complex to do as the link still has to be constructed
571     relative to the inlining page.)
572   * Make page edit textarea resize to fit browser window.
573   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
574     do not need a full rebuild, in order to update any basewiki pages.
575
576  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
577
578 ikiwiki (1.3) unstable; urgency=low
579
580   * Fix the preinst introduced in the last version. Closes: #367458
581
582  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
583
584 ikiwiki (1.2) unstable; urgency=low
585
586   * Remove dups from the brokenlinks list.
587   * Add libc6-dev to dependencies, needed to build wrappers.
588   * Install wikilist in correct location. Closes: #367371
589
590  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
591
592 ikiwiki (1.1) unstable; urgency=low
593
594   * Rename inlinepage to depends, so that it can be used to refer to more
595     dependency relationships than just inlining. This will require a rebuild
596     on upgrade to this version.
597   * Move the rss link, put it in the blogpost form if there is one and at the
598     top if not. This is both nicer because easier to find, and it cleans up
599     the code which had used inlinepage as a flag for adding the link later.
600   * Allow the depends GlobList to be built up from multiple sources (such as
601     plugins) during a page render.
602   * Which means that more than one blog is now supported to appear on a
603     single page. (With some limitations, like only the last one getting an
604     rss file.)
605   * Added a plugin system.
606   * Added a pagecount plugin, enabled by default.
607   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
608   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
609     backlinks when the backlinks hadn't really changed.
610   * Moved inline page support, rss generation etc into the inline plugin,
611     enabled by default.
612   * Added brokenlinks plugin, not enabled by default, but rather handy.
613   * Fix several broken links in the doc wiki.
614   * Smarter behavior when creating a page and a page of the same name (but
615     different location) already exists.
616   * Add an orphans plugin for finding pages that nothing links to.
617   * Removed backlinks page, which it turns out nothing used.
618   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
619     it, this will allow for adding a unit test suite.
620   * Add unit tests for several core functions, including globlist_match,
621     dirname, basename, bestlink, linkify, pagetitle, titlepage.
622   * Smart globlist merging.
623   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
624     to pave the way for adding other RCS support. This also changes the
625     setup files, where before they had svn => 1 or svn => 0, now they have
626     rcs => "svn" or rcs => "".
627   * Add a debian/NEWS file with upgrade notes.
628   * Load whatever rcs module is specified, so new ones can be just dropped in
629     as plugins and work. (Well, in theory.)
630   * Add some basic docs about writing RCS modules.
631   * Broke search capability out into a plugin, removed the --hyperestraier
632     switch.
633   * Added smiley plugin, nicely controlled and documented by the smileys page.
634   * Copied in some smileys from Moin Moin.
635   * Allow links of the form [[some page|page]], with whitespace in the link
636     text.
637   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
638     and --disable-plugin htmlscrubber.
639   * Allow discussion links on pages to be turned off with --no-discussion.
640   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
641   * Add some new config items to the estseek.conf template, which are needed
642     by hyperestraier 1.2.3.
643
644  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
645
646 ikiwiki (1.0) unstable; urgency=low
647
648   * First official release.
649
650  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400