]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
notes on OpenID migration
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Add an openid plugin to support logging in using OpenID.
4   * Web commits by OpenID users will record the full OpenID url for the user,
5     but in recentchanges, these urls will be converted to a simplified display
6     form+link.
7   * Modified svn, git, tla backends to recognise such web commits.
8   * Move httpauth support to a plugin.
9   * Add openidsignup config option.
10   * Make the openid plugin support the callbacks from myopenid.com via its
11     affiliate program.
12   * Change how post signin actions are propigated through the signin process;
13     they're now stored in the session.
14   * Add optional "desc" parameter to shortcut definitions.
15   * Avoid locking the wiki at all when handling some basic cgi stuff
16     (searches, recentchanges).
17   * Add "last" parameter to hook function. Very basic ordering, and hopefully
18     nothing more spohisticated will be needed.
19   * Add formbuilder_setup and formbuilder hooks.
20   * Split out a passwordauth module, that holds all the traditional password
21     based authentication etc code. It's enabled by default, but can be disabled
22     if you want only openid or some other auth method.
23
24  -- Joey Hess <joeyh@debian.org>  Mon, 20 Nov 2006 09:17:07 -0500
25
26 ikiwiki (1.33) unstable; urgency=low
27
28   * Fix issue with aggregate plugin updating expired pages.
29   * Avoid syntax errors in templates used by the template plugin crashing
30     ikiwiki.
31   * Enable utf8 file IO in aggregate plugin.
32   * Fix some issues with the new registration form.
33   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
34   * Make sure to check for errors from every eval.
35   * Fix img plugin's handling of adding dependencies for images that do not
36     yet exist.
37   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
38     FORM-SUBMIT unusable on customised formbuilder templates. For now,
39     hardcode the submit buttons in editpage.tmpl instead of using the
40     template variable, which is ok, since the buttons are static.
41   * Work with hyperestraier 1.4.9.
42
43  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
44
45 ikiwiki (1.32) unstable; urgency=low
46
47   * Add a separate pass to find page links, and only render each page once,
48     instead of over and over. Typical speedup is ~4x. Max possible speedup:
49     8x.
50   * Add "scan" parameter to hook(), which is used to make the hook be called
51     during the scanning pass, as well as the render pass. The meta and tag
52     plugins need to use the new scan parameter, so will any others that modify
53     %links.
54   * Now that links are calculated in a separate pass, it can also
55     precalculate backlinks in one pass, which is O(N^2) instead of the
56     previous code that was O(N^3). A very nice speedup for wikis with lots
57     (thousands) of pages.
58   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
59     Erdem.
60   * Add a default stylesheet entry for the pagecloud.
61   * Add examples page with some examples of things that can be done using
62     ikiwiki, like a weblog. The examples can be copied into a user's wiki
63     for a quick start, without needing to learn everything about how to put
64     them together.
65   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
66   * Add perlmagick to build-depends so syntax check of img plugin works.
67     Closes: #396702
68   * Improve login/register process, the login dialog has only name and
69     password fields, which allows more web browsers to regognise it as a login
70     field, and is less confusing.
71   * Implemented expiry options for aggregate plugin.
72   * Use precalculated backlinks info when determining if files need an update
73     due to a page they link to being added/removed. Mostly significant if
74     there are lots of pages.
75   * Remove duplicate link info when saving index. In some cases it could
76     pile up rather badly. (Probably not the best way to deal with this
77     problem.)
78   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
79     or what have you, by creating enclosures for non-page items that are
80     included in feeds.
81
82  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
83
84 ikiwiki (1.31) unstable; urgency=low
85
86   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
87   * Change the rss feed title from the wikiname to the page title, with
88     an exception for the wiki's toplevel index page, which will still use the
89     wikiname as the feed title.
90     Overriding the page title with meta title already overrode the rss feed
91     tittle.
92   * Add an img plugin, based on Christian Mock's img plugin, but stripped
93     down to the bare essentials. Useful for handling large images on websites.
94   * Sanitize possibly problimatic characters out of the polygen grammar names,
95     just in case. Should not be exploitable anyway, since it only tries to run
96     polygen after finding the specified grammar file.
97   * Add missing dependency on the URI perl module.
98   * Add basic spam fighting tool for admins: An admin's prefs page now allows
99     editing a list of banned users.
100
101  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
102
103 ikiwiki (1.30) unstable; urgency=low
104
105   * Add no_override parameter to hook().
106   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
107     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
108     can be configured using a page in wiki.
109   * Fix support for --pingurl at the command line.
110   * Fix a subtle bug in will_render that broke some builds, by only clearing
111     items from renderedfiles the first time per build.
112   * Wrap entire technortati ping operation in an eval to catch all possible
113     failure modes, after I observed a simple ->value crashing ikiwiki when
114     a ping failed.
115
116  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
117
118 ikiwiki (1.29) unstable; urgency=low
119
120   * Patch from Paul Tötterman to use CP in the Makefile.
121   * Patch from Alec Berryman adding a http_auth config item that allows
122     using HTTP Authentication instead of ikiwiki's built in authentication.
123     Useful for eg, large sites with their own previously existing user auth
124     setup. Closes: #384534
125   * Change %renderedfiles to store an array of files rendered from a given
126     source file, to allow tracking of extra rendered files like rss feeds.
127   * Note that plugins that accessed this variable will need to be updated!
128     The plugin interface has been increased to version 1.01 for this change.
129     As few plugins use %renderedfiles I haven't done anything else to ensure
130     compatability of old plugins.
131   * Add will_render function to the plugin interface, used to register that a
132     page renders a destination file, and do some security checks. Previously
133     but no longer rendered files will be cleaned up.
134   * Use will_render in the inline and linkmap plugins.
135   * You will need to rebuild your wiki on upgrade to this version.
136   * Atom feed support based on a patch by Clint Adams.
137   * Add feeds=no option to inline preprocessor directive to turn off all types
138     of feeds.
139   * $IkiWiki::version now holds the program version, and is accessible to
140     plugins.
141   * Make the aggregate plugin emphasize error messages.
142   * Patch from Recai to limit recentchanges to displaying max 10 files for a
143     given changeset (to avoid large number of file changes excessively
144     bloating the page).
145
146  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
147
148 ikiwiki (1.28) unstable; urgency=low
149
150   * inline: Add ability to sort by page name, based on a patch from
151     Benjamin A'Lee.
152   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
153     braindead interface. Closes: #389383
154   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
155     and b) those poor Mac OSX users and their case insensative files!
156   * Don't fail syntax check if Text::Typography isn't installed.
157     Closes: #389406
158
159  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
160
161 ikiwiki (1.27) unstable; urgency=low
162
163   * Work on firming up the plugin interface:
164     - Plugins should not need to load IkiWiki::Render to get commonly
165       used functions, so moved some functions from there to IkiWiki.
166     - Picked out the set of functions and variables that most plugins
167       use, documented them, and made IkiWiki export them by default,
168       like a proper perl module should.
169     - Use the other functions at your own risk.
170     - This is not quite complete, I still have to decide whether to
171       export some other things.
172   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
173     referring to stuff now exported by the IkiWiki module.
174   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
175     to declare which version of the interface your plugin needs.
176   * Anyone with a third-party ikiwiki plugin is strongly encouraged
177     to make like changes to it and avoid use of non-exported symbols from
178     "IkiWiki::".
179   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
180   * Support hyperestradier version 1.4.2, which adds a new required phraseform
181     setting.
182   * If an inlined page has a permalink, link the page title to that.
183   * Patch from Recai to use utf8 when reading the setup file, so that
184     utf8 wikinames from there will be used properly.
185   * Patch from Recai to kill utf-8 on the wiki name when generating the
186     session cookie.
187   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
188   * Fix a baseurl problem in hyperestradier search results.
189   * Add a stub local.css to avoid problems with 404's.
190   * Patch from Recai to fix a wide character warning from the search plugin
191     during setup if the wikiname contains utf8.
192   * Yet another fix for those poor case-insensative OS X users.
193   * pagetemplate hooks are now also called when generating cgi pages.
194   * Add a favicon plugin, which simply adds a link tag for an icon to each
195     page (and cgis).
196   * Patch from James Westby to deal with the case where you're editing a
197     new page, hit cancel, and need to be redirected to somewhere sane.
198   * Various documentation improvements by various wiki users.
199   * Support Text::Markdown from CPAN, which has a different interface from
200     the original markdown or the one in Debian.
201   * Version the libcgi-session-perl dependency, some features that need
202     the new version are used in some cases (sslcookie).
203   * Numerous tla fixes from Clint.
204   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
205     a multi-resolution favicon.ico.
206   * README.Debian: typo Closes: #388110
207   * chomp trailing newline at the end of templates read in by the template
208     plugin, to allow use of the template preprocessor directive in
209     whitespace-sensative situations. Closes: #387073
210   * Patch from James Westby to make the location of the estseek.cgi script
211     configurable.
212   * Add typography (SmartyPants) plugin by Recai.
213   * Add --render mode, which can be used to preview an edit at the command
214     line by test rendering a single page.
215   * Add a googlecalendar plugin. A bit special-purpose, but it shows
216     one way to to deal with user-supplied content that could cause XSS
217     issues w/o the htmlscrubber, and won't survive the scrubber.
218
219  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
220
221 ikiwiki (1.26) unstable; urgency=low
222
223   * Add a missing -n to tla undo call.
224   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
225     writes before consuming its whole stdin. Avoid this deadlock.
226   * Fix alt tags for outline checkboxes.
227
228  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
229
230 ikiwiki (1.25) unstable; urgency=low
231
232   * Add proper waitpid calls for open2ed processes throughout to avoid
233     zombies; this hit htmltidy especially badly.
234   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
235     subversion repos and fixing some other issues.
236   * Add support for tla, contributed by Clint Adams. Closes: #385936
237   * Add support for mercurial, contributed by Emanuele Aina.
238   * Include <link rel> tag for RSS feeds, used by some aggregators and
239     firefox to find the feed.
240   * Add a linkmap plugin (requires graphviz).
241
242  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
243
244 ikiwiki (1.24) unstable; urgency=low
245
246   * Simplify the data structure returned by rcs_recentchanges to avoid
247     each rcs plugin needing to form complex strings on its own.
248   * Fix another destpage issue in the inline directive. Closes: #385512
249     again.
250
251  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
252
253 ikiwiki (1.23) unstable; urgency=low
254
255   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
256
257  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
258
259 ikiwiki (1.22) unstable; urgency=low
260
261   * Change how the stylesheet url is determined in the templates: Remove
262     STYLEURL and add BASEURL to all templates (some already had it). This
263     new more general variable can be used to link to other things (eg, images)
264     from the template, as well as stylesheets.
265   * Fix a bug introduced last version to do with nested inlines.
266   * Allow preprocessor directives to span multiple lines, both to make
267     long ones with lots of values easier to write, and to allow for ones with
268     multi-line quoted values.
269   * Allow preprocessor directives to contain python-like triple-quoted
270     text blocks, for easy nesting of quotes inside.
271   * Add a template plugin.
272   * Make pagespec merge code smarter about merging duplicate pagespecs.
273   * Patch from Jordà Polo to make Setup::Standard support hashes in config
274     files.
275   * Change order of linkify and preprocess; first preprocess and then linkify.
276     This allows passing a wikilink inside a parameter to a preprocessor
277     directive without it being expanded to html, and leaking out of the
278     parameter, which had required some non-obvious use of triple-quoting
279     to avoid. Note that any preprocessor plugins that output something
280     that looks like a wikilink will now have it treated as such; AFAIK
281     this doesn't change any behavior though except for the template plugin.
282   * Enable preprocessor directives when previewing an edit.
283   * Make all pages pull in a local.css style sheet, if present. This won't
284     be included in ikiwiki, but can be created to make local styling changes
285     w/o needing to merge in every new change to the distributed style.css.
286   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
287   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
288     from a different directory.
289   * Generalised preprocesser loop protection code.
290   * Patch from James Westby to allow a description to be set for rss feeds.
291   * Patch from James Westby to add a template for the search form.
292   * Added a ddate plugin.
293   * Patch from James Westby to add a --sslcookie switch, which forces
294     cookies to only be sent over ssl connections to avoid interception.
295   * Fix preferences page on anonok wikis; still need to sign in to get
296     to the preferences page.
297   * Add toc (table of contents) plugin.
298   * Change htmlize, format, and sanitize hooks to use named parameters.
299   * Patch from James Westby to add an actions option to inline; this
300     adds Edit and Discussion links at the end of blog entries.
301   * Due to some css changes, you'll want to rebuild your wiki on upgrade
302     to this version. Will be handled automatically by the deb.
303   * Add processed date to aggregate preprocessor directive status output.
304
305  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
306
307 ikiwiki (1.21) unstable; urgency=low
308
309   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
310   * If a page links to itself, mark up the link text in a span with
311     class="selflink" so that it can be styled. I don't have a useful style
312     defined for that though.
313   * Call filter hooks on inlined page content.
314   * Support inlining pages raw, rather than creating a blog.
315   * Clean up yes/no parameter parsing in inline plugin.
316   * Implemented better cycle detection in the inline plugin; nested inlines
317     will now work.
318   * Add a map plugin contributed by Alessandro Dotti Contra.
319   * Add otl format plugin, which handles files as created by vimoutliner.
320   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
321   * Add first draft at a Restructured Text (rst) plugin, by Sergio
322     Talens-Oliag. Note that this has many known issues -- see the caveats on
323     the plugin's page.
324   * Credit everyone who wrote a plugin on the plugins' wiki pages.
325   * Fix utf-8 in blog post form.
326
327  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
328
329 ikiwiki (1.20) unstable; urgency=low
330
331   * Relicense the templates and basewiki under the 2-clause BSD license.
332     Since these can easily become part of other people's websites, they
333     should be under as permissive a license as possible.
334   * Add --syslog config option, to log to the syslog.
335   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
336     transient failure to fork (which I've seen happen in the wild).
337   * Fix a bug in the aggregator introduced last version that caused all
338     aggregator state to be lost during a non-aggregating build.
339
340  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
341
342 ikiwiki (1.19) unstable; urgency=low
343
344   * Fix several related bugs in page type determination during online editing.
345   * Add some locking to prevent 2 aggregators from running at once.
346   * Fix an infinite loop in the aggregator when finding a unique filename.
347
348  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
349
350 ikiwiki (1.18) unstable; urgency=low
351
352   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
353   * Add --version.
354   * Man page format fixups.
355   * If the meta plugin overides the page title, set a title_overridden
356     variable in the template to true. This allows doing things with the
357     templates conditional on the title being overriden.
358   * Add a %pagecase which maps lower-case page names to the actual case
359     used in the filename. Use this in bestlinks calculation instead of
360     forcing the link to lowercase.
361   * Also use %pagecase in various other places that want to check if a page
362     with a given name exists.
363   * This means that links to pages with mixed case names will now work,
364     even if the link is in some other case mixture, and mixed case pages
365     should be fully supported throughout ikiwiki.
366   * Recommend rebuilding wikis on upgrade to this version.
367
368  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
369
370 ikiwiki (1.17) unstable; urgency=low
371
372   * Disable tidy generator tag.
373   * Move tidy back to sanitize hook, found out how to only show body.
374   * Turn off tidy indentation too.
375   * Turn on HTML::Template loop_context_vars; not actually used in stock
376     templates but can be useful for things like making comma-delimited lists
377     of tags or what have you.
378   * Remove <br> from end of aggregate preprocessor directive output.
379   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
380     case-sensative filesystems like OSX.
381   * Improve markdown loading. First, try to load it as a proper perl module,
382     in case it was installed as one. Then fall back to trying
383     /usr/bin/markdown.
384   * Document in install page how to install markdown, since it has no
385     installation procedure in the upstream tarball.
386   * Set die_on_bad_params => 0 for all templates, to allow users to modify
387     them without annoyances.
388   * Suck in the page content when generating an inline archive page, to work
389     around the meta plugin's lack of caching of title metadata across runs.
390
391  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
392
393 ikiwiki (1.16) unstable; urgency=low
394
395   * Try to handle relative links in aggregated feeds. However,
396     the current support is a crude hack due to limitations of XML::Feed:
397     xml:base is not supported, neither is Content-Location. And of course,
398     relative links in RSS feeds are ill-undefined..
399   * Make aggregator save permalinks and author name to pages as metadata.
400   * Add permalink and author support to meta plugin, affecting RSS feeds
401     and blog pages.
402   * Various CSS and formatting changes.
403   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
404   * Add xhtml files to the default prune regexp.
405   * Also generate rel=bookmark links for permalinks.
406   * Fix the htmltidy plugin, which wasn't working due my breaking it when
407     I added it..
408   * Don't run tidy with -xml as that fails if the input is not well-formed.
409     Run it with -asxhtml instead, so it will output well-formed xhtml no
410     matter what the input.
411   * Disable tidy warnings too.
412   * Add a new format hook, and make tidy use it, since tidy can really only
413     operate on and output complete html documents, not the body chunks
414     that sanitise gets.
415   * Fix dates in rss feeds if running localised, so they're still rfc 822.
416
417  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
418
419 ikiwiki (1.15) unstable; urgency=low
420
421   * Remove CDPATH and other env vars perl taint checking doesn't like.
422     Closes: #381279
423   * Added created_before and created_after PageSpec limits.
424
425  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
426
427 ikiwiki (1.14) unstable; urgency=low
428
429   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
430     by 10% or so.
431   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
432   * Added many unit tests for pagespec_match.
433
434  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
435
436 ikiwiki (1.13) unstable; urgency=low
437
438   * ikiwiki can now download and aggregate feeds with its new aggregate
439     plugin, so it's possible to implement a Planet using ikiwiki!
440   * Add a run_hooks function for the common task of running all hooks of a
441     given type.
442   * Add a savestate hook.
443   * Don't put blog post forms on pages if there's no cgiurl set.
444   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
445     --wrappers to do that.
446   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
447     to update pages that haven't changed on disk.
448   * Change meta tags to use html entity-escaped text for values, so that
449     quotes and such can be represented in title tags.
450   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
451     for the above.
452   * Make --rebuild also cause --aggregate to re-download and write aggregated
453     pages.
454   * Avoid outputting duplicate meta info.
455   * Include title metadata on aggregated posts for capitalised and un-munged
456     titles.
457   * Title metadata of inlined pages now shows up in blogs and rss feeds.
458   * Fix issue with unicode filenames and updating the hyper estradier search
459     index. (Aka Please Please Please, let that be the last one.)
460   * Patch from Roland Mas to support an rss=no parameter to inline directives.
461     Closes: #380743
462   * Renamed GlobLists to PageSpecs.
463   * PageSpecs can now include nested parens, "and", and "or". This remains
464     backwards compatible to the old GlobList format. It's implemented by
465     treating the GlobList as a very limited microlanguage that is transformed
466     to perl code that does the matching.
467   * The old GlobList format is deprecated, and I encourage users to switch to
468     using the new PageSpec format. Compatability with the old format will be
469     removed at some point, possibly by 2.0.
470   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
471   * Add support for creation_month and creation_year to PageSpec.
472     Closes: #380680
473   * Changes to index file encoding.
474
475  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
476
477 ikiwiki (1.12) unstable; urgency=low
478
479   "Viva l'Italia!"
480   * New pagestats plugin from Enrico, which can generate a table counting
481     the backlinks for each page, or a del.icio.us style cloud.
482   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
483     the wikiformat plugin works. Thanks, Emanuele Aina.
484   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
485     display, running them through pagetitle. This removes ugly underscores and
486     other gunk from the display, much nicer. You may want to rebuild your wiki
487     when upgrading to get the cleanup globally.
488   * Polygen plugin from Enrico.
489   * htmltidy plugin from Faidon.
490   * Locale patch from Faidon:
491     - Adds a locale setting to setup files.
492     - Proper local time, if the locale configuration option is used.
493     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
494       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
495       impossible.
496   * Add getopt hook type, this allows plugins to add new command-line options.
497   * Add --tagbase option to tag plugin.
498   * Add exclude option in setup files, works same as --exclude.
499   * Put categories in rss feeds for tagged items.
500   * Allow preprocessor directives to be expanded in inlined blog pages.
501     However, to avoid inlining loops etc, don't expand inline directives in
502     inlined pages.
503   * fortune plugin (trivial)
504   * Tag plugins according to type.
505
506  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
507
508 ikiwiki (1.11) unstable; urgency=low
509
510   * Patch from Enrico that
511     - Adds a tag plugin that allows more easily tagging pages.
512       The meta plugin can also still be used for that, but the tag plugin
513       also lists a page's tags at the bottom of the page.
514     - Allows preprocessor directives to have parameters with no specified
515       value.
516     - Fixes preprocessor directive parameter parsing so that
517       foo=bar baz now means "foo=bar" and a "baz" with no value.
518   * Run pagetemplate hooks when inlining pages so that inlined pages also
519     list their tags.
520   * Make all plugins with pagetemplate hooks check that variables exist
521     on the template before setting them, for robustness.
522   * Switch pagetemplate hooks to using named parameters.
523   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
524     This will be the page that a source page will be part of, which is
525     different than the source page for inlined pages.
526   * Audited all plugins to endure they pass (page, destpage) to htmllink
527     appropriatly. This means inlining of various plugins will not work
528     properly, with correct links generated.
529
530  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
531
532 ikiwiki (1.10) unstable; urgency=low
533
534   * Run page through any relevant filters when generating a page preview.
535   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
536     default throughout the wiki, not only on wikitext pages. Decided to call
537     this a feature, and split the camelcase support out into a separate plugin
538     that is independant of wikitext.
539   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
540
541  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
542
543 ikiwiki (1.9) unstable; urgency=low
544
545   * Improve display of parentlinks and page title of toplevel index page.
546   * Patch from Faidon to use svn --limit when possible for recentchanges,
547     speeds up recentchanges a lot for wikis with more history.
548   * Patch from Recai to fix utf8 issues in git backend.
549   * Add wikitext markup plugin, which supports ".wiki" pages written in the
550     original wiki syntax, CamelCase links and all.
551   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
552     support, to edit pages etc without a web server.
553   * Display CGI processing errors if present.
554   * Fix from Faidon for a XML parser issue that breaks utf-8 for
555     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
556     area, and also way slow.
557   * Match 'web commit from' in SVN and git, these are web commits too.
558     (Faidon)
559   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
560     readable and avoid future mistakes. The patch seems to work and for the
561     first time I have a UTF-8 username ;-) (Faidon)
562   * Use form->field consistently, not form->param.
563   * Patch from Recai to allow selection of page type when creating a new page.
564     Default page type is inherited from the link clicked on to create the new
565     page.
566
567  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
568
569 ikiwiki (1.8) unstable; urgency=low
570
571   * Fix orphans plugin to not count a link to a nonexistant page as a reason
572     for a page not being an orphan.
573   * Support pinging services such as Technorati using XML-RPC to notify them
574     about changes to rss feeds.
575   * Parse svn log as xml for improved utf8 and security. Note that this makes
576     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
577   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
578     flagged string even if the locale causes it to generate utf8 output,
579     so make sure to let perl know it should be handled as utf8. Also,
580     the optimised version used for standard time formats won't work if the
581     user has changed locale, so drop it. Thanks, Faidon Liambotis.
582   * Fix re-encoding of the comments field to utf8 if a commit fails
583     due to a conflict. Thanks, Faidon Liambotis.
584   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
585     Liambotis.
586   * Add insane double encode/decode to utf8 around call to markdown.
587     This works around a truely strange bug, which is apparently a bug in
588     perl, #376329. Also added a test case for it.
589   * Improve layout of edit page so formatting help link is always visible w/o
590     getting in the way of the preview.
591   * Centralised all calls to HTML::Template and force all the templates
592     to be read as utf8.
593   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
594   * Introduce add_plugins and disable_plugins config options in setup files.
595     This allows adding or removing plugins w/o overriding the whole list of
596     default plugins, which makes it easier to upgrade when new default plugins
597     are added.
598   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
599     default (of course!). Based on a patch by Faidon Liambotis.
600   * Add a html plugin, which can be used to write wikis in raw html,
601     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
602     defaults to not processing .html files, since w/o this plugin they would
603     be copied unsanitised. With this plugin, it will process and html
604     sanitise them, like any other page type.
605   * Rebuilding wrappers is necessary on upgrade to this version.
606   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
607     will be automatically done on all upgrades.
608   * Don't send pings if the wiki is being rebuilt.
609   * Work around very innefficient behavior in File::Spec::abs2rel. Result
610     is a savings of 2 pointless fork/execs per link calculation, which
611     results in ~25% speedup of ikiwiki building its own doc wiki, and
612     about 35% speedup displaying RecentChanges!
613   * Make RecentChanges use a table and some CSS, should be much more readable.
614     No code changes involved.
615   * Encode & in diffurl in examples, to conform to pedantic rules.
616   * Speed up RecentChanges by another 40% or so with some memoization.
617   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
618     in time to build the doc wiki.
619
620  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
621
622 ikiwiki (1.7) unstable; urgency=low
623
624   * Updated logo from Recai with some kerning and alingment tuning.
625   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
626     changed some output.
627   * Copyright update.
628
629  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
630
631 ikiwiki (1.6) unstable; urgency=low
632
633   * YA utf-8 patch from Recai, this time to fix previewing a page so that
634     the text in the input box is re-encoded back to utf-8.
635   * -CSD does not affect modules, so readfile() was not using the utf-8 input
636     layer, which led to lots of problems; make it force read files as utf-8.
637     Closes: #373203
638   * Note that as a consequence, this version of ikiwiki will actually try to
639     parse utf8 in source files for the first time, which may expose broken
640     utf8 in wiki sources that was hidden before. Most common will be
641     perl warnings like "utf8 "\xE9" does not map to Unicode"
642   * writefile() likewise needs to use the utf8 output layer.
643   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
644     there.
645   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
646     given the readfile fix.
647   * Add utf-8 testcases for readfile and htmlize.
648   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
649     safe.
650   * More utf-8 fixes from Recai, partly to things I broke above:
651     - The serious problem is that writefile() saves the content in undecoded
652       format in CGI, hence all (non-ascii) chars are corrupted permanently.
653     - Comment field in edit page is not decoded and all the non-ascii chars in
654       this field are corrupted as the result.  We should decode it as we do it
655       for the content.
656     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
657       character in print.
658   * New SVG logo from Recai.
659
660  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
661
662 ikiwiki (1.5) unstable; urgency=low
663
664   * Add --timeformat config option to allow changing how dates are displayed.
665     Note that as a side effect, dates will now be displayed using the local
666     timezone, not as GMT.
667   * More security review.
668   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
669     for some handy stuff like:
670     - Using links as a kind of tag; creating blog pages that list all pages
671       containing a given tag/link or not containing some other tag.
672     - Subscribing to mail notifications whenever a change is made to a page
673       that is a backlink of page foo. Ie, "Please notify me of changes in all
674       pages that link to my home page in the wiki"
675     - Locking any pages that are linked to from a particular page, so that
676       lists of locks can be exposed in the wiki.
677   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
678     when a todo item is done, instead of the previous moving it to a different
679     subdir.
680   * Allow pagetemplate plugins to override *anything* in the template.
681   * Add a meta plugin, which allows specifying various metadata about pages,
682     like license and author. It also allows for inserting html link and meta
683     tags into html, overriding the title, and adding hidden WikiLinks, which
684     can be useful when using link-based globbing for page categorisation.
685   * Remove preprocessor directives from inlined pages.
686   * Allow simple preprocessor directive values to be specified w/o quotes.
687   * Add support for using git instead of subversion as the RCS backend,
688     tremendous thanks to Recai Oktaş for this.
689   * Doc updates for git.
690   * Fix absolute url munging in rss generation to support https, ftp, etc urls
691     not just http urls.
692   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
693     utf-8 for edit and other fields, and for recentchanges. There may still
694     be utf-8 issues with the preferences page though.
695
696  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
697
698 ikiwiki (1.4) unstable; urgency=low
699
700   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
701     very strange way of enabling proper XHTML <br /> type tags. Output html
702     should be always valid again now.
703   * The page name and parent links has switched from using a <h1> to a styled
704     <span>, so pages can use <h1> internally instead of needing to use <h2>.
705   * Updated all of ikiwiki's own wiki pages for that.
706   * Add pagetemplate hook, which can be used by plugins that want to mess
707     around with adding new stuff to the page template.
708   * Remove headercontent; the search plugin now adds the search box to the
709     header by registering a pagetemplate hook, and other plugins should do
710     similarly.
711   * Rebuilding on upgrade to this version is recommended.
712   * Add a html validity check to the test suite, using the wdg-html-validator,
713     if available.
714   * Make the html valid when there is nothing in the actions list.
715   * Reordered some function call parameters for consistency.
716   * Enable full utf-8 support for page input and output.
717   * Add a workaround for markdown, which does not work well with utf-8
718     strings.
719   * --getctime had bitrotted (well I only ever used it the once so far..),
720     fix and make it a bit more flexible
721   * rcs_getctime is changed, now rather than needing to loop over all pages,
722     it should just use the rcs to get the ctime of the passed file.
723   * When inlining a page in another one, links from the inlined page are now
724     expanded the same as they are when rendering the inlined page as a
725     standalone page. So rather than being expanded from the POV of the
726     inlining page, they are expanded from the POV of the inlined page.
727
728     For example, a link from blog/foo to "bar" will now link to blog/bar
729     if it exists. Previously this needed to be a link explicitly to
730     "blog/bar"; such links will also continue to work.
731
732     (This was slightly complex to do as the link still has to be constructed
733     relative to the inlining page.)
734   * Make page edit textarea resize to fit browser window.
735   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
736     do not need a full rebuild, in order to update any basewiki pages.
737
738  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
739
740 ikiwiki (1.3) unstable; urgency=low
741
742   * Fix the preinst introduced in the last version. Closes: #367458
743
744  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
745
746 ikiwiki (1.2) unstable; urgency=low
747
748   * Remove dups from the brokenlinks list.
749   * Add libc6-dev to dependencies, needed to build wrappers.
750   * Install wikilist in correct location. Closes: #367371
751
752  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
753
754 ikiwiki (1.1) unstable; urgency=low
755
756   * Rename inlinepage to depends, so that it can be used to refer to more
757     dependency relationships than just inlining. This will require a rebuild
758     on upgrade to this version.
759   * Move the rss link, put it in the blogpost form if there is one and at the
760     top if not. This is both nicer because easier to find, and it cleans up
761     the code which had used inlinepage as a flag for adding the link later.
762   * Allow the depends GlobList to be built up from multiple sources (such as
763     plugins) during a page render.
764   * Which means that more than one blog is now supported to appear on a
765     single page. (With some limitations, like only the last one getting an
766     rss file.)
767   * Added a plugin system.
768   * Added a pagecount plugin, enabled by default.
769   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
770   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
771     backlinks when the backlinks hadn't really changed.
772   * Moved inline page support, rss generation etc into the inline plugin,
773     enabled by default.
774   * Added brokenlinks plugin, not enabled by default, but rather handy.
775   * Fix several broken links in the doc wiki.
776   * Smarter behavior when creating a page and a page of the same name (but
777     different location) already exists.
778   * Add an orphans plugin for finding pages that nothing links to.
779   * Removed backlinks page, which it turns out nothing used.
780   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
781     it, this will allow for adding a unit test suite.
782   * Add unit tests for several core functions, including globlist_match,
783     dirname, basename, bestlink, linkify, pagetitle, titlepage.
784   * Smart globlist merging.
785   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
786     to pave the way for adding other RCS support. This also changes the
787     setup files, where before they had svn => 1 or svn => 0, now they have
788     rcs => "svn" or rcs => "".
789   * Add a debian/NEWS file with upgrade notes.
790   * Load whatever rcs module is specified, so new ones can be just dropped in
791     as plugins and work. (Well, in theory.)
792   * Add some basic docs about writing RCS modules.
793   * Broke search capability out into a plugin, removed the --hyperestraier
794     switch.
795   * Added smiley plugin, nicely controlled and documented by the smileys page.
796   * Copied in some smileys from Moin Moin.
797   * Allow links of the form [[some page|page]], with whitespace in the link
798     text.
799   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
800     and --disable-plugin htmlscrubber.
801   * Allow discussion links on pages to be turned off with --no-discussion.
802   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
803   * Add some new config items to the estseek.conf template, which are needed
804     by hyperestraier 1.2.3.
805
806  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
807
808 ikiwiki (1.0) unstable; urgency=low
809
810   * First official release.
811
812  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400