]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
testing
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Add an openid plugin to support logging in using OpenID.
4   * Web commits by OpenID users will record the full OpenID url for the user,
5     but in recentchanges, these urls will be converted to a simplified display
6     form+link.
7   * Modified svn, git, tla backends to recognise such web commits.
8   * Move httpauth support to a plugin.
9   * Add openidsignup config option.
10   * Make the openid plugin support the callbacks from myopenid.com via its
11     affiliate program.
12   * Change how post signin actions are propigated through the signin process;
13     they're now stored in the session.
14   * Add optional "desc" parameter to shortcut definitions.
15
16  -- Joey Hess <joeyh@debian.org>  Mon, 20 Nov 2006 06:14:51 -0500
17
18 ikiwiki (1.33) unstable; urgency=low
19
20   * Fix issue with aggregate plugin updating expired pages.
21   * Avoid syntax errors in templates used by the template plugin crashing
22     ikiwiki.
23   * Enable utf8 file IO in aggregate plugin.
24   * Fix some issues with the new registration form.
25   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
26   * Make sure to check for errors from every eval.
27   * Fix img plugin's handling of adding dependencies for images that do not
28     yet exist.
29   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
30     FORM-SUBMIT unusable on customised formbuilder templates. For now,
31     hardcode the submit buttons in editpage.tmpl instead of using the
32     template variable, which is ok, since the buttons are static.
33   * Work with hyperestraier 1.4.9.
34
35  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
36
37 ikiwiki (1.32) unstable; urgency=low
38
39   * Add a separate pass to find page links, and only render each page once,
40     instead of over and over. Typical speedup is ~4x. Max possible speedup:
41     8x.
42   * Add "scan" parameter to hook(), which is used to make the hook be called
43     during the scanning pass, as well as the render pass. The meta and tag
44     plugins need to use the new scan parameter, so will any others that modify
45     %links.
46   * Now that links are calculated in a separate pass, it can also
47     precalculate backlinks in one pass, which is O(N^2) instead of the
48     previous code that was O(N^3). A very nice speedup for wikis with lots
49     (thousands) of pages.
50   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
51     Erdem.
52   * Add a default stylesheet entry for the pagecloud.
53   * Add examples page with some examples of things that can be done using
54     ikiwiki, like a weblog. The examples can be copied into a user's wiki
55     for a quick start, without needing to learn everything about how to put
56     them together.
57   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
58   * Add perlmagick to build-depends so syntax check of img plugin works.
59     Closes: #396702
60   * Improve login/register process, the login dialog has only name and
61     password fields, which allows more web browsers to regognise it as a login
62     field, and is less confusing.
63   * Implemented expiry options for aggregate plugin.
64   * Use precalculated backlinks info when determining if files need an update
65     due to a page they link to being added/removed. Mostly significant if
66     there are lots of pages.
67   * Remove duplicate link info when saving index. In some cases it could
68     pile up rather badly. (Probably not the best way to deal with this
69     problem.)
70   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
71     or what have you, by creating enclosures for non-page items that are
72     included in feeds.
73
74  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
75
76 ikiwiki (1.31) unstable; urgency=low
77
78   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
79   * Change the rss feed title from the wikiname to the page title, with
80     an exception for the wiki's toplevel index page, which will still use the
81     wikiname as the feed title.
82     Overriding the page title with meta title already overrode the rss feed
83     tittle.
84   * Add an img plugin, based on Christian Mock's img plugin, but stripped
85     down to the bare essentials. Useful for handling large images on websites.
86   * Sanitize possibly problimatic characters out of the polygen grammar names,
87     just in case. Should not be exploitable anyway, since it only tries to run
88     polygen after finding the specified grammar file.
89   * Add missing dependency on the URI perl module.
90   * Add basic spam fighting tool for admins: An admin's prefs page now allows
91     editing a list of banned users.
92
93  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
94
95 ikiwiki (1.30) unstable; urgency=low
96
97   * Add no_override parameter to hook().
98   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
99     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
100     can be configured using a page in wiki.
101   * Fix support for --pingurl at the command line.
102   * Fix a subtle bug in will_render that broke some builds, by only clearing
103     items from renderedfiles the first time per build.
104   * Wrap entire technortati ping operation in an eval to catch all possible
105     failure modes, after I observed a simple ->value crashing ikiwiki when
106     a ping failed.
107
108  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
109
110 ikiwiki (1.29) unstable; urgency=low
111
112   * Patch from Paul Tötterman to use CP in the Makefile.
113   * Patch from Alec Berryman adding a http_auth config item that allows
114     using HTTP Authentication instead of ikiwiki's built in authentication.
115     Useful for eg, large sites with their own previously existing user auth
116     setup. Closes: #384534
117   * Change %renderedfiles to store an array of files rendered from a given
118     source file, to allow tracking of extra rendered files like rss feeds.
119   * Note that plugins that accessed this variable will need to be updated!
120     The plugin interface has been increased to version 1.01 for this change.
121     As few plugins use %renderedfiles I haven't done anything else to ensure
122     compatability of old plugins.
123   * Add will_render function to the plugin interface, used to register that a
124     page renders a destination file, and do some security checks. Previously
125     but no longer rendered files will be cleaned up.
126   * Use will_render in the inline and linkmap plugins.
127   * You will need to rebuild your wiki on upgrade to this version.
128   * Atom feed support based on a patch by Clint Adams.
129   * Add feeds=no option to inline preprocessor directive to turn off all types
130     of feeds.
131   * $IkiWiki::version now holds the program version, and is accessible to
132     plugins.
133   * Make the aggregate plugin emphasize error messages.
134   * Patch from Recai to limit recentchanges to displaying max 10 files for a
135     given changeset (to avoid large number of file changes excessively
136     bloating the page).
137
138  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
139
140 ikiwiki (1.28) unstable; urgency=low
141
142   * inline: Add ability to sort by page name, based on a patch from
143     Benjamin A'Lee.
144   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
145     braindead interface. Closes: #389383
146   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
147     and b) those poor Mac OSX users and their case insensative files!
148   * Don't fail syntax check if Text::Typography isn't installed.
149     Closes: #389406
150
151  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
152
153 ikiwiki (1.27) unstable; urgency=low
154
155   * Work on firming up the plugin interface:
156     - Plugins should not need to load IkiWiki::Render to get commonly
157       used functions, so moved some functions from there to IkiWiki.
158     - Picked out the set of functions and variables that most plugins
159       use, documented them, and made IkiWiki export them by default,
160       like a proper perl module should.
161     - Use the other functions at your own risk.
162     - This is not quite complete, I still have to decide whether to
163       export some other things.
164   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
165     referring to stuff now exported by the IkiWiki module.
166   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
167     to declare which version of the interface your plugin needs.
168   * Anyone with a third-party ikiwiki plugin is strongly encouraged
169     to make like changes to it and avoid use of non-exported symbols from
170     "IkiWiki::".
171   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
172   * Support hyperestradier version 1.4.2, which adds a new required phraseform
173     setting.
174   * If an inlined page has a permalink, link the page title to that.
175   * Patch from Recai to use utf8 when reading the setup file, so that
176     utf8 wikinames from there will be used properly.
177   * Patch from Recai to kill utf-8 on the wiki name when generating the
178     session cookie.
179   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
180   * Fix a baseurl problem in hyperestradier search results.
181   * Add a stub local.css to avoid problems with 404's.
182   * Patch from Recai to fix a wide character warning from the search plugin
183     during setup if the wikiname contains utf8.
184   * Yet another fix for those poor case-insensative OS X users.
185   * pagetemplate hooks are now also called when generating cgi pages.
186   * Add a favicon plugin, which simply adds a link tag for an icon to each
187     page (and cgis).
188   * Patch from James Westby to deal with the case where you're editing a
189     new page, hit cancel, and need to be redirected to somewhere sane.
190   * Various documentation improvements by various wiki users.
191   * Support Text::Markdown from CPAN, which has a different interface from
192     the original markdown or the one in Debian.
193   * Version the libcgi-session-perl dependency, some features that need
194     the new version are used in some cases (sslcookie).
195   * Numerous tla fixes from Clint.
196   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
197     a multi-resolution favicon.ico.
198   * README.Debian: typo Closes: #388110
199   * chomp trailing newline at the end of templates read in by the template
200     plugin, to allow use of the template preprocessor directive in
201     whitespace-sensative situations. Closes: #387073
202   * Patch from James Westby to make the location of the estseek.cgi script
203     configurable.
204   * Add typography (SmartyPants) plugin by Recai.
205   * Add --render mode, which can be used to preview an edit at the command
206     line by test rendering a single page.
207   * Add a googlecalendar plugin. A bit special-purpose, but it shows
208     one way to to deal with user-supplied content that could cause XSS
209     issues w/o the htmlscrubber, and won't survive the scrubber.
210
211  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
212
213 ikiwiki (1.26) unstable; urgency=low
214
215   * Add a missing -n to tla undo call.
216   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
217     writes before consuming its whole stdin. Avoid this deadlock.
218   * Fix alt tags for outline checkboxes.
219
220  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
221
222 ikiwiki (1.25) unstable; urgency=low
223
224   * Add proper waitpid calls for open2ed processes throughout to avoid
225     zombies; this hit htmltidy especially badly.
226   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
227     subversion repos and fixing some other issues.
228   * Add support for tla, contributed by Clint Adams. Closes: #385936
229   * Add support for mercurial, contributed by Emanuele Aina.
230   * Include <link rel> tag for RSS feeds, used by some aggregators and
231     firefox to find the feed.
232   * Add a linkmap plugin (requires graphviz).
233
234  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
235
236 ikiwiki (1.24) unstable; urgency=low
237
238   * Simplify the data structure returned by rcs_recentchanges to avoid
239     each rcs plugin needing to form complex strings on its own.
240   * Fix another destpage issue in the inline directive. Closes: #385512
241     again.
242
243  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
244
245 ikiwiki (1.23) unstable; urgency=low
246
247   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
248
249  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
250
251 ikiwiki (1.22) unstable; urgency=low
252
253   * Change how the stylesheet url is determined in the templates: Remove
254     STYLEURL and add BASEURL to all templates (some already had it). This
255     new more general variable can be used to link to other things (eg, images)
256     from the template, as well as stylesheets.
257   * Fix a bug introduced last version to do with nested inlines.
258   * Allow preprocessor directives to span multiple lines, both to make
259     long ones with lots of values easier to write, and to allow for ones with
260     multi-line quoted values.
261   * Allow preprocessor directives to contain python-like triple-quoted
262     text blocks, for easy nesting of quotes inside.
263   * Add a template plugin.
264   * Make pagespec merge code smarter about merging duplicate pagespecs.
265   * Patch from Jordà Polo to make Setup::Standard support hashes in config
266     files.
267   * Change order of linkify and preprocess; first preprocess and then linkify.
268     This allows passing a wikilink inside a parameter to a preprocessor
269     directive without it being expanded to html, and leaking out of the
270     parameter, which had required some non-obvious use of triple-quoting
271     to avoid. Note that any preprocessor plugins that output something
272     that looks like a wikilink will now have it treated as such; AFAIK
273     this doesn't change any behavior though except for the template plugin.
274   * Enable preprocessor directives when previewing an edit.
275   * Make all pages pull in a local.css style sheet, if present. This won't
276     be included in ikiwiki, but can be created to make local styling changes
277     w/o needing to merge in every new change to the distributed style.css.
278   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
279   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
280     from a different directory.
281   * Generalised preprocesser loop protection code.
282   * Patch from James Westby to allow a description to be set for rss feeds.
283   * Patch from James Westby to add a template for the search form.
284   * Added a ddate plugin.
285   * Patch from James Westby to add a --sslcookie switch, which forces
286     cookies to only be sent over ssl connections to avoid interception.
287   * Fix preferences page on anonok wikis; still need to sign in to get
288     to the preferences page.
289   * Add toc (table of contents) plugin.
290   * Change htmlize, format, and sanitize hooks to use named parameters.
291   * Patch from James Westby to add an actions option to inline; this
292     adds Edit and Discussion links at the end of blog entries.
293   * Due to some css changes, you'll want to rebuild your wiki on upgrade
294     to this version. Will be handled automatically by the deb.
295   * Add processed date to aggregate preprocessor directive status output.
296
297  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
298
299 ikiwiki (1.21) unstable; urgency=low
300
301   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
302   * If a page links to itself, mark up the link text in a span with
303     class="selflink" so that it can be styled. I don't have a useful style
304     defined for that though.
305   * Call filter hooks on inlined page content.
306   * Support inlining pages raw, rather than creating a blog.
307   * Clean up yes/no parameter parsing in inline plugin.
308   * Implemented better cycle detection in the inline plugin; nested inlines
309     will now work.
310   * Add a map plugin contributed by Alessandro Dotti Contra.
311   * Add otl format plugin, which handles files as created by vimoutliner.
312   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
313   * Add first draft at a Restructured Text (rst) plugin, by Sergio
314     Talens-Oliag. Note that this has many known issues -- see the caveats on
315     the plugin's page.
316   * Credit everyone who wrote a plugin on the plugins' wiki pages.
317   * Fix utf-8 in blog post form.
318
319  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
320
321 ikiwiki (1.20) unstable; urgency=low
322
323   * Relicense the templates and basewiki under the 2-clause BSD license.
324     Since these can easily become part of other people's websites, they
325     should be under as permissive a license as possible.
326   * Add --syslog config option, to log to the syslog.
327   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
328     transient failure to fork (which I've seen happen in the wild).
329   * Fix a bug in the aggregator introduced last version that caused all
330     aggregator state to be lost during a non-aggregating build.
331
332  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
333
334 ikiwiki (1.19) unstable; urgency=low
335
336   * Fix several related bugs in page type determination during online editing.
337   * Add some locking to prevent 2 aggregators from running at once.
338   * Fix an infinite loop in the aggregator when finding a unique filename.
339
340  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
341
342 ikiwiki (1.18) unstable; urgency=low
343
344   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
345   * Add --version.
346   * Man page format fixups.
347   * If the meta plugin overides the page title, set a title_overridden
348     variable in the template to true. This allows doing things with the
349     templates conditional on the title being overriden.
350   * Add a %pagecase which maps lower-case page names to the actual case
351     used in the filename. Use this in bestlinks calculation instead of
352     forcing the link to lowercase.
353   * Also use %pagecase in various other places that want to check if a page
354     with a given name exists.
355   * This means that links to pages with mixed case names will now work,
356     even if the link is in some other case mixture, and mixed case pages
357     should be fully supported throughout ikiwiki.
358   * Recommend rebuilding wikis on upgrade to this version.
359
360  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
361
362 ikiwiki (1.17) unstable; urgency=low
363
364   * Disable tidy generator tag.
365   * Move tidy back to sanitize hook, found out how to only show body.
366   * Turn off tidy indentation too.
367   * Turn on HTML::Template loop_context_vars; not actually used in stock
368     templates but can be useful for things like making comma-delimited lists
369     of tags or what have you.
370   * Remove <br> from end of aggregate preprocessor directive output.
371   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
372     case-sensative filesystems like OSX.
373   * Improve markdown loading. First, try to load it as a proper perl module,
374     in case it was installed as one. Then fall back to trying
375     /usr/bin/markdown.
376   * Document in install page how to install markdown, since it has no
377     installation procedure in the upstream tarball.
378   * Set die_on_bad_params => 0 for all templates, to allow users to modify
379     them without annoyances.
380   * Suck in the page content when generating an inline archive page, to work
381     around the meta plugin's lack of caching of title metadata across runs.
382
383  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
384
385 ikiwiki (1.16) unstable; urgency=low
386
387   * Try to handle relative links in aggregated feeds. However,
388     the current support is a crude hack due to limitations of XML::Feed:
389     xml:base is not supported, neither is Content-Location. And of course,
390     relative links in RSS feeds are ill-undefined..
391   * Make aggregator save permalinks and author name to pages as metadata.
392   * Add permalink and author support to meta plugin, affecting RSS feeds
393     and blog pages.
394   * Various CSS and formatting changes.
395   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
396   * Add xhtml files to the default prune regexp.
397   * Also generate rel=bookmark links for permalinks.
398   * Fix the htmltidy plugin, which wasn't working due my breaking it when
399     I added it..
400   * Don't run tidy with -xml as that fails if the input is not well-formed.
401     Run it with -asxhtml instead, so it will output well-formed xhtml no
402     matter what the input.
403   * Disable tidy warnings too.
404   * Add a new format hook, and make tidy use it, since tidy can really only
405     operate on and output complete html documents, not the body chunks
406     that sanitise gets.
407   * Fix dates in rss feeds if running localised, so they're still rfc 822.
408
409  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
410
411 ikiwiki (1.15) unstable; urgency=low
412
413   * Remove CDPATH and other env vars perl taint checking doesn't like.
414     Closes: #381279
415   * Added created_before and created_after PageSpec limits.
416
417  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
418
419 ikiwiki (1.14) unstable; urgency=low
420
421   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
422     by 10% or so.
423   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
424   * Added many unit tests for pagespec_match.
425
426  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
427
428 ikiwiki (1.13) unstable; urgency=low
429
430   * ikiwiki can now download and aggregate feeds with its new aggregate
431     plugin, so it's possible to implement a Planet using ikiwiki!
432   * Add a run_hooks function for the common task of running all hooks of a
433     given type.
434   * Add a savestate hook.
435   * Don't put blog post forms on pages if there's no cgiurl set.
436   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
437     --wrappers to do that.
438   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
439     to update pages that haven't changed on disk.
440   * Change meta tags to use html entity-escaped text for values, so that
441     quotes and such can be represented in title tags.
442   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
443     for the above.
444   * Make --rebuild also cause --aggregate to re-download and write aggregated
445     pages.
446   * Avoid outputting duplicate meta info.
447   * Include title metadata on aggregated posts for capitalised and un-munged
448     titles.
449   * Title metadata of inlined pages now shows up in blogs and rss feeds.
450   * Fix issue with unicode filenames and updating the hyper estradier search
451     index. (Aka Please Please Please, let that be the last one.)
452   * Patch from Roland Mas to support an rss=no parameter to inline directives.
453     Closes: #380743
454   * Renamed GlobLists to PageSpecs.
455   * PageSpecs can now include nested parens, "and", and "or". This remains
456     backwards compatible to the old GlobList format. It's implemented by
457     treating the GlobList as a very limited microlanguage that is transformed
458     to perl code that does the matching.
459   * The old GlobList format is deprecated, and I encourage users to switch to
460     using the new PageSpec format. Compatability with the old format will be
461     removed at some point, possibly by 2.0.
462   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
463   * Add support for creation_month and creation_year to PageSpec.
464     Closes: #380680
465   * Changes to index file encoding.
466
467  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
468
469 ikiwiki (1.12) unstable; urgency=low
470
471   "Viva l'Italia!"
472   * New pagestats plugin from Enrico, which can generate a table counting
473     the backlinks for each page, or a del.icio.us style cloud.
474   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
475     the wikiformat plugin works. Thanks, Emanuele Aina.
476   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
477     display, running them through pagetitle. This removes ugly underscores and
478     other gunk from the display, much nicer. You may want to rebuild your wiki
479     when upgrading to get the cleanup globally.
480   * Polygen plugin from Enrico.
481   * htmltidy plugin from Faidon.
482   * Locale patch from Faidon:
483     - Adds a locale setting to setup files.
484     - Proper local time, if the locale configuration option is used.
485     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
486       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
487       impossible.
488   * Add getopt hook type, this allows plugins to add new command-line options.
489   * Add --tagbase option to tag plugin.
490   * Add exclude option in setup files, works same as --exclude.
491   * Put categories in rss feeds for tagged items.
492   * Allow preprocessor directives to be expanded in inlined blog pages.
493     However, to avoid inlining loops etc, don't expand inline directives in
494     inlined pages.
495   * fortune plugin (trivial)
496   * Tag plugins according to type.
497
498  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
499
500 ikiwiki (1.11) unstable; urgency=low
501
502   * Patch from Enrico that
503     - Adds a tag plugin that allows more easily tagging pages.
504       The meta plugin can also still be used for that, but the tag plugin
505       also lists a page's tags at the bottom of the page.
506     - Allows preprocessor directives to have parameters with no specified
507       value.
508     - Fixes preprocessor directive parameter parsing so that
509       foo=bar baz now means "foo=bar" and a "baz" with no value.
510   * Run pagetemplate hooks when inlining pages so that inlined pages also
511     list their tags.
512   * Make all plugins with pagetemplate hooks check that variables exist
513     on the template before setting them, for robustness.
514   * Switch pagetemplate hooks to using named parameters.
515   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
516     This will be the page that a source page will be part of, which is
517     different than the source page for inlined pages.
518   * Audited all plugins to endure they pass (page, destpage) to htmllink
519     appropriatly. This means inlining of various plugins will not work
520     properly, with correct links generated.
521
522  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
523
524 ikiwiki (1.10) unstable; urgency=low
525
526   * Run page through any relevant filters when generating a page preview.
527   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
528     default throughout the wiki, not only on wikitext pages. Decided to call
529     this a feature, and split the camelcase support out into a separate plugin
530     that is independant of wikitext.
531   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
532
533  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
534
535 ikiwiki (1.9) unstable; urgency=low
536
537   * Improve display of parentlinks and page title of toplevel index page.
538   * Patch from Faidon to use svn --limit when possible for recentchanges,
539     speeds up recentchanges a lot for wikis with more history.
540   * Patch from Recai to fix utf8 issues in git backend.
541   * Add wikitext markup plugin, which supports ".wiki" pages written in the
542     original wiki syntax, CamelCase links and all.
543   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
544     support, to edit pages etc without a web server.
545   * Display CGI processing errors if present.
546   * Fix from Faidon for a XML parser issue that breaks utf-8 for
547     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
548     area, and also way slow.
549   * Match 'web commit from' in SVN and git, these are web commits too.
550     (Faidon)
551   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
552     readable and avoid future mistakes. The patch seems to work and for the
553     first time I have a UTF-8 username ;-) (Faidon)
554   * Use form->field consistently, not form->param.
555   * Patch from Recai to allow selection of page type when creating a new page.
556     Default page type is inherited from the link clicked on to create the new
557     page.
558
559  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
560
561 ikiwiki (1.8) unstable; urgency=low
562
563   * Fix orphans plugin to not count a link to a nonexistant page as a reason
564     for a page not being an orphan.
565   * Support pinging services such as Technorati using XML-RPC to notify them
566     about changes to rss feeds.
567   * Parse svn log as xml for improved utf8 and security. Note that this makes
568     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
569   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
570     flagged string even if the locale causes it to generate utf8 output,
571     so make sure to let perl know it should be handled as utf8. Also,
572     the optimised version used for standard time formats won't work if the
573     user has changed locale, so drop it. Thanks, Faidon Liambotis.
574   * Fix re-encoding of the comments field to utf8 if a commit fails
575     due to a conflict. Thanks, Faidon Liambotis.
576   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
577     Liambotis.
578   * Add insane double encode/decode to utf8 around call to markdown.
579     This works around a truely strange bug, which is apparently a bug in
580     perl, #376329. Also added a test case for it.
581   * Improve layout of edit page so formatting help link is always visible w/o
582     getting in the way of the preview.
583   * Centralised all calls to HTML::Template and force all the templates
584     to be read as utf8.
585   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
586   * Introduce add_plugins and disable_plugins config options in setup files.
587     This allows adding or removing plugins w/o overriding the whole list of
588     default plugins, which makes it easier to upgrade when new default plugins
589     are added.
590   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
591     default (of course!). Based on a patch by Faidon Liambotis.
592   * Add a html plugin, which can be used to write wikis in raw html,
593     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
594     defaults to not processing .html files, since w/o this plugin they would
595     be copied unsanitised. With this plugin, it will process and html
596     sanitise them, like any other page type.
597   * Rebuilding wrappers is necessary on upgrade to this version.
598   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
599     will be automatically done on all upgrades.
600   * Don't send pings if the wiki is being rebuilt.
601   * Work around very innefficient behavior in File::Spec::abs2rel. Result
602     is a savings of 2 pointless fork/execs per link calculation, which
603     results in ~25% speedup of ikiwiki building its own doc wiki, and
604     about 35% speedup displaying RecentChanges!
605   * Make RecentChanges use a table and some CSS, should be much more readable.
606     No code changes involved.
607   * Encode & in diffurl in examples, to conform to pedantic rules.
608   * Speed up RecentChanges by another 40% or so with some memoization.
609   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
610     in time to build the doc wiki.
611
612  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
613
614 ikiwiki (1.7) unstable; urgency=low
615
616   * Updated logo from Recai with some kerning and alingment tuning.
617   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
618     changed some output.
619   * Copyright update.
620
621  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
622
623 ikiwiki (1.6) unstable; urgency=low
624
625   * YA utf-8 patch from Recai, this time to fix previewing a page so that
626     the text in the input box is re-encoded back to utf-8.
627   * -CSD does not affect modules, so readfile() was not using the utf-8 input
628     layer, which led to lots of problems; make it force read files as utf-8.
629     Closes: #373203
630   * Note that as a consequence, this version of ikiwiki will actually try to
631     parse utf8 in source files for the first time, which may expose broken
632     utf8 in wiki sources that was hidden before. Most common will be
633     perl warnings like "utf8 "\xE9" does not map to Unicode"
634   * writefile() likewise needs to use the utf8 output layer.
635   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
636     there.
637   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
638     given the readfile fix.
639   * Add utf-8 testcases for readfile and htmlize.
640   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
641     safe.
642   * More utf-8 fixes from Recai, partly to things I broke above:
643     - The serious problem is that writefile() saves the content in undecoded
644       format in CGI, hence all (non-ascii) chars are corrupted permanently.
645     - Comment field in edit page is not decoded and all the non-ascii chars in
646       this field are corrupted as the result.  We should decode it as we do it
647       for the content.
648     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
649       character in print.
650   * New SVG logo from Recai.
651
652  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
653
654 ikiwiki (1.5) unstable; urgency=low
655
656   * Add --timeformat config option to allow changing how dates are displayed.
657     Note that as a side effect, dates will now be displayed using the local
658     timezone, not as GMT.
659   * More security review.
660   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
661     for some handy stuff like:
662     - Using links as a kind of tag; creating blog pages that list all pages
663       containing a given tag/link or not containing some other tag.
664     - Subscribing to mail notifications whenever a change is made to a page
665       that is a backlink of page foo. Ie, "Please notify me of changes in all
666       pages that link to my home page in the wiki"
667     - Locking any pages that are linked to from a particular page, so that
668       lists of locks can be exposed in the wiki.
669   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
670     when a todo item is done, instead of the previous moving it to a different
671     subdir.
672   * Allow pagetemplate plugins to override *anything* in the template.
673   * Add a meta plugin, which allows specifying various metadata about pages,
674     like license and author. It also allows for inserting html link and meta
675     tags into html, overriding the title, and adding hidden WikiLinks, which
676     can be useful when using link-based globbing for page categorisation.
677   * Remove preprocessor directives from inlined pages.
678   * Allow simple preprocessor directive values to be specified w/o quotes.
679   * Add support for using git instead of subversion as the RCS backend,
680     tremendous thanks to Recai Oktaş for this.
681   * Doc updates for git.
682   * Fix absolute url munging in rss generation to support https, ftp, etc urls
683     not just http urls.
684   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
685     utf-8 for edit and other fields, and for recentchanges. There may still
686     be utf-8 issues with the preferences page though.
687
688  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
689
690 ikiwiki (1.4) unstable; urgency=low
691
692   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
693     very strange way of enabling proper XHTML <br /> type tags. Output html
694     should be always valid again now.
695   * The page name and parent links has switched from using a <h1> to a styled
696     <span>, so pages can use <h1> internally instead of needing to use <h2>.
697   * Updated all of ikiwiki's own wiki pages for that.
698   * Add pagetemplate hook, which can be used by plugins that want to mess
699     around with adding new stuff to the page template.
700   * Remove headercontent; the search plugin now adds the search box to the
701     header by registering a pagetemplate hook, and other plugins should do
702     similarly.
703   * Rebuilding on upgrade to this version is recommended.
704   * Add a html validity check to the test suite, using the wdg-html-validator,
705     if available.
706   * Make the html valid when there is nothing in the actions list.
707   * Reordered some function call parameters for consistency.
708   * Enable full utf-8 support for page input and output.
709   * Add a workaround for markdown, which does not work well with utf-8
710     strings.
711   * --getctime had bitrotted (well I only ever used it the once so far..),
712     fix and make it a bit more flexible
713   * rcs_getctime is changed, now rather than needing to loop over all pages,
714     it should just use the rcs to get the ctime of the passed file.
715   * When inlining a page in another one, links from the inlined page are now
716     expanded the same as they are when rendering the inlined page as a
717     standalone page. So rather than being expanded from the POV of the
718     inlining page, they are expanded from the POV of the inlined page.
719
720     For example, a link from blog/foo to "bar" will now link to blog/bar
721     if it exists. Previously this needed to be a link explicitly to
722     "blog/bar"; such links will also continue to work.
723
724     (This was slightly complex to do as the link still has to be constructed
725     relative to the inlining page.)
726   * Make page edit textarea resize to fit browser window.
727   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
728     do not need a full rebuild, in order to update any basewiki pages.
729
730  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
731
732 ikiwiki (1.3) unstable; urgency=low
733
734   * Fix the preinst introduced in the last version. Closes: #367458
735
736  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
737
738 ikiwiki (1.2) unstable; urgency=low
739
740   * Remove dups from the brokenlinks list.
741   * Add libc6-dev to dependencies, needed to build wrappers.
742   * Install wikilist in correct location. Closes: #367371
743
744  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
745
746 ikiwiki (1.1) unstable; urgency=low
747
748   * Rename inlinepage to depends, so that it can be used to refer to more
749     dependency relationships than just inlining. This will require a rebuild
750     on upgrade to this version.
751   * Move the rss link, put it in the blogpost form if there is one and at the
752     top if not. This is both nicer because easier to find, and it cleans up
753     the code which had used inlinepage as a flag for adding the link later.
754   * Allow the depends GlobList to be built up from multiple sources (such as
755     plugins) during a page render.
756   * Which means that more than one blog is now supported to appear on a
757     single page. (With some limitations, like only the last one getting an
758     rss file.)
759   * Added a plugin system.
760   * Added a pagecount plugin, enabled by default.
761   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
762   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
763     backlinks when the backlinks hadn't really changed.
764   * Moved inline page support, rss generation etc into the inline plugin,
765     enabled by default.
766   * Added brokenlinks plugin, not enabled by default, but rather handy.
767   * Fix several broken links in the doc wiki.
768   * Smarter behavior when creating a page and a page of the same name (but
769     different location) already exists.
770   * Add an orphans plugin for finding pages that nothing links to.
771   * Removed backlinks page, which it turns out nothing used.
772   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
773     it, this will allow for adding a unit test suite.
774   * Add unit tests for several core functions, including globlist_match,
775     dirname, basename, bestlink, linkify, pagetitle, titlepage.
776   * Smart globlist merging.
777   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
778     to pave the way for adding other RCS support. This also changes the
779     setup files, where before they had svn => 1 or svn => 0, now they have
780     rcs => "svn" or rcs => "".
781   * Add a debian/NEWS file with upgrade notes.
782   * Load whatever rcs module is specified, so new ones can be just dropped in
783     as plugins and work. (Well, in theory.)
784   * Add some basic docs about writing RCS modules.
785   * Broke search capability out into a plugin, removed the --hyperestraier
786     switch.
787   * Added smiley plugin, nicely controlled and documented by the smileys page.
788   * Copied in some smileys from Moin Moin.
789   * Allow links of the form [[some page|page]], with whitespace in the link
790     text.
791   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
792     and --disable-plugin htmlscrubber.
793   * Allow discussion links on pages to be turned off with --no-discussion.
794   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
795   * Add some new config items to the estseek.conf template, which are needed
796     by hyperestraier 1.2.3.
797
798  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
799
800 ikiwiki (1.0) unstable; urgency=low
801
802   * First official release.
803
804  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400