]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
improve
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Add an openid plugin to support logging in using OpenID.
4   * Web commits by OpenID users will record the full OpenID url for the user,
5     but in recentchanges, these urls will be converted to a simplified display
6     form+link.
7   * Modified svn, git, tla backends to recognise such web commits.
8   * Move httpauth support to a plugin.
9   * Add openidsignup config option.
10   * Make the openid plugin support the callbacks from myopenid.com via its
11     affiliate program.
12   * Change how post signin actions are propigated through the signin process;
13     they're now stored in the session.
14   * Add optional "desc" parameter to shortcut definitions.
15   * Avoid locking the wiki at all when handling some basic cgi stuff
16     (searches, recentchanges).
17   * Add "last" parameter to hook function. Very basic ordering, and hopefully
18     nothing more spohisticated will be needed.
19   * Add formbuilder_setup and formbuilder hooks.
20   * Split out a passwordauth module, that holds all the traditional password
21     based authentication etc code. It's enabled by default, but can be disabled
22     if you want only openid or some other auth method.
23   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
24   * Add some code to the build system that tries to determine if the
25     lib installation directory is in @INC. If it's not, munge ikiwiki
26     to hardcode the path to the lib directory. This should allow installing
27     ikiwiki in nonstandard locations, including home directories, by just
28     setting PREFIX at build time.
29   * Fix nested examples directory in deb.
30   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
31   * Add a test suite for the svn backend.
32   * Daemonize before sending RPC pings, since that can take a while
33     and/or hang.
34   * Daemonize before sending commit mails, as that can also take a long
35     time/hang if the mail server is unhappy.
36   * Factor out commit mail sending code into new function.
37
38  -- Joey Hess <joeyh@debian.org>  Tue, 21 Nov 2006 11:58:30 -0500
39
40 ikiwiki (1.33) unstable; urgency=low
41
42   * Fix issue with aggregate plugin updating expired pages.
43   * Avoid syntax errors in templates used by the template plugin crashing
44     ikiwiki.
45   * Enable utf8 file IO in aggregate plugin.
46   * Fix some issues with the new registration form.
47   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
48   * Make sure to check for errors from every eval.
49   * Fix img plugin's handling of adding dependencies for images that do not
50     yet exist.
51   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
52     FORM-SUBMIT unusable on customised formbuilder templates. For now,
53     hardcode the submit buttons in editpage.tmpl instead of using the
54     template variable, which is ok, since the buttons are static.
55   * Work with hyperestraier 1.4.9.
56
57  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
58
59 ikiwiki (1.32) unstable; urgency=low
60
61   * Add a separate pass to find page links, and only render each page once,
62     instead of over and over. Typical speedup is ~4x. Max possible speedup:
63     8x.
64   * Add "scan" parameter to hook(), which is used to make the hook be called
65     during the scanning pass, as well as the render pass. The meta and tag
66     plugins need to use the new scan parameter, so will any others that modify
67     %links.
68   * Now that links are calculated in a separate pass, it can also
69     precalculate backlinks in one pass, which is O(N^2) instead of the
70     previous code that was O(N^3). A very nice speedup for wikis with lots
71     (thousands) of pages.
72   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
73     Erdem.
74   * Add a default stylesheet entry for the pagecloud.
75   * Add examples page with some examples of things that can be done using
76     ikiwiki, like a weblog. The examples can be copied into a user's wiki
77     for a quick start, without needing to learn everything about how to put
78     them together.
79   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
80   * Add perlmagick to build-depends so syntax check of img plugin works.
81     Closes: #396702
82   * Improve login/register process, the login dialog has only name and
83     password fields, which allows more web browsers to regognise it as a login
84     field, and is less confusing.
85   * Implemented expiry options for aggregate plugin.
86   * Use precalculated backlinks info when determining if files need an update
87     due to a page they link to being added/removed. Mostly significant if
88     there are lots of pages.
89   * Remove duplicate link info when saving index. In some cases it could
90     pile up rather badly. (Probably not the best way to deal with this
91     problem.)
92   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
93     or what have you, by creating enclosures for non-page items that are
94     included in feeds.
95
96  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
97
98 ikiwiki (1.31) unstable; urgency=low
99
100   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
101   * Change the rss feed title from the wikiname to the page title, with
102     an exception for the wiki's toplevel index page, which will still use the
103     wikiname as the feed title.
104     Overriding the page title with meta title already overrode the rss feed
105     tittle.
106   * Add an img plugin, based on Christian Mock's img plugin, but stripped
107     down to the bare essentials. Useful for handling large images on websites.
108   * Sanitize possibly problimatic characters out of the polygen grammar names,
109     just in case. Should not be exploitable anyway, since it only tries to run
110     polygen after finding the specified grammar file.
111   * Add missing dependency on the URI perl module.
112   * Add basic spam fighting tool for admins: An admin's prefs page now allows
113     editing a list of banned users.
114
115  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
116
117 ikiwiki (1.30) unstable; urgency=low
118
119   * Add no_override parameter to hook().
120   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
121     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
122     can be configured using a page in wiki.
123   * Fix support for --pingurl at the command line.
124   * Fix a subtle bug in will_render that broke some builds, by only clearing
125     items from renderedfiles the first time per build.
126   * Wrap entire technortati ping operation in an eval to catch all possible
127     failure modes, after I observed a simple ->value crashing ikiwiki when
128     a ping failed.
129
130  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
131
132 ikiwiki (1.29) unstable; urgency=low
133
134   * Patch from Paul Tötterman to use CP in the Makefile.
135   * Patch from Alec Berryman adding a http_auth config item that allows
136     using HTTP Authentication instead of ikiwiki's built in authentication.
137     Useful for eg, large sites with their own previously existing user auth
138     setup. Closes: #384534
139   * Change %renderedfiles to store an array of files rendered from a given
140     source file, to allow tracking of extra rendered files like rss feeds.
141   * Note that plugins that accessed this variable will need to be updated!
142     The plugin interface has been increased to version 1.01 for this change.
143     As few plugins use %renderedfiles I haven't done anything else to ensure
144     compatability of old plugins.
145   * Add will_render function to the plugin interface, used to register that a
146     page renders a destination file, and do some security checks. Previously
147     but no longer rendered files will be cleaned up.
148   * Use will_render in the inline and linkmap plugins.
149   * You will need to rebuild your wiki on upgrade to this version.
150   * Atom feed support based on a patch by Clint Adams.
151   * Add feeds=no option to inline preprocessor directive to turn off all types
152     of feeds.
153   * $IkiWiki::version now holds the program version, and is accessible to
154     plugins.
155   * Make the aggregate plugin emphasize error messages.
156   * Patch from Recai to limit recentchanges to displaying max 10 files for a
157     given changeset (to avoid large number of file changes excessively
158     bloating the page).
159
160  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
161
162 ikiwiki (1.28) unstable; urgency=low
163
164   * inline: Add ability to sort by page name, based on a patch from
165     Benjamin A'Lee.
166   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
167     braindead interface. Closes: #389383
168   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
169     and b) those poor Mac OSX users and their case insensative files!
170   * Don't fail syntax check if Text::Typography isn't installed.
171     Closes: #389406
172
173  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
174
175 ikiwiki (1.27) unstable; urgency=low
176
177   * Work on firming up the plugin interface:
178     - Plugins should not need to load IkiWiki::Render to get commonly
179       used functions, so moved some functions from there to IkiWiki.
180     - Picked out the set of functions and variables that most plugins
181       use, documented them, and made IkiWiki export them by default,
182       like a proper perl module should.
183     - Use the other functions at your own risk.
184     - This is not quite complete, I still have to decide whether to
185       export some other things.
186   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
187     referring to stuff now exported by the IkiWiki module.
188   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
189     to declare which version of the interface your plugin needs.
190   * Anyone with a third-party ikiwiki plugin is strongly encouraged
191     to make like changes to it and avoid use of non-exported symbols from
192     "IkiWiki::".
193   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
194   * Support hyperestradier version 1.4.2, which adds a new required phraseform
195     setting.
196   * If an inlined page has a permalink, link the page title to that.
197   * Patch from Recai to use utf8 when reading the setup file, so that
198     utf8 wikinames from there will be used properly.
199   * Patch from Recai to kill utf-8 on the wiki name when generating the
200     session cookie.
201   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
202   * Fix a baseurl problem in hyperestradier search results.
203   * Add a stub local.css to avoid problems with 404's.
204   * Patch from Recai to fix a wide character warning from the search plugin
205     during setup if the wikiname contains utf8.
206   * Yet another fix for those poor case-insensative OS X users.
207   * pagetemplate hooks are now also called when generating cgi pages.
208   * Add a favicon plugin, which simply adds a link tag for an icon to each
209     page (and cgis).
210   * Patch from James Westby to deal with the case where you're editing a
211     new page, hit cancel, and need to be redirected to somewhere sane.
212   * Various documentation improvements by various wiki users.
213   * Support Text::Markdown from CPAN, which has a different interface from
214     the original markdown or the one in Debian.
215   * Version the libcgi-session-perl dependency, some features that need
216     the new version are used in some cases (sslcookie).
217   * Numerous tla fixes from Clint.
218   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
219     a multi-resolution favicon.ico.
220   * README.Debian: typo Closes: #388110
221   * chomp trailing newline at the end of templates read in by the template
222     plugin, to allow use of the template preprocessor directive in
223     whitespace-sensative situations. Closes: #387073
224   * Patch from James Westby to make the location of the estseek.cgi script
225     configurable.
226   * Add typography (SmartyPants) plugin by Recai.
227   * Add --render mode, which can be used to preview an edit at the command
228     line by test rendering a single page.
229   * Add a googlecalendar plugin. A bit special-purpose, but it shows
230     one way to to deal with user-supplied content that could cause XSS
231     issues w/o the htmlscrubber, and won't survive the scrubber.
232
233  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
234
235 ikiwiki (1.26) unstable; urgency=low
236
237   * Add a missing -n to tla undo call.
238   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
239     writes before consuming its whole stdin. Avoid this deadlock.
240   * Fix alt tags for outline checkboxes.
241
242  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
243
244 ikiwiki (1.25) unstable; urgency=low
245
246   * Add proper waitpid calls for open2ed processes throughout to avoid
247     zombies; this hit htmltidy especially badly.
248   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
249     subversion repos and fixing some other issues.
250   * Add support for tla, contributed by Clint Adams. Closes: #385936
251   * Add support for mercurial, contributed by Emanuele Aina.
252   * Include <link rel> tag for RSS feeds, used by some aggregators and
253     firefox to find the feed.
254   * Add a linkmap plugin (requires graphviz).
255
256  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
257
258 ikiwiki (1.24) unstable; urgency=low
259
260   * Simplify the data structure returned by rcs_recentchanges to avoid
261     each rcs plugin needing to form complex strings on its own.
262   * Fix another destpage issue in the inline directive. Closes: #385512
263     again.
264
265  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
266
267 ikiwiki (1.23) unstable; urgency=low
268
269   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
270
271  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
272
273 ikiwiki (1.22) unstable; urgency=low
274
275   * Change how the stylesheet url is determined in the templates: Remove
276     STYLEURL and add BASEURL to all templates (some already had it). This
277     new more general variable can be used to link to other things (eg, images)
278     from the template, as well as stylesheets.
279   * Fix a bug introduced last version to do with nested inlines.
280   * Allow preprocessor directives to span multiple lines, both to make
281     long ones with lots of values easier to write, and to allow for ones with
282     multi-line quoted values.
283   * Allow preprocessor directives to contain python-like triple-quoted
284     text blocks, for easy nesting of quotes inside.
285   * Add a template plugin.
286   * Make pagespec merge code smarter about merging duplicate pagespecs.
287   * Patch from Jordà Polo to make Setup::Standard support hashes in config
288     files.
289   * Change order of linkify and preprocess; first preprocess and then linkify.
290     This allows passing a wikilink inside a parameter to a preprocessor
291     directive without it being expanded to html, and leaking out of the
292     parameter, which had required some non-obvious use of triple-quoting
293     to avoid. Note that any preprocessor plugins that output something
294     that looks like a wikilink will now have it treated as such; AFAIK
295     this doesn't change any behavior though except for the template plugin.
296   * Enable preprocessor directives when previewing an edit.
297   * Make all pages pull in a local.css style sheet, if present. This won't
298     be included in ikiwiki, but can be created to make local styling changes
299     w/o needing to merge in every new change to the distributed style.css.
300   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
301   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
302     from a different directory.
303   * Generalised preprocesser loop protection code.
304   * Patch from James Westby to allow a description to be set for rss feeds.
305   * Patch from James Westby to add a template for the search form.
306   * Added a ddate plugin.
307   * Patch from James Westby to add a --sslcookie switch, which forces
308     cookies to only be sent over ssl connections to avoid interception.
309   * Fix preferences page on anonok wikis; still need to sign in to get
310     to the preferences page.
311   * Add toc (table of contents) plugin.
312   * Change htmlize, format, and sanitize hooks to use named parameters.
313   * Patch from James Westby to add an actions option to inline; this
314     adds Edit and Discussion links at the end of blog entries.
315   * Due to some css changes, you'll want to rebuild your wiki on upgrade
316     to this version. Will be handled automatically by the deb.
317   * Add processed date to aggregate preprocessor directive status output.
318
319  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
320
321 ikiwiki (1.21) unstable; urgency=low
322
323   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
324   * If a page links to itself, mark up the link text in a span with
325     class="selflink" so that it can be styled. I don't have a useful style
326     defined for that though.
327   * Call filter hooks on inlined page content.
328   * Support inlining pages raw, rather than creating a blog.
329   * Clean up yes/no parameter parsing in inline plugin.
330   * Implemented better cycle detection in the inline plugin; nested inlines
331     will now work.
332   * Add a map plugin contributed by Alessandro Dotti Contra.
333   * Add otl format plugin, which handles files as created by vimoutliner.
334   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
335   * Add first draft at a Restructured Text (rst) plugin, by Sergio
336     Talens-Oliag. Note that this has many known issues -- see the caveats on
337     the plugin's page.
338   * Credit everyone who wrote a plugin on the plugins' wiki pages.
339   * Fix utf-8 in blog post form.
340
341  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
342
343 ikiwiki (1.20) unstable; urgency=low
344
345   * Relicense the templates and basewiki under the 2-clause BSD license.
346     Since these can easily become part of other people's websites, they
347     should be under as permissive a license as possible.
348   * Add --syslog config option, to log to the syslog.
349   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
350     transient failure to fork (which I've seen happen in the wild).
351   * Fix a bug in the aggregator introduced last version that caused all
352     aggregator state to be lost during a non-aggregating build.
353
354  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
355
356 ikiwiki (1.19) unstable; urgency=low
357
358   * Fix several related bugs in page type determination during online editing.
359   * Add some locking to prevent 2 aggregators from running at once.
360   * Fix an infinite loop in the aggregator when finding a unique filename.
361
362  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
363
364 ikiwiki (1.18) unstable; urgency=low
365
366   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
367   * Add --version.
368   * Man page format fixups.
369   * If the meta plugin overides the page title, set a title_overridden
370     variable in the template to true. This allows doing things with the
371     templates conditional on the title being overriden.
372   * Add a %pagecase which maps lower-case page names to the actual case
373     used in the filename. Use this in bestlinks calculation instead of
374     forcing the link to lowercase.
375   * Also use %pagecase in various other places that want to check if a page
376     with a given name exists.
377   * This means that links to pages with mixed case names will now work,
378     even if the link is in some other case mixture, and mixed case pages
379     should be fully supported throughout ikiwiki.
380   * Recommend rebuilding wikis on upgrade to this version.
381
382  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
383
384 ikiwiki (1.17) unstable; urgency=low
385
386   * Disable tidy generator tag.
387   * Move tidy back to sanitize hook, found out how to only show body.
388   * Turn off tidy indentation too.
389   * Turn on HTML::Template loop_context_vars; not actually used in stock
390     templates but can be useful for things like making comma-delimited lists
391     of tags or what have you.
392   * Remove <br> from end of aggregate preprocessor directive output.
393   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
394     case-sensative filesystems like OSX.
395   * Improve markdown loading. First, try to load it as a proper perl module,
396     in case it was installed as one. Then fall back to trying
397     /usr/bin/markdown.
398   * Document in install page how to install markdown, since it has no
399     installation procedure in the upstream tarball.
400   * Set die_on_bad_params => 0 for all templates, to allow users to modify
401     them without annoyances.
402   * Suck in the page content when generating an inline archive page, to work
403     around the meta plugin's lack of caching of title metadata across runs.
404
405  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
406
407 ikiwiki (1.16) unstable; urgency=low
408
409   * Try to handle relative links in aggregated feeds. However,
410     the current support is a crude hack due to limitations of XML::Feed:
411     xml:base is not supported, neither is Content-Location. And of course,
412     relative links in RSS feeds are ill-undefined..
413   * Make aggregator save permalinks and author name to pages as metadata.
414   * Add permalink and author support to meta plugin, affecting RSS feeds
415     and blog pages.
416   * Various CSS and formatting changes.
417   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
418   * Add xhtml files to the default prune regexp.
419   * Also generate rel=bookmark links for permalinks.
420   * Fix the htmltidy plugin, which wasn't working due my breaking it when
421     I added it..
422   * Don't run tidy with -xml as that fails if the input is not well-formed.
423     Run it with -asxhtml instead, so it will output well-formed xhtml no
424     matter what the input.
425   * Disable tidy warnings too.
426   * Add a new format hook, and make tidy use it, since tidy can really only
427     operate on and output complete html documents, not the body chunks
428     that sanitise gets.
429   * Fix dates in rss feeds if running localised, so they're still rfc 822.
430
431  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
432
433 ikiwiki (1.15) unstable; urgency=low
434
435   * Remove CDPATH and other env vars perl taint checking doesn't like.
436     Closes: #381279
437   * Added created_before and created_after PageSpec limits.
438
439  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
440
441 ikiwiki (1.14) unstable; urgency=low
442
443   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
444     by 10% or so.
445   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
446   * Added many unit tests for pagespec_match.
447
448  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
449
450 ikiwiki (1.13) unstable; urgency=low
451
452   * ikiwiki can now download and aggregate feeds with its new aggregate
453     plugin, so it's possible to implement a Planet using ikiwiki!
454   * Add a run_hooks function for the common task of running all hooks of a
455     given type.
456   * Add a savestate hook.
457   * Don't put blog post forms on pages if there's no cgiurl set.
458   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
459     --wrappers to do that.
460   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
461     to update pages that haven't changed on disk.
462   * Change meta tags to use html entity-escaped text for values, so that
463     quotes and such can be represented in title tags.
464   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
465     for the above.
466   * Make --rebuild also cause --aggregate to re-download and write aggregated
467     pages.
468   * Avoid outputting duplicate meta info.
469   * Include title metadata on aggregated posts for capitalised and un-munged
470     titles.
471   * Title metadata of inlined pages now shows up in blogs and rss feeds.
472   * Fix issue with unicode filenames and updating the hyper estradier search
473     index. (Aka Please Please Please, let that be the last one.)
474   * Patch from Roland Mas to support an rss=no parameter to inline directives.
475     Closes: #380743
476   * Renamed GlobLists to PageSpecs.
477   * PageSpecs can now include nested parens, "and", and "or". This remains
478     backwards compatible to the old GlobList format. It's implemented by
479     treating the GlobList as a very limited microlanguage that is transformed
480     to perl code that does the matching.
481   * The old GlobList format is deprecated, and I encourage users to switch to
482     using the new PageSpec format. Compatability with the old format will be
483     removed at some point, possibly by 2.0.
484   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
485   * Add support for creation_month and creation_year to PageSpec.
486     Closes: #380680
487   * Changes to index file encoding.
488
489  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
490
491 ikiwiki (1.12) unstable; urgency=low
492
493   "Viva l'Italia!"
494   * New pagestats plugin from Enrico, which can generate a table counting
495     the backlinks for each page, or a del.icio.us style cloud.
496   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
497     the wikiformat plugin works. Thanks, Emanuele Aina.
498   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
499     display, running them through pagetitle. This removes ugly underscores and
500     other gunk from the display, much nicer. You may want to rebuild your wiki
501     when upgrading to get the cleanup globally.
502   * Polygen plugin from Enrico.
503   * htmltidy plugin from Faidon.
504   * Locale patch from Faidon:
505     - Adds a locale setting to setup files.
506     - Proper local time, if the locale configuration option is used.
507     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
508       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
509       impossible.
510   * Add getopt hook type, this allows plugins to add new command-line options.
511   * Add --tagbase option to tag plugin.
512   * Add exclude option in setup files, works same as --exclude.
513   * Put categories in rss feeds for tagged items.
514   * Allow preprocessor directives to be expanded in inlined blog pages.
515     However, to avoid inlining loops etc, don't expand inline directives in
516     inlined pages.
517   * fortune plugin (trivial)
518   * Tag plugins according to type.
519
520  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
521
522 ikiwiki (1.11) unstable; urgency=low
523
524   * Patch from Enrico that
525     - Adds a tag plugin that allows more easily tagging pages.
526       The meta plugin can also still be used for that, but the tag plugin
527       also lists a page's tags at the bottom of the page.
528     - Allows preprocessor directives to have parameters with no specified
529       value.
530     - Fixes preprocessor directive parameter parsing so that
531       foo=bar baz now means "foo=bar" and a "baz" with no value.
532   * Run pagetemplate hooks when inlining pages so that inlined pages also
533     list their tags.
534   * Make all plugins with pagetemplate hooks check that variables exist
535     on the template before setting them, for robustness.
536   * Switch pagetemplate hooks to using named parameters.
537   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
538     This will be the page that a source page will be part of, which is
539     different than the source page for inlined pages.
540   * Audited all plugins to endure they pass (page, destpage) to htmllink
541     appropriatly. This means inlining of various plugins will not work
542     properly, with correct links generated.
543
544  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
545
546 ikiwiki (1.10) unstable; urgency=low
547
548   * Run page through any relevant filters when generating a page preview.
549   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
550     default throughout the wiki, not only on wikitext pages. Decided to call
551     this a feature, and split the camelcase support out into a separate plugin
552     that is independant of wikitext.
553   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
554
555  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
556
557 ikiwiki (1.9) unstable; urgency=low
558
559   * Improve display of parentlinks and page title of toplevel index page.
560   * Patch from Faidon to use svn --limit when possible for recentchanges,
561     speeds up recentchanges a lot for wikis with more history.
562   * Patch from Recai to fix utf8 issues in git backend.
563   * Add wikitext markup plugin, which supports ".wiki" pages written in the
564     original wiki syntax, CamelCase links and all.
565   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
566     support, to edit pages etc without a web server.
567   * Display CGI processing errors if present.
568   * Fix from Faidon for a XML parser issue that breaks utf-8 for
569     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
570     area, and also way slow.
571   * Match 'web commit from' in SVN and git, these are web commits too.
572     (Faidon)
573   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
574     readable and avoid future mistakes. The patch seems to work and for the
575     first time I have a UTF-8 username ;-) (Faidon)
576   * Use form->field consistently, not form->param.
577   * Patch from Recai to allow selection of page type when creating a new page.
578     Default page type is inherited from the link clicked on to create the new
579     page.
580
581  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
582
583 ikiwiki (1.8) unstable; urgency=low
584
585   * Fix orphans plugin to not count a link to a nonexistant page as a reason
586     for a page not being an orphan.
587   * Support pinging services such as Technorati using XML-RPC to notify them
588     about changes to rss feeds.
589   * Parse svn log as xml for improved utf8 and security. Note that this makes
590     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
591   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
592     flagged string even if the locale causes it to generate utf8 output,
593     so make sure to let perl know it should be handled as utf8. Also,
594     the optimised version used for standard time formats won't work if the
595     user has changed locale, so drop it. Thanks, Faidon Liambotis.
596   * Fix re-encoding of the comments field to utf8 if a commit fails
597     due to a conflict. Thanks, Faidon Liambotis.
598   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
599     Liambotis.
600   * Add insane double encode/decode to utf8 around call to markdown.
601     This works around a truely strange bug, which is apparently a bug in
602     perl, #376329. Also added a test case for it.
603   * Improve layout of edit page so formatting help link is always visible w/o
604     getting in the way of the preview.
605   * Centralised all calls to HTML::Template and force all the templates
606     to be read as utf8.
607   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
608   * Introduce add_plugins and disable_plugins config options in setup files.
609     This allows adding or removing plugins w/o overriding the whole list of
610     default plugins, which makes it easier to upgrade when new default plugins
611     are added.
612   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
613     default (of course!). Based on a patch by Faidon Liambotis.
614   * Add a html plugin, which can be used to write wikis in raw html,
615     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
616     defaults to not processing .html files, since w/o this plugin they would
617     be copied unsanitised. With this plugin, it will process and html
618     sanitise them, like any other page type.
619   * Rebuilding wrappers is necessary on upgrade to this version.
620   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
621     will be automatically done on all upgrades.
622   * Don't send pings if the wiki is being rebuilt.
623   * Work around very innefficient behavior in File::Spec::abs2rel. Result
624     is a savings of 2 pointless fork/execs per link calculation, which
625     results in ~25% speedup of ikiwiki building its own doc wiki, and
626     about 35% speedup displaying RecentChanges!
627   * Make RecentChanges use a table and some CSS, should be much more readable.
628     No code changes involved.
629   * Encode & in diffurl in examples, to conform to pedantic rules.
630   * Speed up RecentChanges by another 40% or so with some memoization.
631   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
632     in time to build the doc wiki.
633
634  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
635
636 ikiwiki (1.7) unstable; urgency=low
637
638   * Updated logo from Recai with some kerning and alingment tuning.
639   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
640     changed some output.
641   * Copyright update.
642
643  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
644
645 ikiwiki (1.6) unstable; urgency=low
646
647   * YA utf-8 patch from Recai, this time to fix previewing a page so that
648     the text in the input box is re-encoded back to utf-8.
649   * -CSD does not affect modules, so readfile() was not using the utf-8 input
650     layer, which led to lots of problems; make it force read files as utf-8.
651     Closes: #373203
652   * Note that as a consequence, this version of ikiwiki will actually try to
653     parse utf8 in source files for the first time, which may expose broken
654     utf8 in wiki sources that was hidden before. Most common will be
655     perl warnings like "utf8 "\xE9" does not map to Unicode"
656   * writefile() likewise needs to use the utf8 output layer.
657   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
658     there.
659   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
660     given the readfile fix.
661   * Add utf-8 testcases for readfile and htmlize.
662   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
663     safe.
664   * More utf-8 fixes from Recai, partly to things I broke above:
665     - The serious problem is that writefile() saves the content in undecoded
666       format in CGI, hence all (non-ascii) chars are corrupted permanently.
667     - Comment field in edit page is not decoded and all the non-ascii chars in
668       this field are corrupted as the result.  We should decode it as we do it
669       for the content.
670     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
671       character in print.
672   * New SVG logo from Recai.
673
674  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
675
676 ikiwiki (1.5) unstable; urgency=low
677
678   * Add --timeformat config option to allow changing how dates are displayed.
679     Note that as a side effect, dates will now be displayed using the local
680     timezone, not as GMT.
681   * More security review.
682   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
683     for some handy stuff like:
684     - Using links as a kind of tag; creating blog pages that list all pages
685       containing a given tag/link or not containing some other tag.
686     - Subscribing to mail notifications whenever a change is made to a page
687       that is a backlink of page foo. Ie, "Please notify me of changes in all
688       pages that link to my home page in the wiki"
689     - Locking any pages that are linked to from a particular page, so that
690       lists of locks can be exposed in the wiki.
691   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
692     when a todo item is done, instead of the previous moving it to a different
693     subdir.
694   * Allow pagetemplate plugins to override *anything* in the template.
695   * Add a meta plugin, which allows specifying various metadata about pages,
696     like license and author. It also allows for inserting html link and meta
697     tags into html, overriding the title, and adding hidden WikiLinks, which
698     can be useful when using link-based globbing for page categorisation.
699   * Remove preprocessor directives from inlined pages.
700   * Allow simple preprocessor directive values to be specified w/o quotes.
701   * Add support for using git instead of subversion as the RCS backend,
702     tremendous thanks to Recai Oktaş for this.
703   * Doc updates for git.
704   * Fix absolute url munging in rss generation to support https, ftp, etc urls
705     not just http urls.
706   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
707     utf-8 for edit and other fields, and for recentchanges. There may still
708     be utf-8 issues with the preferences page though.
709
710  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
711
712 ikiwiki (1.4) unstable; urgency=low
713
714   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
715     very strange way of enabling proper XHTML <br /> type tags. Output html
716     should be always valid again now.
717   * The page name and parent links has switched from using a <h1> to a styled
718     <span>, so pages can use <h1> internally instead of needing to use <h2>.
719   * Updated all of ikiwiki's own wiki pages for that.
720   * Add pagetemplate hook, which can be used by plugins that want to mess
721     around with adding new stuff to the page template.
722   * Remove headercontent; the search plugin now adds the search box to the
723     header by registering a pagetemplate hook, and other plugins should do
724     similarly.
725   * Rebuilding on upgrade to this version is recommended.
726   * Add a html validity check to the test suite, using the wdg-html-validator,
727     if available.
728   * Make the html valid when there is nothing in the actions list.
729   * Reordered some function call parameters for consistency.
730   * Enable full utf-8 support for page input and output.
731   * Add a workaround for markdown, which does not work well with utf-8
732     strings.
733   * --getctime had bitrotted (well I only ever used it the once so far..),
734     fix and make it a bit more flexible
735   * rcs_getctime is changed, now rather than needing to loop over all pages,
736     it should just use the rcs to get the ctime of the passed file.
737   * When inlining a page in another one, links from the inlined page are now
738     expanded the same as they are when rendering the inlined page as a
739     standalone page. So rather than being expanded from the POV of the
740     inlining page, they are expanded from the POV of the inlined page.
741
742     For example, a link from blog/foo to "bar" will now link to blog/bar
743     if it exists. Previously this needed to be a link explicitly to
744     "blog/bar"; such links will also continue to work.
745
746     (This was slightly complex to do as the link still has to be constructed
747     relative to the inlining page.)
748   * Make page edit textarea resize to fit browser window.
749   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
750     do not need a full rebuild, in order to update any basewiki pages.
751
752  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
753
754 ikiwiki (1.3) unstable; urgency=low
755
756   * Fix the preinst introduced in the last version. Closes: #367458
757
758  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
759
760 ikiwiki (1.2) unstable; urgency=low
761
762   * Remove dups from the brokenlinks list.
763   * Add libc6-dev to dependencies, needed to build wrappers.
764   * Install wikilist in correct location. Closes: #367371
765
766  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
767
768 ikiwiki (1.1) unstable; urgency=low
769
770   * Rename inlinepage to depends, so that it can be used to refer to more
771     dependency relationships than just inlining. This will require a rebuild
772     on upgrade to this version.
773   * Move the rss link, put it in the blogpost form if there is one and at the
774     top if not. This is both nicer because easier to find, and it cleans up
775     the code which had used inlinepage as a flag for adding the link later.
776   * Allow the depends GlobList to be built up from multiple sources (such as
777     plugins) during a page render.
778   * Which means that more than one blog is now supported to appear on a
779     single page. (With some limitations, like only the last one getting an
780     rss file.)
781   * Added a plugin system.
782   * Added a pagecount plugin, enabled by default.
783   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
784   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
785     backlinks when the backlinks hadn't really changed.
786   * Moved inline page support, rss generation etc into the inline plugin,
787     enabled by default.
788   * Added brokenlinks plugin, not enabled by default, but rather handy.
789   * Fix several broken links in the doc wiki.
790   * Smarter behavior when creating a page and a page of the same name (but
791     different location) already exists.
792   * Add an orphans plugin for finding pages that nothing links to.
793   * Removed backlinks page, which it turns out nothing used.
794   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
795     it, this will allow for adding a unit test suite.
796   * Add unit tests for several core functions, including globlist_match,
797     dirname, basename, bestlink, linkify, pagetitle, titlepage.
798   * Smart globlist merging.
799   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
800     to pave the way for adding other RCS support. This also changes the
801     setup files, where before they had svn => 1 or svn => 0, now they have
802     rcs => "svn" or rcs => "".
803   * Add a debian/NEWS file with upgrade notes.
804   * Load whatever rcs module is specified, so new ones can be just dropped in
805     as plugins and work. (Well, in theory.)
806   * Add some basic docs about writing RCS modules.
807   * Broke search capability out into a plugin, removed the --hyperestraier
808     switch.
809   * Added smiley plugin, nicely controlled and documented by the smileys page.
810   * Copied in some smileys from Moin Moin.
811   * Allow links of the form [[some page|page]], with whitespace in the link
812     text.
813   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
814     and --disable-plugin htmlscrubber.
815   * Allow discussion links on pages to be turned off with --no-discussion.
816   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
817   * Add some new config items to the estseek.conf template, which are needed
818     by hyperestraier 1.2.3.
819
820  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
821
822 ikiwiki (1.0) unstable; urgency=low
823
824   * First official release.
825
826  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400