]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
web commit by RecaiOktas: [Git] Document some design issues.
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.27) UNRELEASED; urgency=low
2
3   * Add a googlecalendar plugin. A bit special-purpose, but it shows
4     one way to to deal with user-supplied content that could cause XSS
5     issues w/o the htmlscrubber, and won't survive the scrubber.
6   * Work on firming up the plugin interface:
7     - Plugins should not need to load IkiWiki::Render to get commonly
8       used functions, so moved some functions from there to IkiWiki.
9     - Picked out the set of functions and variables that most plugins
10       use, documented them, and made IkiWiki export them by default,
11       like a proper perl module should.
12     - Use the other functions at your own risk.
13     - This is not quite complete, I still have to decide whether to
14       export some other things.
15   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16     referring to stuff now exported by the IkiWiki module.
17   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18     to declare which version of the interface your plugin needs.
19   * Anyone with a third-party ikiwiki plugin is strongly encouraged
20     to make like changes to it and avoid use of non-exported symboles from
21     "IkiWiki::".
22   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23   * Support hyperestradier version 1.4.2, which adds a new required phraseform
24     setting.
25   * If an inlined page has a permalink, link the page title to that.
26
27  -- Joey Hess <joeyh@debian.org>  Sat,  9 Sep 2006 23:56:48 -0400
28
29 ikiwiki (1.26) unstable; urgency=low
30
31   * Add a missing -n to tla undo call.
32   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
33     writes before consuming its whole stdin. Avoid this deadlock.
34   * Fix alt tags for outline checkboxes.
35
36  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
37
38 ikiwiki (1.25) unstable; urgency=low
39
40   * Add proper waitpid calls for open2ed processes throughout to avoid
41     zombies; this hit htmltidy especially badly.
42   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
43     subversion repos and fixing some other issues.
44   * Add support for tla, contributed by Clint Adams. Closes: #385936
45   * Add support for mercurial, contributed by Emanuele Aina.
46   * Include <link rel> tag for RSS feeds, used by some aggregators and
47     firefox to find the feed.
48   * Add a linkmap plugin (requires graphviz).
49
50  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
51
52 ikiwiki (1.24) unstable; urgency=low
53
54   * Simplify the data structure returned by rcs_recentchanges to avoid
55     each rcs plugin needing to form complex strings on its own.
56   * Fix another destpage issue in the inline directive. Closes: #385512
57     again.
58
59  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
60
61 ikiwiki (1.23) unstable; urgency=low
62
63   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
64
65  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
66
67 ikiwiki (1.22) unstable; urgency=low
68
69   * Change how the stylesheet url is determined in the templates: Remove
70     STYLEURL and add BASEURL to all templates (some already had it). This
71     new more general variable can be used to link to other things (eg, images)
72     from the template, as well as stylesheets.
73   * Fix a bug introduced last version to do with nested inlines.
74   * Allow preprocessor directives to span multiple lines, both to make
75     long ones with lots of values easier to write, and to allow for ones with
76     multi-line quoted values.
77   * Allow preprocessor directives to contain python-like triple-quoted
78     text blocks, for easy nesting of quotes inside.
79   * Add a template plugin.
80   * Make pagespec merge code smarter about merging duplicate pagespecs.
81   * Patch from Jordà Polo to make Setup::Standard support hashes in config
82     files.
83   * Change order of linkify and preprocess; first preprocess and then linkify.
84     This allows passing a wikilink inside a parameter to a preprocessor
85     directive without it being expanded to html, and leaking out of the
86     parameter, which had required some non-obvious use of triple-quoting
87     to avoid. Note that any preprocessor plugins that output something
88     that looks like a wikilink will now have it treated as such; AFAIK
89     this doesn't change any behavior though except for the template plugin.
90   * Enable preprocessor directives when previewing an edit.
91   * Make all pages pull in a local.css style sheet, if present. This won't
92     be included in ikiwiki, but can be created to make local styling changes
93     w/o needing to merge in every new change to the distributed style.css.
94   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
95   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
96     from a different directory.
97   * Generalised preprocesser loop protection code.
98   * Patch from James Westby to allow a description to be set for rss feeds.
99   * Patch from James Westby to add a template for the search form.
100   * Added a ddate plugin.
101   * Patch from James Westby to add a --sslcookie switch, which forces
102     cookies to only be sent over ssl connections to avoid interception.
103   * Fix preferences page on anonok wikis; still need to sign in to get
104     to the preferences page.
105   * Add toc (table of contents) plugin.
106   * Change htmlize, format, and sanitize hooks to use named parameters.
107   * Patch from James Westby to add an actions option to inline; this
108     adds Edit and Discussion links at the end of blog entries.
109   * Due to some css changes, you'll want to rebuild your wiki on upgrade
110     to this version. Will be handled automatically by the deb.
111   * Add processed date to aggregate preprocessor directive status output.
112
113  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
114
115 ikiwiki (1.21) unstable; urgency=low
116
117   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
118   * If a page links to itself, mark up the link text in a span with
119     class="selflink" so that it can be styled. I don't have a useful style
120     defined for that though.
121   * Call filter hooks on inlined page content.
122   * Support inlining pages raw, rather than creating a blog.
123   * Clean up yes/no parameter parsing in inline plugin.
124   * Implemented better cycle detection in the inline plugin; nested inlines
125     will now work.
126   * Add a map plugin contributed by Alessandro Dotti Contra.
127   * Add otl format plugin, which handles files as created by vimoutliner.
128   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
129   * Add first draft at a Restructured Text (rst) plugin, by Sergio
130     Talens-Oliag. Note that this has many known issues -- see the caveats on
131     the plugin's page.
132   * Credit everyone who wrote a plugin on the plugins' wiki pages.
133   * Fix utf-8 in blog post form.
134
135  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
136
137 ikiwiki (1.20) unstable; urgency=low
138
139   * Relicense the templates and basewiki under the 2-clause BSD license.
140     Since these can easily become part of other people's websites, they
141     should be under as permissive a license as possible.
142   * Add --syslog config option, to log to the syslog.
143   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
144     transient failure to fork (which I've seen happen in the wild).
145   * Fix a bug in the aggregator introduced last version that caused all
146     aggregator state to be lost during a non-aggregating build.
147
148  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
149
150 ikiwiki (1.19) unstable; urgency=low
151
152   * Fix several related bugs in page type determination during online editing.
153   * Add some locking to prevent 2 aggregators from running at once.
154   * Fix an infinite loop in the aggregator when finding a unique filename.
155
156  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
157
158 ikiwiki (1.18) unstable; urgency=low
159
160   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
161   * Add --version.
162   * Man page format fixups.
163   * If the meta plugin overides the page title, set a title_overridden
164     variable in the template to true. This allows doing things with the
165     templates conditional on the title being overriden.
166   * Add a %pagecase which maps lower-case page names to the actual case
167     used in the filename. Use this in bestlinks calculation instead of
168     forcing the link to lowercase.
169   * Also use %pagecase in various other places that want to check if a page
170     with a given name exists.
171   * This means that links to pages with mixed case names will now work,
172     even if the link is in some other case mixture, and mixed case pages
173     should be fully supported throughout ikiwiki.
174   * Recommend rebuilding wikis on upgrade to this version.
175
176  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
177
178 ikiwiki (1.17) unstable; urgency=low
179
180   * Disable tidy generator tag.
181   * Move tidy back to sanitize hook, found out how to only show body.
182   * Turn off tidy indentation too.
183   * Turn on HTML::Template loop_context_vars; not actually used in stock
184     templates but can be useful for things like making comma-delimited lists
185     of tags or what have you.
186   * Remove <br> from end of aggregate preprocessor directive output.
187   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
188     case-sensative filesystems like OSX.
189   * Improve markdown loading. First, try to load it as a proper perl module,
190     in case it was installed as one. Then fall back to trying
191     /usr/bin/markdown.
192   * Document in install page how to install markdown, since it has no
193     installation procedure in the upstream tarball.
194   * Set die_on_bad_params => 0 for all templates, to allow users to modify
195     them without annoyances.
196   * Suck in the page content when generating an inline archive page, to work
197     around the meta plugin's lack of caching of title metadata across runs.
198
199  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
200
201 ikiwiki (1.16) unstable; urgency=low
202
203   * Try to handle relative links in aggregated feeds. However,
204     the current support is a crude hack due to limitations of XML::Feed:
205     xml:base is not supported, neither is Content-Location. And of course,
206     relative links in RSS feeds are ill-undefined..
207   * Make aggregator save permalinks and author name to pages as metadata.
208   * Add permalink and author support to meta plugin, affecting RSS feeds
209     and blog pages.
210   * Various CSS and formatting changes.
211   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
212   * Add xhtml files to the default prune regexp.
213   * Also generate rel=bookmark links for permalinks.
214   * Fix the htmltidy plugin, which wasn't working due my breaking it when
215     I added it..
216   * Don't run tidy with -xml as that fails if the input is not well-formed.
217     Run it with -asxhtml instead, so it will output well-formed xhtml no
218     matter what the input.
219   * Disable tidy warnings too.
220   * Add a new format hook, and make tidy use it, since tidy can really only
221     operate on and output complete html documents, not the body chunks
222     that sanitise gets.
223   * Fix dates in rss feeds if running localised, so they're still rfc 822.
224
225  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
226
227 ikiwiki (1.15) unstable; urgency=low
228
229   * Remove CDPATH and other env vars perl taint checking doesn't like.
230     Closes: #381279
231   * Added created_before and created_after PageSpec limits.
232
233  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
234
235 ikiwiki (1.14) unstable; urgency=low
236
237   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
238     by 10% or so.
239   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
240   * Added many unit tests for pagespec_match.
241
242  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
243
244 ikiwiki (1.13) unstable; urgency=low
245
246   * ikiwiki can now download and aggregate feeds with its new aggregate
247     plugin, so it's possible to implement a Planet using ikiwiki!
248   * Add a run_hooks function for the common task of running all hooks of a
249     given type.
250   * Add a savestate hook.
251   * Don't put blog post forms on pages if there's no cgiurl set.
252   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
253     --wrappers to do that.
254   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
255     to update pages that haven't changed on disk.
256   * Change meta tags to use html entity-escaped text for values, so that
257     quotes and such can be represented in title tags.
258   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
259     for the above.
260   * Make --rebuild also cause --aggregate to re-download and write aggregated
261     pages.
262   * Avoid outputting duplicate meta info.
263   * Include title metadata on aggregated posts for capitalised and un-munged
264     titles.
265   * Title metadata of inlined pages now shows up in blogs and rss feeds.
266   * Fix issue with unicode filenames and updating the hyper estradier search
267     index. (Aka Please Please Please, let that be the last one.)
268   * Patch from Roland Mas to support an rss=no parameter to inline directives.
269     Closes: #380743
270   * Renamed GlobLists to PageSpecs.
271   * PageSpecs can now include nested parens, "and", and "or". This remains
272     backwards compatible to the old GlobList format. It's implemented by
273     treating the GlobList as a very limited microlanguage that is transformed
274     to perl code that does the matching.
275   * The old GlobList format is deprecated, and I encourage users to switch to
276     using the new PageSpec format. Compatability with the old format will be
277     removed at some point, possibly by 2.0.
278   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
279   * Add support for creation_month and creation_year to PageSpec.
280     Closes: #380680
281   * Changes to index file encoding.
282
283  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
284
285 ikiwiki (1.12) unstable; urgency=low
286
287   "Viva l'Italia!"
288   * New pagestats plugin from Enrico, which can generate a table counting
289     the backlinks for each page, or a del.icio.us style cloud.
290   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
291     the wikiformat plugin works. Thanks, Emanuele Aina.
292   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
293     display, running them through pagetitle. This removes ugly underscores and
294     other gunk from the display, much nicer. You may want to rebuild your wiki
295     when upgrading to get the cleanup globally.
296   * Polygen plugin from Enrico.
297   * htmltidy plugin from Faidon.
298   * Locale patch from Faidon:
299     - Adds a locale setting to setup files.
300     - Proper local time, if the locale configuration option is used.
301     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
302       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
303       impossible.
304   * Add getopt hook type, this allows plugins to add new command-line options.
305   * Add --tagbase option to tag plugin.
306   * Add exclude option in setup files, works same as --exclude.
307   * Put categories in rss feeds for tagged items.
308   * Allow preprocessor directives to be expanded in inlined blog pages.
309     However, to avoid inlining loops etc, don't expand inline directives in
310     inlined pages.
311   * fortune plugin (trivial)
312   * Tag plugins according to type.
313
314  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
315
316 ikiwiki (1.11) unstable; urgency=low
317
318   * Patch from Enrico that
319     - Adds a tag plugin that allows more easily tagging pages.
320       The meta plugin can also still be used for that, but the tag plugin
321       also lists a page's tags at the bottom of the page.
322     - Allows preprocessor directives to have parameters with no specified
323       value.
324     - Fixes preprocessor directive parameter parsing so that
325       foo=bar baz now means "foo=bar" and a "baz" with no value.
326   * Run pagetemplate hooks when inlining pages so that inlined pages also
327     list their tags.
328   * Make all plugins with pagetemplate hooks check that variables exist
329     on the template before setting them, for robustness.
330   * Switch pagetemplate hooks to using named parameters.
331   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
332     This will be the page that a source page will be part of, which is
333     different than the source page for inlined pages.
334   * Audited all plugins to endure they pass (page, destpage) to htmllink
335     appropriatly. This means inlining of various plugins will not work
336     properly, with correct links generated.
337
338  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
339
340 ikiwiki (1.10) unstable; urgency=low
341
342   * Run page through any relevant filters when generating a page preview.
343   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
344     default throughout the wiki, not only on wikitext pages. Decided to call
345     this a feature, and split the camelcase support out into a separate plugin
346     that is independant of wikitext.
347   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
348
349  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
350
351 ikiwiki (1.9) unstable; urgency=low
352
353   * Improve display of parentlinks and page title of toplevel index page.
354   * Patch from Faidon to use svn --limit when possible for recentchanges,
355     speeds up recentchanges a lot for wikis with more history.
356   * Patch from Recai to fix utf8 issues in git backend.
357   * Add wikitext markup plugin, which supports ".wiki" pages written in the
358     original wiki syntax, CamelCase links and all.
359   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
360     support, to edit pages etc without a web server.
361   * Display CGI processing errors if present.
362   * Fix from Faidon for a XML parser issue that breaks utf-8 for
363     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
364     area, and also way slow.
365   * Match 'web commit from' in SVN and git, these are web commits too.
366     (Faidon)
367   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
368     readable and avoid future mistakes. The patch seems to work and for the
369     first time I have a UTF-8 username ;-) (Faidon)
370   * Use form->field consistently, not form->param.
371   * Patch from Recai to allow selection of page type when creating a new page.
372     Default page type is inherited from the link clicked on to create the new
373     page.
374
375  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
376
377 ikiwiki (1.8) unstable; urgency=low
378
379   * Fix orphans plugin to not count a link to a nonexistant page as a reason
380     for a page not being an orphan.
381   * Support pinging services such as Technorati using XML-RPC to notify them
382     about changes to rss feeds.
383   * Parse svn log as xml for improved utf8 and security. Note that this makes
384     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
385   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
386     flagged string even if the locale causes it to generate utf8 output,
387     so make sure to let perl know it should be handled as utf8. Also,
388     the optimised version used for standard time formats won't work if the
389     user has changed locale, so drop it. Thanks, Faidon Liambotis.
390   * Fix re-encoding of the comments field to utf8 if a commit fails
391     due to a conflict. Thanks, Faidon Liambotis.
392   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
393     Liambotis.
394   * Add insane double encode/decode to utf8 around call to markdown.
395     This works around a truely strange bug, which is apparently a bug in
396     perl, #376329. Also added a test case for it.
397   * Improve layout of edit page so formatting help link is always visible w/o
398     getting in the way of the preview.
399   * Centralised all calls to HTML::Template and force all the templates
400     to be read as utf8.
401   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
402   * Introduce add_plugins and disable_plugins config options in setup files.
403     This allows adding or removing plugins w/o overriding the whole list of
404     default plugins, which makes it easier to upgrade when new default plugins
405     are added.
406   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
407     default (of course!). Based on a patch by Faidon Liambotis.
408   * Add a html plugin, which can be used to write wikis in raw html,
409     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
410     defaults to not processing .html files, since w/o this plugin they would
411     be copied unsanitised. With this plugin, it will process and html
412     sanitise them, like any other page type.
413   * Rebuilding wrappers is necessary on upgrade to this version.
414   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
415     will be automatically done on all upgrades.
416   * Don't send pings if the wiki is being rebuilt.
417   * Work around very innefficient behavior in File::Spec::abs2rel. Result
418     is a savings of 2 pointless fork/execs per link calculation, which
419     results in ~25% speedup of ikiwiki building its own doc wiki, and
420     about 35% speedup displaying RecentChanges!
421   * Make RecentChanges use a table and some CSS, should be much more readable.
422     No code changes involved.
423   * Encode & in diffurl in examples, to conform to pedantic rules.
424   * Speed up RecentChanges by another 40% or so with some memoization.
425   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
426     in time to build the doc wiki.
427
428  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
429
430 ikiwiki (1.7) unstable; urgency=low
431
432   * Updated logo from Recai with some kerning and alingment tuning.
433   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
434     changed some output.
435   * Copyright update.
436
437  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
438
439 ikiwiki (1.6) unstable; urgency=low
440
441   * YA utf-8 patch from Recai, this time to fix previewing a page so that
442     the text in the input box is re-encoded back to utf-8.
443   * -CSD does not affect modules, so readfile() was not using the utf-8 input
444     layer, which led to lots of problems; make it force read files as utf-8.
445     Closes: #373203
446   * Note that as a consequence, this version of ikiwiki will actually try to
447     parse utf8 in source files for the first time, which may expose broken
448     utf8 in wiki sources that was hidden before. Most common will be
449     perl warnings like "utf8 "\xE9" does not map to Unicode"
450   * writefile() likewise needs to use the utf8 output layer.
451   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
452     there.
453   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
454     given the readfile fix.
455   * Add utf-8 testcases for readfile and htmlize.
456   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
457     safe.
458   * More utf-8 fixes from Recai, partly to things I broke above:
459     - The serious problem is that writefile() saves the content in undecoded
460       format in CGI, hence all (non-ascii) chars are corrupted permanently.
461     - Comment field in edit page is not decoded and all the non-ascii chars in
462       this field are corrupted as the result.  We should decode it as we do it
463       for the content.
464     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
465       character in print.
466   * New SVG logo from Recai.
467
468  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
469
470 ikiwiki (1.5) unstable; urgency=low
471
472   * Add --timeformat config option to allow changing how dates are displayed.
473     Note that as a side effect, dates will now be displayed using the local
474     timezone, not as GMT.
475   * More security review.
476   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
477     for some handy stuff like:
478     - Using links as a kind of tag; creating blog pages that list all pages
479       containing a given tag/link or not containing some other tag.
480     - Subscribing to mail notifications whenever a change is made to a page
481       that is a backlink of page foo. Ie, "Please notify me of changes in all
482       pages that link to my home page in the wiki"
483     - Locking any pages that are linked to from a particular page, so that
484       lists of locks can be exposed in the wiki.
485   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
486     when a todo item is done, instead of the previous moving it to a different
487     subdir.
488   * Allow pagetemplate plugins to override *anything* in the template.
489   * Add a meta plugin, which allows specifying various metadata about pages,
490     like license and author. It also allows for inserting html link and meta
491     tags into html, overriding the title, and adding hidden WikiLinks, which
492     can be useful when using link-based globbing for page categorisation.
493   * Remove preprocessor directives from inlined pages.
494   * Allow simple preprocessor directive values to be specified w/o quotes.
495   * Add support for using git instead of subversion as the RCS backend,
496     tremendous thanks to Recai Oktaş for this.
497   * Doc updates for git.
498   * Fix absolute url munging in rss generation to support https, ftp, etc urls
499     not just http urls.
500   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
501     utf-8 for edit and other fields, and for recentchanges. There may still
502     be utf-8 issues with the preferences page though.
503
504  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
505
506 ikiwiki (1.4) unstable; urgency=low
507
508   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
509     very strange way of enabling proper XHTML <br /> type tags. Output html
510     should be always valid again now.
511   * The page name and parent links has switched from using a <h1> to a styled
512     <span>, so pages can use <h1> internally instead of needing to use <h2>.
513   * Updated all of ikiwiki's own wiki pages for that.
514   * Add pagetemplate hook, which can be used by plugins that want to mess
515     around with adding new stuff to the page template.
516   * Remove headercontent; the search plugin now adds the search box to the
517     header by registering a pagetemplate hook, and other plugins should do
518     similarly.
519   * Rebuilding on upgrade to this version is recommended.
520   * Add a html validity check to the test suite, using the wdg-html-validator,
521     if available.
522   * Make the html valid when there is nothing in the actions list.
523   * Reordered some function call parameters for consistency.
524   * Enable full utf-8 support for page input and output.
525   * Add a workaround for markdown, which does not work well with utf-8
526     strings.
527   * --getctime had bitrotted (well I only ever used it the once so far..),
528     fix and make it a bit more flexible
529   * rcs_getctime is changed, now rather than needing to loop over all pages,
530     it should just use the rcs to get the ctime of the passed file.
531   * When inlining a page in another one, links from the inlined page are now
532     expanded the same as they are when rendering the inlined page as a
533     standalone page. So rather than being expanded from the POV of the
534     inlining page, they are expanded from the POV of the inlined page.
535
536     For example, a link from blog/foo to "bar" will now link to blog/bar
537     if it exists. Previously this needed to be a link explicitly to
538     "blog/bar"; such links will also continue to work.
539
540     (This was slightly complex to do as the link still has to be constructed
541     relative to the inlining page.)
542   * Make page edit textarea resize to fit browser window.
543   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
544     do not need a full rebuild, in order to update any basewiki pages.
545
546  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
547
548 ikiwiki (1.3) unstable; urgency=low
549
550   * Fix the preinst introduced in the last version. Closes: #367458
551
552  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
553
554 ikiwiki (1.2) unstable; urgency=low
555
556   * Remove dups from the brokenlinks list.
557   * Add libc6-dev to dependencies, needed to build wrappers.
558   * Install wikilist in correct location. Closes: #367371
559
560  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
561
562 ikiwiki (1.1) unstable; urgency=low
563
564   * Rename inlinepage to depends, so that it can be used to refer to more
565     dependency relationships than just inlining. This will require a rebuild
566     on upgrade to this version.
567   * Move the rss link, put it in the blogpost form if there is one and at the
568     top if not. This is both nicer because easier to find, and it cleans up
569     the code which had used inlinepage as a flag for adding the link later.
570   * Allow the depends GlobList to be built up from multiple sources (such as
571     plugins) during a page render.
572   * Which means that more than one blog is now supported to appear on a
573     single page. (With some limitations, like only the last one getting an
574     rss file.)
575   * Added a plugin system.
576   * Added a pagecount plugin, enabled by default.
577   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
578   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
579     backlinks when the backlinks hadn't really changed.
580   * Moved inline page support, rss generation etc into the inline plugin,
581     enabled by default.
582   * Added brokenlinks plugin, not enabled by default, but rather handy.
583   * Fix several broken links in the doc wiki.
584   * Smarter behavior when creating a page and a page of the same name (but
585     different location) already exists.
586   * Add an orphans plugin for finding pages that nothing links to.
587   * Removed backlinks page, which it turns out nothing used.
588   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
589     it, this will allow for adding a unit test suite.
590   * Add unit tests for several core functions, including globlist_match,
591     dirname, basename, bestlink, linkify, pagetitle, titlepage.
592   * Smart globlist merging.
593   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
594     to pave the way for adding other RCS support. This also changes the
595     setup files, where before they had svn => 1 or svn => 0, now they have
596     rcs => "svn" or rcs => "".
597   * Add a debian/NEWS file with upgrade notes.
598   * Load whatever rcs module is specified, so new ones can be just dropped in
599     as plugins and work. (Well, in theory.)
600   * Add some basic docs about writing RCS modules.
601   * Broke search capability out into a plugin, removed the --hyperestraier
602     switch.
603   * Added smiley plugin, nicely controlled and documented by the smileys page.
604   * Copied in some smileys from Moin Moin.
605   * Allow links of the form [[some page|page]], with whitespace in the link
606     text.
607   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
608     and --disable-plugin htmlscrubber.
609   * Allow discussion links on pages to be turned off with --no-discussion.
610   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
611   * Add some new config items to the estseek.conf template, which are needed
612     by hyperestraier 1.2.3.
613
614  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
615
616 ikiwiki (1.0) unstable; urgency=low
617
618   * First official release.
619
620  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400