]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
* Yet another fix for those poor case-sensative OSX users.
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.27) UNRELEASED; urgency=low
2
3   * Add a googlecalendar plugin. A bit special-purpose, but it shows
4     one way to to deal with user-supplied content that could cause XSS
5     issues w/o the htmlscrubber, and won't survive the scrubber.
6   * Work on firming up the plugin interface:
7     - Plugins should not need to load IkiWiki::Render to get commonly
8       used functions, so moved some functions from there to IkiWiki.
9     - Picked out the set of functions and variables that most plugins
10       use, documented them, and made IkiWiki export them by default,
11       like a proper perl module should.
12     - Use the other functions at your own risk.
13     - This is not quite complete, I still have to decide whether to
14       export some other things.
15   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16     referring to stuff now exported by the IkiWiki module.
17   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18     to declare which version of the interface your plugin needs.
19   * Anyone with a third-party ikiwiki plugin is strongly encouraged
20     to make like changes to it and avoid use of non-exported symboles from
21     "IkiWiki::".
22   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23   * Support hyperestradier version 1.4.2, which adds a new required phraseform
24     setting.
25   * If an inlined page has a permalink, link the page title to that.
26   * Patch from Recai to use utf8 when reading the setup file, so that
27     utf8 wikinames from there will be used properly.
28   * Patch from Recai to kill utf-8 on the wiki name when generating the
29     session cookie.
30   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31   * Fix a baseurl problem in hyperestradier search results.
32   * Add a stub local.css to avoid problems with 404's.
33   * Patch from Recai to fix a wide character warning from the search plugin
34     during setup if the wikiname contains utf8.
35   * Yet another fix for those poor case-sensative OSX users.
36
37  -- Joey Hess <joeyh@debian.org>  Fri, 15 Sep 2006 13:19:54 -0400
38
39 ikiwiki (1.26) unstable; urgency=low
40
41   * Add a missing -n to tla undo call.
42   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
43     writes before consuming its whole stdin. Avoid this deadlock.
44   * Fix alt tags for outline checkboxes.
45
46  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
47
48 ikiwiki (1.25) unstable; urgency=low
49
50   * Add proper waitpid calls for open2ed processes throughout to avoid
51     zombies; this hit htmltidy especially badly.
52   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
53     subversion repos and fixing some other issues.
54   * Add support for tla, contributed by Clint Adams. Closes: #385936
55   * Add support for mercurial, contributed by Emanuele Aina.
56   * Include <link rel> tag for RSS feeds, used by some aggregators and
57     firefox to find the feed.
58   * Add a linkmap plugin (requires graphviz).
59
60  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
61
62 ikiwiki (1.24) unstable; urgency=low
63
64   * Simplify the data structure returned by rcs_recentchanges to avoid
65     each rcs plugin needing to form complex strings on its own.
66   * Fix another destpage issue in the inline directive. Closes: #385512
67     again.
68
69  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
70
71 ikiwiki (1.23) unstable; urgency=low
72
73   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
74
75  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
76
77 ikiwiki (1.22) unstable; urgency=low
78
79   * Change how the stylesheet url is determined in the templates: Remove
80     STYLEURL and add BASEURL to all templates (some already had it). This
81     new more general variable can be used to link to other things (eg, images)
82     from the template, as well as stylesheets.
83   * Fix a bug introduced last version to do with nested inlines.
84   * Allow preprocessor directives to span multiple lines, both to make
85     long ones with lots of values easier to write, and to allow for ones with
86     multi-line quoted values.
87   * Allow preprocessor directives to contain python-like triple-quoted
88     text blocks, for easy nesting of quotes inside.
89   * Add a template plugin.
90   * Make pagespec merge code smarter about merging duplicate pagespecs.
91   * Patch from Jordà Polo to make Setup::Standard support hashes in config
92     files.
93   * Change order of linkify and preprocess; first preprocess and then linkify.
94     This allows passing a wikilink inside a parameter to a preprocessor
95     directive without it being expanded to html, and leaking out of the
96     parameter, which had required some non-obvious use of triple-quoting
97     to avoid. Note that any preprocessor plugins that output something
98     that looks like a wikilink will now have it treated as such; AFAIK
99     this doesn't change any behavior though except for the template plugin.
100   * Enable preprocessor directives when previewing an edit.
101   * Make all pages pull in a local.css style sheet, if present. This won't
102     be included in ikiwiki, but can be created to make local styling changes
103     w/o needing to merge in every new change to the distributed style.css.
104   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
105   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
106     from a different directory.
107   * Generalised preprocesser loop protection code.
108   * Patch from James Westby to allow a description to be set for rss feeds.
109   * Patch from James Westby to add a template for the search form.
110   * Added a ddate plugin.
111   * Patch from James Westby to add a --sslcookie switch, which forces
112     cookies to only be sent over ssl connections to avoid interception.
113   * Fix preferences page on anonok wikis; still need to sign in to get
114     to the preferences page.
115   * Add toc (table of contents) plugin.
116   * Change htmlize, format, and sanitize hooks to use named parameters.
117   * Patch from James Westby to add an actions option to inline; this
118     adds Edit and Discussion links at the end of blog entries.
119   * Due to some css changes, you'll want to rebuild your wiki on upgrade
120     to this version. Will be handled automatically by the deb.
121   * Add processed date to aggregate preprocessor directive status output.
122
123  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
124
125 ikiwiki (1.21) unstable; urgency=low
126
127   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
128   * If a page links to itself, mark up the link text in a span with
129     class="selflink" so that it can be styled. I don't have a useful style
130     defined for that though.
131   * Call filter hooks on inlined page content.
132   * Support inlining pages raw, rather than creating a blog.
133   * Clean up yes/no parameter parsing in inline plugin.
134   * Implemented better cycle detection in the inline plugin; nested inlines
135     will now work.
136   * Add a map plugin contributed by Alessandro Dotti Contra.
137   * Add otl format plugin, which handles files as created by vimoutliner.
138   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
139   * Add first draft at a Restructured Text (rst) plugin, by Sergio
140     Talens-Oliag. Note that this has many known issues -- see the caveats on
141     the plugin's page.
142   * Credit everyone who wrote a plugin on the plugins' wiki pages.
143   * Fix utf-8 in blog post form.
144
145  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
146
147 ikiwiki (1.20) unstable; urgency=low
148
149   * Relicense the templates and basewiki under the 2-clause BSD license.
150     Since these can easily become part of other people's websites, they
151     should be under as permissive a license as possible.
152   * Add --syslog config option, to log to the syslog.
153   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
154     transient failure to fork (which I've seen happen in the wild).
155   * Fix a bug in the aggregator introduced last version that caused all
156     aggregator state to be lost during a non-aggregating build.
157
158  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
159
160 ikiwiki (1.19) unstable; urgency=low
161
162   * Fix several related bugs in page type determination during online editing.
163   * Add some locking to prevent 2 aggregators from running at once.
164   * Fix an infinite loop in the aggregator when finding a unique filename.
165
166  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
167
168 ikiwiki (1.18) unstable; urgency=low
169
170   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
171   * Add --version.
172   * Man page format fixups.
173   * If the meta plugin overides the page title, set a title_overridden
174     variable in the template to true. This allows doing things with the
175     templates conditional on the title being overriden.
176   * Add a %pagecase which maps lower-case page names to the actual case
177     used in the filename. Use this in bestlinks calculation instead of
178     forcing the link to lowercase.
179   * Also use %pagecase in various other places that want to check if a page
180     with a given name exists.
181   * This means that links to pages with mixed case names will now work,
182     even if the link is in some other case mixture, and mixed case pages
183     should be fully supported throughout ikiwiki.
184   * Recommend rebuilding wikis on upgrade to this version.
185
186  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
187
188 ikiwiki (1.17) unstable; urgency=low
189
190   * Disable tidy generator tag.
191   * Move tidy back to sanitize hook, found out how to only show body.
192   * Turn off tidy indentation too.
193   * Turn on HTML::Template loop_context_vars; not actually used in stock
194     templates but can be useful for things like making comma-delimited lists
195     of tags or what have you.
196   * Remove <br> from end of aggregate preprocessor directive output.
197   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
198     case-sensative filesystems like OSX.
199   * Improve markdown loading. First, try to load it as a proper perl module,
200     in case it was installed as one. Then fall back to trying
201     /usr/bin/markdown.
202   * Document in install page how to install markdown, since it has no
203     installation procedure in the upstream tarball.
204   * Set die_on_bad_params => 0 for all templates, to allow users to modify
205     them without annoyances.
206   * Suck in the page content when generating an inline archive page, to work
207     around the meta plugin's lack of caching of title metadata across runs.
208
209  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
210
211 ikiwiki (1.16) unstable; urgency=low
212
213   * Try to handle relative links in aggregated feeds. However,
214     the current support is a crude hack due to limitations of XML::Feed:
215     xml:base is not supported, neither is Content-Location. And of course,
216     relative links in RSS feeds are ill-undefined..
217   * Make aggregator save permalinks and author name to pages as metadata.
218   * Add permalink and author support to meta plugin, affecting RSS feeds
219     and blog pages.
220   * Various CSS and formatting changes.
221   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
222   * Add xhtml files to the default prune regexp.
223   * Also generate rel=bookmark links for permalinks.
224   * Fix the htmltidy plugin, which wasn't working due my breaking it when
225     I added it..
226   * Don't run tidy with -xml as that fails if the input is not well-formed.
227     Run it with -asxhtml instead, so it will output well-formed xhtml no
228     matter what the input.
229   * Disable tidy warnings too.
230   * Add a new format hook, and make tidy use it, since tidy can really only
231     operate on and output complete html documents, not the body chunks
232     that sanitise gets.
233   * Fix dates in rss feeds if running localised, so they're still rfc 822.
234
235  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
236
237 ikiwiki (1.15) unstable; urgency=low
238
239   * Remove CDPATH and other env vars perl taint checking doesn't like.
240     Closes: #381279
241   * Added created_before and created_after PageSpec limits.
242
243  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
244
245 ikiwiki (1.14) unstable; urgency=low
246
247   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
248     by 10% or so.
249   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
250   * Added many unit tests for pagespec_match.
251
252  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
253
254 ikiwiki (1.13) unstable; urgency=low
255
256   * ikiwiki can now download and aggregate feeds with its new aggregate
257     plugin, so it's possible to implement a Planet using ikiwiki!
258   * Add a run_hooks function for the common task of running all hooks of a
259     given type.
260   * Add a savestate hook.
261   * Don't put blog post forms on pages if there's no cgiurl set.
262   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
263     --wrappers to do that.
264   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
265     to update pages that haven't changed on disk.
266   * Change meta tags to use html entity-escaped text for values, so that
267     quotes and such can be represented in title tags.
268   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
269     for the above.
270   * Make --rebuild also cause --aggregate to re-download and write aggregated
271     pages.
272   * Avoid outputting duplicate meta info.
273   * Include title metadata on aggregated posts for capitalised and un-munged
274     titles.
275   * Title metadata of inlined pages now shows up in blogs and rss feeds.
276   * Fix issue with unicode filenames and updating the hyper estradier search
277     index. (Aka Please Please Please, let that be the last one.)
278   * Patch from Roland Mas to support an rss=no parameter to inline directives.
279     Closes: #380743
280   * Renamed GlobLists to PageSpecs.
281   * PageSpecs can now include nested parens, "and", and "or". This remains
282     backwards compatible to the old GlobList format. It's implemented by
283     treating the GlobList as a very limited microlanguage that is transformed
284     to perl code that does the matching.
285   * The old GlobList format is deprecated, and I encourage users to switch to
286     using the new PageSpec format. Compatability with the old format will be
287     removed at some point, possibly by 2.0.
288   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
289   * Add support for creation_month and creation_year to PageSpec.
290     Closes: #380680
291   * Changes to index file encoding.
292
293  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
294
295 ikiwiki (1.12) unstable; urgency=low
296
297   "Viva l'Italia!"
298   * New pagestats plugin from Enrico, which can generate a table counting
299     the backlinks for each page, or a del.icio.us style cloud.
300   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
301     the wikiformat plugin works. Thanks, Emanuele Aina.
302   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
303     display, running them through pagetitle. This removes ugly underscores and
304     other gunk from the display, much nicer. You may want to rebuild your wiki
305     when upgrading to get the cleanup globally.
306   * Polygen plugin from Enrico.
307   * htmltidy plugin from Faidon.
308   * Locale patch from Faidon:
309     - Adds a locale setting to setup files.
310     - Proper local time, if the locale configuration option is used.
311     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
312       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
313       impossible.
314   * Add getopt hook type, this allows plugins to add new command-line options.
315   * Add --tagbase option to tag plugin.
316   * Add exclude option in setup files, works same as --exclude.
317   * Put categories in rss feeds for tagged items.
318   * Allow preprocessor directives to be expanded in inlined blog pages.
319     However, to avoid inlining loops etc, don't expand inline directives in
320     inlined pages.
321   * fortune plugin (trivial)
322   * Tag plugins according to type.
323
324  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
325
326 ikiwiki (1.11) unstable; urgency=low
327
328   * Patch from Enrico that
329     - Adds a tag plugin that allows more easily tagging pages.
330       The meta plugin can also still be used for that, but the tag plugin
331       also lists a page's tags at the bottom of the page.
332     - Allows preprocessor directives to have parameters with no specified
333       value.
334     - Fixes preprocessor directive parameter parsing so that
335       foo=bar baz now means "foo=bar" and a "baz" with no value.
336   * Run pagetemplate hooks when inlining pages so that inlined pages also
337     list their tags.
338   * Make all plugins with pagetemplate hooks check that variables exist
339     on the template before setting them, for robustness.
340   * Switch pagetemplate hooks to using named parameters.
341   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
342     This will be the page that a source page will be part of, which is
343     different than the source page for inlined pages.
344   * Audited all plugins to endure they pass (page, destpage) to htmllink
345     appropriatly. This means inlining of various plugins will not work
346     properly, with correct links generated.
347
348  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
349
350 ikiwiki (1.10) unstable; urgency=low
351
352   * Run page through any relevant filters when generating a page preview.
353   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
354     default throughout the wiki, not only on wikitext pages. Decided to call
355     this a feature, and split the camelcase support out into a separate plugin
356     that is independant of wikitext.
357   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
358
359  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
360
361 ikiwiki (1.9) unstable; urgency=low
362
363   * Improve display of parentlinks and page title of toplevel index page.
364   * Patch from Faidon to use svn --limit when possible for recentchanges,
365     speeds up recentchanges a lot for wikis with more history.
366   * Patch from Recai to fix utf8 issues in git backend.
367   * Add wikitext markup plugin, which supports ".wiki" pages written in the
368     original wiki syntax, CamelCase links and all.
369   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
370     support, to edit pages etc without a web server.
371   * Display CGI processing errors if present.
372   * Fix from Faidon for a XML parser issue that breaks utf-8 for
373     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
374     area, and also way slow.
375   * Match 'web commit from' in SVN and git, these are web commits too.
376     (Faidon)
377   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
378     readable and avoid future mistakes. The patch seems to work and for the
379     first time I have a UTF-8 username ;-) (Faidon)
380   * Use form->field consistently, not form->param.
381   * Patch from Recai to allow selection of page type when creating a new page.
382     Default page type is inherited from the link clicked on to create the new
383     page.
384
385  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
386
387 ikiwiki (1.8) unstable; urgency=low
388
389   * Fix orphans plugin to not count a link to a nonexistant page as a reason
390     for a page not being an orphan.
391   * Support pinging services such as Technorati using XML-RPC to notify them
392     about changes to rss feeds.
393   * Parse svn log as xml for improved utf8 and security. Note that this makes
394     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
395   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
396     flagged string even if the locale causes it to generate utf8 output,
397     so make sure to let perl know it should be handled as utf8. Also,
398     the optimised version used for standard time formats won't work if the
399     user has changed locale, so drop it. Thanks, Faidon Liambotis.
400   * Fix re-encoding of the comments field to utf8 if a commit fails
401     due to a conflict. Thanks, Faidon Liambotis.
402   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
403     Liambotis.
404   * Add insane double encode/decode to utf8 around call to markdown.
405     This works around a truely strange bug, which is apparently a bug in
406     perl, #376329. Also added a test case for it.
407   * Improve layout of edit page so formatting help link is always visible w/o
408     getting in the way of the preview.
409   * Centralised all calls to HTML::Template and force all the templates
410     to be read as utf8.
411   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
412   * Introduce add_plugins and disable_plugins config options in setup files.
413     This allows adding or removing plugins w/o overriding the whole list of
414     default plugins, which makes it easier to upgrade when new default plugins
415     are added.
416   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
417     default (of course!). Based on a patch by Faidon Liambotis.
418   * Add a html plugin, which can be used to write wikis in raw html,
419     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
420     defaults to not processing .html files, since w/o this plugin they would
421     be copied unsanitised. With this plugin, it will process and html
422     sanitise them, like any other page type.
423   * Rebuilding wrappers is necessary on upgrade to this version.
424   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
425     will be automatically done on all upgrades.
426   * Don't send pings if the wiki is being rebuilt.
427   * Work around very innefficient behavior in File::Spec::abs2rel. Result
428     is a savings of 2 pointless fork/execs per link calculation, which
429     results in ~25% speedup of ikiwiki building its own doc wiki, and
430     about 35% speedup displaying RecentChanges!
431   * Make RecentChanges use a table and some CSS, should be much more readable.
432     No code changes involved.
433   * Encode & in diffurl in examples, to conform to pedantic rules.
434   * Speed up RecentChanges by another 40% or so with some memoization.
435   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
436     in time to build the doc wiki.
437
438  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
439
440 ikiwiki (1.7) unstable; urgency=low
441
442   * Updated logo from Recai with some kerning and alingment tuning.
443   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
444     changed some output.
445   * Copyright update.
446
447  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
448
449 ikiwiki (1.6) unstable; urgency=low
450
451   * YA utf-8 patch from Recai, this time to fix previewing a page so that
452     the text in the input box is re-encoded back to utf-8.
453   * -CSD does not affect modules, so readfile() was not using the utf-8 input
454     layer, which led to lots of problems; make it force read files as utf-8.
455     Closes: #373203
456   * Note that as a consequence, this version of ikiwiki will actually try to
457     parse utf8 in source files for the first time, which may expose broken
458     utf8 in wiki sources that was hidden before. Most common will be
459     perl warnings like "utf8 "\xE9" does not map to Unicode"
460   * writefile() likewise needs to use the utf8 output layer.
461   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
462     there.
463   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
464     given the readfile fix.
465   * Add utf-8 testcases for readfile and htmlize.
466   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
467     safe.
468   * More utf-8 fixes from Recai, partly to things I broke above:
469     - The serious problem is that writefile() saves the content in undecoded
470       format in CGI, hence all (non-ascii) chars are corrupted permanently.
471     - Comment field in edit page is not decoded and all the non-ascii chars in
472       this field are corrupted as the result.  We should decode it as we do it
473       for the content.
474     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
475       character in print.
476   * New SVG logo from Recai.
477
478  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
479
480 ikiwiki (1.5) unstable; urgency=low
481
482   * Add --timeformat config option to allow changing how dates are displayed.
483     Note that as a side effect, dates will now be displayed using the local
484     timezone, not as GMT.
485   * More security review.
486   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
487     for some handy stuff like:
488     - Using links as a kind of tag; creating blog pages that list all pages
489       containing a given tag/link or not containing some other tag.
490     - Subscribing to mail notifications whenever a change is made to a page
491       that is a backlink of page foo. Ie, "Please notify me of changes in all
492       pages that link to my home page in the wiki"
493     - Locking any pages that are linked to from a particular page, so that
494       lists of locks can be exposed in the wiki.
495   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
496     when a todo item is done, instead of the previous moving it to a different
497     subdir.
498   * Allow pagetemplate plugins to override *anything* in the template.
499   * Add a meta plugin, which allows specifying various metadata about pages,
500     like license and author. It also allows for inserting html link and meta
501     tags into html, overriding the title, and adding hidden WikiLinks, which
502     can be useful when using link-based globbing for page categorisation.
503   * Remove preprocessor directives from inlined pages.
504   * Allow simple preprocessor directive values to be specified w/o quotes.
505   * Add support for using git instead of subversion as the RCS backend,
506     tremendous thanks to Recai Oktaş for this.
507   * Doc updates for git.
508   * Fix absolute url munging in rss generation to support https, ftp, etc urls
509     not just http urls.
510   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
511     utf-8 for edit and other fields, and for recentchanges. There may still
512     be utf-8 issues with the preferences page though.
513
514  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
515
516 ikiwiki (1.4) unstable; urgency=low
517
518   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
519     very strange way of enabling proper XHTML <br /> type tags. Output html
520     should be always valid again now.
521   * The page name and parent links has switched from using a <h1> to a styled
522     <span>, so pages can use <h1> internally instead of needing to use <h2>.
523   * Updated all of ikiwiki's own wiki pages for that.
524   * Add pagetemplate hook, which can be used by plugins that want to mess
525     around with adding new stuff to the page template.
526   * Remove headercontent; the search plugin now adds the search box to the
527     header by registering a pagetemplate hook, and other plugins should do
528     similarly.
529   * Rebuilding on upgrade to this version is recommended.
530   * Add a html validity check to the test suite, using the wdg-html-validator,
531     if available.
532   * Make the html valid when there is nothing in the actions list.
533   * Reordered some function call parameters for consistency.
534   * Enable full utf-8 support for page input and output.
535   * Add a workaround for markdown, which does not work well with utf-8
536     strings.
537   * --getctime had bitrotted (well I only ever used it the once so far..),
538     fix and make it a bit more flexible
539   * rcs_getctime is changed, now rather than needing to loop over all pages,
540     it should just use the rcs to get the ctime of the passed file.
541   * When inlining a page in another one, links from the inlined page are now
542     expanded the same as they are when rendering the inlined page as a
543     standalone page. So rather than being expanded from the POV of the
544     inlining page, they are expanded from the POV of the inlined page.
545
546     For example, a link from blog/foo to "bar" will now link to blog/bar
547     if it exists. Previously this needed to be a link explicitly to
548     "blog/bar"; such links will also continue to work.
549
550     (This was slightly complex to do as the link still has to be constructed
551     relative to the inlining page.)
552   * Make page edit textarea resize to fit browser window.
553   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
554     do not need a full rebuild, in order to update any basewiki pages.
555
556  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
557
558 ikiwiki (1.3) unstable; urgency=low
559
560   * Fix the preinst introduced in the last version. Closes: #367458
561
562  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
563
564 ikiwiki (1.2) unstable; urgency=low
565
566   * Remove dups from the brokenlinks list.
567   * Add libc6-dev to dependencies, needed to build wrappers.
568   * Install wikilist in correct location. Closes: #367371
569
570  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
571
572 ikiwiki (1.1) unstable; urgency=low
573
574   * Rename inlinepage to depends, so that it can be used to refer to more
575     dependency relationships than just inlining. This will require a rebuild
576     on upgrade to this version.
577   * Move the rss link, put it in the blogpost form if there is one and at the
578     top if not. This is both nicer because easier to find, and it cleans up
579     the code which had used inlinepage as a flag for adding the link later.
580   * Allow the depends GlobList to be built up from multiple sources (such as
581     plugins) during a page render.
582   * Which means that more than one blog is now supported to appear on a
583     single page. (With some limitations, like only the last one getting an
584     rss file.)
585   * Added a plugin system.
586   * Added a pagecount plugin, enabled by default.
587   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
588   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
589     backlinks when the backlinks hadn't really changed.
590   * Moved inline page support, rss generation etc into the inline plugin,
591     enabled by default.
592   * Added brokenlinks plugin, not enabled by default, but rather handy.
593   * Fix several broken links in the doc wiki.
594   * Smarter behavior when creating a page and a page of the same name (but
595     different location) already exists.
596   * Add an orphans plugin for finding pages that nothing links to.
597   * Removed backlinks page, which it turns out nothing used.
598   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
599     it, this will allow for adding a unit test suite.
600   * Add unit tests for several core functions, including globlist_match,
601     dirname, basename, bestlink, linkify, pagetitle, titlepage.
602   * Smart globlist merging.
603   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
604     to pave the way for adding other RCS support. This also changes the
605     setup files, where before they had svn => 1 or svn => 0, now they have
606     rcs => "svn" or rcs => "".
607   * Add a debian/NEWS file with upgrade notes.
608   * Load whatever rcs module is specified, so new ones can be just dropped in
609     as plugins and work. (Well, in theory.)
610   * Add some basic docs about writing RCS modules.
611   * Broke search capability out into a plugin, removed the --hyperestraier
612     switch.
613   * Added smiley plugin, nicely controlled and documented by the smileys page.
614   * Copied in some smileys from Moin Moin.
615   * Allow links of the form [[some page|page]], with whitespace in the link
616     text.
617   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
618     and --disable-plugin htmlscrubber.
619   * Allow discussion links on pages to be turned off with --no-discussion.
620   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
621   * Add some new config items to the estseek.conf template, which are needed
622     by hyperestraier 1.2.3.
623
624  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
625
626 ikiwiki (1.0) unstable; urgency=low
627
628   * First official release.
629
630  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400