]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
web commit by ClintAdams: playing with patchqueue
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.27) UNRELEASED; urgency=low
2
3   * Add a googlecalendar plugin. A bit special-purpose, but it shows
4     one way to to deal with user-supplied content that could cause XSS
5     issues w/o the htmlscrubber, and won't survive the scrubber.
6   * Work on firming up the plugin interface:
7     - Plugins should not need to load IkiWiki::Render to get commonly
8       used functions, so moved some functions from there to IkiWiki.
9     - Picked out the set of functions and variables that most plugins
10       use, documented them, and made IkiWiki export them by default,
11       like a proper perl module should.
12     - Use the other functions at your own risk.
13     - This is not quite complete, I still have to decide whether to
14       export some other things.
15   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16     referring to stuff now exported by the IkiWiki module.
17   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18     to declare which version of the interface your plugin needs.
19   * Anyone with a third-party ikiwiki plugin is strongly encouraged
20     to make like changes to it and avoid use of non-exported symboles from
21     "IkiWiki::".
22   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23   * Support hyperestradier version 1.4.2, which adds a new required phraseform
24     setting.
25   * If an inlined page has a permalink, link the page title to that.
26   * Patch from Recai to use utf8 when reading the setup file, so that
27     utf8 wikinames from there will be used properly.
28   * Patch from Recai to kill utf-8 on the wiki name when generating the
29     session cookie.
30   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31   * Fix a baseurl problem in hyperestradier search results.
32   * Add a stub local.css to avoid problems with 404's.
33   * Patch from Recai to fix a wide character warning from the search plugin
34     during setup if the wikiname contains utf8.
35   * Yet another fix for those poor case-insensative OSX users.
36   * pagetemplate hooks are now also called when generating cgi pages.
37   * Add a favicon plugin, which simply adds a link tag for an icon to each
38     page (and cgis).
39   * Patch from James Westby to deal with the case where you're editing a
40     new page, hit cancel, and need to be redirected to somewhere sane.
41   * Various documentation improvements by various wiki users.
42   * Support Text::Markdown from CPAN, which has a different interface from
43     the original markdown or the one in Debian.
44   * Version the libcgi-session-perl dependency, some features that need
45     the new version are used in some cases (sslcookie).
46   * Numerous tla fixes from Clint.
47   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
48     a multi-resolution favicon.ico.
49
50  -- Joey Hess <joeyh@debian.org>  Sat, 16 Sep 2006 10:30:35 -0400
51
52 ikiwiki (1.26) unstable; urgency=low
53
54   * Add a missing -n to tla undo call.
55   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
56     writes before consuming its whole stdin. Avoid this deadlock.
57   * Fix alt tags for outline checkboxes.
58
59  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
60
61 ikiwiki (1.25) unstable; urgency=low
62
63   * Add proper waitpid calls for open2ed processes throughout to avoid
64     zombies; this hit htmltidy especially badly.
65   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
66     subversion repos and fixing some other issues.
67   * Add support for tla, contributed by Clint Adams. Closes: #385936
68   * Add support for mercurial, contributed by Emanuele Aina.
69   * Include <link rel> tag for RSS feeds, used by some aggregators and
70     firefox to find the feed.
71   * Add a linkmap plugin (requires graphviz).
72
73  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
74
75 ikiwiki (1.24) unstable; urgency=low
76
77   * Simplify the data structure returned by rcs_recentchanges to avoid
78     each rcs plugin needing to form complex strings on its own.
79   * Fix another destpage issue in the inline directive. Closes: #385512
80     again.
81
82  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
83
84 ikiwiki (1.23) unstable; urgency=low
85
86   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
87
88  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
89
90 ikiwiki (1.22) unstable; urgency=low
91
92   * Change how the stylesheet url is determined in the templates: Remove
93     STYLEURL and add BASEURL to all templates (some already had it). This
94     new more general variable can be used to link to other things (eg, images)
95     from the template, as well as stylesheets.
96   * Fix a bug introduced last version to do with nested inlines.
97   * Allow preprocessor directives to span multiple lines, both to make
98     long ones with lots of values easier to write, and to allow for ones with
99     multi-line quoted values.
100   * Allow preprocessor directives to contain python-like triple-quoted
101     text blocks, for easy nesting of quotes inside.
102   * Add a template plugin.
103   * Make pagespec merge code smarter about merging duplicate pagespecs.
104   * Patch from Jordà Polo to make Setup::Standard support hashes in config
105     files.
106   * Change order of linkify and preprocess; first preprocess and then linkify.
107     This allows passing a wikilink inside a parameter to a preprocessor
108     directive without it being expanded to html, and leaking out of the
109     parameter, which had required some non-obvious use of triple-quoting
110     to avoid. Note that any preprocessor plugins that output something
111     that looks like a wikilink will now have it treated as such; AFAIK
112     this doesn't change any behavior though except for the template plugin.
113   * Enable preprocessor directives when previewing an edit.
114   * Make all pages pull in a local.css style sheet, if present. This won't
115     be included in ikiwiki, but can be created to make local styling changes
116     w/o needing to merge in every new change to the distributed style.css.
117   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
118   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
119     from a different directory.
120   * Generalised preprocesser loop protection code.
121   * Patch from James Westby to allow a description to be set for rss feeds.
122   * Patch from James Westby to add a template for the search form.
123   * Added a ddate plugin.
124   * Patch from James Westby to add a --sslcookie switch, which forces
125     cookies to only be sent over ssl connections to avoid interception.
126   * Fix preferences page on anonok wikis; still need to sign in to get
127     to the preferences page.
128   * Add toc (table of contents) plugin.
129   * Change htmlize, format, and sanitize hooks to use named parameters.
130   * Patch from James Westby to add an actions option to inline; this
131     adds Edit and Discussion links at the end of blog entries.
132   * Due to some css changes, you'll want to rebuild your wiki on upgrade
133     to this version. Will be handled automatically by the deb.
134   * Add processed date to aggregate preprocessor directive status output.
135
136  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
137
138 ikiwiki (1.21) unstable; urgency=low
139
140   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
141   * If a page links to itself, mark up the link text in a span with
142     class="selflink" so that it can be styled. I don't have a useful style
143     defined for that though.
144   * Call filter hooks on inlined page content.
145   * Support inlining pages raw, rather than creating a blog.
146   * Clean up yes/no parameter parsing in inline plugin.
147   * Implemented better cycle detection in the inline plugin; nested inlines
148     will now work.
149   * Add a map plugin contributed by Alessandro Dotti Contra.
150   * Add otl format plugin, which handles files as created by vimoutliner.
151   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
152   * Add first draft at a Restructured Text (rst) plugin, by Sergio
153     Talens-Oliag. Note that this has many known issues -- see the caveats on
154     the plugin's page.
155   * Credit everyone who wrote a plugin on the plugins' wiki pages.
156   * Fix utf-8 in blog post form.
157
158  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
159
160 ikiwiki (1.20) unstable; urgency=low
161
162   * Relicense the templates and basewiki under the 2-clause BSD license.
163     Since these can easily become part of other people's websites, they
164     should be under as permissive a license as possible.
165   * Add --syslog config option, to log to the syslog.
166   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
167     transient failure to fork (which I've seen happen in the wild).
168   * Fix a bug in the aggregator introduced last version that caused all
169     aggregator state to be lost during a non-aggregating build.
170
171  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
172
173 ikiwiki (1.19) unstable; urgency=low
174
175   * Fix several related bugs in page type determination during online editing.
176   * Add some locking to prevent 2 aggregators from running at once.
177   * Fix an infinite loop in the aggregator when finding a unique filename.
178
179  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
180
181 ikiwiki (1.18) unstable; urgency=low
182
183   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
184   * Add --version.
185   * Man page format fixups.
186   * If the meta plugin overides the page title, set a title_overridden
187     variable in the template to true. This allows doing things with the
188     templates conditional on the title being overriden.
189   * Add a %pagecase which maps lower-case page names to the actual case
190     used in the filename. Use this in bestlinks calculation instead of
191     forcing the link to lowercase.
192   * Also use %pagecase in various other places that want to check if a page
193     with a given name exists.
194   * This means that links to pages with mixed case names will now work,
195     even if the link is in some other case mixture, and mixed case pages
196     should be fully supported throughout ikiwiki.
197   * Recommend rebuilding wikis on upgrade to this version.
198
199  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
200
201 ikiwiki (1.17) unstable; urgency=low
202
203   * Disable tidy generator tag.
204   * Move tidy back to sanitize hook, found out how to only show body.
205   * Turn off tidy indentation too.
206   * Turn on HTML::Template loop_context_vars; not actually used in stock
207     templates but can be useful for things like making comma-delimited lists
208     of tags or what have you.
209   * Remove <br> from end of aggregate preprocessor directive output.
210   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
211     case-sensative filesystems like OSX.
212   * Improve markdown loading. First, try to load it as a proper perl module,
213     in case it was installed as one. Then fall back to trying
214     /usr/bin/markdown.
215   * Document in install page how to install markdown, since it has no
216     installation procedure in the upstream tarball.
217   * Set die_on_bad_params => 0 for all templates, to allow users to modify
218     them without annoyances.
219   * Suck in the page content when generating an inline archive page, to work
220     around the meta plugin's lack of caching of title metadata across runs.
221
222  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
223
224 ikiwiki (1.16) unstable; urgency=low
225
226   * Try to handle relative links in aggregated feeds. However,
227     the current support is a crude hack due to limitations of XML::Feed:
228     xml:base is not supported, neither is Content-Location. And of course,
229     relative links in RSS feeds are ill-undefined..
230   * Make aggregator save permalinks and author name to pages as metadata.
231   * Add permalink and author support to meta plugin, affecting RSS feeds
232     and blog pages.
233   * Various CSS and formatting changes.
234   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
235   * Add xhtml files to the default prune regexp.
236   * Also generate rel=bookmark links for permalinks.
237   * Fix the htmltidy plugin, which wasn't working due my breaking it when
238     I added it..
239   * Don't run tidy with -xml as that fails if the input is not well-formed.
240     Run it with -asxhtml instead, so it will output well-formed xhtml no
241     matter what the input.
242   * Disable tidy warnings too.
243   * Add a new format hook, and make tidy use it, since tidy can really only
244     operate on and output complete html documents, not the body chunks
245     that sanitise gets.
246   * Fix dates in rss feeds if running localised, so they're still rfc 822.
247
248  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
249
250 ikiwiki (1.15) unstable; urgency=low
251
252   * Remove CDPATH and other env vars perl taint checking doesn't like.
253     Closes: #381279
254   * Added created_before and created_after PageSpec limits.
255
256  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
257
258 ikiwiki (1.14) unstable; urgency=low
259
260   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
261     by 10% or so.
262   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
263   * Added many unit tests for pagespec_match.
264
265  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
266
267 ikiwiki (1.13) unstable; urgency=low
268
269   * ikiwiki can now download and aggregate feeds with its new aggregate
270     plugin, so it's possible to implement a Planet using ikiwiki!
271   * Add a run_hooks function for the common task of running all hooks of a
272     given type.
273   * Add a savestate hook.
274   * Don't put blog post forms on pages if there's no cgiurl set.
275   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
276     --wrappers to do that.
277   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
278     to update pages that haven't changed on disk.
279   * Change meta tags to use html entity-escaped text for values, so that
280     quotes and such can be represented in title tags.
281   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
282     for the above.
283   * Make --rebuild also cause --aggregate to re-download and write aggregated
284     pages.
285   * Avoid outputting duplicate meta info.
286   * Include title metadata on aggregated posts for capitalised and un-munged
287     titles.
288   * Title metadata of inlined pages now shows up in blogs and rss feeds.
289   * Fix issue with unicode filenames and updating the hyper estradier search
290     index. (Aka Please Please Please, let that be the last one.)
291   * Patch from Roland Mas to support an rss=no parameter to inline directives.
292     Closes: #380743
293   * Renamed GlobLists to PageSpecs.
294   * PageSpecs can now include nested parens, "and", and "or". This remains
295     backwards compatible to the old GlobList format. It's implemented by
296     treating the GlobList as a very limited microlanguage that is transformed
297     to perl code that does the matching.
298   * The old GlobList format is deprecated, and I encourage users to switch to
299     using the new PageSpec format. Compatability with the old format will be
300     removed at some point, possibly by 2.0.
301   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
302   * Add support for creation_month and creation_year to PageSpec.
303     Closes: #380680
304   * Changes to index file encoding.
305
306  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
307
308 ikiwiki (1.12) unstable; urgency=low
309
310   "Viva l'Italia!"
311   * New pagestats plugin from Enrico, which can generate a table counting
312     the backlinks for each page, or a del.icio.us style cloud.
313   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
314     the wikiformat plugin works. Thanks, Emanuele Aina.
315   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
316     display, running them through pagetitle. This removes ugly underscores and
317     other gunk from the display, much nicer. You may want to rebuild your wiki
318     when upgrading to get the cleanup globally.
319   * Polygen plugin from Enrico.
320   * htmltidy plugin from Faidon.
321   * Locale patch from Faidon:
322     - Adds a locale setting to setup files.
323     - Proper local time, if the locale configuration option is used.
324     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
325       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
326       impossible.
327   * Add getopt hook type, this allows plugins to add new command-line options.
328   * Add --tagbase option to tag plugin.
329   * Add exclude option in setup files, works same as --exclude.
330   * Put categories in rss feeds for tagged items.
331   * Allow preprocessor directives to be expanded in inlined blog pages.
332     However, to avoid inlining loops etc, don't expand inline directives in
333     inlined pages.
334   * fortune plugin (trivial)
335   * Tag plugins according to type.
336
337  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
338
339 ikiwiki (1.11) unstable; urgency=low
340
341   * Patch from Enrico that
342     - Adds a tag plugin that allows more easily tagging pages.
343       The meta plugin can also still be used for that, but the tag plugin
344       also lists a page's tags at the bottom of the page.
345     - Allows preprocessor directives to have parameters with no specified
346       value.
347     - Fixes preprocessor directive parameter parsing so that
348       foo=bar baz now means "foo=bar" and a "baz" with no value.
349   * Run pagetemplate hooks when inlining pages so that inlined pages also
350     list their tags.
351   * Make all plugins with pagetemplate hooks check that variables exist
352     on the template before setting them, for robustness.
353   * Switch pagetemplate hooks to using named parameters.
354   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
355     This will be the page that a source page will be part of, which is
356     different than the source page for inlined pages.
357   * Audited all plugins to endure they pass (page, destpage) to htmllink
358     appropriatly. This means inlining of various plugins will not work
359     properly, with correct links generated.
360
361  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
362
363 ikiwiki (1.10) unstable; urgency=low
364
365   * Run page through any relevant filters when generating a page preview.
366   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
367     default throughout the wiki, not only on wikitext pages. Decided to call
368     this a feature, and split the camelcase support out into a separate plugin
369     that is independant of wikitext.
370   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
371
372  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
373
374 ikiwiki (1.9) unstable; urgency=low
375
376   * Improve display of parentlinks and page title of toplevel index page.
377   * Patch from Faidon to use svn --limit when possible for recentchanges,
378     speeds up recentchanges a lot for wikis with more history.
379   * Patch from Recai to fix utf8 issues in git backend.
380   * Add wikitext markup plugin, which supports ".wiki" pages written in the
381     original wiki syntax, CamelCase links and all.
382   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
383     support, to edit pages etc without a web server.
384   * Display CGI processing errors if present.
385   * Fix from Faidon for a XML parser issue that breaks utf-8 for
386     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
387     area, and also way slow.
388   * Match 'web commit from' in SVN and git, these are web commits too.
389     (Faidon)
390   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
391     readable and avoid future mistakes. The patch seems to work and for the
392     first time I have a UTF-8 username ;-) (Faidon)
393   * Use form->field consistently, not form->param.
394   * Patch from Recai to allow selection of page type when creating a new page.
395     Default page type is inherited from the link clicked on to create the new
396     page.
397
398  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
399
400 ikiwiki (1.8) unstable; urgency=low
401
402   * Fix orphans plugin to not count a link to a nonexistant page as a reason
403     for a page not being an orphan.
404   * Support pinging services such as Technorati using XML-RPC to notify them
405     about changes to rss feeds.
406   * Parse svn log as xml for improved utf8 and security. Note that this makes
407     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
408   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
409     flagged string even if the locale causes it to generate utf8 output,
410     so make sure to let perl know it should be handled as utf8. Also,
411     the optimised version used for standard time formats won't work if the
412     user has changed locale, so drop it. Thanks, Faidon Liambotis.
413   * Fix re-encoding of the comments field to utf8 if a commit fails
414     due to a conflict. Thanks, Faidon Liambotis.
415   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
416     Liambotis.
417   * Add insane double encode/decode to utf8 around call to markdown.
418     This works around a truely strange bug, which is apparently a bug in
419     perl, #376329. Also added a test case for it.
420   * Improve layout of edit page so formatting help link is always visible w/o
421     getting in the way of the preview.
422   * Centralised all calls to HTML::Template and force all the templates
423     to be read as utf8.
424   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
425   * Introduce add_plugins and disable_plugins config options in setup files.
426     This allows adding or removing plugins w/o overriding the whole list of
427     default plugins, which makes it easier to upgrade when new default plugins
428     are added.
429   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
430     default (of course!). Based on a patch by Faidon Liambotis.
431   * Add a html plugin, which can be used to write wikis in raw html,
432     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
433     defaults to not processing .html files, since w/o this plugin they would
434     be copied unsanitised. With this plugin, it will process and html
435     sanitise them, like any other page type.
436   * Rebuilding wrappers is necessary on upgrade to this version.
437   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
438     will be automatically done on all upgrades.
439   * Don't send pings if the wiki is being rebuilt.
440   * Work around very innefficient behavior in File::Spec::abs2rel. Result
441     is a savings of 2 pointless fork/execs per link calculation, which
442     results in ~25% speedup of ikiwiki building its own doc wiki, and
443     about 35% speedup displaying RecentChanges!
444   * Make RecentChanges use a table and some CSS, should be much more readable.
445     No code changes involved.
446   * Encode & in diffurl in examples, to conform to pedantic rules.
447   * Speed up RecentChanges by another 40% or so with some memoization.
448   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
449     in time to build the doc wiki.
450
451  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
452
453 ikiwiki (1.7) unstable; urgency=low
454
455   * Updated logo from Recai with some kerning and alingment tuning.
456   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
457     changed some output.
458   * Copyright update.
459
460  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
461
462 ikiwiki (1.6) unstable; urgency=low
463
464   * YA utf-8 patch from Recai, this time to fix previewing a page so that
465     the text in the input box is re-encoded back to utf-8.
466   * -CSD does not affect modules, so readfile() was not using the utf-8 input
467     layer, which led to lots of problems; make it force read files as utf-8.
468     Closes: #373203
469   * Note that as a consequence, this version of ikiwiki will actually try to
470     parse utf8 in source files for the first time, which may expose broken
471     utf8 in wiki sources that was hidden before. Most common will be
472     perl warnings like "utf8 "\xE9" does not map to Unicode"
473   * writefile() likewise needs to use the utf8 output layer.
474   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
475     there.
476   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
477     given the readfile fix.
478   * Add utf-8 testcases for readfile and htmlize.
479   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
480     safe.
481   * More utf-8 fixes from Recai, partly to things I broke above:
482     - The serious problem is that writefile() saves the content in undecoded
483       format in CGI, hence all (non-ascii) chars are corrupted permanently.
484     - Comment field in edit page is not decoded and all the non-ascii chars in
485       this field are corrupted as the result.  We should decode it as we do it
486       for the content.
487     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
488       character in print.
489   * New SVG logo from Recai.
490
491  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
492
493 ikiwiki (1.5) unstable; urgency=low
494
495   * Add --timeformat config option to allow changing how dates are displayed.
496     Note that as a side effect, dates will now be displayed using the local
497     timezone, not as GMT.
498   * More security review.
499   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
500     for some handy stuff like:
501     - Using links as a kind of tag; creating blog pages that list all pages
502       containing a given tag/link or not containing some other tag.
503     - Subscribing to mail notifications whenever a change is made to a page
504       that is a backlink of page foo. Ie, "Please notify me of changes in all
505       pages that link to my home page in the wiki"
506     - Locking any pages that are linked to from a particular page, so that
507       lists of locks can be exposed in the wiki.
508   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
509     when a todo item is done, instead of the previous moving it to a different
510     subdir.
511   * Allow pagetemplate plugins to override *anything* in the template.
512   * Add a meta plugin, which allows specifying various metadata about pages,
513     like license and author. It also allows for inserting html link and meta
514     tags into html, overriding the title, and adding hidden WikiLinks, which
515     can be useful when using link-based globbing for page categorisation.
516   * Remove preprocessor directives from inlined pages.
517   * Allow simple preprocessor directive values to be specified w/o quotes.
518   * Add support for using git instead of subversion as the RCS backend,
519     tremendous thanks to Recai Oktaş for this.
520   * Doc updates for git.
521   * Fix absolute url munging in rss generation to support https, ftp, etc urls
522     not just http urls.
523   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
524     utf-8 for edit and other fields, and for recentchanges. There may still
525     be utf-8 issues with the preferences page though.
526
527  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
528
529 ikiwiki (1.4) unstable; urgency=low
530
531   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
532     very strange way of enabling proper XHTML <br /> type tags. Output html
533     should be always valid again now.
534   * The page name and parent links has switched from using a <h1> to a styled
535     <span>, so pages can use <h1> internally instead of needing to use <h2>.
536   * Updated all of ikiwiki's own wiki pages for that.
537   * Add pagetemplate hook, which can be used by plugins that want to mess
538     around with adding new stuff to the page template.
539   * Remove headercontent; the search plugin now adds the search box to the
540     header by registering a pagetemplate hook, and other plugins should do
541     similarly.
542   * Rebuilding on upgrade to this version is recommended.
543   * Add a html validity check to the test suite, using the wdg-html-validator,
544     if available.
545   * Make the html valid when there is nothing in the actions list.
546   * Reordered some function call parameters for consistency.
547   * Enable full utf-8 support for page input and output.
548   * Add a workaround for markdown, which does not work well with utf-8
549     strings.
550   * --getctime had bitrotted (well I only ever used it the once so far..),
551     fix and make it a bit more flexible
552   * rcs_getctime is changed, now rather than needing to loop over all pages,
553     it should just use the rcs to get the ctime of the passed file.
554   * When inlining a page in another one, links from the inlined page are now
555     expanded the same as they are when rendering the inlined page as a
556     standalone page. So rather than being expanded from the POV of the
557     inlining page, they are expanded from the POV of the inlined page.
558
559     For example, a link from blog/foo to "bar" will now link to blog/bar
560     if it exists. Previously this needed to be a link explicitly to
561     "blog/bar"; such links will also continue to work.
562
563     (This was slightly complex to do as the link still has to be constructed
564     relative to the inlining page.)
565   * Make page edit textarea resize to fit browser window.
566   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
567     do not need a full rebuild, in order to update any basewiki pages.
568
569  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
570
571 ikiwiki (1.3) unstable; urgency=low
572
573   * Fix the preinst introduced in the last version. Closes: #367458
574
575  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
576
577 ikiwiki (1.2) unstable; urgency=low
578
579   * Remove dups from the brokenlinks list.
580   * Add libc6-dev to dependencies, needed to build wrappers.
581   * Install wikilist in correct location. Closes: #367371
582
583  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
584
585 ikiwiki (1.1) unstable; urgency=low
586
587   * Rename inlinepage to depends, so that it can be used to refer to more
588     dependency relationships than just inlining. This will require a rebuild
589     on upgrade to this version.
590   * Move the rss link, put it in the blogpost form if there is one and at the
591     top if not. This is both nicer because easier to find, and it cleans up
592     the code which had used inlinepage as a flag for adding the link later.
593   * Allow the depends GlobList to be built up from multiple sources (such as
594     plugins) during a page render.
595   * Which means that more than one blog is now supported to appear on a
596     single page. (With some limitations, like only the last one getting an
597     rss file.)
598   * Added a plugin system.
599   * Added a pagecount plugin, enabled by default.
600   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
601   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
602     backlinks when the backlinks hadn't really changed.
603   * Moved inline page support, rss generation etc into the inline plugin,
604     enabled by default.
605   * Added brokenlinks plugin, not enabled by default, but rather handy.
606   * Fix several broken links in the doc wiki.
607   * Smarter behavior when creating a page and a page of the same name (but
608     different location) already exists.
609   * Add an orphans plugin for finding pages that nothing links to.
610   * Removed backlinks page, which it turns out nothing used.
611   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
612     it, this will allow for adding a unit test suite.
613   * Add unit tests for several core functions, including globlist_match,
614     dirname, basename, bestlink, linkify, pagetitle, titlepage.
615   * Smart globlist merging.
616   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
617     to pave the way for adding other RCS support. This also changes the
618     setup files, where before they had svn => 1 or svn => 0, now they have
619     rcs => "svn" or rcs => "".
620   * Add a debian/NEWS file with upgrade notes.
621   * Load whatever rcs module is specified, so new ones can be just dropped in
622     as plugins and work. (Well, in theory.)
623   * Add some basic docs about writing RCS modules.
624   * Broke search capability out into a plugin, removed the --hyperestraier
625     switch.
626   * Added smiley plugin, nicely controlled and documented by the smileys page.
627   * Copied in some smileys from Moin Moin.
628   * Allow links of the form [[some page|page]], with whitespace in the link
629     text.
630   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
631     and --disable-plugin htmlscrubber.
632   * Allow discussion links on pages to be turned off with --no-discussion.
633   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
634   * Add some new config items to the estseek.conf template, which are needed
635     by hyperestraier 1.2.3.
636
637  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
638
639 ikiwiki (1.0) unstable; urgency=low
640
641   * First official release.
642
643  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400