]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
* Allow /etc/ikiwiki/wikilist to list just the names of users, if so then
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.34.2) UNRELEASED; urgency=low
2
3   * Allow /etc/ikiwiki/wikilist to list just the names of users, if so then
4     ~user/.ikiwiki/wikilist will be read.
5   * Fix url absolution code in inline plugin to support class and id fields in
6     links and imgs, and to support anchor urls.
7
8  -- Joey Hess <joeyh@debian.org>  Tue, 28 Nov 2006 04:04:39 -0500
9
10 ikiwiki (1.34.1) unstable; urgency=low
11
12   * Add libtime-duraiton-perl to build deps, as it's used by the svn module
13     which is now tested at build.
14
15  -- Joey Hess <joeyh@debian.org>  Mon, 27 Nov 2006 12:26:12 -0500
16
17 ikiwiki (1.34) unstable; urgency=low
18
19   * Add an openid plugin to support logging in using OpenID.
20   * Web commits by OpenID users will record the full OpenID url for the user,
21     but in recentchanges, these urls will be converted to a simplified display
22     form+link.
23   * Modified svn, git, tla backends to recognise such web commits.
24   * Move httpauth support to a plugin.
25   * Add openidsignup config option.
26   * Make the openid plugin support the callbacks from myopenid.com via its
27     affiliate program.
28   * Add toggle plugin.
29   * Add a poll plugin.
30   * Add quick mode for archive page generation.
31   * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
32     many other plugins. It's an easy way to boost ikiwiki from its default,
33     basic wiki, to a full-featured wiki, without manually picking the right
34     set of plugins. New plugins will be added to goodstuff from time to
35     time.
36   * Change how post signin actions are propigated through the signin process;
37     they're now stored in the session.
38   * Add optional "desc" parameter to shortcut definitions.
39   * Avoid locking the wiki at all when handling some basic cgi stuff
40     (searches, recentchanges).
41   * Add "last" parameter to hook function. Very basic ordering, and hopefully
42     nothing more spohisticated will be needed.
43   * Add formbuilder_setup and formbuilder hooks.
44   * Split out a passwordauth module, that holds all the traditional password
45     based authentication etc code. It's enabled by default, but can be disabled
46     if you want only openid or some other auth method.
47   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
48   * Add some code to the build system that tries to determine if the
49     lib installation directory is in @INC. If it's not, munge ikiwiki
50     to hardcode the path to the lib directory. This should allow installing
51     ikiwiki in nonstandard locations, including home directories, by just
52     setting PREFIX at build time.
53   * Fix nested examples directory in deb.
54   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
55   * Add a test suite for the svn backend.
56   * Add a test suite for the git backend, from Recai
57   * Daemonize before sending RPC pings, since that can take a while
58     and/or hang.
59   * Daemonize before sending commit mails, as that can also take a long
60     time/hang if the mail server is unhappy.
61   * Factor out commit mail sending code into new function.
62   * Change rcs_commit, it is now passed the name of the user doing the commit
63     and their IP address, and needs to construct its own commit message
64     containing them, or do something more appropriate for the given RCS.
65   * Add softwaresite example.
66   * Mercurial backend improvements, including --get-ctime support. (Emanuele
67     Aina)
68   * Git backend improvements, including bug fixes and better robustness,
69     from Recai.
70
71  -- Joey Hess <joeyh@debian.org>  Sun, 26 Nov 2006 20:46:56 -0500
72
73 ikiwiki (1.33) unstable; urgency=low
74
75   * Fix issue with aggregate plugin updating expired pages.
76   * Avoid syntax errors in templates used by the template plugin crashing
77     ikiwiki.
78   * Enable utf8 file IO in aggregate plugin.
79   * Fix some issues with the new registration form.
80   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
81   * Make sure to check for errors from every eval.
82   * Fix img plugin's handling of adding dependencies for images that do not
83     yet exist.
84   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
85     FORM-SUBMIT unusable on customised formbuilder templates. For now,
86     hardcode the submit buttons in editpage.tmpl instead of using the
87     template variable, which is ok, since the buttons are static.
88   * Work with hyperestraier 1.4.9.
89
90  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
91
92 ikiwiki (1.32) unstable; urgency=low
93
94   * Add a separate pass to find page links, and only render each page once,
95     instead of over and over. Typical speedup is ~4x. Max possible speedup:
96     8x.
97   * Add "scan" parameter to hook(), which is used to make the hook be called
98     during the scanning pass, as well as the render pass. The meta and tag
99     plugins need to use the new scan parameter, so will any others that modify
100     %links.
101   * Now that links are calculated in a separate pass, it can also
102     precalculate backlinks in one pass, which is O(N^2) instead of the
103     previous code that was O(N^3). A very nice speedup for wikis with lots
104     (thousands) of pages.
105   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
106     Erdem.
107   * Add a default stylesheet entry for the pagecloud.
108   * Add examples page with some examples of things that can be done using
109     ikiwiki, like a weblog. The examples can be copied into a user's wiki
110     for a quick start, without needing to learn everything about how to put
111     them together.
112   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
113   * Add perlmagick to build-depends so syntax check of img plugin works.
114     Closes: #396702
115   * Improve login/register process, the login dialog has only name and
116     password fields, which allows more web browsers to regognise it as a login
117     field, and is less confusing.
118   * Implemented expiry options for aggregate plugin.
119   * Use precalculated backlinks info when determining if files need an update
120     due to a page they link to being added/removed. Mostly significant if
121     there are lots of pages.
122   * Remove duplicate link info when saving index. In some cases it could
123     pile up rather badly. (Probably not the best way to deal with this
124     problem.)
125   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
126     or what have you, by creating enclosures for non-page items that are
127     included in feeds.
128
129  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
130
131 ikiwiki (1.31) unstable; urgency=low
132
133   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
134   * Change the rss feed title from the wikiname to the page title, with
135     an exception for the wiki's toplevel index page, which will still use the
136     wikiname as the feed title.
137     Overriding the page title with meta title already overrode the rss feed
138     tittle.
139   * Add an img plugin, based on Christian Mock's img plugin, but stripped
140     down to the bare essentials. Useful for handling large images on websites.
141   * Sanitize possibly problimatic characters out of the polygen grammar names,
142     just in case. Should not be exploitable anyway, since it only tries to run
143     polygen after finding the specified grammar file.
144   * Add missing dependency on the URI perl module.
145   * Add basic spam fighting tool for admins: An admin's prefs page now allows
146     editing a list of banned users.
147
148  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
149
150 ikiwiki (1.30) unstable; urgency=low
151
152   * Add no_override parameter to hook().
153   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
154     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
155     can be configured using a page in wiki.
156   * Fix support for --pingurl at the command line.
157   * Fix a subtle bug in will_render that broke some builds, by only clearing
158     items from renderedfiles the first time per build.
159   * Wrap entire technortati ping operation in an eval to catch all possible
160     failure modes, after I observed a simple ->value crashing ikiwiki when
161     a ping failed.
162
163  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
164
165 ikiwiki (1.29) unstable; urgency=low
166
167   * Patch from Paul Tötterman to use CP in the Makefile.
168   * Patch from Alec Berryman adding a http_auth config item that allows
169     using HTTP Authentication instead of ikiwiki's built in authentication.
170     Useful for eg, large sites with their own previously existing user auth
171     setup. Closes: #384534
172   * Change %renderedfiles to store an array of files rendered from a given
173     source file, to allow tracking of extra rendered files like rss feeds.
174   * Note that plugins that accessed this variable will need to be updated!
175     The plugin interface has been increased to version 1.01 for this change.
176     As few plugins use %renderedfiles I haven't done anything else to ensure
177     compatability of old plugins.
178   * Add will_render function to the plugin interface, used to register that a
179     page renders a destination file, and do some security checks. Previously
180     but no longer rendered files will be cleaned up.
181   * Use will_render in the inline and linkmap plugins.
182   * You will need to rebuild your wiki on upgrade to this version.
183   * Atom feed support based on a patch by Clint Adams.
184   * Add feeds=no option to inline preprocessor directive to turn off all types
185     of feeds.
186   * $IkiWiki::version now holds the program version, and is accessible to
187     plugins.
188   * Make the aggregate plugin emphasize error messages.
189   * Patch from Recai to limit recentchanges to displaying max 10 files for a
190     given changeset (to avoid large number of file changes excessively
191     bloating the page).
192
193  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
194
195 ikiwiki (1.28) unstable; urgency=low
196
197   * inline: Add ability to sort by page name, based on a patch from
198     Benjamin A'Lee.
199   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
200     braindead interface. Closes: #389383
201   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
202     and b) those poor Mac OSX users and their case insensative files!
203   * Don't fail syntax check if Text::Typography isn't installed.
204     Closes: #389406
205
206  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
207
208 ikiwiki (1.27) unstable; urgency=low
209
210   * Work on firming up the plugin interface:
211     - Plugins should not need to load IkiWiki::Render to get commonly
212       used functions, so moved some functions from there to IkiWiki.
213     - Picked out the set of functions and variables that most plugins
214       use, documented them, and made IkiWiki export them by default,
215       like a proper perl module should.
216     - Use the other functions at your own risk.
217     - This is not quite complete, I still have to decide whether to
218       export some other things.
219   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
220     referring to stuff now exported by the IkiWiki module.
221   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
222     to declare which version of the interface your plugin needs.
223   * Anyone with a third-party ikiwiki plugin is strongly encouraged
224     to make like changes to it and avoid use of non-exported symbols from
225     "IkiWiki::".
226   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
227   * Support hyperestradier version 1.4.2, which adds a new required phraseform
228     setting.
229   * If an inlined page has a permalink, link the page title to that.
230   * Patch from Recai to use utf8 when reading the setup file, so that
231     utf8 wikinames from there will be used properly.
232   * Patch from Recai to kill utf-8 on the wiki name when generating the
233     session cookie.
234   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
235   * Fix a baseurl problem in hyperestradier search results.
236   * Add a stub local.css to avoid problems with 404's.
237   * Patch from Recai to fix a wide character warning from the search plugin
238     during setup if the wikiname contains utf8.
239   * Yet another fix for those poor case-insensative OS X users.
240   * pagetemplate hooks are now also called when generating cgi pages.
241   * Add a favicon plugin, which simply adds a link tag for an icon to each
242     page (and cgis).
243   * Patch from James Westby to deal with the case where you're editing a
244     new page, hit cancel, and need to be redirected to somewhere sane.
245   * Various documentation improvements by various wiki users.
246   * Support Text::Markdown from CPAN, which has a different interface from
247     the original markdown or the one in Debian.
248   * Version the libcgi-session-perl dependency, some features that need
249     the new version are used in some cases (sslcookie).
250   * Numerous tla fixes from Clint.
251   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
252     a multi-resolution favicon.ico.
253   * README.Debian: typo Closes: #388110
254   * chomp trailing newline at the end of templates read in by the template
255     plugin, to allow use of the template preprocessor directive in
256     whitespace-sensative situations. Closes: #387073
257   * Patch from James Westby to make the location of the estseek.cgi script
258     configurable.
259   * Add typography (SmartyPants) plugin by Recai.
260   * Add --render mode, which can be used to preview an edit at the command
261     line by test rendering a single page.
262   * Add a googlecalendar plugin. A bit special-purpose, but it shows
263     one way to to deal with user-supplied content that could cause XSS
264     issues w/o the htmlscrubber, and won't survive the scrubber.
265
266  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
267
268 ikiwiki (1.26) unstable; urgency=low
269
270   * Add a missing -n to tla undo call.
271   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
272     writes before consuming its whole stdin. Avoid this deadlock.
273   * Fix alt tags for outline checkboxes.
274
275  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
276
277 ikiwiki (1.25) unstable; urgency=low
278
279   * Add proper waitpid calls for open2ed processes throughout to avoid
280     zombies; this hit htmltidy especially badly.
281   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
282     subversion repos and fixing some other issues.
283   * Add support for tla, contributed by Clint Adams. Closes: #385936
284   * Add support for mercurial, contributed by Emanuele Aina.
285   * Include <link rel> tag for RSS feeds, used by some aggregators and
286     firefox to find the feed.
287   * Add a linkmap plugin (requires graphviz).
288
289  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
290
291 ikiwiki (1.24) unstable; urgency=low
292
293   * Simplify the data structure returned by rcs_recentchanges to avoid
294     each rcs plugin needing to form complex strings on its own.
295   * Fix another destpage issue in the inline directive. Closes: #385512
296     again.
297
298  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
299
300 ikiwiki (1.23) unstable; urgency=low
301
302   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
303
304  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
305
306 ikiwiki (1.22) unstable; urgency=low
307
308   * Change how the stylesheet url is determined in the templates: Remove
309     STYLEURL and add BASEURL to all templates (some already had it). This
310     new more general variable can be used to link to other things (eg, images)
311     from the template, as well as stylesheets.
312   * Fix a bug introduced last version to do with nested inlines.
313   * Allow preprocessor directives to span multiple lines, both to make
314     long ones with lots of values easier to write, and to allow for ones with
315     multi-line quoted values.
316   * Allow preprocessor directives to contain python-like triple-quoted
317     text blocks, for easy nesting of quotes inside.
318   * Add a template plugin.
319   * Make pagespec merge code smarter about merging duplicate pagespecs.
320   * Patch from Jordà Polo to make Setup::Standard support hashes in config
321     files.
322   * Change order of linkify and preprocess; first preprocess and then linkify.
323     This allows passing a wikilink inside a parameter to a preprocessor
324     directive without it being expanded to html, and leaking out of the
325     parameter, which had required some non-obvious use of triple-quoting
326     to avoid. Note that any preprocessor plugins that output something
327     that looks like a wikilink will now have it treated as such; AFAIK
328     this doesn't change any behavior though except for the template plugin.
329   * Enable preprocessor directives when previewing an edit.
330   * Make all pages pull in a local.css style sheet, if present. This won't
331     be included in ikiwiki, but can be created to make local styling changes
332     w/o needing to merge in every new change to the distributed style.css.
333   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
334   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
335     from a different directory.
336   * Generalised preprocesser loop protection code.
337   * Patch from James Westby to allow a description to be set for rss feeds.
338   * Patch from James Westby to add a template for the search form.
339   * Added a ddate plugin.
340   * Patch from James Westby to add a --sslcookie switch, which forces
341     cookies to only be sent over ssl connections to avoid interception.
342   * Fix preferences page on anonok wikis; still need to sign in to get
343     to the preferences page.
344   * Add toc (table of contents) plugin.
345   * Change htmlize, format, and sanitize hooks to use named parameters.
346   * Patch from James Westby to add an actions option to inline; this
347     adds Edit and Discussion links at the end of blog entries.
348   * Due to some css changes, you'll want to rebuild your wiki on upgrade
349     to this version. Will be handled automatically by the deb.
350   * Add processed date to aggregate preprocessor directive status output.
351
352  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
353
354 ikiwiki (1.21) unstable; urgency=low
355
356   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
357   * If a page links to itself, mark up the link text in a span with
358     class="selflink" so that it can be styled. I don't have a useful style
359     defined for that though.
360   * Call filter hooks on inlined page content.
361   * Support inlining pages raw, rather than creating a blog.
362   * Clean up yes/no parameter parsing in inline plugin.
363   * Implemented better cycle detection in the inline plugin; nested inlines
364     will now work.
365   * Add a map plugin contributed by Alessandro Dotti Contra.
366   * Add otl format plugin, which handles files as created by vimoutliner.
367   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
368   * Add first draft at a Restructured Text (rst) plugin, by Sergio
369     Talens-Oliag. Note that this has many known issues -- see the caveats on
370     the plugin's page.
371   * Credit everyone who wrote a plugin on the plugins' wiki pages.
372   * Fix utf-8 in blog post form.
373
374  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
375
376 ikiwiki (1.20) unstable; urgency=low
377
378   * Relicense the templates and basewiki under the 2-clause BSD license.
379     Since these can easily become part of other people's websites, they
380     should be under as permissive a license as possible.
381   * Add --syslog config option, to log to the syslog.
382   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
383     transient failure to fork (which I've seen happen in the wild).
384   * Fix a bug in the aggregator introduced last version that caused all
385     aggregator state to be lost during a non-aggregating build.
386
387  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
388
389 ikiwiki (1.19) unstable; urgency=low
390
391   * Fix several related bugs in page type determination during online editing.
392   * Add some locking to prevent 2 aggregators from running at once.
393   * Fix an infinite loop in the aggregator when finding a unique filename.
394
395  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
396
397 ikiwiki (1.18) unstable; urgency=low
398
399   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
400   * Add --version.
401   * Man page format fixups.
402   * If the meta plugin overides the page title, set a title_overridden
403     variable in the template to true. This allows doing things with the
404     templates conditional on the title being overriden.
405   * Add a %pagecase which maps lower-case page names to the actual case
406     used in the filename. Use this in bestlinks calculation instead of
407     forcing the link to lowercase.
408   * Also use %pagecase in various other places that want to check if a page
409     with a given name exists.
410   * This means that links to pages with mixed case names will now work,
411     even if the link is in some other case mixture, and mixed case pages
412     should be fully supported throughout ikiwiki.
413   * Recommend rebuilding wikis on upgrade to this version.
414
415  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
416
417 ikiwiki (1.17) unstable; urgency=low
418
419   * Disable tidy generator tag.
420   * Move tidy back to sanitize hook, found out how to only show body.
421   * Turn off tidy indentation too.
422   * Turn on HTML::Template loop_context_vars; not actually used in stock
423     templates but can be useful for things like making comma-delimited lists
424     of tags or what have you.
425   * Remove <br> from end of aggregate preprocessor directive output.
426   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
427     case-sensative filesystems like OSX.
428   * Improve markdown loading. First, try to load it as a proper perl module,
429     in case it was installed as one. Then fall back to trying
430     /usr/bin/markdown.
431   * Document in install page how to install markdown, since it has no
432     installation procedure in the upstream tarball.
433   * Set die_on_bad_params => 0 for all templates, to allow users to modify
434     them without annoyances.
435   * Suck in the page content when generating an inline archive page, to work
436     around the meta plugin's lack of caching of title metadata across runs.
437
438  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
439
440 ikiwiki (1.16) unstable; urgency=low
441
442   * Try to handle relative links in aggregated feeds. However,
443     the current support is a crude hack due to limitations of XML::Feed:
444     xml:base is not supported, neither is Content-Location. And of course,
445     relative links in RSS feeds are ill-undefined..
446   * Make aggregator save permalinks and author name to pages as metadata.
447   * Add permalink and author support to meta plugin, affecting RSS feeds
448     and blog pages.
449   * Various CSS and formatting changes.
450   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
451   * Add xhtml files to the default prune regexp.
452   * Also generate rel=bookmark links for permalinks.
453   * Fix the htmltidy plugin, which wasn't working due my breaking it when
454     I added it..
455   * Don't run tidy with -xml as that fails if the input is not well-formed.
456     Run it with -asxhtml instead, so it will output well-formed xhtml no
457     matter what the input.
458   * Disable tidy warnings too.
459   * Add a new format hook, and make tidy use it, since tidy can really only
460     operate on and output complete html documents, not the body chunks
461     that sanitise gets.
462   * Fix dates in rss feeds if running localised, so they're still rfc 822.
463
464  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
465
466 ikiwiki (1.15) unstable; urgency=low
467
468   * Remove CDPATH and other env vars perl taint checking doesn't like.
469     Closes: #381279
470   * Added created_before and created_after PageSpec limits.
471
472  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
473
474 ikiwiki (1.14) unstable; urgency=low
475
476   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
477     by 10% or so.
478   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
479   * Added many unit tests for pagespec_match.
480
481  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
482
483 ikiwiki (1.13) unstable; urgency=low
484
485   * ikiwiki can now download and aggregate feeds with its new aggregate
486     plugin, so it's possible to implement a Planet using ikiwiki!
487   * Add a run_hooks function for the common task of running all hooks of a
488     given type.
489   * Add a savestate hook.
490   * Don't put blog post forms on pages if there's no cgiurl set.
491   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
492     --wrappers to do that.
493   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
494     to update pages that haven't changed on disk.
495   * Change meta tags to use html entity-escaped text for values, so that
496     quotes and such can be represented in title tags.
497   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
498     for the above.
499   * Make --rebuild also cause --aggregate to re-download and write aggregated
500     pages.
501   * Avoid outputting duplicate meta info.
502   * Include title metadata on aggregated posts for capitalised and un-munged
503     titles.
504   * Title metadata of inlined pages now shows up in blogs and rss feeds.
505   * Fix issue with unicode filenames and updating the hyper estradier search
506     index. (Aka Please Please Please, let that be the last one.)
507   * Patch from Roland Mas to support an rss=no parameter to inline directives.
508     Closes: #380743
509   * Renamed GlobLists to PageSpecs.
510   * PageSpecs can now include nested parens, "and", and "or". This remains
511     backwards compatible to the old GlobList format. It's implemented by
512     treating the GlobList as a very limited microlanguage that is transformed
513     to perl code that does the matching.
514   * The old GlobList format is deprecated, and I encourage users to switch to
515     using the new PageSpec format. Compatability with the old format will be
516     removed at some point, possibly by 2.0.
517   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
518   * Add support for creation_month and creation_year to PageSpec.
519     Closes: #380680
520   * Changes to index file encoding.
521
522  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
523
524 ikiwiki (1.12) unstable; urgency=low
525
526   "Viva l'Italia!"
527   * New pagestats plugin from Enrico, which can generate a table counting
528     the backlinks for each page, or a del.icio.us style cloud.
529   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
530     the wikiformat plugin works. Thanks, Emanuele Aina.
531   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
532     display, running them through pagetitle. This removes ugly underscores and
533     other gunk from the display, much nicer. You may want to rebuild your wiki
534     when upgrading to get the cleanup globally.
535   * Polygen plugin from Enrico.
536   * htmltidy plugin from Faidon.
537   * Locale patch from Faidon:
538     - Adds a locale setting to setup files.
539     - Proper local time, if the locale configuration option is used.
540     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
541       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
542       impossible.
543   * Add getopt hook type, this allows plugins to add new command-line options.
544   * Add --tagbase option to tag plugin.
545   * Add exclude option in setup files, works same as --exclude.
546   * Put categories in rss feeds for tagged items.
547   * Allow preprocessor directives to be expanded in inlined blog pages.
548     However, to avoid inlining loops etc, don't expand inline directives in
549     inlined pages.
550   * fortune plugin (trivial)
551   * Tag plugins according to type.
552
553  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
554
555 ikiwiki (1.11) unstable; urgency=low
556
557   * Patch from Enrico that
558     - Adds a tag plugin that allows more easily tagging pages.
559       The meta plugin can also still be used for that, but the tag plugin
560       also lists a page's tags at the bottom of the page.
561     - Allows preprocessor directives to have parameters with no specified
562       value.
563     - Fixes preprocessor directive parameter parsing so that
564       foo=bar baz now means "foo=bar" and a "baz" with no value.
565   * Run pagetemplate hooks when inlining pages so that inlined pages also
566     list their tags.
567   * Make all plugins with pagetemplate hooks check that variables exist
568     on the template before setting them, for robustness.
569   * Switch pagetemplate hooks to using named parameters.
570   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
571     This will be the page that a source page will be part of, which is
572     different than the source page for inlined pages.
573   * Audited all plugins to endure they pass (page, destpage) to htmllink
574     appropriatly. This means inlining of various plugins will not work
575     properly, with correct links generated.
576
577  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
578
579 ikiwiki (1.10) unstable; urgency=low
580
581   * Run page through any relevant filters when generating a page preview.
582   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
583     default throughout the wiki, not only on wikitext pages. Decided to call
584     this a feature, and split the camelcase support out into a separate plugin
585     that is independant of wikitext.
586   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
587
588  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
589
590 ikiwiki (1.9) unstable; urgency=low
591
592   * Improve display of parentlinks and page title of toplevel index page.
593   * Patch from Faidon to use svn --limit when possible for recentchanges,
594     speeds up recentchanges a lot for wikis with more history.
595   * Patch from Recai to fix utf8 issues in git backend.
596   * Add wikitext markup plugin, which supports ".wiki" pages written in the
597     original wiki syntax, CamelCase links and all.
598   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
599     support, to edit pages etc without a web server.
600   * Display CGI processing errors if present.
601   * Fix from Faidon for a XML parser issue that breaks utf-8 for
602     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
603     area, and also way slow.
604   * Match 'web commit from' in SVN and git, these are web commits too.
605     (Faidon)
606   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
607     readable and avoid future mistakes. The patch seems to work and for the
608     first time I have a UTF-8 username ;-) (Faidon)
609   * Use form->field consistently, not form->param.
610   * Patch from Recai to allow selection of page type when creating a new page.
611     Default page type is inherited from the link clicked on to create the new
612     page.
613
614  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
615
616 ikiwiki (1.8) unstable; urgency=low
617
618   * Fix orphans plugin to not count a link to a nonexistant page as a reason
619     for a page not being an orphan.
620   * Support pinging services such as Technorati using XML-RPC to notify them
621     about changes to rss feeds.
622   * Parse svn log as xml for improved utf8 and security. Note that this makes
623     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
624   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
625     flagged string even if the locale causes it to generate utf8 output,
626     so make sure to let perl know it should be handled as utf8. Also,
627     the optimised version used for standard time formats won't work if the
628     user has changed locale, so drop it. Thanks, Faidon Liambotis.
629   * Fix re-encoding of the comments field to utf8 if a commit fails
630     due to a conflict. Thanks, Faidon Liambotis.
631   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
632     Liambotis.
633   * Add insane double encode/decode to utf8 around call to markdown.
634     This works around a truely strange bug, which is apparently a bug in
635     perl, #376329. Also added a test case for it.
636   * Improve layout of edit page so formatting help link is always visible w/o
637     getting in the way of the preview.
638   * Centralised all calls to HTML::Template and force all the templates
639     to be read as utf8.
640   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
641   * Introduce add_plugins and disable_plugins config options in setup files.
642     This allows adding or removing plugins w/o overriding the whole list of
643     default plugins, which makes it easier to upgrade when new default plugins
644     are added.
645   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
646     default (of course!). Based on a patch by Faidon Liambotis.
647   * Add a html plugin, which can be used to write wikis in raw html,
648     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
649     defaults to not processing .html files, since w/o this plugin they would
650     be copied unsanitised. With this plugin, it will process and html
651     sanitise them, like any other page type.
652   * Rebuilding wrappers is necessary on upgrade to this version.
653   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
654     will be automatically done on all upgrades.
655   * Don't send pings if the wiki is being rebuilt.
656   * Work around very innefficient behavior in File::Spec::abs2rel. Result
657     is a savings of 2 pointless fork/execs per link calculation, which
658     results in ~25% speedup of ikiwiki building its own doc wiki, and
659     about 35% speedup displaying RecentChanges!
660   * Make RecentChanges use a table and some CSS, should be much more readable.
661     No code changes involved.
662   * Encode & in diffurl in examples, to conform to pedantic rules.
663   * Speed up RecentChanges by another 40% or so with some memoization.
664   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
665     in time to build the doc wiki.
666
667  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
668
669 ikiwiki (1.7) unstable; urgency=low
670
671   * Updated logo from Recai with some kerning and alingment tuning.
672   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
673     changed some output.
674   * Copyright update.
675
676  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
677
678 ikiwiki (1.6) unstable; urgency=low
679
680   * YA utf-8 patch from Recai, this time to fix previewing a page so that
681     the text in the input box is re-encoded back to utf-8.
682   * -CSD does not affect modules, so readfile() was not using the utf-8 input
683     layer, which led to lots of problems; make it force read files as utf-8.
684     Closes: #373203
685   * Note that as a consequence, this version of ikiwiki will actually try to
686     parse utf8 in source files for the first time, which may expose broken
687     utf8 in wiki sources that was hidden before. Most common will be
688     perl warnings like "utf8 "\xE9" does not map to Unicode"
689   * writefile() likewise needs to use the utf8 output layer.
690   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
691     there.
692   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
693     given the readfile fix.
694   * Add utf-8 testcases for readfile and htmlize.
695   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
696     safe.
697   * More utf-8 fixes from Recai, partly to things I broke above:
698     - The serious problem is that writefile() saves the content in undecoded
699       format in CGI, hence all (non-ascii) chars are corrupted permanently.
700     - Comment field in edit page is not decoded and all the non-ascii chars in
701       this field are corrupted as the result.  We should decode it as we do it
702       for the content.
703     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
704       character in print.
705   * New SVG logo from Recai.
706
707  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
708
709 ikiwiki (1.5) unstable; urgency=low
710
711   * Add --timeformat config option to allow changing how dates are displayed.
712     Note that as a side effect, dates will now be displayed using the local
713     timezone, not as GMT.
714   * More security review.
715   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
716     for some handy stuff like:
717     - Using links as a kind of tag; creating blog pages that list all pages
718       containing a given tag/link or not containing some other tag.
719     - Subscribing to mail notifications whenever a change is made to a page
720       that is a backlink of page foo. Ie, "Please notify me of changes in all
721       pages that link to my home page in the wiki"
722     - Locking any pages that are linked to from a particular page, so that
723       lists of locks can be exposed in the wiki.
724   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
725     when a todo item is done, instead of the previous moving it to a different
726     subdir.
727   * Allow pagetemplate plugins to override *anything* in the template.
728   * Add a meta plugin, which allows specifying various metadata about pages,
729     like license and author. It also allows for inserting html link and meta
730     tags into html, overriding the title, and adding hidden WikiLinks, which
731     can be useful when using link-based globbing for page categorisation.
732   * Remove preprocessor directives from inlined pages.
733   * Allow simple preprocessor directive values to be specified w/o quotes.
734   * Add support for using git instead of subversion as the RCS backend,
735     tremendous thanks to Recai Oktaş for this.
736   * Doc updates for git.
737   * Fix absolute url munging in rss generation to support https, ftp, etc urls
738     not just http urls.
739   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
740     utf-8 for edit and other fields, and for recentchanges. There may still
741     be utf-8 issues with the preferences page though.
742
743  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
744
745 ikiwiki (1.4) unstable; urgency=low
746
747   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
748     very strange way of enabling proper XHTML <br /> type tags. Output html
749     should be always valid again now.
750   * The page name and parent links has switched from using a <h1> to a styled
751     <span>, so pages can use <h1> internally instead of needing to use <h2>.
752   * Updated all of ikiwiki's own wiki pages for that.
753   * Add pagetemplate hook, which can be used by plugins that want to mess
754     around with adding new stuff to the page template.
755   * Remove headercontent; the search plugin now adds the search box to the
756     header by registering a pagetemplate hook, and other plugins should do
757     similarly.
758   * Rebuilding on upgrade to this version is recommended.
759   * Add a html validity check to the test suite, using the wdg-html-validator,
760     if available.
761   * Make the html valid when there is nothing in the actions list.
762   * Reordered some function call parameters for consistency.
763   * Enable full utf-8 support for page input and output.
764   * Add a workaround for markdown, which does not work well with utf-8
765     strings.
766   * --getctime had bitrotted (well I only ever used it the once so far..),
767     fix and make it a bit more flexible
768   * rcs_getctime is changed, now rather than needing to loop over all pages,
769     it should just use the rcs to get the ctime of the passed file.
770   * When inlining a page in another one, links from the inlined page are now
771     expanded the same as they are when rendering the inlined page as a
772     standalone page. So rather than being expanded from the POV of the
773     inlining page, they are expanded from the POV of the inlined page.
774
775     For example, a link from blog/foo to "bar" will now link to blog/bar
776     if it exists. Previously this needed to be a link explicitly to
777     "blog/bar"; such links will also continue to work.
778
779     (This was slightly complex to do as the link still has to be constructed
780     relative to the inlining page.)
781   * Make page edit textarea resize to fit browser window.
782   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
783     do not need a full rebuild, in order to update any basewiki pages.
784
785  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
786
787 ikiwiki (1.3) unstable; urgency=low
788
789   * Fix the preinst introduced in the last version. Closes: #367458
790
791  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
792
793 ikiwiki (1.2) unstable; urgency=low
794
795   * Remove dups from the brokenlinks list.
796   * Add libc6-dev to dependencies, needed to build wrappers.
797   * Install wikilist in correct location. Closes: #367371
798
799  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
800
801 ikiwiki (1.1) unstable; urgency=low
802
803   * Rename inlinepage to depends, so that it can be used to refer to more
804     dependency relationships than just inlining. This will require a rebuild
805     on upgrade to this version.
806   * Move the rss link, put it in the blogpost form if there is one and at the
807     top if not. This is both nicer because easier to find, and it cleans up
808     the code which had used inlinepage as a flag for adding the link later.
809   * Allow the depends GlobList to be built up from multiple sources (such as
810     plugins) during a page render.
811   * Which means that more than one blog is now supported to appear on a
812     single page. (With some limitations, like only the last one getting an
813     rss file.)
814   * Added a plugin system.
815   * Added a pagecount plugin, enabled by default.
816   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
817   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
818     backlinks when the backlinks hadn't really changed.
819   * Moved inline page support, rss generation etc into the inline plugin,
820     enabled by default.
821   * Added brokenlinks plugin, not enabled by default, but rather handy.
822   * Fix several broken links in the doc wiki.
823   * Smarter behavior when creating a page and a page of the same name (but
824     different location) already exists.
825   * Add an orphans plugin for finding pages that nothing links to.
826   * Removed backlinks page, which it turns out nothing used.
827   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
828     it, this will allow for adding a unit test suite.
829   * Add unit tests for several core functions, including globlist_match,
830     dirname, basename, bestlink, linkify, pagetitle, titlepage.
831   * Smart globlist merging.
832   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
833     to pave the way for adding other RCS support. This also changes the
834     setup files, where before they had svn => 1 or svn => 0, now they have
835     rcs => "svn" or rcs => "".
836   * Add a debian/NEWS file with upgrade notes.
837   * Load whatever rcs module is specified, so new ones can be just dropped in
838     as plugins and work. (Well, in theory.)
839   * Add some basic docs about writing RCS modules.
840   * Broke search capability out into a plugin, removed the --hyperestraier
841     switch.
842   * Added smiley plugin, nicely controlled and documented by the smileys page.
843   * Copied in some smileys from Moin Moin.
844   * Allow links of the form [[some page|page]], with whitespace in the link
845     text.
846   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
847     and --disable-plugin htmlscrubber.
848   * Allow discussion links on pages to be turned off with --no-discussion.
849   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
850   * Add some new config items to the estseek.conf template, which are needed
851     by hyperestraier 1.2.3.
852
853  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
854
855 ikiwiki (1.0) unstable; urgency=low
856
857   * First official release.
858
859  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400