]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
testing
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Add an openid plugin to support logging in using OpenID.
4   * Web commits by OpenID users will record the full OpenID url for the user,
5     but in recentchanges, these urls will be converted to a simplified display
6     form+link.
7   * Modified svn, git, tla backends to recognise such web commits.
8   * Move httpauth support to a plugin.
9   * Add openidsignup config option.
10   * Make the openid plugin support the callbacks from myopenid.com via its
11     affiliate program.
12   * Change how post signin actions are propigated through the signin process;
13     they're now stored in the session.
14   * Add optional "desc" parameter to shortcut definitions.
15   * Avoid locking the wiki at all when handling some basic cgi stuff
16     (searches, recentchanges).
17
18  -- Joey Hess <joeyh@debian.org>  Mon, 20 Nov 2006 06:54:12 -0500
19
20 ikiwiki (1.33) unstable; urgency=low
21
22   * Fix issue with aggregate plugin updating expired pages.
23   * Avoid syntax errors in templates used by the template plugin crashing
24     ikiwiki.
25   * Enable utf8 file IO in aggregate plugin.
26   * Fix some issues with the new registration form.
27   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
28   * Make sure to check for errors from every eval.
29   * Fix img plugin's handling of adding dependencies for images that do not
30     yet exist.
31   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
32     FORM-SUBMIT unusable on customised formbuilder templates. For now,
33     hardcode the submit buttons in editpage.tmpl instead of using the
34     template variable, which is ok, since the buttons are static.
35   * Work with hyperestraier 1.4.9.
36
37  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
38
39 ikiwiki (1.32) unstable; urgency=low
40
41   * Add a separate pass to find page links, and only render each page once,
42     instead of over and over. Typical speedup is ~4x. Max possible speedup:
43     8x.
44   * Add "scan" parameter to hook(), which is used to make the hook be called
45     during the scanning pass, as well as the render pass. The meta and tag
46     plugins need to use the new scan parameter, so will any others that modify
47     %links.
48   * Now that links are calculated in a separate pass, it can also
49     precalculate backlinks in one pass, which is O(N^2) instead of the
50     previous code that was O(N^3). A very nice speedup for wikis with lots
51     (thousands) of pages.
52   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
53     Erdem.
54   * Add a default stylesheet entry for the pagecloud.
55   * Add examples page with some examples of things that can be done using
56     ikiwiki, like a weblog. The examples can be copied into a user's wiki
57     for a quick start, without needing to learn everything about how to put
58     them together.
59   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
60   * Add perlmagick to build-depends so syntax check of img plugin works.
61     Closes: #396702
62   * Improve login/register process, the login dialog has only name and
63     password fields, which allows more web browsers to regognise it as a login
64     field, and is less confusing.
65   * Implemented expiry options for aggregate plugin.
66   * Use precalculated backlinks info when determining if files need an update
67     due to a page they link to being added/removed. Mostly significant if
68     there are lots of pages.
69   * Remove duplicate link info when saving index. In some cases it could
70     pile up rather badly. (Probably not the best way to deal with this
71     problem.)
72   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
73     or what have you, by creating enclosures for non-page items that are
74     included in feeds.
75
76  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
77
78 ikiwiki (1.31) unstable; urgency=low
79
80   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
81   * Change the rss feed title from the wikiname to the page title, with
82     an exception for the wiki's toplevel index page, which will still use the
83     wikiname as the feed title.
84     Overriding the page title with meta title already overrode the rss feed
85     tittle.
86   * Add an img plugin, based on Christian Mock's img plugin, but stripped
87     down to the bare essentials. Useful for handling large images on websites.
88   * Sanitize possibly problimatic characters out of the polygen grammar names,
89     just in case. Should not be exploitable anyway, since it only tries to run
90     polygen after finding the specified grammar file.
91   * Add missing dependency on the URI perl module.
92   * Add basic spam fighting tool for admins: An admin's prefs page now allows
93     editing a list of banned users.
94
95  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
96
97 ikiwiki (1.30) unstable; urgency=low
98
99   * Add no_override parameter to hook().
100   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
101     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
102     can be configured using a page in wiki.
103   * Fix support for --pingurl at the command line.
104   * Fix a subtle bug in will_render that broke some builds, by only clearing
105     items from renderedfiles the first time per build.
106   * Wrap entire technortati ping operation in an eval to catch all possible
107     failure modes, after I observed a simple ->value crashing ikiwiki when
108     a ping failed.
109
110  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
111
112 ikiwiki (1.29) unstable; urgency=low
113
114   * Patch from Paul Tötterman to use CP in the Makefile.
115   * Patch from Alec Berryman adding a http_auth config item that allows
116     using HTTP Authentication instead of ikiwiki's built in authentication.
117     Useful for eg, large sites with their own previously existing user auth
118     setup. Closes: #384534
119   * Change %renderedfiles to store an array of files rendered from a given
120     source file, to allow tracking of extra rendered files like rss feeds.
121   * Note that plugins that accessed this variable will need to be updated!
122     The plugin interface has been increased to version 1.01 for this change.
123     As few plugins use %renderedfiles I haven't done anything else to ensure
124     compatability of old plugins.
125   * Add will_render function to the plugin interface, used to register that a
126     page renders a destination file, and do some security checks. Previously
127     but no longer rendered files will be cleaned up.
128   * Use will_render in the inline and linkmap plugins.
129   * You will need to rebuild your wiki on upgrade to this version.
130   * Atom feed support based on a patch by Clint Adams.
131   * Add feeds=no option to inline preprocessor directive to turn off all types
132     of feeds.
133   * $IkiWiki::version now holds the program version, and is accessible to
134     plugins.
135   * Make the aggregate plugin emphasize error messages.
136   * Patch from Recai to limit recentchanges to displaying max 10 files for a
137     given changeset (to avoid large number of file changes excessively
138     bloating the page).
139
140  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
141
142 ikiwiki (1.28) unstable; urgency=low
143
144   * inline: Add ability to sort by page name, based on a patch from
145     Benjamin A'Lee.
146   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
147     braindead interface. Closes: #389383
148   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
149     and b) those poor Mac OSX users and their case insensative files!
150   * Don't fail syntax check if Text::Typography isn't installed.
151     Closes: #389406
152
153  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
154
155 ikiwiki (1.27) unstable; urgency=low
156
157   * Work on firming up the plugin interface:
158     - Plugins should not need to load IkiWiki::Render to get commonly
159       used functions, so moved some functions from there to IkiWiki.
160     - Picked out the set of functions and variables that most plugins
161       use, documented them, and made IkiWiki export them by default,
162       like a proper perl module should.
163     - Use the other functions at your own risk.
164     - This is not quite complete, I still have to decide whether to
165       export some other things.
166   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
167     referring to stuff now exported by the IkiWiki module.
168   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
169     to declare which version of the interface your plugin needs.
170   * Anyone with a third-party ikiwiki plugin is strongly encouraged
171     to make like changes to it and avoid use of non-exported symbols from
172     "IkiWiki::".
173   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
174   * Support hyperestradier version 1.4.2, which adds a new required phraseform
175     setting.
176   * If an inlined page has a permalink, link the page title to that.
177   * Patch from Recai to use utf8 when reading the setup file, so that
178     utf8 wikinames from there will be used properly.
179   * Patch from Recai to kill utf-8 on the wiki name when generating the
180     session cookie.
181   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
182   * Fix a baseurl problem in hyperestradier search results.
183   * Add a stub local.css to avoid problems with 404's.
184   * Patch from Recai to fix a wide character warning from the search plugin
185     during setup if the wikiname contains utf8.
186   * Yet another fix for those poor case-insensative OS X users.
187   * pagetemplate hooks are now also called when generating cgi pages.
188   * Add a favicon plugin, which simply adds a link tag for an icon to each
189     page (and cgis).
190   * Patch from James Westby to deal with the case where you're editing a
191     new page, hit cancel, and need to be redirected to somewhere sane.
192   * Various documentation improvements by various wiki users.
193   * Support Text::Markdown from CPAN, which has a different interface from
194     the original markdown or the one in Debian.
195   * Version the libcgi-session-perl dependency, some features that need
196     the new version are used in some cases (sslcookie).
197   * Numerous tla fixes from Clint.
198   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
199     a multi-resolution favicon.ico.
200   * README.Debian: typo Closes: #388110
201   * chomp trailing newline at the end of templates read in by the template
202     plugin, to allow use of the template preprocessor directive in
203     whitespace-sensative situations. Closes: #387073
204   * Patch from James Westby to make the location of the estseek.cgi script
205     configurable.
206   * Add typography (SmartyPants) plugin by Recai.
207   * Add --render mode, which can be used to preview an edit at the command
208     line by test rendering a single page.
209   * Add a googlecalendar plugin. A bit special-purpose, but it shows
210     one way to to deal with user-supplied content that could cause XSS
211     issues w/o the htmlscrubber, and won't survive the scrubber.
212
213  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
214
215 ikiwiki (1.26) unstable; urgency=low
216
217   * Add a missing -n to tla undo call.
218   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
219     writes before consuming its whole stdin. Avoid this deadlock.
220   * Fix alt tags for outline checkboxes.
221
222  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
223
224 ikiwiki (1.25) unstable; urgency=low
225
226   * Add proper waitpid calls for open2ed processes throughout to avoid
227     zombies; this hit htmltidy especially badly.
228   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
229     subversion repos and fixing some other issues.
230   * Add support for tla, contributed by Clint Adams. Closes: #385936
231   * Add support for mercurial, contributed by Emanuele Aina.
232   * Include <link rel> tag for RSS feeds, used by some aggregators and
233     firefox to find the feed.
234   * Add a linkmap plugin (requires graphviz).
235
236  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
237
238 ikiwiki (1.24) unstable; urgency=low
239
240   * Simplify the data structure returned by rcs_recentchanges to avoid
241     each rcs plugin needing to form complex strings on its own.
242   * Fix another destpage issue in the inline directive. Closes: #385512
243     again.
244
245  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
246
247 ikiwiki (1.23) unstable; urgency=low
248
249   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
250
251  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
252
253 ikiwiki (1.22) unstable; urgency=low
254
255   * Change how the stylesheet url is determined in the templates: Remove
256     STYLEURL and add BASEURL to all templates (some already had it). This
257     new more general variable can be used to link to other things (eg, images)
258     from the template, as well as stylesheets.
259   * Fix a bug introduced last version to do with nested inlines.
260   * Allow preprocessor directives to span multiple lines, both to make
261     long ones with lots of values easier to write, and to allow for ones with
262     multi-line quoted values.
263   * Allow preprocessor directives to contain python-like triple-quoted
264     text blocks, for easy nesting of quotes inside.
265   * Add a template plugin.
266   * Make pagespec merge code smarter about merging duplicate pagespecs.
267   * Patch from Jordà Polo to make Setup::Standard support hashes in config
268     files.
269   * Change order of linkify and preprocess; first preprocess and then linkify.
270     This allows passing a wikilink inside a parameter to a preprocessor
271     directive without it being expanded to html, and leaking out of the
272     parameter, which had required some non-obvious use of triple-quoting
273     to avoid. Note that any preprocessor plugins that output something
274     that looks like a wikilink will now have it treated as such; AFAIK
275     this doesn't change any behavior though except for the template plugin.
276   * Enable preprocessor directives when previewing an edit.
277   * Make all pages pull in a local.css style sheet, if present. This won't
278     be included in ikiwiki, but can be created to make local styling changes
279     w/o needing to merge in every new change to the distributed style.css.
280   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
281   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
282     from a different directory.
283   * Generalised preprocesser loop protection code.
284   * Patch from James Westby to allow a description to be set for rss feeds.
285   * Patch from James Westby to add a template for the search form.
286   * Added a ddate plugin.
287   * Patch from James Westby to add a --sslcookie switch, which forces
288     cookies to only be sent over ssl connections to avoid interception.
289   * Fix preferences page on anonok wikis; still need to sign in to get
290     to the preferences page.
291   * Add toc (table of contents) plugin.
292   * Change htmlize, format, and sanitize hooks to use named parameters.
293   * Patch from James Westby to add an actions option to inline; this
294     adds Edit and Discussion links at the end of blog entries.
295   * Due to some css changes, you'll want to rebuild your wiki on upgrade
296     to this version. Will be handled automatically by the deb.
297   * Add processed date to aggregate preprocessor directive status output.
298
299  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
300
301 ikiwiki (1.21) unstable; urgency=low
302
303   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
304   * If a page links to itself, mark up the link text in a span with
305     class="selflink" so that it can be styled. I don't have a useful style
306     defined for that though.
307   * Call filter hooks on inlined page content.
308   * Support inlining pages raw, rather than creating a blog.
309   * Clean up yes/no parameter parsing in inline plugin.
310   * Implemented better cycle detection in the inline plugin; nested inlines
311     will now work.
312   * Add a map plugin contributed by Alessandro Dotti Contra.
313   * Add otl format plugin, which handles files as created by vimoutliner.
314   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
315   * Add first draft at a Restructured Text (rst) plugin, by Sergio
316     Talens-Oliag. Note that this has many known issues -- see the caveats on
317     the plugin's page.
318   * Credit everyone who wrote a plugin on the plugins' wiki pages.
319   * Fix utf-8 in blog post form.
320
321  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
322
323 ikiwiki (1.20) unstable; urgency=low
324
325   * Relicense the templates and basewiki under the 2-clause BSD license.
326     Since these can easily become part of other people's websites, they
327     should be under as permissive a license as possible.
328   * Add --syslog config option, to log to the syslog.
329   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
330     transient failure to fork (which I've seen happen in the wild).
331   * Fix a bug in the aggregator introduced last version that caused all
332     aggregator state to be lost during a non-aggregating build.
333
334  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
335
336 ikiwiki (1.19) unstable; urgency=low
337
338   * Fix several related bugs in page type determination during online editing.
339   * Add some locking to prevent 2 aggregators from running at once.
340   * Fix an infinite loop in the aggregator when finding a unique filename.
341
342  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
343
344 ikiwiki (1.18) unstable; urgency=low
345
346   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
347   * Add --version.
348   * Man page format fixups.
349   * If the meta plugin overides the page title, set a title_overridden
350     variable in the template to true. This allows doing things with the
351     templates conditional on the title being overriden.
352   * Add a %pagecase which maps lower-case page names to the actual case
353     used in the filename. Use this in bestlinks calculation instead of
354     forcing the link to lowercase.
355   * Also use %pagecase in various other places that want to check if a page
356     with a given name exists.
357   * This means that links to pages with mixed case names will now work,
358     even if the link is in some other case mixture, and mixed case pages
359     should be fully supported throughout ikiwiki.
360   * Recommend rebuilding wikis on upgrade to this version.
361
362  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
363
364 ikiwiki (1.17) unstable; urgency=low
365
366   * Disable tidy generator tag.
367   * Move tidy back to sanitize hook, found out how to only show body.
368   * Turn off tidy indentation too.
369   * Turn on HTML::Template loop_context_vars; not actually used in stock
370     templates but can be useful for things like making comma-delimited lists
371     of tags or what have you.
372   * Remove <br> from end of aggregate preprocessor directive output.
373   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
374     case-sensative filesystems like OSX.
375   * Improve markdown loading. First, try to load it as a proper perl module,
376     in case it was installed as one. Then fall back to trying
377     /usr/bin/markdown.
378   * Document in install page how to install markdown, since it has no
379     installation procedure in the upstream tarball.
380   * Set die_on_bad_params => 0 for all templates, to allow users to modify
381     them without annoyances.
382   * Suck in the page content when generating an inline archive page, to work
383     around the meta plugin's lack of caching of title metadata across runs.
384
385  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
386
387 ikiwiki (1.16) unstable; urgency=low
388
389   * Try to handle relative links in aggregated feeds. However,
390     the current support is a crude hack due to limitations of XML::Feed:
391     xml:base is not supported, neither is Content-Location. And of course,
392     relative links in RSS feeds are ill-undefined..
393   * Make aggregator save permalinks and author name to pages as metadata.
394   * Add permalink and author support to meta plugin, affecting RSS feeds
395     and blog pages.
396   * Various CSS and formatting changes.
397   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
398   * Add xhtml files to the default prune regexp.
399   * Also generate rel=bookmark links for permalinks.
400   * Fix the htmltidy plugin, which wasn't working due my breaking it when
401     I added it..
402   * Don't run tidy with -xml as that fails if the input is not well-formed.
403     Run it with -asxhtml instead, so it will output well-formed xhtml no
404     matter what the input.
405   * Disable tidy warnings too.
406   * Add a new format hook, and make tidy use it, since tidy can really only
407     operate on and output complete html documents, not the body chunks
408     that sanitise gets.
409   * Fix dates in rss feeds if running localised, so they're still rfc 822.
410
411  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
412
413 ikiwiki (1.15) unstable; urgency=low
414
415   * Remove CDPATH and other env vars perl taint checking doesn't like.
416     Closes: #381279
417   * Added created_before and created_after PageSpec limits.
418
419  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
420
421 ikiwiki (1.14) unstable; urgency=low
422
423   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
424     by 10% or so.
425   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
426   * Added many unit tests for pagespec_match.
427
428  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
429
430 ikiwiki (1.13) unstable; urgency=low
431
432   * ikiwiki can now download and aggregate feeds with its new aggregate
433     plugin, so it's possible to implement a Planet using ikiwiki!
434   * Add a run_hooks function for the common task of running all hooks of a
435     given type.
436   * Add a savestate hook.
437   * Don't put blog post forms on pages if there's no cgiurl set.
438   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
439     --wrappers to do that.
440   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
441     to update pages that haven't changed on disk.
442   * Change meta tags to use html entity-escaped text for values, so that
443     quotes and such can be represented in title tags.
444   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
445     for the above.
446   * Make --rebuild also cause --aggregate to re-download and write aggregated
447     pages.
448   * Avoid outputting duplicate meta info.
449   * Include title metadata on aggregated posts for capitalised and un-munged
450     titles.
451   * Title metadata of inlined pages now shows up in blogs and rss feeds.
452   * Fix issue with unicode filenames and updating the hyper estradier search
453     index. (Aka Please Please Please, let that be the last one.)
454   * Patch from Roland Mas to support an rss=no parameter to inline directives.
455     Closes: #380743
456   * Renamed GlobLists to PageSpecs.
457   * PageSpecs can now include nested parens, "and", and "or". This remains
458     backwards compatible to the old GlobList format. It's implemented by
459     treating the GlobList as a very limited microlanguage that is transformed
460     to perl code that does the matching.
461   * The old GlobList format is deprecated, and I encourage users to switch to
462     using the new PageSpec format. Compatability with the old format will be
463     removed at some point, possibly by 2.0.
464   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
465   * Add support for creation_month and creation_year to PageSpec.
466     Closes: #380680
467   * Changes to index file encoding.
468
469  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
470
471 ikiwiki (1.12) unstable; urgency=low
472
473   "Viva l'Italia!"
474   * New pagestats plugin from Enrico, which can generate a table counting
475     the backlinks for each page, or a del.icio.us style cloud.
476   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
477     the wikiformat plugin works. Thanks, Emanuele Aina.
478   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
479     display, running them through pagetitle. This removes ugly underscores and
480     other gunk from the display, much nicer. You may want to rebuild your wiki
481     when upgrading to get the cleanup globally.
482   * Polygen plugin from Enrico.
483   * htmltidy plugin from Faidon.
484   * Locale patch from Faidon:
485     - Adds a locale setting to setup files.
486     - Proper local time, if the locale configuration option is used.
487     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
488       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
489       impossible.
490   * Add getopt hook type, this allows plugins to add new command-line options.
491   * Add --tagbase option to tag plugin.
492   * Add exclude option in setup files, works same as --exclude.
493   * Put categories in rss feeds for tagged items.
494   * Allow preprocessor directives to be expanded in inlined blog pages.
495     However, to avoid inlining loops etc, don't expand inline directives in
496     inlined pages.
497   * fortune plugin (trivial)
498   * Tag plugins according to type.
499
500  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
501
502 ikiwiki (1.11) unstable; urgency=low
503
504   * Patch from Enrico that
505     - Adds a tag plugin that allows more easily tagging pages.
506       The meta plugin can also still be used for that, but the tag plugin
507       also lists a page's tags at the bottom of the page.
508     - Allows preprocessor directives to have parameters with no specified
509       value.
510     - Fixes preprocessor directive parameter parsing so that
511       foo=bar baz now means "foo=bar" and a "baz" with no value.
512   * Run pagetemplate hooks when inlining pages so that inlined pages also
513     list their tags.
514   * Make all plugins with pagetemplate hooks check that variables exist
515     on the template before setting them, for robustness.
516   * Switch pagetemplate hooks to using named parameters.
517   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
518     This will be the page that a source page will be part of, which is
519     different than the source page for inlined pages.
520   * Audited all plugins to endure they pass (page, destpage) to htmllink
521     appropriatly. This means inlining of various plugins will not work
522     properly, with correct links generated.
523
524  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
525
526 ikiwiki (1.10) unstable; urgency=low
527
528   * Run page through any relevant filters when generating a page preview.
529   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
530     default throughout the wiki, not only on wikitext pages. Decided to call
531     this a feature, and split the camelcase support out into a separate plugin
532     that is independant of wikitext.
533   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
534
535  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
536
537 ikiwiki (1.9) unstable; urgency=low
538
539   * Improve display of parentlinks and page title of toplevel index page.
540   * Patch from Faidon to use svn --limit when possible for recentchanges,
541     speeds up recentchanges a lot for wikis with more history.
542   * Patch from Recai to fix utf8 issues in git backend.
543   * Add wikitext markup plugin, which supports ".wiki" pages written in the
544     original wiki syntax, CamelCase links and all.
545   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
546     support, to edit pages etc without a web server.
547   * Display CGI processing errors if present.
548   * Fix from Faidon for a XML parser issue that breaks utf-8 for
549     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
550     area, and also way slow.
551   * Match 'web commit from' in SVN and git, these are web commits too.
552     (Faidon)
553   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
554     readable and avoid future mistakes. The patch seems to work and for the
555     first time I have a UTF-8 username ;-) (Faidon)
556   * Use form->field consistently, not form->param.
557   * Patch from Recai to allow selection of page type when creating a new page.
558     Default page type is inherited from the link clicked on to create the new
559     page.
560
561  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
562
563 ikiwiki (1.8) unstable; urgency=low
564
565   * Fix orphans plugin to not count a link to a nonexistant page as a reason
566     for a page not being an orphan.
567   * Support pinging services such as Technorati using XML-RPC to notify them
568     about changes to rss feeds.
569   * Parse svn log as xml for improved utf8 and security. Note that this makes
570     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
571   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
572     flagged string even if the locale causes it to generate utf8 output,
573     so make sure to let perl know it should be handled as utf8. Also,
574     the optimised version used for standard time formats won't work if the
575     user has changed locale, so drop it. Thanks, Faidon Liambotis.
576   * Fix re-encoding of the comments field to utf8 if a commit fails
577     due to a conflict. Thanks, Faidon Liambotis.
578   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
579     Liambotis.
580   * Add insane double encode/decode to utf8 around call to markdown.
581     This works around a truely strange bug, which is apparently a bug in
582     perl, #376329. Also added a test case for it.
583   * Improve layout of edit page so formatting help link is always visible w/o
584     getting in the way of the preview.
585   * Centralised all calls to HTML::Template and force all the templates
586     to be read as utf8.
587   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
588   * Introduce add_plugins and disable_plugins config options in setup files.
589     This allows adding or removing plugins w/o overriding the whole list of
590     default plugins, which makes it easier to upgrade when new default plugins
591     are added.
592   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
593     default (of course!). Based on a patch by Faidon Liambotis.
594   * Add a html plugin, which can be used to write wikis in raw html,
595     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
596     defaults to not processing .html files, since w/o this plugin they would
597     be copied unsanitised. With this plugin, it will process and html
598     sanitise them, like any other page type.
599   * Rebuilding wrappers is necessary on upgrade to this version.
600   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
601     will be automatically done on all upgrades.
602   * Don't send pings if the wiki is being rebuilt.
603   * Work around very innefficient behavior in File::Spec::abs2rel. Result
604     is a savings of 2 pointless fork/execs per link calculation, which
605     results in ~25% speedup of ikiwiki building its own doc wiki, and
606     about 35% speedup displaying RecentChanges!
607   * Make RecentChanges use a table and some CSS, should be much more readable.
608     No code changes involved.
609   * Encode & in diffurl in examples, to conform to pedantic rules.
610   * Speed up RecentChanges by another 40% or so with some memoization.
611   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
612     in time to build the doc wiki.
613
614  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
615
616 ikiwiki (1.7) unstable; urgency=low
617
618   * Updated logo from Recai with some kerning and alingment tuning.
619   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
620     changed some output.
621   * Copyright update.
622
623  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
624
625 ikiwiki (1.6) unstable; urgency=low
626
627   * YA utf-8 patch from Recai, this time to fix previewing a page so that
628     the text in the input box is re-encoded back to utf-8.
629   * -CSD does not affect modules, so readfile() was not using the utf-8 input
630     layer, which led to lots of problems; make it force read files as utf-8.
631     Closes: #373203
632   * Note that as a consequence, this version of ikiwiki will actually try to
633     parse utf8 in source files for the first time, which may expose broken
634     utf8 in wiki sources that was hidden before. Most common will be
635     perl warnings like "utf8 "\xE9" does not map to Unicode"
636   * writefile() likewise needs to use the utf8 output layer.
637   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
638     there.
639   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
640     given the readfile fix.
641   * Add utf-8 testcases for readfile and htmlize.
642   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
643     safe.
644   * More utf-8 fixes from Recai, partly to things I broke above:
645     - The serious problem is that writefile() saves the content in undecoded
646       format in CGI, hence all (non-ascii) chars are corrupted permanently.
647     - Comment field in edit page is not decoded and all the non-ascii chars in
648       this field are corrupted as the result.  We should decode it as we do it
649       for the content.
650     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
651       character in print.
652   * New SVG logo from Recai.
653
654  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
655
656 ikiwiki (1.5) unstable; urgency=low
657
658   * Add --timeformat config option to allow changing how dates are displayed.
659     Note that as a side effect, dates will now be displayed using the local
660     timezone, not as GMT.
661   * More security review.
662   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
663     for some handy stuff like:
664     - Using links as a kind of tag; creating blog pages that list all pages
665       containing a given tag/link or not containing some other tag.
666     - Subscribing to mail notifications whenever a change is made to a page
667       that is a backlink of page foo. Ie, "Please notify me of changes in all
668       pages that link to my home page in the wiki"
669     - Locking any pages that are linked to from a particular page, so that
670       lists of locks can be exposed in the wiki.
671   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
672     when a todo item is done, instead of the previous moving it to a different
673     subdir.
674   * Allow pagetemplate plugins to override *anything* in the template.
675   * Add a meta plugin, which allows specifying various metadata about pages,
676     like license and author. It also allows for inserting html link and meta
677     tags into html, overriding the title, and adding hidden WikiLinks, which
678     can be useful when using link-based globbing for page categorisation.
679   * Remove preprocessor directives from inlined pages.
680   * Allow simple preprocessor directive values to be specified w/o quotes.
681   * Add support for using git instead of subversion as the RCS backend,
682     tremendous thanks to Recai Oktaş for this.
683   * Doc updates for git.
684   * Fix absolute url munging in rss generation to support https, ftp, etc urls
685     not just http urls.
686   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
687     utf-8 for edit and other fields, and for recentchanges. There may still
688     be utf-8 issues with the preferences page though.
689
690  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
691
692 ikiwiki (1.4) unstable; urgency=low
693
694   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
695     very strange way of enabling proper XHTML <br /> type tags. Output html
696     should be always valid again now.
697   * The page name and parent links has switched from using a <h1> to a styled
698     <span>, so pages can use <h1> internally instead of needing to use <h2>.
699   * Updated all of ikiwiki's own wiki pages for that.
700   * Add pagetemplate hook, which can be used by plugins that want to mess
701     around with adding new stuff to the page template.
702   * Remove headercontent; the search plugin now adds the search box to the
703     header by registering a pagetemplate hook, and other plugins should do
704     similarly.
705   * Rebuilding on upgrade to this version is recommended.
706   * Add a html validity check to the test suite, using the wdg-html-validator,
707     if available.
708   * Make the html valid when there is nothing in the actions list.
709   * Reordered some function call parameters for consistency.
710   * Enable full utf-8 support for page input and output.
711   * Add a workaround for markdown, which does not work well with utf-8
712     strings.
713   * --getctime had bitrotted (well I only ever used it the once so far..),
714     fix and make it a bit more flexible
715   * rcs_getctime is changed, now rather than needing to loop over all pages,
716     it should just use the rcs to get the ctime of the passed file.
717   * When inlining a page in another one, links from the inlined page are now
718     expanded the same as they are when rendering the inlined page as a
719     standalone page. So rather than being expanded from the POV of the
720     inlining page, they are expanded from the POV of the inlined page.
721
722     For example, a link from blog/foo to "bar" will now link to blog/bar
723     if it exists. Previously this needed to be a link explicitly to
724     "blog/bar"; such links will also continue to work.
725
726     (This was slightly complex to do as the link still has to be constructed
727     relative to the inlining page.)
728   * Make page edit textarea resize to fit browser window.
729   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
730     do not need a full rebuild, in order to update any basewiki pages.
731
732  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
733
734 ikiwiki (1.3) unstable; urgency=low
735
736   * Fix the preinst introduced in the last version. Closes: #367458
737
738  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
739
740 ikiwiki (1.2) unstable; urgency=low
741
742   * Remove dups from the brokenlinks list.
743   * Add libc6-dev to dependencies, needed to build wrappers.
744   * Install wikilist in correct location. Closes: #367371
745
746  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
747
748 ikiwiki (1.1) unstable; urgency=low
749
750   * Rename inlinepage to depends, so that it can be used to refer to more
751     dependency relationships than just inlining. This will require a rebuild
752     on upgrade to this version.
753   * Move the rss link, put it in the blogpost form if there is one and at the
754     top if not. This is both nicer because easier to find, and it cleans up
755     the code which had used inlinepage as a flag for adding the link later.
756   * Allow the depends GlobList to be built up from multiple sources (such as
757     plugins) during a page render.
758   * Which means that more than one blog is now supported to appear on a
759     single page. (With some limitations, like only the last one getting an
760     rss file.)
761   * Added a plugin system.
762   * Added a pagecount plugin, enabled by default.
763   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
764   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
765     backlinks when the backlinks hadn't really changed.
766   * Moved inline page support, rss generation etc into the inline plugin,
767     enabled by default.
768   * Added brokenlinks plugin, not enabled by default, but rather handy.
769   * Fix several broken links in the doc wiki.
770   * Smarter behavior when creating a page and a page of the same name (but
771     different location) already exists.
772   * Add an orphans plugin for finding pages that nothing links to.
773   * Removed backlinks page, which it turns out nothing used.
774   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
775     it, this will allow for adding a unit test suite.
776   * Add unit tests for several core functions, including globlist_match,
777     dirname, basename, bestlink, linkify, pagetitle, titlepage.
778   * Smart globlist merging.
779   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
780     to pave the way for adding other RCS support. This also changes the
781     setup files, where before they had svn => 1 or svn => 0, now they have
782     rcs => "svn" or rcs => "".
783   * Add a debian/NEWS file with upgrade notes.
784   * Load whatever rcs module is specified, so new ones can be just dropped in
785     as plugins and work. (Well, in theory.)
786   * Add some basic docs about writing RCS modules.
787   * Broke search capability out into a plugin, removed the --hyperestraier
788     switch.
789   * Added smiley plugin, nicely controlled and documented by the smileys page.
790   * Copied in some smileys from Moin Moin.
791   * Allow links of the form [[some page|page]], with whitespace in the link
792     text.
793   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
794     and --disable-plugin htmlscrubber.
795   * Allow discussion links on pages to be turned off with --no-discussion.
796   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
797   * Add some new config items to the estseek.conf template, which are needed
798     by hyperestraier 1.2.3.
799
800  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
801
802 ikiwiki (1.0) unstable; urgency=low
803
804   * First official release.
805
806  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400