]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
todo
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.30) UNRELEASED; urgency=low
2
3   * Add no_override parameter to hook().
4   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
5     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
6     can be configured using a page in wiki.
7   * Fix support for --pingurl at the command line.
8   * Fix a subtle bug in will_render that broke some builds, by only clearing
9     items from renderedfiles the first time per build.
10   * Wrap entire technortati ping operation in an eval to catch all possible
11     failure modes, after I observed a simple ->value crashing ikiwiki when
12     a ping failed.
13
14  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:02:39 -0400
15
16 ikiwiki (1.29) unstable; urgency=low
17
18   * Patch from Paul Tötterman to use CP in the Makefile.
19   * Patch from Alec Berryman adding a http_auth config item that allows
20     using HTTP Authentication instead of ikiwiki's built in authentication.
21     Useful for eg, large sites with their own previously existing user auth
22     setup. Closes: #384534
23   * Change %renderedfiles to store an array of files rendered from a given
24     source file, to allow tracking of extra rendered files like rss feeds.
25   * Note that plugins that accessed this variable will need to be updated!
26     The plugin interface has been increased to version 1.01 for this change.
27     As few plugins use %renderedfiles I haven't done anything else to ensure
28     compatability of old plugins.
29   * Add will_render function to the plugin interface, used to register that a
30     page renders a destination file, and do some security checks. Previously
31     but no longer rendered files will be cleaned up.
32   * Use will_render in the inline and linkmap plugins.
33   * You will need to rebuild your wiki on upgrade to this version.
34   * Atom feed support based on a patch by Clint Adams.
35   * Add feeds=no option to inline preprocessor directive to turn off all types
36     of feeds.
37   * $IkiWiki::version now holds the program version, and is accessible to
38     plugins.
39   * Make the aggregate plugin emphasize error messages.
40   * Patch from Recai to limit recentchanges to displaying max 10 files for a
41     given changeset (to avoid large number of file changes excessively
42     bloating the page).
43
44  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
45
46 ikiwiki (1.28) unstable; urgency=low
47
48   * inline: Add ability to sort by page name, based on a patch from
49     Benjamin A'Lee.
50   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
51     braindead interface. Closes: #389383
52   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
53     and b) those poor Mac OSX users and their case insensative files!
54   * Don't fail syntax check if Text::Typography isn't installed.
55     Closes: #389406
56
57  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
58
59 ikiwiki (1.27) unstable; urgency=low
60
61   * Work on firming up the plugin interface:
62     - Plugins should not need to load IkiWiki::Render to get commonly
63       used functions, so moved some functions from there to IkiWiki.
64     - Picked out the set of functions and variables that most plugins
65       use, documented them, and made IkiWiki export them by default,
66       like a proper perl module should.
67     - Use the other functions at your own risk.
68     - This is not quite complete, I still have to decide whether to
69       export some other things.
70   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
71     referring to stuff now exported by the IkiWiki module.
72   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
73     to declare which version of the interface your plugin needs.
74   * Anyone with a third-party ikiwiki plugin is strongly encouraged
75     to make like changes to it and avoid use of non-exported symbols from
76     "IkiWiki::".
77   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
78   * Support hyperestradier version 1.4.2, which adds a new required phraseform
79     setting.
80   * If an inlined page has a permalink, link the page title to that.
81   * Patch from Recai to use utf8 when reading the setup file, so that
82     utf8 wikinames from there will be used properly.
83   * Patch from Recai to kill utf-8 on the wiki name when generating the
84     session cookie.
85   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
86   * Fix a baseurl problem in hyperestradier search results.
87   * Add a stub local.css to avoid problems with 404's.
88   * Patch from Recai to fix a wide character warning from the search plugin
89     during setup if the wikiname contains utf8.
90   * Yet another fix for those poor case-insensative OS X users.
91   * pagetemplate hooks are now also called when generating cgi pages.
92   * Add a favicon plugin, which simply adds a link tag for an icon to each
93     page (and cgis).
94   * Patch from James Westby to deal with the case where you're editing a
95     new page, hit cancel, and need to be redirected to somewhere sane.
96   * Various documentation improvements by various wiki users.
97   * Support Text::Markdown from CPAN, which has a different interface from
98     the original markdown or the one in Debian.
99   * Version the libcgi-session-perl dependency, some features that need
100     the new version are used in some cases (sslcookie).
101   * Numerous tla fixes from Clint.
102   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
103     a multi-resolution favicon.ico.
104   * README.Debian: typo Closes: #388110
105   * chomp trailing newline at the end of templates read in by the template
106     plugin, to allow use of the template preprocessor directive in
107     whitespace-sensative situations. Closes: #387073
108   * Patch from James Westby to make the location of the estseek.cgi script
109     configurable.
110   * Add typography (SmartyPants) plugin by Recai.
111   * Add --render mode, which can be used to preview an edit at the command
112     line by test rendering a single page.
113   * Add a googlecalendar plugin. A bit special-purpose, but it shows
114     one way to to deal with user-supplied content that could cause XSS
115     issues w/o the htmlscrubber, and won't survive the scrubber.
116
117  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
118
119 ikiwiki (1.26) unstable; urgency=low
120
121   * Add a missing -n to tla undo call.
122   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
123     writes before consuming its whole stdin. Avoid this deadlock.
124   * Fix alt tags for outline checkboxes.
125
126  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
127
128 ikiwiki (1.25) unstable; urgency=low
129
130   * Add proper waitpid calls for open2ed processes throughout to avoid
131     zombies; this hit htmltidy especially badly.
132   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
133     subversion repos and fixing some other issues.
134   * Add support for tla, contributed by Clint Adams. Closes: #385936
135   * Add support for mercurial, contributed by Emanuele Aina.
136   * Include <link rel> tag for RSS feeds, used by some aggregators and
137     firefox to find the feed.
138   * Add a linkmap plugin (requires graphviz).
139
140  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
141
142 ikiwiki (1.24) unstable; urgency=low
143
144   * Simplify the data structure returned by rcs_recentchanges to avoid
145     each rcs plugin needing to form complex strings on its own.
146   * Fix another destpage issue in the inline directive. Closes: #385512
147     again.
148
149  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
150
151 ikiwiki (1.23) unstable; urgency=low
152
153   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
154
155  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
156
157 ikiwiki (1.22) unstable; urgency=low
158
159   * Change how the stylesheet url is determined in the templates: Remove
160     STYLEURL and add BASEURL to all templates (some already had it). This
161     new more general variable can be used to link to other things (eg, images)
162     from the template, as well as stylesheets.
163   * Fix a bug introduced last version to do with nested inlines.
164   * Allow preprocessor directives to span multiple lines, both to make
165     long ones with lots of values easier to write, and to allow for ones with
166     multi-line quoted values.
167   * Allow preprocessor directives to contain python-like triple-quoted
168     text blocks, for easy nesting of quotes inside.
169   * Add a template plugin.
170   * Make pagespec merge code smarter about merging duplicate pagespecs.
171   * Patch from Jordà Polo to make Setup::Standard support hashes in config
172     files.
173   * Change order of linkify and preprocess; first preprocess and then linkify.
174     This allows passing a wikilink inside a parameter to a preprocessor
175     directive without it being expanded to html, and leaking out of the
176     parameter, which had required some non-obvious use of triple-quoting
177     to avoid. Note that any preprocessor plugins that output something
178     that looks like a wikilink will now have it treated as such; AFAIK
179     this doesn't change any behavior though except for the template plugin.
180   * Enable preprocessor directives when previewing an edit.
181   * Make all pages pull in a local.css style sheet, if present. This won't
182     be included in ikiwiki, but can be created to make local styling changes
183     w/o needing to merge in every new change to the distributed style.css.
184   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
185   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
186     from a different directory.
187   * Generalised preprocesser loop protection code.
188   * Patch from James Westby to allow a description to be set for rss feeds.
189   * Patch from James Westby to add a template for the search form.
190   * Added a ddate plugin.
191   * Patch from James Westby to add a --sslcookie switch, which forces
192     cookies to only be sent over ssl connections to avoid interception.
193   * Fix preferences page on anonok wikis; still need to sign in to get
194     to the preferences page.
195   * Add toc (table of contents) plugin.
196   * Change htmlize, format, and sanitize hooks to use named parameters.
197   * Patch from James Westby to add an actions option to inline; this
198     adds Edit and Discussion links at the end of blog entries.
199   * Due to some css changes, you'll want to rebuild your wiki on upgrade
200     to this version. Will be handled automatically by the deb.
201   * Add processed date to aggregate preprocessor directive status output.
202
203  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
204
205 ikiwiki (1.21) unstable; urgency=low
206
207   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
208   * If a page links to itself, mark up the link text in a span with
209     class="selflink" so that it can be styled. I don't have a useful style
210     defined for that though.
211   * Call filter hooks on inlined page content.
212   * Support inlining pages raw, rather than creating a blog.
213   * Clean up yes/no parameter parsing in inline plugin.
214   * Implemented better cycle detection in the inline plugin; nested inlines
215     will now work.
216   * Add a map plugin contributed by Alessandro Dotti Contra.
217   * Add otl format plugin, which handles files as created by vimoutliner.
218   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
219   * Add first draft at a Restructured Text (rst) plugin, by Sergio
220     Talens-Oliag. Note that this has many known issues -- see the caveats on
221     the plugin's page.
222   * Credit everyone who wrote a plugin on the plugins' wiki pages.
223   * Fix utf-8 in blog post form.
224
225  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
226
227 ikiwiki (1.20) unstable; urgency=low
228
229   * Relicense the templates and basewiki under the 2-clause BSD license.
230     Since these can easily become part of other people's websites, they
231     should be under as permissive a license as possible.
232   * Add --syslog config option, to log to the syslog.
233   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
234     transient failure to fork (which I've seen happen in the wild).
235   * Fix a bug in the aggregator introduced last version that caused all
236     aggregator state to be lost during a non-aggregating build.
237
238  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
239
240 ikiwiki (1.19) unstable; urgency=low
241
242   * Fix several related bugs in page type determination during online editing.
243   * Add some locking to prevent 2 aggregators from running at once.
244   * Fix an infinite loop in the aggregator when finding a unique filename.
245
246  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
247
248 ikiwiki (1.18) unstable; urgency=low
249
250   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
251   * Add --version.
252   * Man page format fixups.
253   * If the meta plugin overides the page title, set a title_overridden
254     variable in the template to true. This allows doing things with the
255     templates conditional on the title being overriden.
256   * Add a %pagecase which maps lower-case page names to the actual case
257     used in the filename. Use this in bestlinks calculation instead of
258     forcing the link to lowercase.
259   * Also use %pagecase in various other places that want to check if a page
260     with a given name exists.
261   * This means that links to pages with mixed case names will now work,
262     even if the link is in some other case mixture, and mixed case pages
263     should be fully supported throughout ikiwiki.
264   * Recommend rebuilding wikis on upgrade to this version.
265
266  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
267
268 ikiwiki (1.17) unstable; urgency=low
269
270   * Disable tidy generator tag.
271   * Move tidy back to sanitize hook, found out how to only show body.
272   * Turn off tidy indentation too.
273   * Turn on HTML::Template loop_context_vars; not actually used in stock
274     templates but can be useful for things like making comma-delimited lists
275     of tags or what have you.
276   * Remove <br> from end of aggregate preprocessor directive output.
277   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
278     case-sensative filesystems like OSX.
279   * Improve markdown loading. First, try to load it as a proper perl module,
280     in case it was installed as one. Then fall back to trying
281     /usr/bin/markdown.
282   * Document in install page how to install markdown, since it has no
283     installation procedure in the upstream tarball.
284   * Set die_on_bad_params => 0 for all templates, to allow users to modify
285     them without annoyances.
286   * Suck in the page content when generating an inline archive page, to work
287     around the meta plugin's lack of caching of title metadata across runs.
288
289  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
290
291 ikiwiki (1.16) unstable; urgency=low
292
293   * Try to handle relative links in aggregated feeds. However,
294     the current support is a crude hack due to limitations of XML::Feed:
295     xml:base is not supported, neither is Content-Location. And of course,
296     relative links in RSS feeds are ill-undefined..
297   * Make aggregator save permalinks and author name to pages as metadata.
298   * Add permalink and author support to meta plugin, affecting RSS feeds
299     and blog pages.
300   * Various CSS and formatting changes.
301   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
302   * Add xhtml files to the default prune regexp.
303   * Also generate rel=bookmark links for permalinks.
304   * Fix the htmltidy plugin, which wasn't working due my breaking it when
305     I added it..
306   * Don't run tidy with -xml as that fails if the input is not well-formed.
307     Run it with -asxhtml instead, so it will output well-formed xhtml no
308     matter what the input.
309   * Disable tidy warnings too.
310   * Add a new format hook, and make tidy use it, since tidy can really only
311     operate on and output complete html documents, not the body chunks
312     that sanitise gets.
313   * Fix dates in rss feeds if running localised, so they're still rfc 822.
314
315  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
316
317 ikiwiki (1.15) unstable; urgency=low
318
319   * Remove CDPATH and other env vars perl taint checking doesn't like.
320     Closes: #381279
321   * Added created_before and created_after PageSpec limits.
322
323  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
324
325 ikiwiki (1.14) unstable; urgency=low
326
327   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
328     by 10% or so.
329   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
330   * Added many unit tests for pagespec_match.
331
332  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
333
334 ikiwiki (1.13) unstable; urgency=low
335
336   * ikiwiki can now download and aggregate feeds with its new aggregate
337     plugin, so it's possible to implement a Planet using ikiwiki!
338   * Add a run_hooks function for the common task of running all hooks of a
339     given type.
340   * Add a savestate hook.
341   * Don't put blog post forms on pages if there's no cgiurl set.
342   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
343     --wrappers to do that.
344   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
345     to update pages that haven't changed on disk.
346   * Change meta tags to use html entity-escaped text for values, so that
347     quotes and such can be represented in title tags.
348   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
349     for the above.
350   * Make --rebuild also cause --aggregate to re-download and write aggregated
351     pages.
352   * Avoid outputting duplicate meta info.
353   * Include title metadata on aggregated posts for capitalised and un-munged
354     titles.
355   * Title metadata of inlined pages now shows up in blogs and rss feeds.
356   * Fix issue with unicode filenames and updating the hyper estradier search
357     index. (Aka Please Please Please, let that be the last one.)
358   * Patch from Roland Mas to support an rss=no parameter to inline directives.
359     Closes: #380743
360   * Renamed GlobLists to PageSpecs.
361   * PageSpecs can now include nested parens, "and", and "or". This remains
362     backwards compatible to the old GlobList format. It's implemented by
363     treating the GlobList as a very limited microlanguage that is transformed
364     to perl code that does the matching.
365   * The old GlobList format is deprecated, and I encourage users to switch to
366     using the new PageSpec format. Compatability with the old format will be
367     removed at some point, possibly by 2.0.
368   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
369   * Add support for creation_month and creation_year to PageSpec.
370     Closes: #380680
371   * Changes to index file encoding.
372
373  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
374
375 ikiwiki (1.12) unstable; urgency=low
376
377   "Viva l'Italia!"
378   * New pagestats plugin from Enrico, which can generate a table counting
379     the backlinks for each page, or a del.icio.us style cloud.
380   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
381     the wikiformat plugin works. Thanks, Emanuele Aina.
382   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
383     display, running them through pagetitle. This removes ugly underscores and
384     other gunk from the display, much nicer. You may want to rebuild your wiki
385     when upgrading to get the cleanup globally.
386   * Polygen plugin from Enrico.
387   * htmltidy plugin from Faidon.
388   * Locale patch from Faidon:
389     - Adds a locale setting to setup files.
390     - Proper local time, if the locale configuration option is used.
391     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
392       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
393       impossible.
394   * Add getopt hook type, this allows plugins to add new command-line options.
395   * Add --tagbase option to tag plugin.
396   * Add exclude option in setup files, works same as --exclude.
397   * Put categories in rss feeds for tagged items.
398   * Allow preprocessor directives to be expanded in inlined blog pages.
399     However, to avoid inlining loops etc, don't expand inline directives in
400     inlined pages.
401   * fortune plugin (trivial)
402   * Tag plugins according to type.
403
404  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
405
406 ikiwiki (1.11) unstable; urgency=low
407
408   * Patch from Enrico that
409     - Adds a tag plugin that allows more easily tagging pages.
410       The meta plugin can also still be used for that, but the tag plugin
411       also lists a page's tags at the bottom of the page.
412     - Allows preprocessor directives to have parameters with no specified
413       value.
414     - Fixes preprocessor directive parameter parsing so that
415       foo=bar baz now means "foo=bar" and a "baz" with no value.
416   * Run pagetemplate hooks when inlining pages so that inlined pages also
417     list their tags.
418   * Make all plugins with pagetemplate hooks check that variables exist
419     on the template before setting them, for robustness.
420   * Switch pagetemplate hooks to using named parameters.
421   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
422     This will be the page that a source page will be part of, which is
423     different than the source page for inlined pages.
424   * Audited all plugins to endure they pass (page, destpage) to htmllink
425     appropriatly. This means inlining of various plugins will not work
426     properly, with correct links generated.
427
428  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
429
430 ikiwiki (1.10) unstable; urgency=low
431
432   * Run page through any relevant filters when generating a page preview.
433   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
434     default throughout the wiki, not only on wikitext pages. Decided to call
435     this a feature, and split the camelcase support out into a separate plugin
436     that is independant of wikitext.
437   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
438
439  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
440
441 ikiwiki (1.9) unstable; urgency=low
442
443   * Improve display of parentlinks and page title of toplevel index page.
444   * Patch from Faidon to use svn --limit when possible for recentchanges,
445     speeds up recentchanges a lot for wikis with more history.
446   * Patch from Recai to fix utf8 issues in git backend.
447   * Add wikitext markup plugin, which supports ".wiki" pages written in the
448     original wiki syntax, CamelCase links and all.
449   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
450     support, to edit pages etc without a web server.
451   * Display CGI processing errors if present.
452   * Fix from Faidon for a XML parser issue that breaks utf-8 for
453     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
454     area, and also way slow.
455   * Match 'web commit from' in SVN and git, these are web commits too.
456     (Faidon)
457   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
458     readable and avoid future mistakes. The patch seems to work and for the
459     first time I have a UTF-8 username ;-) (Faidon)
460   * Use form->field consistently, not form->param.
461   * Patch from Recai to allow selection of page type when creating a new page.
462     Default page type is inherited from the link clicked on to create the new
463     page.
464
465  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
466
467 ikiwiki (1.8) unstable; urgency=low
468
469   * Fix orphans plugin to not count a link to a nonexistant page as a reason
470     for a page not being an orphan.
471   * Support pinging services such as Technorati using XML-RPC to notify them
472     about changes to rss feeds.
473   * Parse svn log as xml for improved utf8 and security. Note that this makes
474     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
475   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
476     flagged string even if the locale causes it to generate utf8 output,
477     so make sure to let perl know it should be handled as utf8. Also,
478     the optimised version used for standard time formats won't work if the
479     user has changed locale, so drop it. Thanks, Faidon Liambotis.
480   * Fix re-encoding of the comments field to utf8 if a commit fails
481     due to a conflict. Thanks, Faidon Liambotis.
482   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
483     Liambotis.
484   * Add insane double encode/decode to utf8 around call to markdown.
485     This works around a truely strange bug, which is apparently a bug in
486     perl, #376329. Also added a test case for it.
487   * Improve layout of edit page so formatting help link is always visible w/o
488     getting in the way of the preview.
489   * Centralised all calls to HTML::Template and force all the templates
490     to be read as utf8.
491   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
492   * Introduce add_plugins and disable_plugins config options in setup files.
493     This allows adding or removing plugins w/o overriding the whole list of
494     default plugins, which makes it easier to upgrade when new default plugins
495     are added.
496   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
497     default (of course!). Based on a patch by Faidon Liambotis.
498   * Add a html plugin, which can be used to write wikis in raw html,
499     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
500     defaults to not processing .html files, since w/o this plugin they would
501     be copied unsanitised. With this plugin, it will process and html
502     sanitise them, like any other page type.
503   * Rebuilding wrappers is necessary on upgrade to this version.
504   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
505     will be automatically done on all upgrades.
506   * Don't send pings if the wiki is being rebuilt.
507   * Work around very innefficient behavior in File::Spec::abs2rel. Result
508     is a savings of 2 pointless fork/execs per link calculation, which
509     results in ~25% speedup of ikiwiki building its own doc wiki, and
510     about 35% speedup displaying RecentChanges!
511   * Make RecentChanges use a table and some CSS, should be much more readable.
512     No code changes involved.
513   * Encode & in diffurl in examples, to conform to pedantic rules.
514   * Speed up RecentChanges by another 40% or so with some memoization.
515   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
516     in time to build the doc wiki.
517
518  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
519
520 ikiwiki (1.7) unstable; urgency=low
521
522   * Updated logo from Recai with some kerning and alingment tuning.
523   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
524     changed some output.
525   * Copyright update.
526
527  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
528
529 ikiwiki (1.6) unstable; urgency=low
530
531   * YA utf-8 patch from Recai, this time to fix previewing a page so that
532     the text in the input box is re-encoded back to utf-8.
533   * -CSD does not affect modules, so readfile() was not using the utf-8 input
534     layer, which led to lots of problems; make it force read files as utf-8.
535     Closes: #373203
536   * Note that as a consequence, this version of ikiwiki will actually try to
537     parse utf8 in source files for the first time, which may expose broken
538     utf8 in wiki sources that was hidden before. Most common will be
539     perl warnings like "utf8 "\xE9" does not map to Unicode"
540   * writefile() likewise needs to use the utf8 output layer.
541   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
542     there.
543   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
544     given the readfile fix.
545   * Add utf-8 testcases for readfile and htmlize.
546   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
547     safe.
548   * More utf-8 fixes from Recai, partly to things I broke above:
549     - The serious problem is that writefile() saves the content in undecoded
550       format in CGI, hence all (non-ascii) chars are corrupted permanently.
551     - Comment field in edit page is not decoded and all the non-ascii chars in
552       this field are corrupted as the result.  We should decode it as we do it
553       for the content.
554     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
555       character in print.
556   * New SVG logo from Recai.
557
558  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
559
560 ikiwiki (1.5) unstable; urgency=low
561
562   * Add --timeformat config option to allow changing how dates are displayed.
563     Note that as a side effect, dates will now be displayed using the local
564     timezone, not as GMT.
565   * More security review.
566   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
567     for some handy stuff like:
568     - Using links as a kind of tag; creating blog pages that list all pages
569       containing a given tag/link or not containing some other tag.
570     - Subscribing to mail notifications whenever a change is made to a page
571       that is a backlink of page foo. Ie, "Please notify me of changes in all
572       pages that link to my home page in the wiki"
573     - Locking any pages that are linked to from a particular page, so that
574       lists of locks can be exposed in the wiki.
575   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
576     when a todo item is done, instead of the previous moving it to a different
577     subdir.
578   * Allow pagetemplate plugins to override *anything* in the template.
579   * Add a meta plugin, which allows specifying various metadata about pages,
580     like license and author. It also allows for inserting html link and meta
581     tags into html, overriding the title, and adding hidden WikiLinks, which
582     can be useful when using link-based globbing for page categorisation.
583   * Remove preprocessor directives from inlined pages.
584   * Allow simple preprocessor directive values to be specified w/o quotes.
585   * Add support for using git instead of subversion as the RCS backend,
586     tremendous thanks to Recai Oktaş for this.
587   * Doc updates for git.
588   * Fix absolute url munging in rss generation to support https, ftp, etc urls
589     not just http urls.
590   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
591     utf-8 for edit and other fields, and for recentchanges. There may still
592     be utf-8 issues with the preferences page though.
593
594  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
595
596 ikiwiki (1.4) unstable; urgency=low
597
598   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
599     very strange way of enabling proper XHTML <br /> type tags. Output html
600     should be always valid again now.
601   * The page name and parent links has switched from using a <h1> to a styled
602     <span>, so pages can use <h1> internally instead of needing to use <h2>.
603   * Updated all of ikiwiki's own wiki pages for that.
604   * Add pagetemplate hook, which can be used by plugins that want to mess
605     around with adding new stuff to the page template.
606   * Remove headercontent; the search plugin now adds the search box to the
607     header by registering a pagetemplate hook, and other plugins should do
608     similarly.
609   * Rebuilding on upgrade to this version is recommended.
610   * Add a html validity check to the test suite, using the wdg-html-validator,
611     if available.
612   * Make the html valid when there is nothing in the actions list.
613   * Reordered some function call parameters for consistency.
614   * Enable full utf-8 support for page input and output.
615   * Add a workaround for markdown, which does not work well with utf-8
616     strings.
617   * --getctime had bitrotted (well I only ever used it the once so far..),
618     fix and make it a bit more flexible
619   * rcs_getctime is changed, now rather than needing to loop over all pages,
620     it should just use the rcs to get the ctime of the passed file.
621   * When inlining a page in another one, links from the inlined page are now
622     expanded the same as they are when rendering the inlined page as a
623     standalone page. So rather than being expanded from the POV of the
624     inlining page, they are expanded from the POV of the inlined page.
625
626     For example, a link from blog/foo to "bar" will now link to blog/bar
627     if it exists. Previously this needed to be a link explicitly to
628     "blog/bar"; such links will also continue to work.
629
630     (This was slightly complex to do as the link still has to be constructed
631     relative to the inlining page.)
632   * Make page edit textarea resize to fit browser window.
633   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
634     do not need a full rebuild, in order to update any basewiki pages.
635
636  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
637
638 ikiwiki (1.3) unstable; urgency=low
639
640   * Fix the preinst introduced in the last version. Closes: #367458
641
642  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
643
644 ikiwiki (1.2) unstable; urgency=low
645
646   * Remove dups from the brokenlinks list.
647   * Add libc6-dev to dependencies, needed to build wrappers.
648   * Install wikilist in correct location. Closes: #367371
649
650  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
651
652 ikiwiki (1.1) unstable; urgency=low
653
654   * Rename inlinepage to depends, so that it can be used to refer to more
655     dependency relationships than just inlining. This will require a rebuild
656     on upgrade to this version.
657   * Move the rss link, put it in the blogpost form if there is one and at the
658     top if not. This is both nicer because easier to find, and it cleans up
659     the code which had used inlinepage as a flag for adding the link later.
660   * Allow the depends GlobList to be built up from multiple sources (such as
661     plugins) during a page render.
662   * Which means that more than one blog is now supported to appear on a
663     single page. (With some limitations, like only the last one getting an
664     rss file.)
665   * Added a plugin system.
666   * Added a pagecount plugin, enabled by default.
667   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
668   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
669     backlinks when the backlinks hadn't really changed.
670   * Moved inline page support, rss generation etc into the inline plugin,
671     enabled by default.
672   * Added brokenlinks plugin, not enabled by default, but rather handy.
673   * Fix several broken links in the doc wiki.
674   * Smarter behavior when creating a page and a page of the same name (but
675     different location) already exists.
676   * Add an orphans plugin for finding pages that nothing links to.
677   * Removed backlinks page, which it turns out nothing used.
678   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
679     it, this will allow for adding a unit test suite.
680   * Add unit tests for several core functions, including globlist_match,
681     dirname, basename, bestlink, linkify, pagetitle, titlepage.
682   * Smart globlist merging.
683   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
684     to pave the way for adding other RCS support. This also changes the
685     setup files, where before they had svn => 1 or svn => 0, now they have
686     rcs => "svn" or rcs => "".
687   * Add a debian/NEWS file with upgrade notes.
688   * Load whatever rcs module is specified, so new ones can be just dropped in
689     as plugins and work. (Well, in theory.)
690   * Add some basic docs about writing RCS modules.
691   * Broke search capability out into a plugin, removed the --hyperestraier
692     switch.
693   * Added smiley plugin, nicely controlled and documented by the smileys page.
694   * Copied in some smileys from Moin Moin.
695   * Allow links of the form [[some page|page]], with whitespace in the link
696     text.
697   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
698     and --disable-plugin htmlscrubber.
699   * Allow discussion links on pages to be turned off with --no-discussion.
700   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
701   * Add some new config items to the estseek.conf template, which are needed
702     by hyperestraier 1.2.3.
703
704  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
705
706 ikiwiki (1.0) unstable; urgency=low
707
708   * First official release.
709
710  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400