]> sipb.mit.edu Git - ikiwiki.git/blob - debian/changelog
foo
[ikiwiki.git] / debian / changelog
1 ikiwiki (1.34) UNRELEASED; urgency=low
2
3   * Add an openid plugin to support logging in using OpenID.
4   * Web commits by OpenID users will record the full OpenID url for the user,
5     but in recentchanges, these urls will be converted to a simplified display
6     form+link.
7   * Modified svn, git, tla backends to recognise such web commits.
8   * Move httpauth support to a plugin.
9   * Add openidsignup config option.
10   * Make the openid plugin support the callbacks from myopenid.com via its
11     affiliate program.
12   * Add toggle plugin.
13   * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
14     many other plugins. It's an easy way to boost ikiwiki from its default,
15     basic wiki, to a full-featured wiki, without manually picking the right
16     set of plugins. New plugins will be added to goodstuff from time to
17     time.
18   * Change how post signin actions are propigated through the signin process;
19     they're now stored in the session.
20   * Add optional "desc" parameter to shortcut definitions.
21   * Avoid locking the wiki at all when handling some basic cgi stuff
22     (searches, recentchanges).
23   * Add "last" parameter to hook function. Very basic ordering, and hopefully
24     nothing more spohisticated will be needed.
25   * Add formbuilder_setup and formbuilder hooks.
26   * Split out a passwordauth module, that holds all the traditional password
27     based authentication etc code. It's enabled by default, but can be disabled
28     if you want only openid or some other auth method.
29   * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
30   * Add some code to the build system that tries to determine if the
31     lib installation directory is in @INC. If it's not, munge ikiwiki
32     to hardcode the path to the lib directory. This should allow installing
33     ikiwiki in nonstandard locations, including home directories, by just
34     setting PREFIX at build time.
35   * Fix nested examples directory in deb.
36   * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
37   * Add a test suite for the svn backend.
38   * Daemonize before sending RPC pings, since that can take a while
39     and/or hang.
40   * Daemonize before sending commit mails, as that can also take a long
41     time/hang if the mail server is unhappy.
42   * Factor out commit mail sending code into new function.
43   * Change rcs_commit, it is now passed the name of the user doing the commit
44     and their IP address, and needs to construct its own commit message
45     containing them, or do something more appropriate for the given RCS.
46   * Add softwaresite example.
47
48  -- Joey Hess <joeyh@debian.org>  Wed, 22 Nov 2006 09:59:12 -0500
49
50 ikiwiki (1.33) unstable; urgency=low
51
52   * Fix issue with aggregate plugin updating expired pages.
53   * Avoid syntax errors in templates used by the template plugin crashing
54     ikiwiki.
55   * Enable utf8 file IO in aggregate plugin.
56   * Fix some issues with the new registration form.
57   * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
58   * Make sure to check for errors from every eval.
59   * Fix img plugin's handling of adding dependencies for images that do not
60     yet exist.
61   * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
62     FORM-SUBMIT unusable on customised formbuilder templates. For now,
63     hardcode the submit buttons in editpage.tmpl instead of using the
64     template variable, which is ok, since the buttons are static.
65   * Work with hyperestraier 1.4.9.
66
67  -- Joey Hess <joeyh@debian.org>  Wed, 15 Nov 2006 18:32:26 -0500
68
69 ikiwiki (1.32) unstable; urgency=low
70
71   * Add a separate pass to find page links, and only render each page once,
72     instead of over and over. Typical speedup is ~4x. Max possible speedup:
73     8x.
74   * Add "scan" parameter to hook(), which is used to make the hook be called
75     during the scanning pass, as well as the render pass. The meta and tag
76     plugins need to use the new scan parameter, so will any others that modify
77     %links.
78   * Now that links are calculated in a separate pass, it can also
79     precalculate backlinks in one pass, which is O(N^2) instead of the
80     previous code that was O(N^3). A very nice speedup for wikis with lots
81     (thousands) of pages.
82   * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
83     Erdem.
84   * Add a default stylesheet entry for the pagecloud.
85   * Add examples page with some examples of things that can be done using
86     ikiwiki, like a weblog. The examples can be copied into a user's wiki
87     for a quick start, without needing to learn everything about how to put
88     them together.
89   * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
90   * Add perlmagick to build-depends so syntax check of img plugin works.
91     Closes: #396702
92   * Improve login/register process, the login dialog has only name and
93     password fields, which allows more web browsers to regognise it as a login
94     field, and is less confusing.
95   * Implemented expiry options for aggregate plugin.
96   * Use precalculated backlinks info when determining if files need an update
97     due to a page they link to being added/removed. Mostly significant if
98     there are lots of pages.
99   * Remove duplicate link info when saving index. In some cases it could
100     pile up rather badly. (Probably not the best way to deal with this
101     problem.)
102   * Patch from James Westby to support podcasting, photoblogging, vidcasting,
103     or what have you, by creating enclosures for non-page items that are
104     included in feeds.
105
106  -- Joey Hess <joeyh@debian.org>  Fri,  3 Nov 2006 14:46:37 -0500
107
108 ikiwiki (1.31) unstable; urgency=low
109
110   * Patch from Pawel Tecza to cp -a the templates in the Makefile.
111   * Change the rss feed title from the wikiname to the page title, with
112     an exception for the wiki's toplevel index page, which will still use the
113     wikiname as the feed title.
114     Overriding the page title with meta title already overrode the rss feed
115     tittle.
116   * Add an img plugin, based on Christian Mock's img plugin, but stripped
117     down to the bare essentials. Useful for handling large images on websites.
118   * Sanitize possibly problimatic characters out of the polygen grammar names,
119     just in case. Should not be exploitable anyway, since it only tries to run
120     polygen after finding the specified grammar file.
121   * Add missing dependency on the URI perl module.
122   * Add basic spam fighting tool for admins: An admin's prefs page now allows
123     editing a list of banned users.
124
125  -- Joey Hess <joeyh@debian.org>  Fri, 27 Oct 2006 23:16:33 -0400
126
127 ikiwiki (1.30) unstable; urgency=low
128
129   * Add no_override parameter to hook().
130   * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
131     plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
132     can be configured using a page in wiki.
133   * Fix support for --pingurl at the command line.
134   * Fix a subtle bug in will_render that broke some builds, by only clearing
135     items from renderedfiles the first time per build.
136   * Wrap entire technortati ping operation in an eval to catch all possible
137     failure modes, after I observed a simple ->value crashing ikiwiki when
138     a ping failed.
139
140  -- Joey Hess <joeyh@debian.org>  Mon, 16 Oct 2006 15:17:38 -0400
141
142 ikiwiki (1.29) unstable; urgency=low
143
144   * Patch from Paul Tötterman to use CP in the Makefile.
145   * Patch from Alec Berryman adding a http_auth config item that allows
146     using HTTP Authentication instead of ikiwiki's built in authentication.
147     Useful for eg, large sites with their own previously existing user auth
148     setup. Closes: #384534
149   * Change %renderedfiles to store an array of files rendered from a given
150     source file, to allow tracking of extra rendered files like rss feeds.
151   * Note that plugins that accessed this variable will need to be updated!
152     The plugin interface has been increased to version 1.01 for this change.
153     As few plugins use %renderedfiles I haven't done anything else to ensure
154     compatability of old plugins.
155   * Add will_render function to the plugin interface, used to register that a
156     page renders a destination file, and do some security checks. Previously
157     but no longer rendered files will be cleaned up.
158   * Use will_render in the inline and linkmap plugins.
159   * You will need to rebuild your wiki on upgrade to this version.
160   * Atom feed support based on a patch by Clint Adams.
161   * Add feeds=no option to inline preprocessor directive to turn off all types
162     of feeds.
163   * $IkiWiki::version now holds the program version, and is accessible to
164     plugins.
165   * Make the aggregate plugin emphasize error messages.
166   * Patch from Recai to limit recentchanges to displaying max 10 files for a
167     given changeset (to avoid large number of file changes excessively
168     bloating the page).
169
170  -- Joey Hess <joeyh@debian.org>  Fri, 13 Oct 2006 23:14:28 -0400
171
172 ikiwiki (1.28) unstable; urgency=low
173
174   * inline: Add ability to sort by page name, based on a patch from
175     Benjamin A'Lee.
176   * Fix a forkbomb in various calls to IPC::Open2, which has a highly
177     braindead interface. Closes: #389383
178   * Don't rm -rf ikiwiki on distclean, since a) there's no such file
179     and b) those poor Mac OSX users and their case insensative files!
180   * Don't fail syntax check if Text::Typography isn't installed.
181     Closes: #389406
182
183  -- Joey Hess <joeyh@debian.org>  Tue, 26 Sep 2006 02:08:17 -0400
184
185 ikiwiki (1.27) unstable; urgency=low
186
187   * Work on firming up the plugin interface:
188     - Plugins should not need to load IkiWiki::Render to get commonly
189       used functions, so moved some functions from there to IkiWiki.
190     - Picked out the set of functions and variables that most plugins
191       use, documented them, and made IkiWiki export them by default,
192       like a proper perl module should.
193     - Use the other functions at your own risk.
194     - This is not quite complete, I still have to decide whether to
195       export some other things.
196   * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
197     referring to stuff now exported by the IkiWiki module.
198   * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
199     to declare which version of the interface your plugin needs.
200   * Anyone with a third-party ikiwiki plugin is strongly encouraged
201     to make like changes to it and avoid use of non-exported symbols from
202     "IkiWiki::".
203   * Link debian/changelog and debian/news to NEWS and CHANGELOG.
204   * Support hyperestradier version 1.4.2, which adds a new required phraseform
205     setting.
206   * If an inlined page has a permalink, link the page title to that.
207   * Patch from Recai to use utf8 when reading the setup file, so that
208     utf8 wikinames from there will be used properly.
209   * Patch from Recai to kill utf-8 on the wiki name when generating the
210     session cookie.
211   * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
212   * Fix a baseurl problem in hyperestradier search results.
213   * Add a stub local.css to avoid problems with 404's.
214   * Patch from Recai to fix a wide character warning from the search plugin
215     during setup if the wikiname contains utf8.
216   * Yet another fix for those poor case-insensative OS X users.
217   * pagetemplate hooks are now also called when generating cgi pages.
218   * Add a favicon plugin, which simply adds a link tag for an icon to each
219     page (and cgis).
220   * Patch from James Westby to deal with the case where you're editing a
221     new page, hit cancel, and need to be redirected to somewhere sane.
222   * Various documentation improvements by various wiki users.
223   * Support Text::Markdown from CPAN, which has a different interface from
224     the original markdown or the one in Debian.
225   * Version the libcgi-session-perl dependency, some features that need
226     the new version are used in some cases (sslcookie).
227   * Numerous tla fixes from Clint.
228   * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
229     a multi-resolution favicon.ico.
230   * README.Debian: typo Closes: #388110
231   * chomp trailing newline at the end of templates read in by the template
232     plugin, to allow use of the template preprocessor directive in
233     whitespace-sensative situations. Closes: #387073
234   * Patch from James Westby to make the location of the estseek.cgi script
235     configurable.
236   * Add typography (SmartyPants) plugin by Recai.
237   * Add --render mode, which can be used to preview an edit at the command
238     line by test rendering a single page.
239   * Add a googlecalendar plugin. A bit special-purpose, but it shows
240     one way to to deal with user-supplied content that could cause XSS
241     issues w/o the htmlscrubber, and won't survive the scrubber.
242
243  -- Joey Hess <joeyh@debian.org>  Sun, 24 Sep 2006 00:02:21 -0400
244
245 ikiwiki (1.26) unstable; urgency=low
246
247   * Add a missing -n to tla undo call.
248   * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
249     writes before consuming its whole stdin. Avoid this deadlock.
250   * Fix alt tags for outline checkboxes.
251
252  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 16:24:16 -0400
253
254 ikiwiki (1.25) unstable; urgency=low
255
256   * Add proper waitpid calls for open2ed processes throughout to avoid
257     zombies; this hit htmltidy especially badly.
258   * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
259     subversion repos and fixing some other issues.
260   * Add support for tla, contributed by Clint Adams. Closes: #385936
261   * Add support for mercurial, contributed by Emanuele Aina.
262   * Include <link rel> tag for RSS feeds, used by some aggregators and
263     firefox to find the feed.
264   * Add a linkmap plugin (requires graphviz).
265
266  -- Joey Hess <joeyh@debian.org>  Fri,  8 Sep 2006 01:54:14 -0400
267
268 ikiwiki (1.24) unstable; urgency=low
269
270   * Simplify the data structure returned by rcs_recentchanges to avoid
271     each rcs plugin needing to form complex strings on its own.
272   * Fix another destpage issue in the inline directive. Closes: #385512
273     again.
274
275  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 15:46:45 -0400
276
277 ikiwiki (1.23) unstable; urgency=low
278
279   * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
280
281  -- Joey Hess <joeyh@debian.org>  Sun,  3 Sep 2006 12:14:45 -0400
282
283 ikiwiki (1.22) unstable; urgency=low
284
285   * Change how the stylesheet url is determined in the templates: Remove
286     STYLEURL and add BASEURL to all templates (some already had it). This
287     new more general variable can be used to link to other things (eg, images)
288     from the template, as well as stylesheets.
289   * Fix a bug introduced last version to do with nested inlines.
290   * Allow preprocessor directives to span multiple lines, both to make
291     long ones with lots of values easier to write, and to allow for ones with
292     multi-line quoted values.
293   * Allow preprocessor directives to contain python-like triple-quoted
294     text blocks, for easy nesting of quotes inside.
295   * Add a template plugin.
296   * Make pagespec merge code smarter about merging duplicate pagespecs.
297   * Patch from Jordà Polo to make Setup::Standard support hashes in config
298     files.
299   * Change order of linkify and preprocess; first preprocess and then linkify.
300     This allows passing a wikilink inside a parameter to a preprocessor
301     directive without it being expanded to html, and leaking out of the
302     parameter, which had required some non-obvious use of triple-quoting
303     to avoid. Note that any preprocessor plugins that output something
304     that looks like a wikilink will now have it treated as such; AFAIK
305     this doesn't change any behavior though except for the template plugin.
306   * Enable preprocessor directives when previewing an edit.
307   * Make all pages pull in a local.css style sheet, if present. This won't
308     be included in ikiwiki, but can be created to make local styling changes
309     w/o needing to merge in every new change to the distributed style.css.
310   * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
311   * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
312     from a different directory.
313   * Generalised preprocesser loop protection code.
314   * Patch from James Westby to allow a description to be set for rss feeds.
315   * Patch from James Westby to add a template for the search form.
316   * Added a ddate plugin.
317   * Patch from James Westby to add a --sslcookie switch, which forces
318     cookies to only be sent over ssl connections to avoid interception.
319   * Fix preferences page on anonok wikis; still need to sign in to get
320     to the preferences page.
321   * Add toc (table of contents) plugin.
322   * Change htmlize, format, and sanitize hooks to use named parameters.
323   * Patch from James Westby to add an actions option to inline; this
324     adds Edit and Discussion links at the end of blog entries.
325   * Due to some css changes, you'll want to rebuild your wiki on upgrade
326     to this version. Will be handled automatically by the deb.
327   * Add processed date to aggregate preprocessor directive status output.
328
329  -- Joey Hess <joeyh@debian.org>  Fri,  1 Sep 2006 22:03:34 -0400
330
331 ikiwiki (1.21) unstable; urgency=low
332
333   * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
334   * If a page links to itself, mark up the link text in a span with
335     class="selflink" so that it can be styled. I don't have a useful style
336     defined for that though.
337   * Call filter hooks on inlined page content.
338   * Support inlining pages raw, rather than creating a blog.
339   * Clean up yes/no parameter parsing in inline plugin.
340   * Implemented better cycle detection in the inline plugin; nested inlines
341     will now work.
342   * Add a map plugin contributed by Alessandro Dotti Contra.
343   * Add otl format plugin, which handles files as created by vimoutliner.
344   * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
345   * Add first draft at a Restructured Text (rst) plugin, by Sergio
346     Talens-Oliag. Note that this has many known issues -- see the caveats on
347     the plugin's page.
348   * Credit everyone who wrote a plugin on the plugins' wiki pages.
349   * Fix utf-8 in blog post form.
350
351  -- Joey Hess <joeyh@debian.org>  Sun, 20 Aug 2006 16:42:54 -0400
352
353 ikiwiki (1.20) unstable; urgency=low
354
355   * Relicense the templates and basewiki under the 2-clause BSD license.
356     Since these can easily become part of other people's websites, they
357     should be under as permissive a license as possible.
358   * Add --syslog config option, to log to the syslog.
359   * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
360     transient failure to fork (which I've seen happen in the wild).
361   * Fix a bug in the aggregator introduced last version that caused all
362     aggregator state to be lost during a non-aggregating build.
363
364  -- Joey Hess <joeyh@debian.org>  Thu, 17 Aug 2006 19:05:56 -0400
365
366 ikiwiki (1.19) unstable; urgency=low
367
368   * Fix several related bugs in page type determination during online editing.
369   * Add some locking to prevent 2 aggregators from running at once.
370   * Fix an infinite loop in the aggregator when finding a unique filename.
371
372  -- Joey Hess <joeyh@debian.org>  Wed, 16 Aug 2006 13:46:25 -0400
373
374 ikiwiki (1.18) unstable; urgency=low
375
376   * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
377   * Add --version.
378   * Man page format fixups.
379   * If the meta plugin overides the page title, set a title_overridden
380     variable in the template to true. This allows doing things with the
381     templates conditional on the title being overriden.
382   * Add a %pagecase which maps lower-case page names to the actual case
383     used in the filename. Use this in bestlinks calculation instead of
384     forcing the link to lowercase.
385   * Also use %pagecase in various other places that want to check if a page
386     with a given name exists.
387   * This means that links to pages with mixed case names will now work,
388     even if the link is in some other case mixture, and mixed case pages
389     should be fully supported throughout ikiwiki.
390   * Recommend rebuilding wikis on upgrade to this version.
391
392  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 22:10:48 -0400
393
394 ikiwiki (1.17) unstable; urgency=low
395
396   * Disable tidy generator tag.
397   * Move tidy back to sanitize hook, found out how to only show body.
398   * Turn off tidy indentation too.
399   * Turn on HTML::Template loop_context_vars; not actually used in stock
400     templates but can be useful for things like making comma-delimited lists
401     of tags or what have you.
402   * Remove <br> from end of aggregate preprocessor directive output.
403   * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
404     case-sensative filesystems like OSX.
405   * Improve markdown loading. First, try to load it as a proper perl module,
406     in case it was installed as one. Then fall back to trying
407     /usr/bin/markdown.
408   * Document in install page how to install markdown, since it has no
409     installation procedure in the upstream tarball.
410   * Set die_on_bad_params => 0 for all templates, to allow users to modify
411     them without annoyances.
412   * Suck in the page content when generating an inline archive page, to work
413     around the meta plugin's lack of caching of title metadata across runs.
414
415  -- Joey Hess <joeyh@debian.org>  Sat, 12 Aug 2006 12:52:13 -0400
416
417 ikiwiki (1.16) unstable; urgency=low
418
419   * Try to handle relative links in aggregated feeds. However,
420     the current support is a crude hack due to limitations of XML::Feed:
421     xml:base is not supported, neither is Content-Location. And of course,
422     relative links in RSS feeds are ill-undefined..
423   * Make aggregator save permalinks and author name to pages as metadata.
424   * Add permalink and author support to meta plugin, affecting RSS feeds
425     and blog pages.
426   * Various CSS and formatting changes.
427   * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
428   * Add xhtml files to the default prune regexp.
429   * Also generate rel=bookmark links for permalinks.
430   * Fix the htmltidy plugin, which wasn't working due my breaking it when
431     I added it..
432   * Don't run tidy with -xml as that fails if the input is not well-formed.
433     Run it with -asxhtml instead, so it will output well-formed xhtml no
434     matter what the input.
435   * Disable tidy warnings too.
436   * Add a new format hook, and make tidy use it, since tidy can really only
437     operate on and output complete html documents, not the body chunks
438     that sanitise gets.
439   * Fix dates in rss feeds if running localised, so they're still rfc 822.
440
441  -- Joey Hess <joeyh@debian.org>  Fri,  4 Aug 2006 20:48:36 -0400
442
443 ikiwiki (1.15) unstable; urgency=low
444
445   * Remove CDPATH and other env vars perl taint checking doesn't like.
446     Closes: #381279
447   * Added created_before and created_after PageSpec limits.
448
449  -- Joey Hess <joeyh@debian.org>  Thu,  3 Aug 2006 13:00:57 -0400
450
451 ikiwiki (1.14) unstable; urgency=low
452
453   * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
454     by 10% or so.
455   * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
456   * Added many unit tests for pagespec_match.
457
458  -- Joey Hess <joeyh@debian.org>  Wed,  2 Aug 2006 11:34:06 -0400
459
460 ikiwiki (1.13) unstable; urgency=low
461
462   * ikiwiki can now download and aggregate feeds with its new aggregate
463     plugin, so it's possible to implement a Planet using ikiwiki!
464   * Add a run_hooks function for the common task of running all hooks of a
465     given type.
466   * Add a savestate hook.
467   * Don't put blog post forms on pages if there's no cgiurl set.
468   * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
469     --wrappers to do that.
470   * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
471     to update pages that haven't changed on disk.
472   * Change meta tags to use html entity-escaped text for values, so that
473     quotes and such can be represented in title tags.
474   * Depend and build-depend on HTML::Parser for HTML::Entities which is used
475     for the above.
476   * Make --rebuild also cause --aggregate to re-download and write aggregated
477     pages.
478   * Avoid outputting duplicate meta info.
479   * Include title metadata on aggregated posts for capitalised and un-munged
480     titles.
481   * Title metadata of inlined pages now shows up in blogs and rss feeds.
482   * Fix issue with unicode filenames and updating the hyper estradier search
483     index. (Aka Please Please Please, let that be the last one.)
484   * Patch from Roland Mas to support an rss=no parameter to inline directives.
485     Closes: #380743
486   * Renamed GlobLists to PageSpecs.
487   * PageSpecs can now include nested parens, "and", and "or". This remains
488     backwards compatible to the old GlobList format. It's implemented by
489     treating the GlobList as a very limited microlanguage that is transformed
490     to perl code that does the matching.
491   * The old GlobList format is deprecated, and I encourage users to switch to
492     using the new PageSpec format. Compatability with the old format will be
493     removed at some point, possibly by 2.0.
494   * Wiki rebuild needed on upgrade to this version due to PageSpec change.
495   * Add support for creation_month and creation_year to PageSpec.
496     Closes: #380680
497   * Changes to index file encoding.
498
499  -- Joey Hess <joeyh@debian.org>  Tue,  1 Aug 2006 21:21:19 -0400
500
501 ikiwiki (1.12) unstable; urgency=low
502
503   "Viva l'Italia!"
504   * New pagestats plugin from Enrico, which can generate a table counting
505     the backlinks for each page, or a del.icio.us style cloud.
506   * Build-depend on libtext-wikiformat-perl, so that the syntax check of
507     the wikiformat plugin works. Thanks, Emanuele Aina.
508   * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
509     display, running them through pagetitle. This removes ugly underscores and
510     other gunk from the display, much nicer. You may want to rebuild your wiki
511     when upgrading to get the cleanup globally.
512   * Polygen plugin from Enrico.
513   * htmltidy plugin from Faidon.
514   * Locale patch from Faidon:
515     - Adds a locale setting to setup files.
516     - Proper local time, if the locale configuration option is used.
517     - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
518       commiting (or even rcs_updating) on repositories with UTF-8 filenames was
519       impossible.
520   * Add getopt hook type, this allows plugins to add new command-line options.
521   * Add --tagbase option to tag plugin.
522   * Add exclude option in setup files, works same as --exclude.
523   * Put categories in rss feeds for tagged items.
524   * Allow preprocessor directives to be expanded in inlined blog pages.
525     However, to avoid inlining loops etc, don't expand inline directives in
526     inlined pages.
527   * fortune plugin (trivial)
528   * Tag plugins according to type.
529
530  -- Joey Hess <joeyh@debian.org>  Sat, 29 Jul 2006 17:12:56 -0400
531
532 ikiwiki (1.11) unstable; urgency=low
533
534   * Patch from Enrico that
535     - Adds a tag plugin that allows more easily tagging pages.
536       The meta plugin can also still be used for that, but the tag plugin
537       also lists a page's tags at the bottom of the page.
538     - Allows preprocessor directives to have parameters with no specified
539       value.
540     - Fixes preprocessor directive parameter parsing so that
541       foo=bar baz now means "foo=bar" and a "baz" with no value.
542   * Run pagetemplate hooks when inlining pages so that inlined pages also
543     list their tags.
544   * Make all plugins with pagetemplate hooks check that variables exist
545     on the template before setting them, for robustness.
546   * Switch pagetemplate hooks to using named parameters.
547   * Pass a destpage parameter to preprocessor and pagetemplate hooks.
548     This will be the page that a source page will be part of, which is
549     different than the source page for inlined pages.
550   * Audited all plugins to endure they pass (page, destpage) to htmllink
551     appropriatly. This means inlining of various plugins will not work
552     properly, with correct links generated.
553
554  -- Joey Hess <joeyh@debian.org>  Thu, 27 Jul 2006 20:51:23 -0400
555
556 ikiwiki (1.10) unstable; urgency=low
557
558   * Run page through any relevant filters when generating a page preview.
559   * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
560     default throughout the wiki, not only on wikitext pages. Decided to call
561     this a feature, and split the camelcase support out into a separate plugin
562     that is independant of wikitext.
563   * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
564
565  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 18:06:35 -0400
566
567 ikiwiki (1.9) unstable; urgency=low
568
569   * Improve display of parentlinks and page title of toplevel index page.
570   * Patch from Faidon to use svn --limit when possible for recentchanges,
571     speeds up recentchanges a lot for wikis with more history.
572   * Patch from Recai to fix utf8 issues in git backend.
573   * Add wikitext markup plugin, which supports ".wiki" pages written in the
574     original wiki syntax, CamelCase links and all.
575   * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
576     support, to edit pages etc without a web server.
577   * Display CGI processing errors if present.
578   * Fix from Faidon for a XML parser issue that breaks utf-8 for
579     RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
580     area, and also way slow.
581   * Match 'web commit from' in SVN and git, these are web commits too.
582     (Faidon)
583   * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
584     readable and avoid future mistakes. The patch seems to work and for the
585     first time I have a UTF-8 username ;-) (Faidon)
586   * Use form->field consistently, not form->param.
587   * Patch from Recai to allow selection of page type when creating a new page.
588     Default page type is inherited from the link clicked on to create the new
589     page.
590
591  -- Joey Hess <joeyh@debian.org>  Wed, 26 Jul 2006 17:25:30 -0400
592
593 ikiwiki (1.8) unstable; urgency=low
594
595   * Fix orphans plugin to not count a link to a nonexistant page as a reason
596     for a page not being an orphan.
597   * Support pinging services such as Technorati using XML-RPC to notify them
598     about changes to rss feeds.
599   * Parse svn log as xml for improved utf8 and security. Note that this makes
600     ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
601   * POSIX::strftime doesn't know about encodings and doesn't return a utf8
602     flagged string even if the locale causes it to generate utf8 output,
603     so make sure to let perl know it should be handled as utf8. Also,
604     the optimised version used for standard time formats won't work if the
605     user has changed locale, so drop it. Thanks, Faidon Liambotis.
606   * Fix re-encoding of the comments field to utf8 if a commit fails
607     due to a conflict. Thanks, Faidon Liambotis.
608   * Let svn know that commits have utf8 commit messages. Thanks, Faidon
609     Liambotis.
610   * Add insane double encode/decode to utf8 around call to markdown.
611     This works around a truely strange bug, which is apparently a bug in
612     perl, #376329. Also added a test case for it.
613   * Improve layout of edit page so formatting help link is always visible w/o
614     getting in the way of the preview.
615   * Centralised all calls to HTML::Template and force all the templates
616     to be read as utf8.
617   * Support pages with utf8 filenames. Patch by Faidon Liambotis.
618   * Introduce add_plugins and disable_plugins config options in setup files.
619     This allows adding or removing plugins w/o overriding the whole list of
620     default plugins, which makes it easier to upgrade when new default plugins
621     are added.
622   * Support htmlize plugins and make mdwn one such plugin, which is enabled by
623     default (of course!). Based on a patch by Faidon Liambotis.
624   * Add a html plugin, which can be used to write wikis in raw html,
625     if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
626     defaults to not processing .html files, since w/o this plugin they would
627     be copied unsanitised. With this plugin, it will process and html
628     sanitise them, like any other page type.
629   * Rebuilding wrappers is necessary on upgrade to this version.
630   * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
631     will be automatically done on all upgrades.
632   * Don't send pings if the wiki is being rebuilt.
633   * Work around very innefficient behavior in File::Spec::abs2rel. Result
634     is a savings of 2 pointless fork/execs per link calculation, which
635     results in ~25% speedup of ikiwiki building its own doc wiki, and
636     about 35% speedup displaying RecentChanges!
637   * Make RecentChanges use a table and some CSS, should be much more readable.
638     No code changes involved.
639   * Encode & in diffurl in examples, to conform to pedantic rules.
640   * Speed up RecentChanges by another 40% or so with some memoization.
641   * Memoize abs2rel, which is still kinda slow, for another 30% speedup
642     in time to build the doc wiki.
643
644  -- Joey Hess <joeyh@debian.org>  Tue,  4 Jul 2006 12:46:29 -0400
645
646 ikiwiki (1.7) unstable; urgency=low
647
648   * Updated logo from Recai with some kerning and alingment tuning.
649   * Patch from Recai to fix git recentchanges code to work with git 1.4 which
650     changed some output.
651   * Copyright update.
652
653  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 23:33:35 -0400
654
655 ikiwiki (1.6) unstable; urgency=low
656
657   * YA utf-8 patch from Recai, this time to fix previewing a page so that
658     the text in the input box is re-encoded back to utf-8.
659   * -CSD does not affect modules, so readfile() was not using the utf-8 input
660     layer, which led to lots of problems; make it force read files as utf-8.
661     Closes: #373203
662   * Note that as a consequence, this version of ikiwiki will actually try to
663     parse utf8 in source files for the first time, which may expose broken
664     utf8 in wiki sources that was hidden before. Most common will be
665     perl warnings like "utf8 "\xE9" does not map to Unicode"
666   * writefile() likewise needs to use the utf8 output layer.
667   * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
668     there.
669   * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
670     given the readfile fix.
671   * Add utf-8 testcases for readfile and htmlize.
672   * Put back the encode_utf8 in the input to markdown; it's really not utf-8
673     safe.
674   * More utf-8 fixes from Recai, partly to things I broke above:
675     - The serious problem is that writefile() saves the content in undecoded
676       format in CGI, hence all (non-ascii) chars are corrupted permanently.
677     - Comment field in edit page is not decoded and all the non-ascii chars in
678       this field are corrupted as the result.  We should decode it as we do it
679       for the content.
680     - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
681       character in print.
682   * New SVG logo from Recai.
683
684  -- Joey Hess <joeyh@debian.org>  Sun, 18 Jun 2006 19:18:46 -0400
685
686 ikiwiki (1.5) unstable; urgency=low
687
688   * Add --timeformat config option to allow changing how dates are displayed.
689     Note that as a side effect, dates will now be displayed using the local
690     timezone, not as GMT.
691   * More security review.
692   * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
693     for some handy stuff like:
694     - Using links as a kind of tag; creating blog pages that list all pages
695       containing a given tag/link or not containing some other tag.
696     - Subscribing to mail notifications whenever a change is made to a page
697       that is a backlink of page foo. Ie, "Please notify me of changes in all
698       pages that link to my home page in the wiki"
699     - Locking any pages that are linked to from a particular page, so that
700       lists of locks can be exposed in the wiki.
701   * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
702     when a todo item is done, instead of the previous moving it to a different
703     subdir.
704   * Allow pagetemplate plugins to override *anything* in the template.
705   * Add a meta plugin, which allows specifying various metadata about pages,
706     like license and author. It also allows for inserting html link and meta
707     tags into html, overriding the title, and adding hidden WikiLinks, which
708     can be useful when using link-based globbing for page categorisation.
709   * Remove preprocessor directives from inlined pages.
710   * Allow simple preprocessor directive values to be specified w/o quotes.
711   * Add support for using git instead of subversion as the RCS backend,
712     tremendous thanks to Recai Oktaş for this.
713   * Doc updates for git.
714   * Fix absolute url munging in rss generation to support https, ftp, etc urls
715     not just http urls.
716   * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
717     utf-8 for edit and other fields, and for recentchanges. There may still
718     be utf-8 issues with the preferences page though.
719
720  -- Joey Hess <joeyh@debian.org>  Sun, 11 Jun 2006 19:56:54 -0400
721
722 ikiwiki (1.4) unstable; urgency=low
723
724   * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
725     very strange way of enabling proper XHTML <br /> type tags. Output html
726     should be always valid again now.
727   * The page name and parent links has switched from using a <h1> to a styled
728     <span>, so pages can use <h1> internally instead of needing to use <h2>.
729   * Updated all of ikiwiki's own wiki pages for that.
730   * Add pagetemplate hook, which can be used by plugins that want to mess
731     around with adding new stuff to the page template.
732   * Remove headercontent; the search plugin now adds the search box to the
733     header by registering a pagetemplate hook, and other plugins should do
734     similarly.
735   * Rebuilding on upgrade to this version is recommended.
736   * Add a html validity check to the test suite, using the wdg-html-validator,
737     if available.
738   * Make the html valid when there is nothing in the actions list.
739   * Reordered some function call parameters for consistency.
740   * Enable full utf-8 support for page input and output.
741   * Add a workaround for markdown, which does not work well with utf-8
742     strings.
743   * --getctime had bitrotted (well I only ever used it the once so far..),
744     fix and make it a bit more flexible
745   * rcs_getctime is changed, now rather than needing to loop over all pages,
746     it should just use the rcs to get the ctime of the passed file.
747   * When inlining a page in another one, links from the inlined page are now
748     expanded the same as they are when rendering the inlined page as a
749     standalone page. So rather than being expanded from the POV of the
750     inlining page, they are expanded from the POV of the inlined page.
751
752     For example, a link from blog/foo to "bar" will now link to blog/bar
753     if it exists. Previously this needed to be a link explicitly to
754     "blog/bar"; such links will also continue to work.
755
756     (This was slightly complex to do as the link still has to be constructed
757     relative to the inlining page.)
758   * Make page edit textarea resize to fit browser window.
759   * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
760     do not need a full rebuild, in order to update any basewiki pages.
761
762  -- Joey Hess <joeyh@debian.org>  Sat, 27 May 2006 15:08:49 -0400
763
764 ikiwiki (1.3) unstable; urgency=low
765
766   * Fix the preinst introduced in the last version. Closes: #367458
767
768  -- Joey Hess <joeyh@debian.org>  Tue, 16 May 2006 02:43:02 -0500
769
770 ikiwiki (1.2) unstable; urgency=low
771
772   * Remove dups from the brokenlinks list.
773   * Add libc6-dev to dependencies, needed to build wrappers.
774   * Install wikilist in correct location. Closes: #367371
775
776  -- Joey Hess <joeyh@debian.org>  Mon, 15 May 2006 10:53:49 -0500
777
778 ikiwiki (1.1) unstable; urgency=low
779
780   * Rename inlinepage to depends, so that it can be used to refer to more
781     dependency relationships than just inlining. This will require a rebuild
782     on upgrade to this version.
783   * Move the rss link, put it in the blogpost form if there is one and at the
784     top if not. This is both nicer because easier to find, and it cleans up
785     the code which had used inlinepage as a flag for adding the link later.
786   * Allow the depends GlobList to be built up from multiple sources (such as
787     plugins) during a page render.
788   * Which means that more than one blog is now supported to appear on a
789     single page. (With some limitations, like only the last one getting an
790     rss file.)
791   * Added a plugin system.
792   * Added a pagecount plugin, enabled by default.
793   * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
794   * Fixed/optimised backlinks code, to avoid rebuilding pages to update
795     backlinks when the backlinks hadn't really changed.
796   * Moved inline page support, rss generation etc into the inline plugin,
797     enabled by default.
798   * Added brokenlinks plugin, not enabled by default, but rather handy.
799   * Fix several broken links in the doc wiki.
800   * Smarter behavior when creating a page and a page of the same name (but
801     different location) already exists.
802   * Add an orphans plugin for finding pages that nothing links to.
803   * Removed backlinks page, which it turns out nothing used.
804   * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
805     it, this will allow for adding a unit test suite.
806   * Add unit tests for several core functions, including globlist_match,
807     dirname, basename, bestlink, linkify, pagetitle, titlepage.
808   * Smart globlist merging.
809   * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
810     to pave the way for adding other RCS support. This also changes the
811     setup files, where before they had svn => 1 or svn => 0, now they have
812     rcs => "svn" or rcs => "".
813   * Add a debian/NEWS file with upgrade notes.
814   * Load whatever rcs module is specified, so new ones can be just dropped in
815     as plugins and work. (Well, in theory.)
816   * Add some basic docs about writing RCS modules.
817   * Broke search capability out into a plugin, removed the --hyperestraier
818     switch.
819   * Added smiley plugin, nicely controlled and documented by the smileys page.
820   * Copied in some smileys from Moin Moin.
821   * Allow links of the form [[some page|page]], with whitespace in the link
822     text.
823   * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
824     and --disable-plugin htmlscrubber.
825   * Allow discussion links on pages to be turned off with --no-discussion.
826   * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
827   * Add some new config items to the estseek.conf template, which are needed
828     by hyperestraier 1.2.3.
829
830  -- Joey Hess <joeyh@debian.org>  Fri,  5 May 2006 17:00:41 -0400
831
832 ikiwiki (1.0) unstable; urgency=low
833
834   * First official release.
835
836  -- Joey Hess <joeyh@debian.org>  Tue, 25 Apr 2006 02:08:17 -0400