remove doubly-outdated server info