make dot_cgi clearly optional