fix add_depends to new api