note that i still need to apply this patch manually on upgrades