d13998657bd5dad49dcbf99d10ad13671acb8b7a
[wiki.git] / doc / LennyBugs
1 = Logistics =
2
3 SIPB is running a bug-squashing hackathon for release-critical bugs in Debian Lenny
4
5 Place: '''W20-557''', the SIPB office[[BR]]
6 Date: '''Saturday''', 2008-12-13, between classes and finals[[BR]]
7 Time: starting '''2 PM''', running to about 10 PM; come for any portion
8
9 = FAQ =
10
11 '''Q''': What's Lenny?[[BR]]
12 '''A''': Lenny is the upcoming next stable release of Debian GNU/Linux.  It was scheduled for September 2008 but has slipped to spring 2009.  The last release was Etch in spring 2007, so Debian users are eagerly awaiting a new release.
13
14 '''Q''': I use Ubuntu.  Why do I care about Debian releases?[[BR]]
15 '''A''': Because Lenny is in the final, "freeze", stage of the cycle, many Debian contributors are holding off new versions of the software they maintain in order to focus on stabilizing and bugfixing Lenny.  Since Ubuntu depends on Debian for 90% of its packaging work, that means less new software for Ubuntu until Lenny releases.
16
17 '''Q''': I've never tried to hack on a Debian package.[[BR]]
18 '''A''': No problem, we have three Debian Developers pledged to attend, and Debian-packaging experts from SIPB's Debathena and XVM projects.  They'll all be focussed on helping newer people find a good bug, make progress and stay unstuck on solving it, and get the fixes applied in Debian.  No Debian experience is necessary.
19
20 = The Bugs =
21
22 Coming soon, this list formatted better and with links to the bug pages.
23
24 {{{
25 507927  acpi-support    Fix suspend-resume in Thinkpad R50e (intel 855gm card)
26 507242  amule-daemon    amule-daemon: causes OOM's by leaking lots of memory
27 507883  asterisk        asterisk: Very frequent segfaults on startup
28 506961  auctex  auctex: reuses old logfile on emacsen upgrades, enabling symlink attack
29 496954  bind9   bind9: Fails to start due to SIGSEGV
30 501800  bind9   bind9: bind crashes with a list for allow-update
31 497471  cdimage.debian.org      sarge images have syslinux binaries without source
32 507706  cdimage.debian.org      Missing sources for d-i components/kernel of etch-n-half images
33 502751  clamav-getfiles clamav-getfiles: piuparts test fails: eicar.com md5sum mismatch, file needs downloading
34 507721  cryptsetup      cryptsetup: Sometimes initrd ends up missing conf/conf.d/cryptroot file in it
35 503532  dbus    send_requested_reply="true" allows all non-reply messages
36 504340  djvulibre-plugin        djvulibre-plugin: Iceweasel crashes when loading DjVu documents
37 481072  dk-filter       dk-filter reliably crashes upon connection from postfix
38 505929  egroupware      egroupware incompatible with php 5.2.6
39 504283  egroupware-core CVE-2007-3215: phpmailer issue (embedded code-copy)
40 456037  fenix   fenix: not 64 bit clean
41 504977  ffmpeg-debian   ffmpeg-debian: Several security issues
42 451628  ftp.debian.org  Packages might enter the archive from security without source
43 497823  ftp.debian.org  longstanding DFSG violations in linux-2.6 package
44 506152  ftp.debian.org  libept0 should have priority important
45 507675  ftp.debian.org  python2.5 should have priority standard
46 507678  ftp.debian.org  libsqlite3-0 should have priority standard
47 507775  ftp.debian.org  libkeyutils1 should have priority standard
48 507778  ftp.debian.org  libldap-2.4-2 should have priority standard
49 507779  ftp.debian.org  [Priorities] libustr-1.0-1 -> standard
50 507780  ftp.debian.org  python-sepolgen should have priority standard
51 507783  ftp.debian.org  libxml2 should have priority standard
52 507784  ftp.debian.org  python2.5-minimal should have priority standard
53 507796  ftp.debian.org  libisccfg40 should have priority standard
54 507797  ftp.debian.org  libisccc40 should have priority standard
55 507798  ftp.debian.org  libedit2 should have priority standard
56 507799  ftp.debian.org  libgssglue1 must have priority standard
57 507800  ftp.debian.org  ucf must have priority standard
58 507801  ftp.debian.org  libpci3 must have priority standard
59 503712  ghostscript     etch->lenny upgrade left the system in broken state
60 504747  gnu-fdisk       gnu-fdisk: wipes out MBR when used on GPT partitions
61 506684  guile-1.8-dev   guile-1.8: includes own definition of jmp_buf type in public header
62 507021  helpdeco        Fails to work on amd64
63 507558  hibernate       ignores "LockXLock yes" setting in /etc/hibernate/common.conf (e.g. does not lock the screen)
64 505563  icedove Mozilla Thunderbird Multiple Vulnerabilities
65 426465  initramfs-tools /init exports MODPROBE_OPTIONS=-qb
66 507059  initramfs-tools initramfs-tools: Wrong check for udevadm in functions
67 394963  installation-reports    installation: Problems with dual booting Dell D600 with winXP pro in the first partition (hd0, 0). After installing the Dell Etch Beta 3, Windows fails to boot and I get the blue screen of death.
68 418972  installation-reports    cdrom: Etch does not detect CD-ROM on Acer Aspire 7100
69 436140  installation-reports    cdrom: Most of the system's files have a future timestamp causing at least update/config problems.
70 494293  installation-reports    installation-reports: Grub error: not a regular file...
71 495603  installation-reports    grub-installer fails on a FSC Primergy RX300 with a level 5 RAID
72 501804  installation-reports    installation-reports: Lenny b2 install on ThinkPad X61 - fails to detect hard disk
73 507072  ipsec-tools     libipsec0 packaged in ipsec-tools without development headers
74 499078  jfsutils        jfsutils: Bus Error when running fsck.jfs on sparc
75 506853  libgnutls26     libgnutls26: 2.4.2-3 breaks OpenLDAP access
76 495178  libjs-jquery    libjs-jquery: Should compile jquery.min.js and jquery.pack.js from jquery.js
77 508133  libmad0 audacity: munmap_chunk(): invalid pointer: 0x00000000026f4eb0
78 490999  libqt3-mt       kicker: crashes on startup
79 504373  libtemplate-perl        libtemplate-perl: Upgrade from etch breaks code using DBI plugins
80 503907  libwebkit-1.0-1 epiphany-webkit: Crashes at startup whenever I go to a site.
81 506353  mailscanner     CVE-2008-5312/3: mailscanner might allow local users to overwrite arbitrary files via a symlink attack
82 496334  mdadm   mdadm segfault on --assemble --force with raid10
83 507889  mdadm   mdadm: initramfs-tools script is broken, system with root on RAID won't boot
84 507818  mldonkey-server mldonkey-server: mlnet does not start, logs syntax error in downloads.ini
85 507947  moodle  moodle: html2text.php is not DFSG-free
86 504918  network-manager Updating to lenny failed when NetworkManager got updated504626  nvidia-glx      [nvidia-glx] Quietly drops support for several chipsets
87 504661  nvidia-glx-legacy-96xx-dev      nvidia-glx-legacy-96xx-dev: /usr/lib/libGL.so symlink broken
88 507003  open-iscsi      initiatorname.iscsi should maybe not be in /etc
89 508351  open-iscsi      open-iscsi: will not install, looking for missing /sys/module/scsi_transport_iscsi/version file
90 507865  openoffice.org-writer   openoffice.org-writer: OOo 2.4.x openinig OOo 3 files doesn't show text (2.x implements standard wrong)
91 500460  oss-compat      oss-compat: modules are not loaded
92 475737  otrs2   otrs2 - makes files in /usr writable by non-root
93 502140  pam     cannot unlock screen during etch -> lenny transition
94 508026  phppgadmin      phpPgAdmin: Local File Inclusion Vulnerability
95 507915  povray  Povray unusable with non-ascii filenames
96 476525  python-hid      python-hid: hid module will not import since python policy transition
97 495232  quagga  quagga: zebra ignores routes added via command line
98 507071  racoon  racoon - Fails after upgrade: symbol lookup error: /usr/sbin/racoon: undefined symbol: libipsec_opt
99 332782  release-notes   release-notes: Where's the license?
100 475958  release-notes   document procedure to recover from "/dev/hda became /dev/sda" boot failure
101 506977  release.debian.org      FPC: copyright infringement in pre 2.2.2 sources507239  release.debian.org      RM: astrolog/stable -- RoQA; orphaned long time, non-free, contains potentially undistributable code
102 490171  rtorrent        rtorrent: random crash
103 506748  rtorrent        crash rtorrent by scgi-interface (function: 'fi.get_filename_last')
104 478717  ruby1.9 ruby1.9: FTBFS on hppa: make[1]: *** [all] Segmentation fault
105 507316  smarty  smarty: Non-free logo included in package
106 505237  snmpd   /etc/init.d/snmpd start reports error if already running
107 506057  splashy splashy: Splashy fails to install due to missing default theme
108 508194  sun-java5       sun-java5: New upstream release fixes several security issues
109 504524  sun-java6       AWT_TOOLKIT=MToolkit causes java to segfault on amd64
110 508265  sysprof-module-source   sysprof-module-source: doesn't compile on AMD64 arch (wrong register names)
111 506883  tuxguitar       tuxguitar: hard-codes dependencies on libraries
112 508091  tuxguitar       maintainer address bounces
113 508257  twiki   CVE-2008-5305: TWiki SEARCH variable allows arbitrary shell command execution
114 507996  uim-tcode       mazegaki conversion cannot be used
115 503303  upgrade-reports etch -> lenny minimal chrrot upgrade fails due to Conflicts/Pre-Depends loop
116 506741  wireshark       wireshark: DoS caused by sending a SMTP request with large content
117 323473  wnpp    ITA: mol-drivers-linux -- The Mac-on-Linux emulator - drivers for Linux
118 508322  wodim   wodim: Cannot load media.  Cannot init drive.
119 504771  wordpress       wordpress can be subject of delayed attacks via cookies
120 476210  xbat    xbat: game elements do not display properly
121 507576  xbattbar-acpi   missing dependency: libconfig
122 507165  xine-lib        xine-lib: CVE-2008-5242 heap-based buffer overflow
123 507184  xine-lib        xine-lib: CVE-2008-5246 heap overflow
124 508313  xine-lib        xine-lib: CVE-2008-5234 heap overflow in atom parsing
125 374644  xine-ui xine-ui: ctrl/shift key press emulation implementation broken
126 506652  xml2rfc Yet another boilerplate change
127 507944  xwhois  xwhois: segfaults on start in get_servers()
128 507579  yocto-reader    Package installation results in license violation
129 508124  yum     Yum crashes when setting-up a CentOS chroot OS
130 }}}
131 (list as of 2008-12-10 at 2240)