group sections
authorGreg Price <price@mit.edu>
Sun, 14 Dec 2008 08:24:04 +0000 (03:24 -0500)
committerTrac <sipb-www@mit.edu>
Sun, 1 Feb 2009 07:25:17 +0000 (02:25 -0500)
doc/LennyBugsAll

index 1ff4011788cf18be05ef467c8d54c5634346d19f..b0f3a09bcedfdad6db5213b7b838a6300215e51a 100644 (file)
@@ -9,10 +9,92 @@ Please sort into useful/not useful, add notes, etc.
 
 = Juicy? =
 
 
 = Juicy? =
 
-All dealt with!  See the section "Fixed by SIPB" below.
+All acted on!  See the "Stuff we did" sections below.
 
 
 
 
-= Flamewars =
+= Stuff we did =
+
+== Fixed by SIPB! ==
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=436140 436140]
+in [http://packages.debian.org/lenny/installation-reports installation-reports]
+"cdrom: Most of the system's files have a future timestamp causing at least update/config problems."
+(closed by wdaher)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=476525 476525] 
+in [http://packages.debian.org/lenny/python-hid python-hid] 
+"python-hid: hid module will not import since python policy transition" 
+(tabbott)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507071 507071] 
+[http://packages.debian.org/lenny/racoon racoon] 
+"racoon - Fails after upgrade: symbol lookup error: /usr/sbin/racoon: undefined symbol: libipsec_opt" 
+(fixed by broder)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507072 507072] 
+in [http://packages.debian.org/lenny/ipsec-tools ipsec-tools] 
+"libipsec0 packaged in ipsec-tools without development headers" 
+(downgraded by hartmans)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=504626 504626] 
+in [http://packages.debian.org/lenny/nvidia-glx nvidia-glx] 
+"[nvidia-glx] Quietly drops support for several chipsets" 
+(downgraded by nelhage)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502845 502845]
+in [http://packages.debian.org/lenny/open-iscsi open-iscsi]
+"open-iscsi: no login using amd64"
+(quentin reassigned; Bastian Blank then lowered priority)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=508265 508265]
+in [http://packages.debian.org/lenny/sysprof-module-source sysprof-module-source]
+"sysprof-module-source: doesn't compile on AMD64 arch (wrong register names)"
+(patch added by andersk)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=506057 506057]
+in [http://packages.debian.org/lenny/splashy splashy]
+"splashy: Splashy fails to install due to missing default theme"
+(fix suggestion added by ecprice with help from tabbott and fawkes)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=506748 506748]
+in [http://packages.debian.org/lenny/rtorrent rtorrent]
+"crash rtorrent by scgi-interface (function: 'fi.get_filename_last')"
+(submitted patch that disables broken RPC; leaving to maintainer to decide if this is what he wants to do)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=426465 426465]
+in [http://packages.debian.org/lenny/initramfs-tools initramfs-tools]
+"/init exports MODPROBE_OPTIONS=-qb"
+[[BR]](patch added by price)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=489501] in [http://packages.debian.org/lenny/zekr zekr] "zekr depends on libxul0d"
+[[BR]](tweaked and sponsored fix by Asheesh Laroia)
+
+== Waiting on feedback ==
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502140 502140]
+in [http://packages.debian.org/lenny/pam pam]
+"cannot unlock screen during etch -> lenny transition"
+(hartmans added comment)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=481072 481072]
+in [http://packages.debian.org/lenny/dk-filter dk-filter]
+"dk-filter reliably crashes upon connection from postfix"
+[[BR]](quentin couldn't reproduce)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507883 507883]
+in [http://packages.debian.org/lenny/asterisk asterisk]
+"asterisk: Very frequent segfaults on startup"
+(quentin couldn't reproduce)
+
+[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=456037 456037]
+in [http://packages.debian.org/lenny/fenix fenix]
+"fenix: not 64 bit clean"[[BR]]
+(ezyang observed upstream's website looks ~dead)
+
+
+
+= Fun stuff to read =
+
+== Flamewars ==
 
 You might enjoy reading these, but they may not be good targets to fix.
 
 
 You might enjoy reading these, but they may not be good targets to fix.
 
@@ -35,7 +117,7 @@ in [http://packages.debian.org/lenny/gnu-fdisk gnu-fdisk]
 "gnu-fdisk: wipes out MBR when used on GPT partitions"
 
 
 "gnu-fdisk: wipes out MBR when used on GPT partitions"
 
 
-= Would have been fun =
+== Would have been fun ==
 
 Entertaining to read but sadly already fixed.
 
 
 Entertaining to read but sadly already fixed.
 
@@ -44,7 +126,7 @@ in auctex
 "auctex: reuses old logfile on emacsen upgrades, enabling symlink attack"
 
 
 "auctex: reuses old logfile on emacsen upgrades, enabling symlink attack"
 
 
-= Examples to live up to =
+== Examples to live up to ==
 
 [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=496954 496954]
 in [http://packages.debian.org/lenny/bind9 bind9]
 
 [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=496954 496954]
 in [http://packages.debian.org/lenny/bind9 bind9]
@@ -53,7 +135,7 @@ in [http://packages.debian.org/lenny/bind9 bind9]
 got the first reproducible testcase, and sent that upstream, which swiftly produced a fix.
 
 
 got the first reproducible testcase, and sent that upstream, which swiftly produced a fix.
 
 
-= Puzzling =
+== Puzzling ==
 
 Someone please explain what's going on (Debian Project-wise) in these bugs.
 
 
 Someone please explain what's going on (Debian Project-wise) in these bugs.
 
@@ -63,7 +145,9 @@ in [http://packages.debian.org/lenny/wnpp wnpp]
 [[BR]](Note: The bug is for someone to take over maintainership.  They did.  Then when the bug gets automatically archived, they reply saying to keep it?  I (price) don't understand.)
 
 
 [[BR]](Note: The bug is for someone to take over maintainership.  They did.  Then when the bug gets automatically archived, they reply saying to keep it?  I (price) don't understand.)
 
 
-= Specific hardware =
+= Not so ripe for us to fix =
+
+== Specific hardware ==
 
 If you have the relevant hardware you could help a lot.
 
 
 If you have the relevant hardware you could help a lot.
 
@@ -92,7 +176,7 @@ in [http://packages.debian.org/lenny/installation-reports installation-reports]
 "grub-installer fails on a FSC Primergy RX300 with a level 5 RAID"
 
 
 "grub-installer fails on a FSC Primergy RX300 with a level 5 RAID"
 
 
-= May be a lot of work =
+== May be a lot of work ==
 
 [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=490171 490171]
 in [http://packages.debian.org/lenny/rtorrent rtorrent]
 
 [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=490171 490171]
 in [http://packages.debian.org/lenny/rtorrent rtorrent]
@@ -100,7 +184,7 @@ in [http://packages.debian.org/lenny/rtorrent rtorrent]
 [[BR]](Reproducing this seems to require runnin 20+ torrents for a ~day)
 
 
 [[BR]](Reproducing this seems to require runnin 20+ torrents for a ~day)
 
 
-= Unclassified =
+== Unclassified ==
 
 Please read these reports and figure out what category they belong in.  Or make a new category.
 
 
 Please read these reports and figure out what category they belong in.  Or make a new category.
 
@@ -112,7 +196,7 @@ in [http://packages.debian.org/lenny/nvidia-glx-legacy-96xx-dev nvidia-glx-legac
 in [http://packages.debian.org/lenny/network-manager network-manager]
 "Updating to lenny failed when NetworkManager got updated"
 
 in [http://packages.debian.org/lenny/network-manager network-manager]
 "Updating to lenny failed when NetworkManager got updated"
 
-= Unclassified Security =
+== Unclassified Security ==
 
 [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505563 505563]
 in [http://packages.debian.org/lenny/icedove icedove]
 
 [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505563 505563]
 in [http://packages.debian.org/lenny/icedove icedove]
@@ -130,7 +214,7 @@ in [http://packages.debian.org/lenny/xine-lib xine-lib]
 in [http://packages.debian.org/lenny/ffmpeg-debian ffmpeg-debian]
 "ffmpeg-debian: Several security issues"
 
 in [http://packages.debian.org/lenny/ffmpeg-debian ffmpeg-debian]
 "ffmpeg-debian: Several security issues"
 
-= Fresh bugs =
+== Fresh bugs ==
 
 These are very recent and presumably will get dealt with by the package maintainers without help.
 
 
 These are very recent and presumably will get dealt with by the package maintainers without help.
 
@@ -226,7 +310,7 @@ in [http://packages.debian.org/lenny/linux-2.6 linux-2.6]
 in [http://packages.debian.org/lenny/autopkgtest-xenlvm autopkgtest-xenlvm]
 "adtxenlvm: initscript assumes eth0"
 
 in [http://packages.debian.org/lenny/autopkgtest-xenlvm autopkgtest-xenlvm]
 "adtxenlvm: initscript assumes eth0"
 
-= Mostly solved? =
+== Mostly solved? ==
 
 These look like good progress is being made and they'll get fixed
 soon. Do we need a DD to do an NMU on any of these?
 
 These look like good progress is being made and they'll get fixed
 soon. Do we need a DD to do an NMU on any of these?
@@ -320,7 +404,7 @@ in [http://packages.debian.org/lenny/oss-compat oss-compat]
 "oss-compat: modules are not loaded"
 
 
 "oss-compat: modules are not loaded"
 
 
-= Not much of use one can do =
+== Not much of use one can do ==
 
 (waiting on reporter to reproduce)
 
 
 (waiting on reporter to reproduce)
 
@@ -385,7 +469,7 @@ in [http://packages.debian.org/lenny/smarty smarty]
 "smarty: Non-free logo included in package"
 
 
 "smarty: Non-free logo included in package"
 
 
-= Special team bugs =
+== Special team bugs ==
 
 These bugs are probably not good targets because the work involved with them at this point is to be done by someone on a special Debian team.
 
 
 These bugs are probably not good targets because the work involved with them at this point is to be done by someone on a special Debian team.
 
@@ -475,79 +559,3 @@ in [http://packages.debian.org/lenny/libwebkit-1.0-1 libwebkit-1.0-1]
 "epiphany-webkit: Crashes at startup whenever I go to a site."
 
 
 "epiphany-webkit: Crashes at startup whenever I go to a site."
 
 
-= Waiting on feedback =
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502140 502140]
-in [http://packages.debian.org/lenny/pam pam]
-"cannot unlock screen during etch -> lenny transition"
-(hartmans added comment)
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=481072 481072]
-in [http://packages.debian.org/lenny/dk-filter dk-filter]
-"dk-filter reliably crashes upon connection from postfix"
-[[BR]](quentin couldn't reproduce)
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507883 507883]
-in [http://packages.debian.org/lenny/asterisk asterisk]
-"asterisk: Very frequent segfaults on startup"
-(quentin couldn't reproduce)
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=456037 456037]
-in [http://packages.debian.org/lenny/fenix fenix]
-"fenix: not 64 bit clean"[[BR]]
-(ezyang observed upstream's website looks ~dead)
-
-= Fixed by SIPB! =
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=436140 436140]
-in [http://packages.debian.org/lenny/installation-reports installation-reports]
-"cdrom: Most of the system's files have a future timestamp causing at least update/config problems."
-(closed by wdaher)
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=476525 476525] 
-in [http://packages.debian.org/lenny/python-hid python-hid] 
-"python-hid: hid module will not import since python policy transition" 
-(tabbott)
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507071 507071] 
-[http://packages.debian.org/lenny/racoon racoon] 
-"racoon - Fails after upgrade: symbol lookup error: /usr/sbin/racoon: undefined symbol: libipsec_opt" 
-(fixed by broder)
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=507072 507072] 
-in [http://packages.debian.org/lenny/ipsec-tools ipsec-tools] 
-"libipsec0 packaged in ipsec-tools without development headers" 
-(downgraded by hartmans)
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=504626 504626] 
-in [http://packages.debian.org/lenny/nvidia-glx nvidia-glx] 
-"[nvidia-glx] Quietly drops support for several chipsets" 
-(downgraded by nelhage)
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=502845 502845]
-in [http://packages.debian.org/lenny/open-iscsi open-iscsi]
-"open-iscsi: no login using amd64"
-(quentin reassigned; Bastian Blank then lowered priority)
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=508265 508265]
-in [http://packages.debian.org/lenny/sysprof-module-source sysprof-module-source]
-"sysprof-module-source: doesn't compile on AMD64 arch (wrong register names)"
-(patch added by andersk)
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=506057 506057]
-in [http://packages.debian.org/lenny/splashy splashy]
-"splashy: Splashy fails to install due to missing default theme"
-(fix suggestion added by ecprice with help from tabbott and fawkes)
-
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=506748 506748]
-in [http://packages.debian.org/lenny/rtorrent rtorrent]
-"crash rtorrent by scgi-interface (function: 'fi.get_filename_last')"
-(submitted patch that disables broken RPC; leaving to maintainer to decide if this is what he wants to do)
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=426465 426465]
-in [http://packages.debian.org/lenny/initramfs-tools initramfs-tools]
-"/init exports MODPROBE_OPTIONS=-qb"
-[[BR]](patch added by price)
-
-[http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=489501] in [http://packages.debian.org/lenny/zekr zekr] "zekr depends on libxul0d"
-[[BR]](tweaked and sponsored fix by Asheesh Laroia)